Update to 0.5.0.
This commit is contained in:
parent
14fa128881
commit
f10de20b10
@ -1 +1 @@
|
||||
yasm-0.4.0.tar.gz
|
||||
yasm-0.5.0.tar.gz
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
2360e20c4e105ba95f4e9135a7901183 yasm-0.4.0.tar.gz
|
||||
d4931fcce497bd4f80ed349384704240 yasm-0.5.0.tar.gz
|
||||
|
@ -1,13 +0,0 @@
|
||||
--- yasm-0.4.0/modules/preprocs/nasm/genmacro.c~ 2004-10-31 03:55:54.000000000 +0000
|
||||
+++ yasm-0.4.0/modules/preprocs/nasm/genmacro.c 2005-02-14 09:21:37.000000000 +0000
|
||||
@@ -102,8 +102,8 @@
|
||||
while (*strp == ' ' || *strp == '\t')
|
||||
strp++;
|
||||
len = strlen(strp);
|
||||
- while (strp[len-1] == ' ' || strp[len-1] == '\t' ||
|
||||
- strp[len-1] == '\n') {
|
||||
+ while (len && (strp[len-1] == ' ' || strp[len-1] == '\t' ||
|
||||
+ strp[len-1] == '\n')) {
|
||||
strp[len-1] = '\0';
|
||||
len--;
|
||||
}
|
25
yasm.spec
25
yasm.spec
@ -1,16 +1,14 @@
|
||||
Summary: Complete rewrite of the NASM assembler
|
||||
Name: yasm
|
||||
Version: 0.4.0
|
||||
Release: 6%{?dist}
|
||||
Version: 0.5.0
|
||||
Release: 1%{?dist}
|
||||
License: BSD
|
||||
Group: Development/Languages
|
||||
URL: http://www.tortall.net/projects/yasm/
|
||||
Source: http://www.tortall.net/projects/yasm/releases/yasm-%{version}.tar.gz
|
||||
Patch0: yasm-0.4.0-genmacro.patch
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
|
||||
BuildRequires: bison, byacc, xmlto, gettext-devel
|
||||
|
||||
|
||||
%description
|
||||
Yasm is a complete rewrite of the NASM assembler under the "new" BSD License
|
||||
(some portions are under other licenses, see COPYING for details). It is
|
||||
@ -37,7 +35,7 @@ Install this package if you need to rebuild applications that use yasm.
|
||||
|
||||
%prep
|
||||
%setup
|
||||
%patch0 -p1
|
||||
|
||||
|
||||
%build
|
||||
%configure
|
||||
@ -60,27 +58,24 @@ Install this package if you need to rebuild applications that use yasm.
|
||||
|
||||
%files
|
||||
%defattr(-, root, root, 0755)
|
||||
%doc Artistic.txt AUTHORS BSD.txt ChangeLog COPYING GNU* NEWS README
|
||||
%doc Artistic.txt AUTHORS BSD.txt COPYING GNU*
|
||||
%{_bindir}/yasm
|
||||
%{_libdir}/*.so.*
|
||||
%dir %{_libdir}/yasm/
|
||||
%{_libdir}/yasm/*.so
|
||||
%{_mandir}/man1/yasm.1*
|
||||
|
||||
%files devel
|
||||
%defattr(-, root, root, 0755)
|
||||
%{_includedir}/libyasm.h
|
||||
%{_includedir}/libyasm/
|
||||
%{_libdir}/*.a
|
||||
%exclude %{_libdir}/*.la
|
||||
%{_libdir}/*.so
|
||||
%dir %{_libdir}/yasm/
|
||||
%{_libdir}/yasm/*.a
|
||||
%exclude %{_libdir}/yasm/*.la
|
||||
%{_libdir}/libyasm.a
|
||||
%{_mandir}/man7/yasm_arch.7*
|
||||
|
||||
|
||||
%changelog
|
||||
* Fri Jul 14 2006 Matthias Saou <http://freshrpms.net/> 0.5.0-1
|
||||
- Update to 0.5.0.
|
||||
- Remove empty files from %%doc.
|
||||
- There are no more shared libraries, only a static one, so update %%files.
|
||||
|
||||
* Mon Mar 6 2006 Matthias Saou <http://freshrpms.net/> 0.4.0-6
|
||||
- FC5 rebuild.
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user