import yara-4.2.3-1.el8

This commit is contained in:
CentOS Sources 2022-08-17 10:15:35 +00:00 committed by Stepan Oksanichenko
parent d1d506e41c
commit d416af0e64
5 changed files with 9 additions and 104 deletions

3
.gitignore vendored
View File

@ -1,2 +1 @@
SOURCES/androguard-yara-2020-04-22-3eea86a.tar.gz
SOURCES/yara-4.2.1.tar.gz
SOURCES/yara-4.2.3.tar.gz

View File

@ -1,2 +1 @@
69f66263250e1b37e0a40cd0fe3a1227dbef419e SOURCES/androguard-yara-2020-04-22-3eea86a.tar.gz
6752396d0441ed5f38569431260527db298d91e9 SOURCES/yara-4.2.1.tar.gz
1c0776d0b147e260dc51b1f2002235f07d9cacd8 SOURCES/yara-4.2.3.tar.gz

View File

@ -1,24 +0,0 @@
diff --git a/libyara/Makefile.am b/libyara/Makefile.am
index 4fa363a..a9242b2 100644
--- a/libyara/Makefile.am
+++ b/libyara/Makefile.am
@@ -48,6 +48,7 @@ MODULES += modules/pe/pe_utils.c
if CUCKOO_MODULE
MODULES += modules/cuckoo/cuckoo.c
+MODULES += modules/androguard/androguard.c
endif
if MAGIC_MODULE
diff --git a/libyara/modules/module_list b/libyara/modules/module_list
index d81b8f3..ba43609 100644
--- a/libyara/modules/module_list
+++ b/libyara/modules/module_list
@@ -10,6 +10,7 @@ MODULE(dotnet)
#ifdef CUCKOO_MODULE
MODULE(cuckoo)
+MODULE(androguard)
#endif
#ifdef MAGIC_MODULE

View File

@ -1,23 +0,0 @@
diff -ru yara-74734418a256c5304ccaf1d322c57e305ff75362/docs/conf.py yara-74734418a256c5304ccaf1d322c57e305ff75362.new/docs/conf.py
--- yara-74734418a256c5304ccaf1d322c57e305ff75362/docs/conf.py 2016-08-02 22:08:18.000000000 +0200
+++ yara-74734418a256c5304ccaf1d322c57e305ff75362.new/docs/conf.py 2016-08-08 23:08:47.637063737 +0200
@@ -102,12 +102,13 @@
# The theme to use for HTML and HTML Help pages. See the documentation for
# a list of builtin themes.
-try:
- import sphinx_rtd_theme
- html_theme = "sphinx_rtd_theme"
- html_theme_path = [sphinx_rtd_theme.get_html_theme_path()]
-except:
- html_theme = "default"
+#try:
+# import sphinx_rtd_theme
+# html_theme = "sphinx_rtd_theme"
+# html_theme_path = [sphinx_rtd_theme.get_html_theme_path()]
+#except:
+# html_theme = "default"
+html_theme = "default"
# Theme options are theme-specific and customize the look and feel of a theme
# further. For a list of options available for each theme, see the

View File

@ -1,6 +1,6 @@
Name: yara
Version: 4.2.1
Release: 4%{?dist}
Version: 4.2.3
Release: 1%{?dist}
Summary: Pattern matching Swiss knife for malware researchers
License: BSD-3-Clause
@ -11,44 +11,10 @@ URL: http://VirusTotal.github.io/yara/
%global gituser VirusTotal
%global gitname yara
# Commit of version 4.1.1
%global commit 8206dc6f728fe50e21af92cb40e454b68ef6af05
%global shortcommit %(c=%{commit}; echo ${c:0:7})
# additional module for yara
%global androguard_gituser Koodous
%global androguard_gitname androguard-yara
# Commit from 2020-04-22
%global androguard_commit 3eea86ae2c4ee6ad3cc1cb3c2711b03db078831a
%global androguard_shortcommit %(c=%{androguard_commit}; echo ${c:0:7})
%global androguard_gitdate 2020-04-22
# Build from git commit baseline
#Source0: https://github.com/%%{gituser}/%%{gitname}/archive/%%{commit}/%%{name}-%%{version}-%%{shortcommit}.tar.gz
# Build from git release version
Source0: https://github.com/%{gituser}/%{gitname}/archive/v%{version}.tar.gz#/%{name}-%{version}.tar.gz
# http://github.com/Koodous/androguard-yara/
Source1: https://github.com/%{androguard_gituser}/%{androguard_gitname}/archive/%{androguard_commit}/%{androguard_gitname}-%{androguard_gitdate}-%{androguard_shortcommit}.tar.gz
# Patch based on the androguard-yara installation guide to enable the androguard module
Patch0: yara-androguard.patch
# Use default sphix theme to generate documentation rather than sphinx_rtd_theme
# to avoid static installation of font files on fedora >= 24
Patch1: yara-docs-theme.patch
# Fixed in 3.6.0 upstream
# Patch https://patch-diff.githubusercontent.com/raw/VirusTotal/yara/pull/627.patch
# Fixes: CVE-2016-10210 CVE-2016-10211 CVE-2017-5923 CVE-2017-5924
# Patch2: %%{name}-pull627.patch
# API of yr_re_match changed, fix needed for Androguard
# https://github.com/Koodous/androguard-yara/issues/8
# merged in https://github.com/Koodous/androguard-yara/commit/034f0a49e58d798abcaa28c9864451da9da29413
# Patch3: yara-androguard-matchapi.patch
BuildRequires: git
BuildRequires: gcc
@ -102,19 +68,8 @@ developing applications that use %{name}.
%prep
# autosetup -n %%{gitname}-%%{commit} -p 1 -S git
%autosetup -p 1 -S git
# Add the Androguard module
# %%setup -qn %%{gitname}-%%{commit} -a 1 -D -T
%setup -q -a 1 -D -T
pushd %{androguard_gitname}-%{androguard_commit}
mkdir -p ../libyara/modules/androguard
cp -p androguard.c ../libyara/modules/androguard/
popd
%setup -q
autoreconf --force --install
@ -150,11 +105,6 @@ rm %{buildroot}%{_libdir}/lib%{name}.a
rm -f %{buildroot}%{_datadir}/doc/%{name}/html/.buildinfo
#%if 0%{?rhel} && 0%{?rhel} <= 7
#%ldconfig_scriptlets
#%endif
%files
%license COPYING
%doc AUTHORS CONTRIBUTORS README.md
@ -178,6 +128,10 @@ rm -f %{buildroot}%{_datadir}/doc/%{name}/html/.buildinfo
%changelog
* Tue Aug 16 2022 Mark Huth <mhuth@redhat.com> - 4.2.3-1
- Bump to 4.2.3
- Remove androguard module - github repo no longer exists
* Thu Jun 16 2022 Mark Huth <mhuth@redhat.com> - 4.2.1-4
- Use licence identifier BSD-3-Clause