yaml-cpp package is retired on branch c10s for BAKERY-412
This commit is contained in:
parent
01ff4c557b
commit
f92439e211
11
.gitignore
vendored
11
.gitignore
vendored
@ -1,11 +0,0 @@
|
||||
yaml-cpp-0.2.5.tar.gz
|
||||
/yaml-cpp-0.2.6.tar.gz
|
||||
/yaml-cpp-0.2.7.tar.gz
|
||||
/yaml-cpp-0.3.0.tar.gz
|
||||
/yaml-cpp-0.5.1.tar.gz
|
||||
/yaml-cpp-0.5.3.tar.gz
|
||||
/yaml-cpp-0.6.0.tar.gz
|
||||
/yaml-cpp-0.6.1.tar.gz
|
||||
/yaml-cpp-0.6.2.tar.gz
|
||||
/yaml-cpp-0.6.3.tar.gz
|
||||
/yaml-cpp-0.7.0.tar.gz
|
1
dead.package
Normal file
1
dead.package
Normal file
@ -0,0 +1 @@
|
||||
yaml-cpp package is retired on branch c10s for BAKERY-412
|
1
sources
1
sources
@ -1 +0,0 @@
|
||||
SHA512 (yaml-cpp-0.7.0.tar.gz) = 2de0f0ec8f003cd3c498d571cda7a796bf220517bad2dc02cba70c522dddde398f33cf1ad20da251adaacb2a07b77844111f297e99d45a7c46ebc01706bbafb5
|
@ -1,245 +0,0 @@
|
||||
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
||||
index b230b9e..6ef6e8a 100644
|
||||
--- a/CMakeLists.txt
|
||||
+++ b/CMakeLists.txt
|
||||
@@ -9,33 +9,39 @@ endif()
|
||||
|
||||
project(YAML_CPP VERSION 0.7.0 LANGUAGES CXX)
|
||||
|
||||
+set(YAML_CPP_MAIN_PROJECT OFF)
|
||||
+if(CMAKE_SOURCE_DIR STREQUAL PROJECT_SOURCE_DIR)
|
||||
+ set(YAML_CPP_MAIN_PROJECT ON)
|
||||
+endif()
|
||||
+
|
||||
include(CMakePackageConfigHelpers)
|
||||
include(CMakeDependentOption)
|
||||
include(CheckCXXCompilerFlag)
|
||||
include(GNUInstallDirs)
|
||||
include(CTest)
|
||||
|
||||
-find_program(YAML_CPP_CLANG_FORMAT_EXE NAMES clang-format)
|
||||
-
|
||||
option(YAML_CPP_BUILD_CONTRIB "Enable yaml-cpp contrib in library" ON)
|
||||
option(YAML_CPP_BUILD_TOOLS "Enable parse tools" ON)
|
||||
option(YAML_BUILD_SHARED_LIBS "Build yaml-cpp shared library" ${BUILD_SHARED_LIBS})
|
||||
-
|
||||
+option(YAML_CPP_INSTALL "Enable generation of yaml-cpp install targets" ${YAML_CPP_MAIN_PROJECT})
|
||||
+option(YAML_CPP_FORMAT_SOURCE "Format source" ON)
|
||||
cmake_dependent_option(YAML_CPP_BUILD_TESTS
|
||||
- "Enable yaml-cpp tests" ON
|
||||
- "BUILD_TESTING;CMAKE_SOURCE_DIR STREQUAL PROJECT_SOURCE_DIR" OFF)
|
||||
-cmake_dependent_option(YAML_CPP_INSTALL
|
||||
- "Enable generation of yaml-cpp install targets" ON
|
||||
- "CMAKE_SOURCE_DIR STREQUAL PROJECT_SOURCE_DIR" OFF)
|
||||
+ "Enable yaml-cpp tests" OFF
|
||||
+ "BUILD_TESTING;YAML_CPP_MAIN_PROJECT" OFF)
|
||||
cmake_dependent_option(YAML_MSVC_SHARED_RT
|
||||
"MSVC: Build yaml-cpp with shared runtime libs (/MD)" ON
|
||||
- "MSVC" OFF)
|
||||
+ "CMAKE_SYSTEM_NAME MATCHES Windows" OFF)
|
||||
+
|
||||
+if (YAML_CPP_FORMAT_SOURCE)
|
||||
+ find_program(YAML_CPP_CLANG_FORMAT_EXE NAMES clang-format)
|
||||
+endif()
|
||||
|
||||
-set(yaml-cpp-type STATIC)
|
||||
-set(yaml-cpp-label-postfix "static")
|
||||
if (YAML_BUILD_SHARED_LIBS)
|
||||
set(yaml-cpp-type SHARED)
|
||||
set(yaml-cpp-label-postfix "shared")
|
||||
+else()
|
||||
+ set(yaml-cpp-type STATIC)
|
||||
+ set(yaml-cpp-label-postfix "static")
|
||||
endif()
|
||||
|
||||
set(build-shared $<BOOL:${YAML_BUILD_SHARED_LIBS}>)
|
||||
@@ -78,6 +84,10 @@ set_property(TARGET yaml-cpp
|
||||
PROPERTY
|
||||
CXX_STANDARD_REQUIRED ON)
|
||||
|
||||
+if (NOT YAML_BUILD_SHARED_LIBS)
|
||||
+ set_property(TARGET yaml-cpp PROPERTY POSITION_INDEPENDENT_CODE ON)
|
||||
+endif()
|
||||
+
|
||||
target_include_directories(yaml-cpp
|
||||
PUBLIC
|
||||
$<BUILD_INTERFACE:${PROJECT_SOURCE_DIR}/include>
|
||||
@@ -91,11 +101,15 @@ if (NOT DEFINED CMAKE_CXX_STANDARD)
|
||||
CXX_STANDARD 11)
|
||||
endif()
|
||||
|
||||
+if(YAML_CPP_MAIN_PROJECT)
|
||||
+ target_compile_options(yaml-cpp
|
||||
+ PRIVATE
|
||||
+ $<${not-msvc}:-Wall -Wextra -Wshadow -Weffc++ -Wno-long-long>
|
||||
+ $<${not-msvc}:-pedantic -pedantic-errors>)
|
||||
+endif()
|
||||
+
|
||||
target_compile_options(yaml-cpp
|
||||
PRIVATE
|
||||
- $<${not-msvc}:-Wall -Wextra -Wshadow -Weffc++ -Wno-long-long>
|
||||
- $<${not-msvc}:-pedantic -pedantic-errors>
|
||||
-
|
||||
$<$<AND:${backport-msvc-runtime},${msvc-rt-mtd-static}>:-MTd>
|
||||
$<$<AND:${backport-msvc-runtime},${msvc-rt-mt-static}>:-MT>
|
||||
$<$<AND:${backport-msvc-runtime},${msvc-rt-mtd-dll}>:-MDd>
|
||||
@@ -108,6 +122,8 @@ target_compile_options(yaml-cpp
|
||||
$<$<CXX_COMPILER_ID:MSVC>:/W3 /wd4127 /wd4355>)
|
||||
|
||||
target_compile_definitions(yaml-cpp
|
||||
+ PUBLIC
|
||||
+ $<$<NOT:$<BOOL:${YAML_BUILD_SHARED_LIBS}>>:YAML_CPP_STATIC_DEFINE>
|
||||
PRIVATE
|
||||
$<${build-windows-dll}:${PROJECT_NAME}_DLL>
|
||||
$<$<NOT:$<BOOL:${YAML_CPP_BUILD_CONTRIB}>>:YAML_CPP_NO_CONTRIB>)
|
||||
@@ -127,10 +143,14 @@ set_target_properties(yaml-cpp PROPERTIES
|
||||
PROJECT_LABEL "yaml-cpp ${yaml-cpp-label-postfix}"
|
||||
DEBUG_POSTFIX "${CMAKE_DEBUG_POSTFIX}")
|
||||
|
||||
+set(CONFIG_EXPORT_DIR "${CMAKE_INSTALL_LIBDIR}/cmake/yaml-cpp")
|
||||
+set(EXPORT_TARGETS yaml-cpp)
|
||||
configure_package_config_file(
|
||||
"${PROJECT_SOURCE_DIR}/yaml-cpp-config.cmake.in"
|
||||
"${PROJECT_BINARY_DIR}/yaml-cpp-config.cmake"
|
||||
- INSTALL_DESTINATION "${CMAKE_INSTALL_DATADIR}/cmake/yaml-cpp")
|
||||
+ INSTALL_DESTINATION "${CONFIG_EXPORT_DIR}"
|
||||
+ PATH_VARS CMAKE_INSTALL_INCLUDEDIR CMAKE_INSTALL_LIBDIR CONFIG_EXPORT_DIR YAML_BUILD_SHARED_LIBS)
|
||||
+unset(EXPORT_TARGETS)
|
||||
|
||||
write_basic_package_version_file(
|
||||
"${PROJECT_BINARY_DIR}/yaml-cpp-config-version.cmake"
|
||||
@@ -139,36 +159,48 @@ write_basic_package_version_file(
|
||||
configure_file(yaml-cpp.pc.in yaml-cpp.pc @ONLY)
|
||||
|
||||
if (YAML_CPP_INSTALL)
|
||||
- install(TARGETS yaml-cpp
|
||||
+ install(TARGETS yaml-cpp
|
||||
EXPORT yaml-cpp-targets
|
||||
RUNTIME DESTINATION ${CMAKE_INSTALL_BINDIR}
|
||||
LIBRARY DESTINATION ${CMAKE_INSTALL_LIBDIR}
|
||||
ARCHIVE DESTINATION ${CMAKE_INSTALL_LIBDIR})
|
||||
- install(DIRECTORY ${PROJECT_SOURCE_DIR}/include/
|
||||
+ install(DIRECTORY ${PROJECT_SOURCE_DIR}/include/
|
||||
DESTINATION ${CMAKE_INSTALL_INCLUDEDIR}
|
||||
- FILES_MATCHING PATTERN "*.h")
|
||||
+ FILES_MATCHING PATTERN "*.h")
|
||||
install(EXPORT yaml-cpp-targets
|
||||
- DESTINATION "${CMAKE_INSTALL_DATADIR}/cmake/yaml-cpp")
|
||||
- install(FILES
|
||||
- "${PROJECT_BINARY_DIR}/yaml-cpp-config.cmake"
|
||||
- "${PROJECT_BINARY_DIR}/yaml-cpp-config-version.cmake"
|
||||
- DESTINATION "${CMAKE_INSTALL_DATADIR}/cmake/yaml-cpp")
|
||||
+ DESTINATION "${CONFIG_EXPORT_DIR}")
|
||||
+ install(FILES
|
||||
+ "${PROJECT_BINARY_DIR}/yaml-cpp-config.cmake"
|
||||
+ "${PROJECT_BINARY_DIR}/yaml-cpp-config-version.cmake"
|
||||
+ DESTINATION "${CONFIG_EXPORT_DIR}")
|
||||
install(FILES "${PROJECT_BINARY_DIR}/yaml-cpp.pc"
|
||||
- DESTINATION ${CMAKE_INSTALL_DATADIR}/pkgconfig)
|
||||
+ DESTINATION ${CMAKE_INSTALL_LIBDIR}/pkgconfig)
|
||||
endif()
|
||||
+unset(CONFIG_EXPORT_DIR)
|
||||
|
||||
if(YAML_CPP_BUILD_TESTS)
|
||||
- add_subdirectory(test)
|
||||
+ add_subdirectory(test)
|
||||
endif()
|
||||
|
||||
if(YAML_CPP_BUILD_TOOLS)
|
||||
- add_subdirectory(util)
|
||||
+ add_subdirectory(util)
|
||||
endif()
|
||||
|
||||
-if (YAML_CPP_CLANG_FORMAT_EXE)
|
||||
+if (YAML_CPP_FORMAT_SOURCE AND YAML_CPP_CLANG_FORMAT_EXE)
|
||||
add_custom_target(format
|
||||
COMMAND clang-format --style=file -i $<TARGET_PROPERTY:yaml-cpp,SOURCES>
|
||||
COMMAND_EXPAND_LISTS
|
||||
COMMENT "Running clang-format"
|
||||
VERBATIM)
|
||||
endif()
|
||||
+
|
||||
+# uninstall target
|
||||
+if(NOT TARGET uninstall)
|
||||
+ configure_file(
|
||||
+ "${CMAKE_CURRENT_SOURCE_DIR}/cmake_uninstall.cmake.in"
|
||||
+ "${CMAKE_CURRENT_BINARY_DIR}/cmake_uninstall.cmake"
|
||||
+ IMMEDIATE @ONLY)
|
||||
+
|
||||
+ add_custom_target(uninstall
|
||||
+ COMMAND ${CMAKE_COMMAND} -P ${CMAKE_CURRENT_BINARY_DIR}/cmake_uninstall.cmake)
|
||||
+endif()
|
||||
diff --git a/cmake_uninstall.cmake.in b/cmake_uninstall.cmake.in
|
||||
new file mode 100644
|
||||
index 0000000..c2d34d4
|
||||
--- /dev/null
|
||||
+++ b/cmake_uninstall.cmake.in
|
||||
@@ -0,0 +1,21 @@
|
||||
+if(NOT EXISTS "@CMAKE_BINARY_DIR@/install_manifest.txt")
|
||||
+ message(FATAL_ERROR "Cannot find install manifest: @CMAKE_BINARY_DIR@/install_manifest.txt")
|
||||
+endif()
|
||||
+
|
||||
+file(READ "@CMAKE_BINARY_DIR@/install_manifest.txt" files)
|
||||
+string(REGEX REPLACE "\n" ";" files "${files}")
|
||||
+foreach(file ${files})
|
||||
+ message(STATUS "Uninstalling $ENV{DESTDIR}${file}")
|
||||
+ if(IS_SYMLINK "$ENV{DESTDIR}${file}" OR EXISTS "$ENV{DESTDIR}${file}")
|
||||
+ exec_program(
|
||||
+ "@CMAKE_COMMAND@" ARGS "-E remove \"$ENV{DESTDIR}${file}\""
|
||||
+ OUTPUT_VARIABLE rm_out
|
||||
+ RETURN_VALUE rm_retval
|
||||
+ )
|
||||
+ if(NOT "${rm_retval}" STREQUAL 0)
|
||||
+ message(FATAL_ERROR "Problem when removing $ENV{DESTDIR}${file}")
|
||||
+ endif()
|
||||
+ else(IS_SYMLINK "$ENV{DESTDIR}${file}" OR EXISTS "$ENV{DESTDIR}${file}")
|
||||
+ message(STATUS "File $ENV{DESTDIR}${file} does not exist.")
|
||||
+ endif()
|
||||
+endforeach()
|
||||
diff --git a/yaml-cpp-config.cmake.in b/yaml-cpp-config.cmake.in
|
||||
index 7b41e3f..799b9b4 100644
|
||||
--- a/yaml-cpp-config.cmake.in
|
||||
+++ b/yaml-cpp-config.cmake.in
|
||||
@@ -1,14 +1,22 @@
|
||||
# - Config file for the yaml-cpp package
|
||||
# It defines the following variables
|
||||
-# YAML_CPP_INCLUDE_DIR - include directory
|
||||
-# YAML_CPP_LIBRARIES - libraries to link against
|
||||
+# YAML_CPP_INCLUDE_DIR - include directory
|
||||
+# YAML_CPP_LIBRARY_DIR - directory containing libraries
|
||||
+# YAML_CPP_SHARED_LIBS_BUILT - whether we have built shared libraries or not
|
||||
+# YAML_CPP_LIBRARIES - libraries to link against
|
||||
|
||||
-# Compute paths
|
||||
-get_filename_component(YAML_CPP_CMAKE_DIR "${CMAKE_CURRENT_LIST_FILE}" PATH)
|
||||
-set(YAML_CPP_INCLUDE_DIR "@CONFIG_INCLUDE_DIRS@")
|
||||
+@PACKAGE_INIT@
|
||||
+
|
||||
+set_and_check(YAML_CPP_INCLUDE_DIR "@PACKAGE_CMAKE_INSTALL_INCLUDEDIR@")
|
||||
+set_and_check(YAML_CPP_LIBRARY_DIR "@PACKAGE_CMAKE_INSTALL_LIBDIR@")
|
||||
+
|
||||
+# Are we building shared libraries?
|
||||
+set(YAML_CPP_SHARED_LIBS_BUILT "@PACKAGE_YAML_BUILD_SHARED_LIBS@")
|
||||
|
||||
# Our library dependencies (contains definitions for IMPORTED targets)
|
||||
-include("${YAML_CPP_CMAKE_DIR}/yaml-cpp-targets.cmake")
|
||||
+include(@PACKAGE_CONFIG_EXPORT_DIR@/yaml-cpp-targets.cmake)
|
||||
|
||||
# These are IMPORTED targets created by yaml-cpp-targets.cmake
|
||||
set(YAML_CPP_LIBRARIES "@EXPORT_TARGETS@")
|
||||
+
|
||||
+check_required_components(@EXPORT_TARGETS@)
|
||||
diff --git a/yaml-cpp.pc.in b/yaml-cpp.pc.in
|
||||
index f713de6..d02dc9e 100644
|
||||
--- a/yaml-cpp.pc.in
|
||||
+++ b/yaml-cpp.pc.in
|
||||
@@ -1,7 +1,7 @@
|
||||
prefix=@CMAKE_INSTALL_PREFIX@
|
||||
exec_prefix=${prefix}
|
||||
-includedir=${prefix}/@CMAKE_INSTALL_INCLUDEDIR@
|
||||
-libdir=${exec_prefix}/@CMAKE_INSTALL_LIBDIR@
|
||||
+includedir=@CMAKE_INSTALL_FULL_INCLUDEDIR@
|
||||
+libdir=@CMAKE_INSTALL_FULL_LIBDIR@
|
||||
|
||||
Name: Yaml-cpp
|
||||
Description: A YAML parser and emitter for C++
|
261
yaml-cpp.spec
261
yaml-cpp.spec
@ -1,261 +0,0 @@
|
||||
%global sover 0.7
|
||||
|
||||
Name: yaml-cpp
|
||||
Version: 0.7.0
|
||||
Release: 4%{?dist}
|
||||
|
||||
License: MIT
|
||||
Summary: A YAML parser and emitter for C++
|
||||
URL: https://github.com/jbeder/yaml-cpp
|
||||
Source0: %{url}/archive/%{name}-%{version}/%{name}-%{version}.tar.gz
|
||||
|
||||
# CMake fixes from 0e6e28d1a38224fc8172fae0109ea7f673c096db commit
|
||||
Patch100: yaml-cpp-cmake.patch
|
||||
|
||||
BuildRequires: cmake
|
||||
BuildRequires: gcc
|
||||
BuildRequires: gcc-c++
|
||||
BuildRequires: make
|
||||
|
||||
%description
|
||||
yaml-cpp is a YAML parser and emitter in C++ written around the YAML 1.2 spec.
|
||||
|
||||
%package devel
|
||||
Summary: Development files for %{name}
|
||||
Requires: %{name}%{?_isa} = %{?epoch:%{epoch}:}%{version}-%{release}
|
||||
Requires: libstdc++-devel%{?_isa}
|
||||
|
||||
%description devel
|
||||
The %{name}-devel package contains libraries and header files for
|
||||
developing applications that use %{name}.
|
||||
|
||||
%package static
|
||||
Summary: Static library for %{name}
|
||||
Requires: %{name}-devel%{?_isa} = %{?epoch:%{epoch}:}%{version}-%{release}
|
||||
|
||||
%description static
|
||||
The %{name}-static package contains the static library for %{name}.
|
||||
|
||||
%prep
|
||||
%autosetup -n %{name}-%{name}-%{version} -p1
|
||||
|
||||
%build
|
||||
%cmake -B build_static \
|
||||
-DCMAKE_BUILD_TYPE=Release \
|
||||
-DYAML_CPP_BUILD_TOOLS:BOOL=OFF \
|
||||
-DYAML_CPP_FORMAT_SOURCE:BOOL=OFF \
|
||||
-DYAML_CPP_INSTALL:BOOL=ON \
|
||||
-DYAML_BUILD_SHARED_LIBS:BOOL=OFF \
|
||||
-DYAML_CPP_BUILD_TESTS:BOOL=OFF
|
||||
%make_build -C build_static
|
||||
|
||||
%cmake -B build_shared \
|
||||
-DCMAKE_BUILD_TYPE=Release \
|
||||
-DYAML_CPP_BUILD_TOOLS:BOOL=OFF \
|
||||
-DYAML_CPP_FORMAT_SOURCE:BOOL=OFF \
|
||||
-DYAML_CPP_INSTALL:BOOL=ON \
|
||||
-DYAML_BUILD_SHARED_LIBS:BOOL=ON \
|
||||
-DYAML_CPP_BUILD_TESTS:BOOL=OFF
|
||||
%make_build -C build_shared
|
||||
|
||||
%install
|
||||
%make_install -C build_static yaml-cpp
|
||||
|
||||
# Move files so they don't get trampled
|
||||
mv %{buildroot}%{_libdir}/cmake/%{name} \
|
||||
%{buildroot}%{_libdir}/cmake/%{name}-static
|
||||
mv %{buildroot}%{_libdir}/pkgconfig/%{name}.pc \
|
||||
%{buildroot}%{_libdir}/pkgconfig/%{name}-static.pc
|
||||
|
||||
%make_install -C build_shared
|
||||
|
||||
%files
|
||||
%doc CONTRIBUTING.md README.md
|
||||
%license LICENSE
|
||||
%{_libdir}/lib%{name}*.so.%{sover}*
|
||||
|
||||
%files devel
|
||||
%{_includedir}/yaml-cpp/
|
||||
%{_libdir}/lib%{name}.so
|
||||
%{_libdir}/cmake/%{name}
|
||||
%{_libdir}/pkgconfig/%{name}.pc
|
||||
|
||||
%files static
|
||||
%license LICENSE
|
||||
%{_libdir}/lib%{name}.a
|
||||
%{_libdir}/cmake/%{name}-static
|
||||
%{_libdir}/pkgconfig/%{name}-static.pc
|
||||
|
||||
%changelog
|
||||
* Sat Jul 22 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.7.0-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
|
||||
|
||||
* Wed Apr 19 2023 Vitaly Zaitsev <vitaly@easycoding.org> - 0.7.0-3
|
||||
- Fixed broken CMake configs (rhbz#2188009).
|
||||
- Backported CMake fixes from upstream.
|
||||
- Converted license tag to SPDX.
|
||||
- Performed minor SPEC cleanup.
|
||||
|
||||
* Sat Jan 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.7.0-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
|
||||
|
||||
* Tue Sep 06 2022 Richard Shaw <hobbes1069@gmail.com> - 0.7.0-1
|
||||
- Update to 0.7.0.
|
||||
|
||||
* Sat Jul 23 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.6.3-7
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
||||
|
||||
* Sat Jan 22 2022 Fedora Release Engineering <releng@fedoraproject.org> - 0.6.3-6
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
|
||||
|
||||
* Fri Jul 23 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.6.3-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
|
||||
|
||||
* Thu Jan 28 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.6.3-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||
|
||||
* Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.6.3-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||
|
||||
* Fri Jan 31 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.6.3-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||
|
||||
* Tue Oct 15 2019 Richard Shaw <hobbes1069@gmail.com> - 0.6.3-1
|
||||
- Update to 0.6.3.
|
||||
|
||||
* Sat Jul 27 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.6.2-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
||||
|
||||
* Sun Jun 09 2019 Till Hofmann <thofmann@fedoraproject.org> - 0.6.2-2
|
||||
- Remove unused boost dependency
|
||||
|
||||
* Sun Jun 09 2019 Till Hofmann <thofmann@fedoraproject.org> - 0.6.2-1
|
||||
- Update to 0.6.2
|
||||
|
||||
* Sun Feb 03 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.6.1-6
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
||||
|
||||
* Thu Jan 24 2019 Jonathan Wakely <jwakely@redhat.com> - 0.6.1-5
|
||||
- Rebuilt for Boost 1.69
|
||||
|
||||
* Sun Sep 16 2018 Richard Shaw <hobbes1069@gmail.com> - 0.6.1-4
|
||||
- Add patch for CVE-2017-5950.
|
||||
|
||||
* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.6.1-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||
|
||||
* Mon Apr 09 2018 Richard Shaw <hobbes1069@gmail.com> - 0.6.1-2
|
||||
- Fixes improperly generated cmake config files, RHBZ#1558637.
|
||||
|
||||
* Sun Feb 18 2018 Richard Shaw <hobbes1069@gmail.com> - 0.6.1-1
|
||||
- Update to 0.6.1.
|
||||
|
||||
* Sun Feb 11 2018 Richard Shaw <hobbes1069@gmail.com> - 0.6.0-1
|
||||
- Update to 0.6.0.
|
||||
- Add static library subpackage.
|
||||
|
||||
* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.5.3-10
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||
|
||||
* Wed Jan 31 2018 Richard Shaw <hobbes1069@gmail.com> - 0.5.3-9
|
||||
- Install yaml cmake files, fixes RHBZ#1509421.
|
||||
|
||||
* Tue Jan 23 2018 Jonathan Wakely <jwakely@redhat.com> - 0.5.3-8
|
||||
- Rebuilt for Boost 1.66
|
||||
|
||||
* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.5.3-7
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||
|
||||
* Wed Jul 19 2017 Jonathan Wakely <jwakely@redhat.com> - 0.5.3-6
|
||||
- Rebuilt for s390x binutils bug
|
||||
|
||||
* Tue Jul 04 2017 Jonathan Wakely <jwakely@redhat.com> - 0.5.3-5
|
||||
- Rebuilt for Boost 1.64
|
||||
|
||||
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.5.3-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||
|
||||
* Fri Jan 27 2017 Jonathan Wakely <jwakely@redhat.com> - 0.5.3-3
|
||||
- Rebuilt for Boost 1.63
|
||||
|
||||
* Fri Jan 27 2017 Jonathan Wakely <jwakely@redhat.com> - 0.5.3-2
|
||||
- Rebuilt for Boost 1.63
|
||||
|
||||
* Tue Aug 23 2016 Richard Shaw <hobbes1069@gmail.com> - 0.5.3-1
|
||||
- Update to latest upstream release.
|
||||
|
||||
* Fri Feb 05 2016 Fedora Release Engineering <releng@fedoraproject.org> - 0.5.1-13
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||
|
||||
* Sat Jan 16 2016 Jonathan Wakely <jwakely@redhat.com> - 0.5.1-12
|
||||
- Rebuilt for Boost 1.60
|
||||
|
||||
* Thu Aug 27 2015 Jonathan Wakely <jwakely@redhat.com> - 0.5.1-11
|
||||
- Rebuilt for Boost 1.59
|
||||
|
||||
* Wed Jul 29 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.5.1-10
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Changes/F23Boost159
|
||||
|
||||
* Wed Jul 22 2015 David Tardon <dtardon@redhat.com> - 0.5.1-9
|
||||
- rebuild for Boost 1.58
|
||||
|
||||
* Fri Jun 19 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.5.1-8
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||
|
||||
* Sat May 02 2015 Kalev Lember <kalevlember@gmail.com> - 0.5.1-7
|
||||
- Rebuilt for GCC 5 C++11 ABI change
|
||||
|
||||
* Thu Feb 26 2015 Guido Grazioli <guido.grazioli@gmail.com> - 0.5.1-6
|
||||
- Rebuild for gcc switching default to -std=gnu11
|
||||
|
||||
* Tue Jan 27 2015 Petr Machata <pmachata@redhat.com> - 0.5.1-5
|
||||
- Rebuild for boost 1.57.0
|
||||
|
||||
* Mon Aug 18 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.5.1-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
|
||||
|
||||
* Sat Jun 07 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.5.1-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||
|
||||
* Fri May 23 2014 Petr Machata <pmachata@redhat.com> - 0.5.1-2
|
||||
- Rebuild for boost 1.55.0
|
||||
|
||||
* Thu Nov 14 2013 Richard Shaw <hobbes1069@gmail.com> - 0.5.1-1
|
||||
- Update to latest upstream release.
|
||||
|
||||
* Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3.0-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||
|
||||
* Fri Feb 15 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3.0-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
||||
|
||||
* Sun Jul 22 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.3.0-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||
|
||||
* Fri Feb 10 2012 Richard Shaw <hobbes1069@gmail.com> - 0.3.0-1
|
||||
- Update to latest release.
|
||||
|
||||
* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org>
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
|
||||
|
||||
* Fri Sep 30 2011 Guido Grazioli <guido.grazioli@gmail.com> - 0.2.7-1
|
||||
- Update to 0.2.7
|
||||
- Remove gcc 4.6 patch fixed upstream
|
||||
|
||||
* Mon May 09 2011 Guido Grazioli <guido.grazioli@gmail.com> - 0.2.6-1
|
||||
- Upstream 0.2.6
|
||||
|
||||
* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.2.5-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
||||
|
||||
* Fri Apr 02 2010 Guido Grazioli <guido.grazioli@gmail.com> - 0.2.5-1
|
||||
- Upstream 0.2.5
|
||||
|
||||
* Fri Jan 15 2010 Guido Grazioli <guido.grazioli@gmail.com> - 0.2.4-1
|
||||
- Upstream 0.2.4
|
||||
|
||||
* Sat Oct 17 2009 Guido Grazioli <guido.grazioli@gmail.com> - 0.2.2-2
|
||||
- Remove duplicate file
|
||||
|
||||
* Wed Oct 14 2009 Guido Grazioli <guido.grazioli@gmail.com> - 0.2.2-1
|
||||
- Initial packaging
|
Loading…
Reference in New Issue
Block a user