Fix ignoring of cflags (rhbz #547500)
This commit is contained in:
parent
4edac00870
commit
fbdac7e645
12
lloyd-yajl-cflags.patch
Normal file
12
lloyd-yajl-cflags.patch
Normal file
@ -0,0 +1,12 @@
|
|||||||
|
diff -rup lloyd-yajl-45a1bdb.orig/CMakeLists.txt lloyd-yajl-45a1bdb.new/CMakeLists.txt
|
||||||
|
--- lloyd-yajl-45a1bdb.orig/CMakeLists.txt 2009-10-29 23:35:39.000000000 +0000
|
||||||
|
+++ lloyd-yajl-45a1bdb.new/CMakeLists.txt 2010-01-11 17:14:01.000000000 +0000
|
||||||
|
@@ -42,7 +42,7 @@ IF (NOT CMAKE_BUILD_TYPE)
|
||||||
|
SET(CMAKE_BUILD_TYPE "Release")
|
||||||
|
ENDIF (NOT CMAKE_BUILD_TYPE)
|
||||||
|
|
||||||
|
-SET(CMAKE_C_FLAGS "-Wall")
|
||||||
|
+SET(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wall")
|
||||||
|
IF (WIN32)
|
||||||
|
ADD_DEFINITIONS(-DWIN32)
|
||||||
|
SET(linkFlags "/PDB:NONE /INCREMENTAL:NO /OPT:NOREF /OPT:NOICF")
|
@ -1,6 +1,6 @@
|
|||||||
Name: yajl
|
Name: yajl
|
||||||
Version: 1.0.7
|
Version: 1.0.7
|
||||||
Release: 2%{?dist}
|
Release: 3%{?dist}
|
||||||
Summary: Yet Another JSON Library (YAJL)
|
Summary: Yet Another JSON Library (YAJL)
|
||||||
|
|
||||||
Group: Development/Libraries
|
Group: Development/Libraries
|
||||||
@ -29,6 +29,7 @@ URL: http://lloyd.github.com/yajl/
|
|||||||
%global githash 45a1bdb
|
%global githash 45a1bdb
|
||||||
Source0: lloyd-%{name}-%{githash}.tar.gz
|
Source0: lloyd-%{name}-%{githash}.tar.gz
|
||||||
Patch1: lloyd-%{name}-lib64.patch
|
Patch1: lloyd-%{name}-lib64.patch
|
||||||
|
Patch2: lloyd-%{name}-cflags.patch
|
||||||
|
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
BuildRequires: cmake
|
BuildRequires: cmake
|
||||||
@ -54,6 +55,8 @@ necessary for developing against the YAJL library
|
|||||||
%setup -q -n lloyd-%{name}-%{githash}
|
%setup -q -n lloyd-%{name}-%{githash}
|
||||||
# Fix lib vs lib64 problems
|
# Fix lib vs lib64 problems
|
||||||
%patch1 -p1
|
%patch1 -p1
|
||||||
|
# Fix ignoring of CFLAGS
|
||||||
|
%patch2 -p1
|
||||||
|
|
||||||
%build
|
%build
|
||||||
# NB, we are not using upstream's 'configure'/'make'
|
# NB, we are not using upstream's 'configure'/'make'
|
||||||
@ -104,6 +107,9 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Jan 11 2010 Daniel P. Berrange <berrange@redhat.com> - 1.0.7-3
|
||||||
|
- Fix ignoring of cflags (rhbz #547500)
|
||||||
|
|
||||||
* Tue Dec 8 2009 Daniel P. Berrange <berrange@redhat.com> - 1.0.7-2
|
* Tue Dec 8 2009 Daniel P. Berrange <berrange@redhat.com> - 1.0.7-2
|
||||||
- Change use of 'define' to 'global'
|
- Change use of 'define' to 'global'
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user