re-import sources as agreed with the maintainer
This commit is contained in:
parent
57340fc56b
commit
db549b08a8
6
.gitignore
vendored
6
.gitignore
vendored
@ -1 +1,5 @@
|
|||||||
/yajl-2.1.0.tar.gz
|
.build*.log
|
||||||
|
*.rpm
|
||||||
|
i386
|
||||||
|
x86_64
|
||||||
|
*.tar.gz
|
||||||
|
13
lloyd-yajl-2.0.4-pkgconfig-includedir.patch
Normal file
13
lloyd-yajl-2.0.4-pkgconfig-includedir.patch
Normal file
@ -0,0 +1,13 @@
|
|||||||
|
Only in lloyd-yajl-fee1ebe.new/src: CMakeLists.txt~
|
||||||
|
diff -rup lloyd-yajl-fee1ebe.orig/src/yajl.pc.cmake lloyd-yajl-fee1ebe.new/src/yajl.pc.cmake
|
||||||
|
--- lloyd-yajl-fee1ebe.orig/src/yajl.pc.cmake 2011-12-20 00:23:22.000000000 +0000
|
||||||
|
+++ lloyd-yajl-fee1ebe.new/src/yajl.pc.cmake 2012-08-06 14:05:49.639854538 +0100
|
||||||
|
@@ -1,6 +1,6 @@
|
||||||
|
prefix=${CMAKE_INSTALL_PREFIX}
|
||||||
|
libdir=${dollar}{prefix}/lib${LIB_SUFFIX}
|
||||||
|
-includedir=${dollar}{prefix}/include/yajl
|
||||||
|
+includedir=${dollar}{prefix}/include
|
||||||
|
|
||||||
|
Name: Yet Another JSON Library
|
||||||
|
Description: A Portable JSON parsing and serialization library in ANSI C
|
||||||
|
Only in lloyd-yajl-fee1ebe.new/src: yajl.pc.cmake~
|
29
lloyd-yajl-2.0.4-pkgconfig-location.patch
Normal file
29
lloyd-yajl-2.0.4-pkgconfig-location.patch
Normal file
@ -0,0 +1,29 @@
|
|||||||
|
diff -rup lloyd-yajl-fee1ebe.orig/src/CMakeLists.txt lloyd-yajl-fee1ebe.new/src/CMakeLists.txt
|
||||||
|
--- lloyd-yajl-fee1ebe.orig/src/CMakeLists.txt 2011-12-20 00:23:22.000000000 +0000
|
||||||
|
+++ lloyd-yajl-fee1ebe.new/src/CMakeLists.txt 2012-08-06 13:59:02.222065755 +0100
|
||||||
|
@@ -30,7 +30,7 @@ ADD_DEFINITIONS(-DYAJL_BUILD)
|
||||||
|
# set up some paths
|
||||||
|
SET (libDir ${CMAKE_CURRENT_BINARY_DIR}/../${YAJL_DIST_NAME}/lib)
|
||||||
|
SET (incDir ${CMAKE_CURRENT_BINARY_DIR}/../${YAJL_DIST_NAME}/include/yajl)
|
||||||
|
-SET (shareDir ${CMAKE_CURRENT_BINARY_DIR}/../${YAJL_DIST_NAME}/share/pkgconfig)
|
||||||
|
+SET (pkgconfigDir ${CMAKE_CURRENT_BINARY_DIR}/../${YAJL_DIST_NAME}/lib/pkgconfig)
|
||||||
|
|
||||||
|
# set the output path for libraries
|
||||||
|
SET(LIBRARY_OUTPUT_PATH ${libDir})
|
||||||
|
@@ -61,7 +61,7 @@ FILE(MAKE_DIRECTORY ${incDir})
|
||||||
|
# generate build-time source
|
||||||
|
SET(dollar $)
|
||||||
|
CONFIGURE_FILE(api/yajl_version.h.cmake ${incDir}/yajl_version.h)
|
||||||
|
-CONFIGURE_FILE(yajl.pc.cmake ${shareDir}/yajl.pc)
|
||||||
|
+CONFIGURE_FILE(yajl.pc.cmake ${pkgconfigDir}/yajl.pc)
|
||||||
|
|
||||||
|
# copy public headers to output directory
|
||||||
|
FOREACH (header ${PUB_HDRS})
|
||||||
|
@@ -82,5 +82,5 @@ IF(NOT WIN32)
|
||||||
|
INSTALL(TARGETS yajl_s ARCHIVE DESTINATION lib${LIB_SUFFIX})
|
||||||
|
INSTALL(FILES ${PUB_HDRS} DESTINATION include/yajl)
|
||||||
|
INSTALL(FILES ${incDir}/yajl_version.h DESTINATION include/yajl)
|
||||||
|
- INSTALL(FILES ${shareDir}/yajl.pc DESTINATION share/pkgconfig)
|
||||||
|
+ INSTALL(FILES ${pkgconfigDir}/yajl.pc DESTINATION lib${LIB_SUFFIX}/pkgconfig)
|
||||||
|
ENDIF()
|
||||||
|
Only in lloyd-yajl-fee1ebe.new/src: CMakeLists.txt~
|
Loading…
Reference in New Issue
Block a user