Update to 2.0.4 release (rhbz #845777)
This commit is contained in:
parent
13d13b3371
commit
a12fae3c60
13
lloyd-yajl-2.0.4-pkgconfig-includedir.patch
Normal file
13
lloyd-yajl-2.0.4-pkgconfig-includedir.patch
Normal file
@ -0,0 +1,13 @@
|
|||||||
|
Only in lloyd-yajl-fee1ebe.new/src: CMakeLists.txt~
|
||||||
|
diff -rup lloyd-yajl-fee1ebe.orig/src/yajl.pc.cmake lloyd-yajl-fee1ebe.new/src/yajl.pc.cmake
|
||||||
|
--- lloyd-yajl-fee1ebe.orig/src/yajl.pc.cmake 2011-12-20 00:23:22.000000000 +0000
|
||||||
|
+++ lloyd-yajl-fee1ebe.new/src/yajl.pc.cmake 2012-08-06 14:05:49.639854538 +0100
|
||||||
|
@@ -1,6 +1,6 @@
|
||||||
|
prefix=${CMAKE_INSTALL_PREFIX}
|
||||||
|
libdir=${dollar}{prefix}/lib${LIB_SUFFIX}
|
||||||
|
-includedir=${dollar}{prefix}/include/yajl
|
||||||
|
+includedir=${dollar}{prefix}/include
|
||||||
|
|
||||||
|
Name: Yet Another JSON Library
|
||||||
|
Description: A Portable JSON parsing and serialization library in ANSI C
|
||||||
|
Only in lloyd-yajl-fee1ebe.new/src: yajl.pc.cmake~
|
29
lloyd-yajl-2.0.4-pkgconfig-location.patch
Normal file
29
lloyd-yajl-2.0.4-pkgconfig-location.patch
Normal file
@ -0,0 +1,29 @@
|
|||||||
|
diff -rup lloyd-yajl-fee1ebe.orig/src/CMakeLists.txt lloyd-yajl-fee1ebe.new/src/CMakeLists.txt
|
||||||
|
--- lloyd-yajl-fee1ebe.orig/src/CMakeLists.txt 2011-12-20 00:23:22.000000000 +0000
|
||||||
|
+++ lloyd-yajl-fee1ebe.new/src/CMakeLists.txt 2012-08-06 13:59:02.222065755 +0100
|
||||||
|
@@ -30,7 +30,7 @@ ADD_DEFINITIONS(-DYAJL_BUILD)
|
||||||
|
# set up some paths
|
||||||
|
SET (libDir ${CMAKE_CURRENT_BINARY_DIR}/../${YAJL_DIST_NAME}/lib)
|
||||||
|
SET (incDir ${CMAKE_CURRENT_BINARY_DIR}/../${YAJL_DIST_NAME}/include/yajl)
|
||||||
|
-SET (shareDir ${CMAKE_CURRENT_BINARY_DIR}/../${YAJL_DIST_NAME}/share/pkgconfig)
|
||||||
|
+SET (pkgconfigDir ${CMAKE_CURRENT_BINARY_DIR}/../${YAJL_DIST_NAME}/lib/pkgconfig)
|
||||||
|
|
||||||
|
# set the output path for libraries
|
||||||
|
SET(LIBRARY_OUTPUT_PATH ${libDir})
|
||||||
|
@@ -61,7 +61,7 @@ FILE(MAKE_DIRECTORY ${incDir})
|
||||||
|
# generate build-time source
|
||||||
|
SET(dollar $)
|
||||||
|
CONFIGURE_FILE(api/yajl_version.h.cmake ${incDir}/yajl_version.h)
|
||||||
|
-CONFIGURE_FILE(yajl.pc.cmake ${shareDir}/yajl.pc)
|
||||||
|
+CONFIGURE_FILE(yajl.pc.cmake ${pkgconfigDir}/yajl.pc)
|
||||||
|
|
||||||
|
# copy public headers to output directory
|
||||||
|
FOREACH (header ${PUB_HDRS})
|
||||||
|
@@ -82,5 +82,5 @@ IF(NOT WIN32)
|
||||||
|
INSTALL(TARGETS yajl_s ARCHIVE DESTINATION lib${LIB_SUFFIX})
|
||||||
|
INSTALL(FILES ${PUB_HDRS} DESTINATION include/yajl)
|
||||||
|
INSTALL(FILES ${incDir}/yajl_version.h DESTINATION include/yajl)
|
||||||
|
- INSTALL(FILES ${shareDir}/yajl.pc DESTINATION share/pkgconfig)
|
||||||
|
+ INSTALL(FILES ${pkgconfigDir}/yajl.pc DESTINATION lib${LIB_SUFFIX}/pkgconfig)
|
||||||
|
ENDIF()
|
||||||
|
Only in lloyd-yajl-fee1ebe.new/src: CMakeLists.txt~
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
df6a751e7797b9c2182efd91b5d64017 lloyd-yajl-2.0.1-0-gf4b2b1a.tar.gz
|
ee6208e697c43dcccf798ce80d370379 lloyd-yajl-2.0.4-0-gfee1ebe.tar.gz
|
||||||
|
14
yajl.spec
14
yajl.spec
@ -1,6 +1,6 @@
|
|||||||
Name: yajl
|
Name: yajl
|
||||||
Version: 2.0.1
|
Version: 2.0.4
|
||||||
Release: 3%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Yet Another JSON Library (YAJL)
|
Summary: Yet Another JSON Library (YAJL)
|
||||||
|
|
||||||
Group: Development/Libraries
|
Group: Development/Libraries
|
||||||
@ -26,8 +26,10 @@ URL: http://lloyd.github.com/yajl/
|
|||||||
#
|
#
|
||||||
# So for new versions, update 'githash' to match the hash of the
|
# So for new versions, update 'githash' to match the hash of the
|
||||||
# GIT tag associated with updated 'Version:' field just above
|
# GIT tag associated with updated 'Version:' field just above
|
||||||
%global githash f4b2b1a
|
%global githash fee1ebe
|
||||||
Source0: lloyd-%{name}-%{version}-0-g%{githash}.tar.gz
|
Source0: lloyd-%{name}-%{version}-0-g%{githash}.tar.gz
|
||||||
|
Patch1: lloyd-%{name}-%{version}-pkgconfig-location.patch
|
||||||
|
Patch2: lloyd-%{name}-%{version}-pkgconfig-includedir.patch
|
||||||
|
|
||||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||||
BuildRequires: cmake
|
BuildRequires: cmake
|
||||||
@ -51,6 +53,8 @@ necessary for developing against the YAJL library
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -n lloyd-%{name}-%{githash}
|
%setup -q -n lloyd-%{name}-%{githash}
|
||||||
|
%patch1 -p1
|
||||||
|
%patch2 -p1
|
||||||
|
|
||||||
%build
|
%build
|
||||||
# NB, we are not using upstream's 'configure'/'make'
|
# NB, we are not using upstream's 'configure'/'make'
|
||||||
@ -101,9 +105,13 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{_includedir}/yajl/yajl_tree.h
|
%{_includedir}/yajl/yajl_tree.h
|
||||||
%{_includedir}/yajl/yajl_version.h
|
%{_includedir}/yajl/yajl_version.h
|
||||||
%{_libdir}/libyajl.so
|
%{_libdir}/libyajl.so
|
||||||
|
%{_libdir}/pkgconfig/yajl.pc
|
||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Mon Aug 6 2012 Daniel P. Berrange <berrange@redhat.com> - 2.0.4-1
|
||||||
|
- Update to 2.0.4 release (rhbz #845777)
|
||||||
|
|
||||||
* Sun Jul 22 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.1-3
|
* Sun Jul 22 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.0.1-3
|
||||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user