Update to 1.0.11 release

This commit is contained in:
Daniel P. Berrange 2010-12-17 16:33:47 +00:00
parent cc297900e1
commit 4662875741
5 changed files with 14 additions and 47 deletions

1
.gitignore vendored
View File

@ -3,3 +3,4 @@
i386
x86_64
lloyd-yajl-45a1bdb.tar.gz
/lloyd-yajl-1.0.11-0-gf4baae0.tar.gz

View File

@ -1,12 +0,0 @@
diff -rup lloyd-yajl-45a1bdb.orig/CMakeLists.txt lloyd-yajl-45a1bdb.new/CMakeLists.txt
--- lloyd-yajl-45a1bdb.orig/CMakeLists.txt 2009-10-29 23:35:39.000000000 +0000
+++ lloyd-yajl-45a1bdb.new/CMakeLists.txt 2010-01-11 17:14:01.000000000 +0000
@@ -42,7 +42,7 @@ IF (NOT CMAKE_BUILD_TYPE)
SET(CMAKE_BUILD_TYPE "Release")
ENDIF (NOT CMAKE_BUILD_TYPE)
-SET(CMAKE_C_FLAGS "-Wall")
+SET(CMAKE_C_FLAGS "${CMAKE_C_FLAGS} -Wall")
IF (WIN32)
ADD_DEFINITIONS(-DWIN32)
SET(linkFlags "/PDB:NONE /INCREMENTAL:NO /OPT:NOREF /OPT:NOICF")

View File

@ -1,23 +0,0 @@
diff -rup lloyd-yajl-45a1bdb.orig/src/CMakeLists.txt lloyd-yajl-45a1bdb.new/src/CMakeLists.txt
--- lloyd-yajl-45a1bdb.orig/src/CMakeLists.txt 2009-10-29 23:35:39.000000000 +0000
+++ lloyd-yajl-45a1bdb.new/src/CMakeLists.txt 2009-12-07 17:20:20.000000000 +0000
@@ -37,7 +37,7 @@ SET (PUB_HDRS api/yajl_parse.h api/yajl_
#ADD_DEFINITIONS(-DYAJL_LEXER_DEBUG)
# set up some paths
-SET (libDir ${CMAKE_CURRENT_BINARY_DIR}/../${YAJL_DIST_NAME}/lib)
+SET (libDir ${CMAKE_CURRENT_BINARY_DIR}/../${YAJL_DIST_NAME}/${LIB_INSTALL_DIR})
SET (incDir ${CMAKE_CURRENT_BINARY_DIR}/../${YAJL_DIST_NAME}/include/yajl)
# set the output path for libraries
@@ -71,8 +71,8 @@ ENDFOREACH (header ${PUB_HDRS})
INCLUDE_DIRECTORIES(${incDir}/..)
IF(NOT WIN32)
- INSTALL(TARGETS yajl LIBRARY DESTINATION lib)
- INSTALL(TARGETS yajl_s ARCHIVE DESTINATION lib)
+ INSTALL(TARGETS yajl LIBRARY DESTINATION ${LIB_INSTALL_DIR})
+ INSTALL(TARGETS yajl_s ARCHIVE DESTINATION ${LIB_INSTALL_DIR})
INSTALL(DIRECTORY api/ DESTINATION include/yajl
FILES_MATCHING PATTERN "*.h")
ENDIF()

View File

@ -1 +1 @@
3b6551d07d493817f87624fa73dc7d5e lloyd-yajl-45a1bdb.tar.gz
5b60f4d59b3b1fb42d7808d08460fb12 lloyd-yajl-1.0.11-0-gf4baae0.tar.gz

View File

@ -1,6 +1,6 @@
Name: yajl
Version: 1.0.7
Release: 3%{?dist}
Version: 1.0.11
Release: 1%{?dist}
Summary: Yet Another JSON Library (YAJL)
Group: Development/Libraries
@ -26,10 +26,8 @@ URL: http://lloyd.github.com/yajl/
#
# So for new versions, update 'githash' to match the hash of the
# GIT tag associated with updated 'Version:' field just above
%global githash 45a1bdb
Source0: lloyd-%{name}-%{githash}.tar.gz
Patch1: lloyd-%{name}-lib64.patch
Patch2: lloyd-%{name}-cflags.patch
%global githash f4baae0
Source0: lloyd-%{name}-%{version}-0-g%{githash}.tar.gz
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: cmake
@ -53,10 +51,6 @@ necessary for developing against the YAJL library
%prep
%setup -q -n lloyd-%{name}-%{githash}
# Fix lib vs lib64 problems
%patch1 -p1
# Fix ignoring of CFLAGS
%patch2 -p1
%build
# NB, we are not using upstream's 'configure'/'make'
@ -72,6 +66,9 @@ make VERBOSE=1 %{?_smp_mflags}
rm -rf $RPM_BUILD_ROOT
cd build
make install DESTDIR=$RPM_BUILD_ROOT
mv $RPM_BUILD_ROOT%{_includedir}/yajl/yajl_version.h.cmake \
$RPM_BUILD_ROOT%{_includedir}/yajl/yajl_version.h
# No static libraries
rm -f $RPM_BUILD_ROOT%{_libdir}/libyajl_s.a
@ -94,7 +91,7 @@ rm -rf $RPM_BUILD_ROOT
%{_bindir}/json_reformat
%{_bindir}/json_verify
%{_libdir}/libyajl.so.1
%{_libdir}/libyajl.so.1.0.7
%{_libdir}/libyajl.so.1.*
%files devel
%defattr(-,root,root,-)
@ -103,10 +100,14 @@ rm -rf $RPM_BUILD_ROOT
%{_includedir}/yajl/yajl_common.h
%{_includedir}/yajl/yajl_gen.h
%{_includedir}/yajl/yajl_parse.h
%{_includedir}/yajl/yajl_version.h
%{_libdir}/libyajl.so
%changelog
* Fri Dec 17 2010 Daniel P. Berrange <berrange@redhat.com> - 1.0.11-1
- Update to 1.0.11 release
* Mon Jan 11 2010 Daniel P. Berrange <berrange@redhat.com> - 1.0.7-3
- Fix ignoring of cflags (rhbz #547500)