Initial import to brew from fedora
This commit is contained in:
parent
677459a7d4
commit
e430945589
9
STAGE1-xz
Normal file
9
STAGE1-xz
Normal file
@ -0,0 +1,9 @@
|
||||
srpm xz
|
||||
mcd $BUILDDIR/$1
|
||||
$SRC/${1}-*/configure \
|
||||
--prefix=/usr \
|
||||
--libdir=/usr/lib${SUFFIX} \
|
||||
--build=$BUILD \
|
||||
--host=$TARGET
|
||||
make $J V=1
|
||||
make $J install DESTDIR=${ROOTFS}
|
5
colorxzgrep.csh
Normal file
5
colorxzgrep.csh
Normal file
@ -0,0 +1,5 @@
|
||||
/usr/libexec/grepconf.sh -c
|
||||
if ( $status == 1 ) exit
|
||||
alias xzgrep 'xzgrep --color=auto'
|
||||
alias xzfgrep 'xzfgrep --color=auto'
|
||||
alias xzegrep 'xzegrep --color=auto'
|
4
colorxzgrep.sh
Normal file
4
colorxzgrep.sh
Normal file
@ -0,0 +1,4 @@
|
||||
/usr/libexec/grepconf.sh -c || return
|
||||
alias xzgrep='xzgrep --color=auto' 2>/dev/null
|
||||
alias xzegrep='xzegrep --color=auto' 2>/dev/null
|
||||
alias xzfgrep='xzfgrep --color=auto' 2>/dev/null
|
13
xz-5.1.2alpha-less-version-check.patch
Normal file
13
xz-5.1.2alpha-less-version-check.patch
Normal file
@ -0,0 +1,13 @@
|
||||
diff --git a/src/scripts/xzless.in b/src/scripts/xzless.in
|
||||
index a3da697..288dd87 100644
|
||||
--- a/src/scripts/xzless.in
|
||||
+++ b/src/scripts/xzless.in
|
||||
@@ -46,7 +46,7 @@ if test "${LESSMETACHARS+set}" != set; then
|
||||
LESSMETACHARS="$space$tab$nl'"';*?"()<>[|&^`#\$%=~'
|
||||
fi
|
||||
|
||||
-if test "$(less -V | { read ver && echo ${ver#less }; })" -ge 429; then
|
||||
+if test "$(less -V | { read less ver re && echo ${ver}; })" -ge 429; then
|
||||
# less 429 or later: LESSOPEN pipe will be used on
|
||||
# standard input if $LESSOPEN begins with |-.
|
||||
LESSOPEN="|-$xz -cdfq -- %s"
|
81
xz-5.1.2alpha-man-page-day.patch
Normal file
81
xz-5.1.2alpha-man-page-day.patch
Normal file
@ -0,0 +1,81 @@
|
||||
diff --git a/src/xz/message.c b/src/xz/message.c
|
||||
index abbd171..ce953ac 100644
|
||||
--- a/src/xz/message.c
|
||||
+++ b/src/xz/message.c
|
||||
@@ -1110,7 +1110,8 @@ message_help(bool long_help)
|
||||
|
||||
puts(_(
|
||||
" -z, --compress force compression\n"
|
||||
-" -d, --decompress force decompression\n"
|
||||
+" -d, --decompress, --uncompress\n"
|
||||
+" force decompression\n"
|
||||
" -t, --test test compressed file integrity\n"
|
||||
" -l, --list list information about .xz files"));
|
||||
|
||||
@@ -1120,7 +1121,8 @@ message_help(bool long_help)
|
||||
puts(_(
|
||||
" -k, --keep keep (don't delete) input files\n"
|
||||
" -f, --force force overwrite of output file and (de)compress links\n"
|
||||
-" -c, --stdout write to standard output and don't delete input files"));
|
||||
+" -c, --stdout, --to-stdout\n"
|
||||
+" write to standard output and don't delete input files"));
|
||||
|
||||
if (long_help) {
|
||||
puts(_(
|
||||
@@ -1152,6 +1154,10 @@ message_help(bool long_help)
|
||||
" -e, --extreme try to improve compression ratio by using more CPU time;\n"
|
||||
" does not affect decompressor memory requirements"));
|
||||
|
||||
+ puts(_(
|
||||
+" -T, --threads=NUM use at most NUM threads; the default is 1; set to 0\n"
|
||||
+" to use the number of processor cores"));
|
||||
+
|
||||
if (long_help) {
|
||||
// FIXME? Mention something about threading?
|
||||
puts(_(
|
||||
@@ -1166,7 +1172,7 @@ message_help(bool long_help)
|
||||
puts(_( // xgettext:no-c-format
|
||||
" --memlimit-compress=LIMIT\n"
|
||||
" --memlimit-decompress=LIMIT\n"
|
||||
-" -M, --memlimit=LIMIT\n"
|
||||
+" -M, --memlimit=LIMIT, (old alias --memory=LIMIT)\n"
|
||||
" set memory usage limit for compression, decompression,\n"
|
||||
" or both; LIMIT is in bytes, % of RAM, or 0 for defaults"));
|
||||
|
||||
diff --git a/src/xz/xz.1 b/src/xz/xz.1
|
||||
index 0368f05..e5da140 100644
|
||||
--- a/src/xz/xz.1
|
||||
+++ b/src/xz/xz.1
|
||||
@@ -912,7 +912,7 @@ See
|
||||
for possible ways to specify the
|
||||
.IR limit .
|
||||
.TP
|
||||
-\fB\-M\fR \fIlimit\fR, \fB\-\-memlimit=\fIlimit\fR, \fB\-\-memory=\fIlimit
|
||||
+\fB\-M\fR \fIlimit\fR, \fB\-\-memlimit=\fIlimit\fR, (old alias \fB\-\-memory=\fIlimit\fR)
|
||||
This is equivalent to specifying \fB\-\-memlimit\-compress=\fIlimit
|
||||
\fB\-\-memlimit\-decompress=\fIlimit\fR.
|
||||
.TP
|
||||
diff --git a/src/xzdec/xzdec.c b/src/xzdec/xzdec.c
|
||||
index b7830db..48ac1fe 100644
|
||||
--- a/src/xzdec/xzdec.c
|
||||
+++ b/src/xzdec/xzdec.c
|
||||
@@ -64,13 +64,15 @@ help(void)
|
||||
"Usage: %s [OPTION]... [FILE]...\n"
|
||||
"Uncompress files in the ." TOOL_FORMAT " format to the standard output.\n"
|
||||
"\n"
|
||||
-" -c, --stdout (ignored)\n"
|
||||
-" -d, --decompress (ignored)\n"
|
||||
-" -k, --keep (ignored)\n"
|
||||
" -q, --quiet specify *twice* to suppress errors\n"
|
||||
-" -Q, --no-warn (ignored)\n"
|
||||
" -h, --help display this help and exit\n"
|
||||
" -V, --version display the version number and exit\n"
|
||||
+" -c, --stdout, --to-stdout\n"
|
||||
+" ignored, data are always written to standard output\n"
|
||||
+" -d, --decompress, --uncompress\n"
|
||||
+" ignored, only decompression is supported\n"
|
||||
+" -k, --keep ignored, we never create/remove any files\n"
|
||||
+" -Q, --no-warn ignored, we never use exit status 2\n"
|
||||
"\n"
|
||||
"With no FILE, or when FILE is -, read standard input.\n"
|
||||
"\n"
|
23
xz-5.1.2alpha-xzgrep-and-h-option.patch
Normal file
23
xz-5.1.2alpha-xzgrep-and-h-option.patch
Normal file
@ -0,0 +1,23 @@
|
||||
commit 5019413a055ce29e660dbbf15e02443cb5a26c59
|
||||
Author: Jeff Bastian <jbastian@redhat.com>
|
||||
AuthorDate: Wed Apr 3 13:59:17 2013 +0200
|
||||
Commit: Lasse Collin <lasse.collin@tukaani.org>
|
||||
CommitDate: Fri Apr 5 19:14:50 2013 +0300
|
||||
|
||||
xzgrep: make the '-h' option to be --no-filename equivalent
|
||||
|
||||
* src/scripts/xzgrep.in: Accept the '-h' option in argument parsing.
|
||||
|
||||
diff --git a/src/scripts/xzgrep.in b/src/scripts/xzgrep.in
|
||||
index d8e9bb5..951266b 100644
|
||||
--- a/src/scripts/xzgrep.in
|
||||
+++ b/src/scripts/xzgrep.in
|
||||
@@ -109,7 +109,7 @@ while test $# -ne 0; do
|
||||
files_with_matches=1;;
|
||||
(-L | --files-witho*)
|
||||
files_without_matches=1;;
|
||||
- (--no-f*)
|
||||
+ (-h | --no-f*)
|
||||
no_filename=1;;
|
||||
(-V | --v | --ve | --ver | --vers | --versi | --versio | --version)
|
||||
echo "$version" || exit 2
|
60
xz-5.1.2alpha-xzgrep-exit-test.patch
Normal file
60
xz-5.1.2alpha-xzgrep-exit-test.patch
Normal file
@ -0,0 +1,60 @@
|
||||
commit 1e60f2c0a0ee6c18b02943ce56214799a70aac26 (HEAD, origin/master, origin/HEAD, master)
|
||||
Author: Lasse Collin <lasse.collin@tukaani.org>
|
||||
AuthorDate: Wed Jun 11 21:03:25 2014 +0300
|
||||
Commit: Lasse Collin <lasse.collin@tukaani.org>
|
||||
CommitDate: Wed Jun 11 21:03:25 2014 +0300
|
||||
|
||||
xzgrep: Add a test for the previous fix.
|
||||
|
||||
This is a simplified version of Pavel Raiskup's
|
||||
original patch.
|
||||
|
||||
diff --git a/tests/test_scripts.sh b/tests/test_scripts.sh
|
||||
index 293929e..7ac1fea 100755
|
||||
--- a/tests/test_scripts.sh
|
||||
+++ b/tests/test_scripts.sh
|
||||
@@ -12,16 +12,18 @@
|
||||
# If scripts weren't built, this test is skipped.
|
||||
XZ=../src/xz/xz
|
||||
XZDIFF=../src/scripts/xzdiff
|
||||
-test -x "$XZ" || XZ=
|
||||
-test -x "$XZDIFF" || XZDIFF=
|
||||
-if test -z "$XZ" || test -z "$XZDIFF"; then
|
||||
+XZGREP=../src/scripts/xzgrep
|
||||
+
|
||||
+for i in XZ XZDIFF XZGREP; do
|
||||
+ eval test -x "\$$i" && continue
|
||||
(exit 77)
|
||||
exit 77
|
||||
-fi
|
||||
+done
|
||||
|
||||
PATH=`pwd`/../src/xz:$PATH
|
||||
export PATH
|
||||
|
||||
+test -z "$srcdir" && srcdir=.
|
||||
preimage=$srcdir/files/good-1-check-crc32.xz
|
||||
samepostimage=$srcdir/files/good-1-check-crc64.xz
|
||||
otherpostimage=$srcdir/files/good-1-lzma2-1.xz
|
||||
@@ -50,5 +52,21 @@ if test "$status" != 2 ; then
|
||||
exit 1
|
||||
fi
|
||||
|
||||
+# The exit status must be 0 when a match was found at least from one file,
|
||||
+# and 1 when no match was found in any file.
|
||||
+for pattern in el Hello NOMATCH; do
|
||||
+ for opts in "" "-l" "-h" "-H"; do
|
||||
+ "$XZGREP" $opts $pattern \
|
||||
+ "$srcdir/files/good-1-lzma2-1.xz" \
|
||||
+ "$srcdir/files/good-2-lzma2.xz" > /dev/null 2>&1
|
||||
+ status=$?
|
||||
+ test $status = 0 && test $pattern != NOMATCH && continue
|
||||
+ test $status = 1 && test $pattern = NOMATCH && continue
|
||||
+ echo "wrong exit status from xzgrep"
|
||||
+ (exit 1)
|
||||
+ exit 1
|
||||
+ done
|
||||
+done
|
||||
+
|
||||
(exit 0)
|
||||
exit 0
|
50
xz-5.1.2alpha-xzgrep-exit.patch
Normal file
50
xz-5.1.2alpha-xzgrep-exit.patch
Normal file
@ -0,0 +1,50 @@
|
||||
commit ceca37901783988204caaf40dff4623d535cc789
|
||||
Author: Lasse Collin <lasse.collin@tukaani.org>
|
||||
AuthorDate: Wed Jun 11 20:43:28 2014 +0300
|
||||
Commit: Lasse Collin <lasse.collin@tukaani.org>
|
||||
CommitDate: Wed Jun 11 20:43:28 2014 +0300
|
||||
|
||||
xzgrep: exit 0 when at least one file matches.
|
||||
|
||||
Mimic the original grep behavior and return exit_success when
|
||||
at least one xz compressed file matches given pattern.
|
||||
|
||||
Original bugreport:
|
||||
https://bugzilla.redhat.com/show_bug.cgi?id=1108085
|
||||
|
||||
Thanks to Pavel Raiskup for the patch.
|
||||
|
||||
diff --git a/src/scripts/xzgrep.in b/src/scripts/xzgrep.in
|
||||
index 951266b..018915f 100644
|
||||
--- a/src/scripts/xzgrep.in
|
||||
+++ b/src/scripts/xzgrep.in
|
||||
@@ -147,7 +147,9 @@ if test $# -eq 0; then
|
||||
fi
|
||||
|
||||
exec 3>&1
|
||||
-res=0
|
||||
+
|
||||
+# res=1 means that no file matched yet
|
||||
+res=1
|
||||
|
||||
for i; do
|
||||
case $i in
|
||||
@@ -195,8 +197,17 @@ for i; do
|
||||
fi >&3 5>&-
|
||||
)
|
||||
r=$?
|
||||
+
|
||||
+ # fail occured previously, nothing worse can happen
|
||||
+ test $res -gt 1 && continue
|
||||
+
|
||||
test "$xz_status" -eq 0 || test "$xz_status" -eq 2 \
|
||||
|| test "$(kill -l "$xz_status" 2> /dev/null)" = "PIPE" || r=2
|
||||
- test $res -lt $r && res=$r
|
||||
+
|
||||
+ # still no match
|
||||
+ test $r -eq 1 && continue
|
||||
+
|
||||
+ # 0 == match, >=2 == fail
|
||||
+ res=$r
|
||||
done
|
||||
exit $res
|
319
xz.spec
Normal file
319
xz.spec
Normal file
@ -0,0 +1,319 @@
|
||||
# Not needed for f21+ and probably RHEL8+
|
||||
%{!?_licensedir:%global license %%doc}
|
||||
|
||||
Summary: LZMA compression utilities
|
||||
Name: xz
|
||||
Version: 5.2.3
|
||||
Release: 2%{?dist}
|
||||
|
||||
# Scripts xz{grep,diff,less,more} and symlinks (copied from gzip) are
|
||||
# GPLv2+, binaries are Public Domain (linked against LGPL getopt_long but its
|
||||
# OK), documentation is Public Domain.
|
||||
License: GPLv2+ and Public Domain
|
||||
Group: Applications/File
|
||||
# official upstream release
|
||||
Source0: http://tukaani.org/%{name}/%{name}-%{version}.tar.xz
|
||||
|
||||
Source100: colorxzgrep.sh
|
||||
Source101: colorxzgrep.csh
|
||||
|
||||
URL: http://tukaani.org/%{name}/
|
||||
Requires: %{name}-libs%{?_isa} = %{version}-%{release}
|
||||
|
||||
# For /usr/libexec/grepconf.sh (RHBZ#1189120).
|
||||
# Unfortunately F21 has a newer version of grep which doesn't
|
||||
# have grepconf, but we're only concerned with F22 here.
|
||||
Requires: grep >= 2.20-5
|
||||
|
||||
BuildRequires: perl
|
||||
|
||||
|
||||
%description
|
||||
XZ Utils are an attempt to make LZMA compression easy to use on free (as in
|
||||
freedom) operating systems. This is achieved by providing tools and libraries
|
||||
which are similar to use than the equivalents of the most popular existing
|
||||
compression algorithms.
|
||||
|
||||
LZMA is a general purpose compression algorithm designed by Igor Pavlov as
|
||||
part of 7-Zip. It provides high compression ratio while keeping the
|
||||
decompression speed fast.
|
||||
|
||||
%package libs
|
||||
Summary: Libraries for decoding LZMA compression
|
||||
Group: System Environment/Libraries
|
||||
License: Public Domain
|
||||
Obsoletes: %{name}-compat-libs < %{version}-%{release}
|
||||
|
||||
%description libs
|
||||
Libraries for decoding files compressed with LZMA or XZ utils.
|
||||
|
||||
%package static
|
||||
Summary: Statically linked library for decoding LZMA compression
|
||||
Group: System Environment/Libraries
|
||||
License: Public Domain
|
||||
|
||||
%description static
|
||||
Statically linked library for decoding files compressed with LZMA or
|
||||
XZ utils. Most users should *not* install this.
|
||||
|
||||
%package devel
|
||||
Summary: Devel libraries & headers for liblzma
|
||||
Group: Development/Libraries
|
||||
License: Public Domain
|
||||
Requires: %{name}-libs%{?_isa} = %{version}-%{release}
|
||||
Requires: pkgconfig
|
||||
|
||||
%description devel
|
||||
Devel libraries and headers for liblzma.
|
||||
|
||||
%package lzma-compat
|
||||
Summary: Older LZMA format compatibility binaries
|
||||
Group: Development/Libraries
|
||||
# Just a set of symlinks to 'xz' + two Public Domain binaries.
|
||||
License: Public Domain
|
||||
Requires: %{name}%{?_isa} = %{version}-%{release}
|
||||
Obsoletes: lzma < %{version}
|
||||
Provides: lzma = %{version}
|
||||
|
||||
%description lzma-compat
|
||||
The lzma-compat package contains compatibility links for older
|
||||
commands that deal with the older LZMA format.
|
||||
|
||||
%prep
|
||||
%setup -q
|
||||
|
||||
for i in `find . -name config.sub`; do
|
||||
perl -pi -e "s/ppc64-\*/ppc64-\* \| ppc64p7-\*/" $i
|
||||
done
|
||||
|
||||
%build
|
||||
CFLAGS="%{optflags} -D_FILE_OFFSET_BITS=64"
|
||||
%ifarch %{power64}
|
||||
CFLAGS=`echo $CFLAGS | xargs -n 1 | sed 's|^-O2$|-O3|g' | xargs -n 100`
|
||||
%endif
|
||||
export CFLAGS
|
||||
|
||||
%configure
|
||||
sed -i 's|^hardcode_libdir_flag_spec=.*|hardcode_libdir_flag_spec=""|g' libtool
|
||||
sed -i 's|^runpath_var=LD_RUN_PATH|runpath_var=DIE_RPATH_DIE|g' libtool
|
||||
make %{?_smp_mflags}
|
||||
|
||||
%install
|
||||
make install DESTDIR=%{buildroot}
|
||||
rm -f %{buildroot}%{_libdir}/*.la
|
||||
|
||||
# xzgrep colorization
|
||||
%global profiledir %{_sysconfdir}/profile.d
|
||||
mkdir -p %{buildroot}%{profiledir}
|
||||
install -p -m 644 %{SOURCE100} %{buildroot}%{profiledir}
|
||||
install -p -m 644 %{SOURCE101} %{buildroot}%{profiledir}
|
||||
|
||||
%find_lang %name
|
||||
|
||||
%check
|
||||
LD_LIBRARY_PATH=$PWD/src/liblzma/.libs make check
|
||||
|
||||
%post libs -p /sbin/ldconfig
|
||||
|
||||
%postun libs -p /sbin/ldconfig
|
||||
|
||||
%files -f %{name}.lang
|
||||
%license %{_pkgdocdir}/COPYING*
|
||||
%doc %{_pkgdocdir}
|
||||
%exclude %_pkgdocdir/examples*
|
||||
%{_bindir}/*xz*
|
||||
%{_mandir}/man1/*xz*
|
||||
%{profiledir}/*
|
||||
|
||||
%files libs
|
||||
%license %{_pkgdocdir}/COPYING
|
||||
%{_libdir}/lib*.so.5*
|
||||
|
||||
%files static
|
||||
%license %{_pkgdocdir}/COPYING
|
||||
%{_libdir}/liblzma.a
|
||||
|
||||
%files devel
|
||||
%dir %{_includedir}/lzma
|
||||
%{_includedir}/lzma/*.h
|
||||
%{_includedir}/lzma.h
|
||||
%{_libdir}/*.so
|
||||
%{_libdir}/pkgconfig/liblzma.pc
|
||||
%doc %_pkgdocdir/examples*
|
||||
|
||||
%files lzma-compat
|
||||
%{_bindir}/*lz*
|
||||
%{_mandir}/man1/*lz*
|
||||
|
||||
%changelog
|
||||
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 5.2.3-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||
|
||||
* Mon Jan 02 2017 Pavel Raiskup <praiskup@redhat.com> - 5.2.3-1
|
||||
- rebase to stable 5.2.3 per release notes:
|
||||
http://www.mail-archive.com/xz-devel@tukaani.org/msg00285.html
|
||||
|
||||
* Mon Nov 28 2016 Lubomir Rintel <lkundrak@v3.sk> - 5.2.2-3
|
||||
- Fix FTBFS by requiring Perl
|
||||
|
||||
* Fri Feb 05 2016 Fedora Release Engineering <releng@fedoraproject.org> - 5.2.2-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||
|
||||
* Tue Sep 29 2015 Pavel Raiskup <praiskup@redhat.com> - 5.2.2-1
|
||||
- rebase to stable 5.2.2 per release notes:
|
||||
http://www.mail-archive.com/xz-devel@tukaani.org/msg00244.html
|
||||
|
||||
* Thu Jul 09 2015 Pavel Raiskup <praiskup@redhat.com> - 5.2.1-3
|
||||
- remove xz-compat-libs as it is not necessary (#1179193)
|
||||
|
||||
* Fri Jun 19 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.2.1-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||
|
||||
* Fri Feb 27 2015 Pavel Raiskup <praiskup@redhat.com> - 5.2.1-1
|
||||
- bugfix rebase to 5.2.1, per release notes
|
||||
http://www.mail-archive.com/xz-devel@tukaani.org/msg00226.html
|
||||
|
||||
* Wed Feb 04 2015 Richard W.M. Jones <rjones@redhat.com> - 5.2.0-2
|
||||
- Depend on grep that contains grepconf.sh (#1189120)
|
||||
|
||||
* Tue Dec 23 2014 Pavel Raiskup <praiskup@redhat.com> - 5.2.0-1
|
||||
- rebase per upstream release notes (#1023718)
|
||||
http://www.mail-archive.com/xz-devel@tukaani.org/msg00216.html
|
||||
- fedora-review fixes, documentation/license fixes in spec
|
||||
|
||||
* Tue Aug 26 2014 Pavel Raiskup <praiskup@redhat.com> - 5.1.2-15alpha
|
||||
- xz*grep's output is colored iff grep's is (#1034846)
|
||||
|
||||
* Mon Aug 18 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.1.2-14alpha
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
|
||||
|
||||
* Wed Aug 6 2014 Tom Callaway <spot@fedoraproject.org> - 5.1.2-13alpha
|
||||
- fix license handling
|
||||
|
||||
* Fri Jun 13 2014 Pavel Raiskup <praiskup@redhat.com> - 5.1.2-12alpha
|
||||
- xzgrep: return 0 when at least one file matches (#1109122)
|
||||
|
||||
* Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.1.2-11alpha
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||
|
||||
* Sat May 31 2014 Peter Robinson <pbrobinson@fedoraproject.org> 5.1.2-10alpha
|
||||
- Drop ChangeLog, it's big and the excitement is summarised in NEWS
|
||||
|
||||
* Fri May 16 2014 Richard W.M. Jones <rjones@redhat.com> - 5.1.2-9alpha
|
||||
- Add a -static subpackage (see RHBZ#547011).
|
||||
|
||||
* Wed Apr 02 2014 Pavel Raiskup <praiskup@redhat.com> - 5.1.2-8alpha
|
||||
- add _isa requirements where appropriate
|
||||
- better check the version of less binary (#1015924)
|
||||
|
||||
* Fri Jan 10 2014 Pavel Raiskup <praiskup@redhat.com> - 5.1.2-7alpha
|
||||
- build with -O3 on ppc64 (private #1051078)
|
||||
|
||||
* Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.1.2-6alpha
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||
|
||||
* Tue Apr 09 2013 Pavel Raiskup <praiskup@redhat.com> - 5.1.2-5alpha
|
||||
- fix manual page inconsistencies with help output (private #948533)
|
||||
- enable/fix the 'xzgrep -h' (private #850898)
|
||||
|
||||
* Thu Feb 21 2013 Karsten Hopp <karsten@redhat.com> 5.1.2-4alpha
|
||||
- add support for ppc64p7 arch (Power7 optimized)
|
||||
|
||||
* Fri Feb 15 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.1.2-3alpha
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
||||
|
||||
* Sun Jul 22 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.1.2-2alpha
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||
|
||||
* Thu Jul 05 2012 Jindrich Novy <jnovy@redhat.com> 5.1.2alpha-1
|
||||
- update to 5.1.2alpha
|
||||
|
||||
* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.1.1-2alpha
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
|
||||
|
||||
* Sun Oct 16 2011 Jindrich Novy <jnovy@redhat.com> 5.1.1alpha-1
|
||||
- update to 5.1.1alpha
|
||||
|
||||
* Mon Jun 20 2011 Jindrich Novy <jnovy@redhat.com> 5.0.3-2
|
||||
- better to have upstream tarballs in different formats than XZ
|
||||
to allow bootstrapping (#714765)
|
||||
|
||||
* Mon May 23 2011 Jindrich Novy <jnovy@redhat.com> 5.0.3-1
|
||||
- update to 5.0.3
|
||||
|
||||
* Mon Apr 04 2011 Jindrich Novy <jnovy@redhat.com> 5.0.2-1
|
||||
- update to 5.0.2
|
||||
|
||||
* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 5.0.1-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
||||
|
||||
* Sat Jan 29 2011 Jindrich Novy <jnovy@redhat.com> 5.0.1-1
|
||||
- update to 5.0.1
|
||||
|
||||
* Tue Oct 26 2010 Jindrich Novy <jnovy@redhat.com> 5.0.0-4
|
||||
- call ldconfig for compat-libs and fix description
|
||||
|
||||
* Mon Oct 25 2010 Jindrich Novy <jnovy@redhat.com> 5.0.0-3
|
||||
- introduce compat-libs subpackage with older soname to
|
||||
resolve problems with soname bump and for packages requiring
|
||||
older xz-4.999.9beta
|
||||
|
||||
* Mon Oct 25 2010 Jindrich Novy <jnovy@redhat.com> 5.0.0-2
|
||||
- rebuild
|
||||
|
||||
* Mon Oct 25 2010 Jindrich Novy <jnovy@redhat.com> 5.0.0-1
|
||||
- update to the new upstream release
|
||||
|
||||
* Sat Oct 16 2010 Jindrich Novy <jnovy@redhat.com> 4.999.9-0.3.beta.212.gacbc
|
||||
- update to latest git snapshot
|
||||
|
||||
* Thu Apr 01 2010 Jindrich Novy <jnovy@redhat.com> 4.999.9-0.2.20100401.beta
|
||||
- sync with upstream (#578925)
|
||||
|
||||
* Thu Feb 18 2010 Jindrich Novy <jnovy@redhat.com> 4.999.9-0.2.20091007.beta
|
||||
- move xz man pages to main package, leave lzma ones where they belong (#566484)
|
||||
|
||||
* Wed Oct 07 2009 Jindrich Novy <jnovy@redhat.com> 4.999.9-0.1.20091007.beta
|
||||
- sync with upstream again
|
||||
|
||||
* Fri Oct 02 2009 Jindrich Novy <jnovy@redhat.com> 4.999.9-0.1.20091002.beta
|
||||
- sync with upstream to generate the same archives on machines with different
|
||||
endianess
|
||||
|
||||
* Fri Aug 28 2009 Jindrich Novy <jnovy@redhat.com> 4.999.9-0.1.beta
|
||||
- update to 4.999.9beta
|
||||
|
||||
* Mon Aug 17 2009 Jindrich Novy <jnovy@redhat.com> 4.999.8-0.10.beta.20090817git
|
||||
- sync with upstream because of #517806
|
||||
|
||||
* Tue Aug 04 2009 Jindrich Novy <jnovy@redhat.com> 4.999.8-0.9.beta.20090804git
|
||||
- update to the latest GIT snapshot
|
||||
|
||||
* Mon Jul 27 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 4.999.8-0.8.beta
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
|
||||
|
||||
* Fri Jul 17 2009 Bill Nottingham <notting@redhat.com> 4.999.8-0.7.beta
|
||||
- tweak summary
|
||||
- add %%check section (<tibbs@math.uh.edu>)
|
||||
|
||||
* Thu Jul 09 2009 Bill Nottingham <notting@redhat.com> 4.999.8-0.6.beta
|
||||
- fix release versioning to match guidelines
|
||||
- fix up lzma-compat summary/description
|
||||
- tweak licensing
|
||||
|
||||
* Mon Jun 22 2009 Jindrich Novy <jnovy@redhat.com> 4.999.8beta-0.5
|
||||
- introduce lzma-compat subpackage
|
||||
|
||||
* Fri Jun 19 2009 Jindrich Novy <jnovy@redhat.com> 4.999.8beta-0.4
|
||||
- try to not to conflict with lzma
|
||||
|
||||
* Thu Jun 18 2009 Jindrich Novy <jnovy@redhat.com> 4.999.8beta-0.3
|
||||
- obsolete but don't provide lzma, they are largely incompatible
|
||||
- put beta to Release
|
||||
|
||||
* Wed Jun 17 2009 Jindrich Novy <jnovy@redhat.com> 4.999.8beta-0.2
|
||||
- obsolete old lzma
|
||||
- add Requires: pkgconfig
|
||||
|
||||
* Tue Jun 16 2009 Jindrich Novy <jnovy@redhat.com> 4.999.8beta-0.1
|
||||
- package XZ Utils, based on LZMA Utils packaged by Per Patrice Bouchand
|
Loading…
Reference in New Issue
Block a user