Update to version 0.8.2
Drop patch xxhash-epel7-ppc64le.patch Use SPDX license identifiers
This commit is contained in:
parent
6967aacd93
commit
ed9bf7bfeb
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (xxhash-0.8.1.tar.gz) = 12feedd6a1859ef55e27218dbd6dcceccbb5a4da34cd80240d2f7d44cd246c7afdeb59830c2d5b90189bb5159293532208bf5bb622250102e12d6e1bad14a193
|
||||
SHA512 (xxhash-0.8.2.tar.gz) = 3e3eef21432fe88bc4dd9940ccad0308fdea3537b06fa5ac0e74c1bde53413dff29c8b3fc617a8a42b9ce88fcf213311d338a31b1ce73b3729342c9e68f06c78
|
||||
|
@ -1,43 +0,0 @@
|
||||
From 15ce80f9f2760609d8cc68cea76d3f3217ab70e1 Mon Sep 17 00:00:00 2001
|
||||
From: Mattias Ellert <mattias.ellert@physics.uu.se>
|
||||
Date: Tue, 30 Nov 2021 23:19:38 +0100
|
||||
Subject: [PATCH] Fix compilation on RHEL 7 ppc64le (gcc 4.8)
|
||||
|
||||
---
|
||||
xxhash.h | 6 +++---
|
||||
1 file changed, 3 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/xxhash.h b/xxhash.h
|
||||
index 08ab794..7850622 100644
|
||||
--- a/xxhash.h
|
||||
+++ b/xxhash.h
|
||||
@@ -4129,7 +4129,7 @@ XXH3_accumulate_512_vsx( void* XXH_RESTRICT acc,
|
||||
const void* XXH_RESTRICT secret)
|
||||
{
|
||||
/* presumed aligned */
|
||||
- unsigned long long* const xacc = (unsigned long long*) acc;
|
||||
+ unsigned int* const xacc = (unsigned int*) acc;
|
||||
xxh_u64x2 const* const xinput = (xxh_u64x2 const*) input; /* no alignment restriction */
|
||||
xxh_u64x2 const* const xsecret = (xxh_u64x2 const*) secret; /* no alignment restriction */
|
||||
xxh_u64x2 const v32 = { 32, 32 };
|
||||
@@ -4145,7 +4145,7 @@ XXH3_accumulate_512_vsx( void* XXH_RESTRICT acc,
|
||||
/* product = ((xxh_u64x2)data_key & 0xFFFFFFFF) * ((xxh_u64x2)shuffled & 0xFFFFFFFF); */
|
||||
xxh_u64x2 const product = XXH_vec_mulo((xxh_u32x4)data_key, shuffled);
|
||||
/* acc_vec = xacc[i]; */
|
||||
- xxh_u64x2 acc_vec = vec_xl(0, xacc + 2 * i);
|
||||
+ xxh_u64x2 acc_vec = (xxh_u64x2)vec_xl(0, xacc + 4 * i);
|
||||
acc_vec += product;
|
||||
|
||||
/* swap high and low halves */
|
||||
@@ -4155,7 +4155,7 @@ XXH3_accumulate_512_vsx( void* XXH_RESTRICT acc,
|
||||
acc_vec += vec_xxpermdi(data_vec, data_vec, 2);
|
||||
#endif
|
||||
/* xacc[i] = acc_vec; */
|
||||
- vec_xst(acc_vec, 0, xacc + 2 * i);
|
||||
+ vec_xst((xxh_u32x4)acc_vec, 0, xacc + 4 * i);
|
||||
}
|
||||
}
|
||||
|
||||
--
|
||||
2.33.1
|
||||
|
37
xxhash.spec
37
xxhash.spec
@ -1,17 +1,13 @@
|
||||
Name: xxhash
|
||||
Version: 0.8.1
|
||||
Release: 6%{?dist}
|
||||
Version: 0.8.2
|
||||
Release: 1%{?dist}
|
||||
Summary: Extremely fast hash algorithm
|
||||
|
||||
# The source for the library (xxhash.c and xxhash.h) is BSD
|
||||
# The source for the command line tool (xxhsum.c) is GPLv2+
|
||||
License: BSD and GPLv2+
|
||||
URL: http://www.xxhash.com/
|
||||
# The source for the library (xxhash.c and xxhash.h) is BSD-2-Clause
|
||||
# The source for the command line tool (xxhsum.c) is GPL-2.0-or-later
|
||||
License: BSD-2-Clause AND GPL-2.0-or-later
|
||||
URL: https://www.xxhash.com/
|
||||
Source0: https://github.com/Cyan4973/xxHash/archive/v%{version}/%{name}-%{version}.tar.gz
|
||||
# Fix compilation on RHEL 7 ppc64le (gcc 4.8)
|
||||
# https://github.com/Cyan4973/xxHash/issues/622
|
||||
# https://github.com/Cyan4973/xxHash/pull/631
|
||||
Patch0: %{name}-epel7-ppc64le.patch
|
||||
|
||||
BuildRequires: make
|
||||
BuildRequires: gcc
|
||||
@ -26,7 +22,7 @@ platforms (little / big endian).
|
||||
|
||||
%package libs
|
||||
Summary: Extremely fast hash algorithm - library
|
||||
License: BSD
|
||||
License: BSD-2-Clause
|
||||
|
||||
%description libs
|
||||
xxHash is an Extremely fast Hash algorithm, running at RAM speed
|
||||
@ -37,7 +33,7 @@ platforms (little / big endian).
|
||||
|
||||
%package devel
|
||||
Summary: Extremely fast hash algorithm - development files
|
||||
License: BSD
|
||||
License: BSD-2-Clause
|
||||
Requires: %{name}-libs%{?_isa} = %{version}-%{release}
|
||||
# By setting XXH_INLINE_ALL, xxhash may be used as a header-only library.
|
||||
# Dependent packages that use xxhash this way must BR this virtual Provide:
|
||||
@ -48,7 +44,7 @@ Development files for the xxhash library
|
||||
|
||||
%package doc
|
||||
Summary: Extremely fast hash algorithm - documentation files
|
||||
License: BSD
|
||||
License: BSD-2-Clause
|
||||
BuildArch: noarch
|
||||
|
||||
%description doc
|
||||
@ -56,22 +52,22 @@ Documentation files for the xxhash library
|
||||
|
||||
%prep
|
||||
%setup -q -n xxHash-%{version}
|
||||
%patch0 -p1
|
||||
|
||||
%build
|
||||
# Enable runtime detection of sse2/avx2/avx512 on intel architectures
|
||||
%ifarch %{ix86} x86_64
|
||||
%global dispatch 1
|
||||
%dnl Some distribution variants build with -march=x86-64-v3.
|
||||
%dnl See xxh_x86dispatch.c.
|
||||
# Some distribution variants build with -march=x86-64-v3.
|
||||
# See xxh_x86dispatch.c.
|
||||
%global moreflags_dispatch -DXXH_X86DISPATCH_ALLOW_AVX
|
||||
%else
|
||||
%global dispatch 0
|
||||
%global moreflags_dispatch %{nil}
|
||||
%endif
|
||||
|
||||
%make_build MOREFLAGS="%{__global_cflags} %{?__global_ldflags} %{moreflags_dispatch}" \
|
||||
DISPATCH=%{dispatch}
|
||||
%make_build \
|
||||
MOREFLAGS="%{__global_cflags} %{?__global_ldflags} %{moreflags_dispatch}" \
|
||||
DISPATCH=%{dispatch}
|
||||
doxygen
|
||||
|
||||
%install
|
||||
@ -105,6 +101,11 @@ make test-xxhsum-c
|
||||
%doc doxygen/html
|
||||
|
||||
%changelog
|
||||
* Sat Jul 22 2023 Mattias Ellert <mattias.ellert@physics.uu.se> - 0.8.2-1
|
||||
- Update to version 0.8.2
|
||||
- Drop patch xxhash-epel7-ppc64le.patch
|
||||
- Use SPDX license identifiers
|
||||
|
||||
* Sat Jul 22 2023 Fedora Release Engineering <releng@fedoraproject.org> - 0.8.1-6
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user