Update to version 0.8.0
Drop patches xxhash-compiler-warning-32-bit.patch (accepted upstream) and xxhash-pkgconfig.patch (issue fixed upstream) Fix empty version in .pc file
This commit is contained in:
parent
8a0c716906
commit
ac5117e6e2
@ -1,29 +0,0 @@
|
||||
From 3a262b04ab139c7ba728b4fa6b3525437a298066 Mon Sep 17 00:00:00 2001
|
||||
From: Mattias Ellert <mattias.ellert@physics.uu.se>
|
||||
Date: Sat, 27 Jun 2020 20:05:58 +0200
|
||||
Subject: [PATCH] Fix compiler warning for 32 bit architectures
|
||||
|
||||
In file included from xxhash.h:2065,
|
||||
from xxhash.c:43:
|
||||
xxh3.h: In function 'XXH3_len_9to16_128b':
|
||||
xxh3.h:2278: warning: integer constant is too large for 'long' type
|
||||
---
|
||||
xxh3.h | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/xxh3.h b/xxh3.h
|
||||
index 07cd911..9b547db 100644
|
||||
--- a/xxh3.h
|
||||
+++ b/xxh3.h
|
||||
@@ -2275,7 +2275,7 @@ XXH3_len_9to16_128b(const xxh_u8* input, size_t len, const xxh_u8* secret, XXH64
|
||||
* On 32-bit, it removes an ADC and delays a dependency between the two
|
||||
* halves of m128.high64, but it generates an extra mask on 64-bit.
|
||||
*/
|
||||
- m128.high64 += (input_hi & 0xFFFFFFFF00000000) + XXH_mult32to64((xxh_u32)input_hi, XXH_PRIME32_2);
|
||||
+ m128.high64 += (input_hi & 0xFFFFFFFF00000000ULL) + XXH_mult32to64((xxh_u32)input_hi, XXH_PRIME32_2);
|
||||
} else {
|
||||
/*
|
||||
* 64-bit optimized (albeit more confusing) version.
|
||||
--
|
||||
2.26.2
|
||||
|
13
xxhash-pkgconfig-version.patch
Normal file
13
xxhash-pkgconfig-version.patch
Normal file
@ -0,0 +1,13 @@
|
||||
diff --git a/Makefile b/Makefile
|
||||
index ef24e94..da1ce06 100644
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -437,7 +437,7 @@ libxxhash.pc: libxxhash.pc.in
|
||||
-e 's|@EXECPREFIX@|$(PCEXECDIR)|' \
|
||||
-e 's|@LIBDIR@|$(PCLIBDIR)|' \
|
||||
-e 's|@INCLUDEDIR@|$(PCINCDIR)|' \
|
||||
- -e 's|@VERSION@|$(VERSION)|' \
|
||||
+ -e 's|@VERSION@|$(LIBVER)|' \
|
||||
$< > $@
|
||||
|
||||
|
@ -1,41 +0,0 @@
|
||||
From b3072a867b0ff394863ec95cc70d296188edcd1d Mon Sep 17 00:00:00 2001
|
||||
From: Mattias Ellert <mattias.ellert@physics.uu.se>
|
||||
Date: Fri, 24 Jul 2020 14:52:36 +0200
|
||||
Subject: [PATCH] Support INCLUDEDIR and LIBDIR in libxxhash.pc
|
||||
|
||||
---
|
||||
Makefile | 2 ++
|
||||
libxxhash.pc.in | 4 ++--
|
||||
2 files changed, 4 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/Makefile b/Makefile
|
||||
index 6852d23..89ee823 100644
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -138,6 +138,8 @@ lib: libxxhash.a libxxhash
|
||||
|
||||
pkgconfig:
|
||||
@$(SED) -e 's|@PREFIX@|$(PREFIX)|' \
|
||||
+ -e 's|@INCLUDEDIR@|$(INCLUDEDIR)|' \
|
||||
+ -e 's|@LIBDIR@|$(LIBDIR)|' \
|
||||
-e 's|@VERSION@|$(LIBVER)|' \
|
||||
libxxhash.pc.in >libxxhash.pc
|
||||
|
||||
diff --git a/libxxhash.pc.in b/libxxhash.pc.in
|
||||
index 3f77f99..4dac3b7 100644
|
||||
--- a/libxxhash.pc.in
|
||||
+++ b/libxxhash.pc.in
|
||||
@@ -3,8 +3,8 @@
|
||||
|
||||
prefix=@PREFIX@
|
||||
exec_prefix=${prefix}
|
||||
-includedir=${prefix}/include
|
||||
-libdir=${exec_prefix}/lib
|
||||
+includedir=@INCLUDEDIR@
|
||||
+libdir=@LIBDIR@
|
||||
|
||||
Name: xxhash
|
||||
Description: extremely fast hash algorithm
|
||||
--
|
||||
2.26.2
|
||||
|
20
xxhash.spec
20
xxhash.spec
@ -1,6 +1,6 @@
|
||||
Name: xxhash
|
||||
Version: 0.7.4
|
||||
Release: 2%{?dist}
|
||||
Version: 0.8.0
|
||||
Release: 1%{?dist}
|
||||
Summary: Extremely fast hash algorithm
|
||||
|
||||
# The source for the library (xxhash.c and xxhash.h) is BSD
|
||||
@ -8,12 +8,9 @@ Summary: Extremely fast hash algorithm
|
||||
License: BSD and GPLv2+
|
||||
URL: http://www.xxhash.com/
|
||||
Source0: https://github.com/Cyan4973/xxHash/archive/v%{version}/%{name}-%{version}.tar.gz
|
||||
# Fix compiler warning for 32 bit architectures
|
||||
# https://github.com/Cyan4973/xxHash/pull/411
|
||||
Patch0: %{name}-compiler-warning-32-bit.patch
|
||||
# Fix libdir in pkg-config file
|
||||
# https://github.com/Cyan4973/xxHash/pull/437
|
||||
Patch1: %{name}-pkgconfig.patch
|
||||
# Fix empty version in .pc file
|
||||
# https://github.com/Cyan4973/xxHash/pull/442
|
||||
Patch0: %{name}-pkgconfig-version.patch
|
||||
|
||||
BuildRequires: gcc
|
||||
|
||||
@ -46,7 +43,6 @@ Development files for the xxhash library
|
||||
%prep
|
||||
%setup -q -n xxHash-%{version}
|
||||
%patch0 -p1
|
||||
%patch1 -p1
|
||||
|
||||
%build
|
||||
# Enable runtime detection of sse2/avx2/avx512 on intel architectures
|
||||
@ -92,6 +88,12 @@ make test-xxhsum-c
|
||||
%{_libdir}/pkgconfig/libxxhash.pc
|
||||
|
||||
%changelog
|
||||
* Tue Jul 28 2020 Mattias Ellert <mattias.ellert@physics.uu.se> - 0.8.0-1
|
||||
- Update to version 0.8.0
|
||||
- Drop patches xxhash-compiler-warning-32-bit.patch (accepted upstream)
|
||||
and xxhash-pkgconfig.patch (issue fixed upstream)
|
||||
- Fix empty version in .pc file
|
||||
|
||||
* Fri Jul 24 2020 Mattias Ellert <mattias.ellert@physics.uu.se> - 0.7.4-2
|
||||
- Fix libdir in pkg-config file
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user