Update to version 0.7.3
Drop patch xxhash-gcc10-altivec.patch (accepted upstream)
This commit is contained in:
parent
fab53c25cd
commit
7c83bf7255
2
sources
2
sources
@ -1 +1 @@
|
|||||||
SHA512 (xxhash-0.7.2.tar.gz) = 90d4e7422729441e5013928b306fd6f394ab6f97628ec88369fbb33891c9a2cfae495516d8dd0741eda9c38859132b1bd78f2c7b8dae1dce80eeca8ea5cba575
|
SHA512 (xxhash-0.7.3.tar.gz) = 72949010a267f063768241b182464c386005b4078f56902fee2f7804bd01f6c27878a6a4ec2a266cd59162934a7e471264ac5757dba570a97a2b5dad7703c664
|
||||||
|
@ -1,31 +0,0 @@
|
|||||||
From 3e3f5f7c2f0782ea190d30bba04d274babeec04f Mon Sep 17 00:00:00 2001
|
|
||||||
From: Mattias Ellert <mattias.ellert@physics.uu.se>
|
|
||||||
Date: Fri, 7 Feb 2020 07:38:48 +0100
|
|
||||||
Subject: [PATCH] Fix build with gcc 10 on ppc64le
|
|
||||||
|
|
||||||
When gcc was updated to version 10 in Fedora the build of the xxhash
|
|
||||||
package started failing. The compilation succeeds, but the checks
|
|
||||||
trigger an error. This change, suggested by the maintainers of the gcc
|
|
||||||
package in Fedora, addresses the issue. F0r details see:
|
|
||||||
|
|
||||||
https://bugzilla.redhat.com/show_bug.cgi?id=1798908
|
|
||||||
---
|
|
||||||
xxh3.h | 2 +-
|
|
||||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
||||||
|
|
||||||
diff --git a/xxh3.h b/xxh3.h
|
|
||||||
index a3a81bc..3fa6c1f 100644
|
|
||||||
--- a/xxh3.h
|
|
||||||
+++ b/xxh3.h
|
|
||||||
@@ -219,7 +219,7 @@ XXH_FORCE_INLINE U64x2 XXH_vec_revb(U64x2 val)
|
|
||||||
* Additionally, the intrinsic wasn't added until GCC 8, despite existing for a while.
|
|
||||||
* Clang has an easy way to control this, we can just use the builtin which doesn't swap.
|
|
||||||
* GCC needs inline assembly. */
|
|
||||||
-#if __has_builtin(__builtin_altivec_vmuleuw)
|
|
||||||
+#if defined(__clang__) && __has_builtin(__builtin_altivec_vmuleuw)
|
|
||||||
# define XXH_vec_mulo __builtin_altivec_vmulouw
|
|
||||||
# define XXH_vec_mule __builtin_altivec_vmuleuw
|
|
||||||
#else
|
|
||||||
--
|
|
||||||
2.24.1
|
|
||||||
|
|
15
xxhash.spec
15
xxhash.spec
@ -1,6 +1,6 @@
|
|||||||
Name: xxhash
|
Name: xxhash
|
||||||
Version: 0.7.2
|
Version: 0.7.3
|
||||||
Release: 3%{?dist}
|
Release: 1%{?dist}
|
||||||
Summary: Extremely fast hash algorithm
|
Summary: Extremely fast hash algorithm
|
||||||
|
|
||||||
# The source for the library (xxhash.c and xxhash.h) is BSD
|
# The source for the library (xxhash.c and xxhash.h) is BSD
|
||||||
@ -8,10 +8,6 @@ Summary: Extremely fast hash algorithm
|
|||||||
License: BSD and GPLv2+
|
License: BSD and GPLv2+
|
||||||
URL: http://www.xxhash.com/
|
URL: http://www.xxhash.com/
|
||||||
Source0: https://github.com/Cyan4973/xxHash/archive/v%{version}/%{name}-%{version}.tar.gz
|
Source0: https://github.com/Cyan4973/xxHash/archive/v%{version}/%{name}-%{version}.tar.gz
|
||||||
# Fix ppc64le build with gcc 10
|
|
||||||
# https://bugzilla.redhat.com/show_bug.cgi?id=1798908
|
|
||||||
# https://github.com/Cyan4973/xxHash/pull/297
|
|
||||||
Patch0: %{name}-gcc10-altivec.patch
|
|
||||||
|
|
||||||
BuildRequires: gcc
|
BuildRequires: gcc
|
||||||
|
|
||||||
@ -43,7 +39,6 @@ Development files for the xxhash library
|
|||||||
|
|
||||||
%prep
|
%prep
|
||||||
%setup -q -n xxHash-%{version}
|
%setup -q -n xxHash-%{version}
|
||||||
%patch0 -p1
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
make %{?_smp_mflags} CFLAGS="%{optflags}" MOREFLAGS="%{?__global_ldflags} -fPIC"
|
make %{?_smp_mflags} CFLAGS="%{optflags}" MOREFLAGS="%{?__global_ldflags} -fPIC"
|
||||||
@ -71,9 +66,15 @@ make test-xxhsum-c
|
|||||||
|
|
||||||
%files devel
|
%files devel
|
||||||
%{_includedir}/xxhash.h
|
%{_includedir}/xxhash.h
|
||||||
|
%{_includedir}/xxh3.h
|
||||||
%{_libdir}/libxxhash.so
|
%{_libdir}/libxxhash.so
|
||||||
|
%{_libdir}/pkgconfig/libxxhash.pc
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Mar 06 2020 Mattias Ellert <mattias.ellert@physics.uu.se> - 0.7.3-1
|
||||||
|
- Update to version 0.7.3
|
||||||
|
- Drop patch xxhash-gcc10-altivec.patch (accepted upstream)
|
||||||
|
|
||||||
* Fri Feb 07 2020 Mattias Ellert <mattias.ellert@physics.uu.se> - 0.7.2-3
|
* Fri Feb 07 2020 Mattias Ellert <mattias.ellert@physics.uu.se> - 0.7.2-3
|
||||||
- Fix ppc64le build with gcc 10
|
- Fix ppc64le build with gcc 10
|
||||||
|
|
||||||
|
Loading…
Reference in New Issue
Block a user