Initial import
Resolves: rhbz#2095255 Signed-off-by: Vladis Dronov <vdronov@redhat.com>
This commit is contained in:
parent
155d86bc4d
commit
0e54548228
2
.gitignore
vendored
2
.gitignore
vendored
@ -1 +1 @@
|
||||
/*.tar.gz
|
||||
/xxhash-*.tar.gz
|
||||
|
6
gating.yaml
Normal file
6
gating.yaml
Normal file
@ -0,0 +1,6 @@
|
||||
--- !Policy
|
||||
product_versions:
|
||||
- rhel-9
|
||||
decision_context: osci_compose_gate
|
||||
rules:
|
||||
- !PassingTestCaseRule {test_case_name: osci.brew-build.tier0.functional}
|
2
sources
2
sources
@ -1 +1 @@
|
||||
SHA512 (xxhash-0.8.0.tar.gz) = c3973b3c98bad44e1d8687ab4f9461aecd1c071bb3d320537a4c50fb7301edd13e990bab48cc6e5ca30536a814c8fa8cac24ceb1803a7e8eca30ef73d449373e
|
||||
SHA512 (xxhash-0.8.1.tar.gz) = 12feedd6a1859ef55e27218dbd6dcceccbb5a4da34cd80240d2f7d44cd246c7afdeb59830c2d5b90189bb5159293532208bf5bb622250102e12d6e1bad14a193
|
||||
|
@ -1,13 +0,0 @@
|
||||
diff --git a/Makefile b/Makefile
|
||||
index ef24e94..da1ce06 100644
|
||||
--- a/Makefile
|
||||
+++ b/Makefile
|
||||
@@ -437,7 +437,7 @@ libxxhash.pc: libxxhash.pc.in
|
||||
-e 's|@EXECPREFIX@|$(PCEXECDIR)|' \
|
||||
-e 's|@LIBDIR@|$(PCLIBDIR)|' \
|
||||
-e 's|@INCLUDEDIR@|$(PCINCDIR)|' \
|
||||
- -e 's|@VERSION@|$(VERSION)|' \
|
||||
+ -e 's|@VERSION@|$(LIBVER)|' \
|
||||
$< > $@
|
||||
|
||||
|
96
xxhash.spec
96
xxhash.spec
@ -1,6 +1,6 @@
|
||||
Name: xxhash
|
||||
Version: 0.8.0
|
||||
Release: 2%{?dist}
|
||||
Version: 0.8.1
|
||||
Release: 1%{?dist}
|
||||
Summary: Extremely fast hash algorithm
|
||||
|
||||
# The source for the library (xxhash.c and xxhash.h) is BSD
|
||||
@ -8,12 +8,10 @@ Summary: Extremely fast hash algorithm
|
||||
License: BSD and GPLv2+
|
||||
URL: http://www.xxhash.com/
|
||||
Source0: https://github.com/Cyan4973/xxHash/archive/v%{version}/%{name}-%{version}.tar.gz
|
||||
# Fix empty version in .pc file
|
||||
# https://github.com/Cyan4973/xxHash/pull/442
|
||||
Patch0: %{name}-pkgconfig-version.patch
|
||||
|
||||
BuildRequires: make
|
||||
BuildRequires: gcc
|
||||
BuildRequires: doxygen
|
||||
|
||||
%description
|
||||
xxHash is an Extremely fast Hash algorithm, running at RAM speed
|
||||
@ -37,29 +35,35 @@ platforms (little / big endian).
|
||||
Summary: Extremely fast hash algorithm - development files
|
||||
License: BSD
|
||||
Requires: %{name}-libs%{?_isa} = %{version}-%{release}
|
||||
# By setting XXH_INLINE_ALL, xxhash may be used as a header-only library.
|
||||
# Dependent packages that use xxhash this way must BR this virtual Provide:
|
||||
Provides: %{name}-static = %{version}-%{release}
|
||||
|
||||
%description devel
|
||||
Development files for the xxhash library
|
||||
|
||||
%package doc
|
||||
Summary: Extremely fast hash algorithm - documentation files
|
||||
License: BSD
|
||||
BuildArch: noarch
|
||||
|
||||
%description doc
|
||||
Documentation files for the xxhash library
|
||||
|
||||
%prep
|
||||
%setup -q -n xxHash-%{version}
|
||||
%patch0 -p1
|
||||
|
||||
%build
|
||||
# Enable runtime detection of sse2/avx2/avx512 on intel architectures
|
||||
%ifarch %{ix86} x86_64
|
||||
# The compiler version in EPEL 6 and 7 does not support avx
|
||||
%if %{?rhel}%{!?rhel:0} == 6 || %{?rhel}%{!?rhel:0} == 7
|
||||
%global dispatch 0
|
||||
%else
|
||||
%global dispatch 1
|
||||
%endif
|
||||
%else
|
||||
%global dispatch 0
|
||||
%endif
|
||||
|
||||
%make_build MOREFLAGS="%{__global_cflags} %{?__global_ldflags}" \
|
||||
DISPATCH=%{dispatch}
|
||||
doxygen
|
||||
|
||||
%install
|
||||
%make_install PREFIX=%{_prefix} LIBDIR=%{_libdir}
|
||||
@ -74,8 +78,8 @@ make test-xxhsum-c
|
||||
%files
|
||||
%{_bindir}/xxh*sum
|
||||
%{_mandir}/man1/xxh*sum.1*
|
||||
%license LICENSE
|
||||
%doc README.md
|
||||
%license cli/COPYING
|
||||
%doc cli/README.md
|
||||
|
||||
%files libs
|
||||
%{_libdir}/libxxhash.so.*
|
||||
@ -88,65 +92,9 @@ make test-xxhsum-c
|
||||
%{_libdir}/libxxhash.so
|
||||
%{_libdir}/pkgconfig/libxxhash.pc
|
||||
|
||||
%files doc
|
||||
%doc doxygen/html
|
||||
|
||||
%changelog
|
||||
* Thu Jan 28 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0.8.0-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||
|
||||
* Tue Jul 28 2020 Mattias Ellert <mattias.ellert@physics.uu.se> - 0.8.0-1
|
||||
- Update to version 0.8.0
|
||||
- Drop patches xxhash-compiler-warning-32-bit.patch (accepted upstream)
|
||||
and xxhash-pkgconfig.patch (issue fixed upstream)
|
||||
- Fix empty version in .pc file
|
||||
|
||||
* Fri Jul 24 2020 Mattias Ellert <mattias.ellert@physics.uu.se> - 0.7.4-2
|
||||
- Fix libdir in pkg-config file
|
||||
|
||||
* Sat Jun 27 2020 Mattias Ellert <mattias.ellert@physics.uu.se> - 0.7.4-1
|
||||
- Update to version 0.7.4
|
||||
- Enable runtime detection of sse2/avx2/avx512 on intel architectures
|
||||
- Fix compiler warning for 32 bit architectures
|
||||
|
||||
* Fri Mar 06 2020 Mattias Ellert <mattias.ellert@physics.uu.se> - 0.7.3-1
|
||||
- Update to version 0.7.3
|
||||
- Drop patch xxhash-gcc10-altivec.patch (accepted upstream)
|
||||
|
||||
* Fri Feb 07 2020 Mattias Ellert <mattias.ellert@physics.uu.se> - 0.7.2-3
|
||||
- Fix ppc64le build with gcc 10
|
||||
|
||||
* Fri Jan 31 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0.7.2-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||
|
||||
* Wed Oct 09 2019 Mattias Ellert <mattias.ellert@physics.uu.se> - 0.7.2-1
|
||||
- Update to version 0.7.2
|
||||
|
||||
* Sat Aug 17 2019 Mattias Ellert <mattias.ellert@physics.uu.se> - 0.7.1-1
|
||||
- Update to version 0.7.1
|
||||
|
||||
* Sat Jul 27 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.7.0-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
||||
|
||||
* Mon Mar 18 2019 Mattias Ellert <mattias.ellert@physics.uu.se> - 0.7.0-1
|
||||
- Update to version 0.7.0
|
||||
|
||||
* Sun Feb 03 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0.6.5-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
||||
|
||||
* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.6.5-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||
|
||||
* Thu Apr 19 2018 Mattias Ellert <mattias.ellert@physics.uu.se> - 0.6.5-1
|
||||
- Update to version 0.6.5
|
||||
|
||||
* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.6.4-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||
|
||||
* Wed Jan 03 2018 Mattias Ellert <mattias.ellert@physics.uu.se> - 0.6.4-1
|
||||
- Update to version 0.6.4
|
||||
- Drop previously backported patches
|
||||
|
||||
* Thu Oct 19 2017 Mattias Ellert <mattias.ellert@physics.uu.se> - 0.6.3-2
|
||||
- Correct License tag (command line tool is GPLv2+)
|
||||
- Adjust Source tag to get a more descriptive tarfile name
|
||||
|
||||
* Wed Oct 18 2017 Mattias Ellert <mattias.ellert@physics.uu.se> - 0.6.3-1
|
||||
- Initial packaging
|
||||
* Fri Jun 17 2022 Vladis Dronov <vdronov@redhat.com> - 0.8.1-1
|
||||
- Packaging of xxhash v0.8.1 for CS and RHEL copied from Fedora 36
|
||||
|
Loading…
Reference in New Issue
Block a user