Refresh kwin support patch
Add provides for other included utilities
This commit is contained in:
parent
f9b6885ad4
commit
9729db0e68
@ -1,14 +1,15 @@
|
||||
From 9f1392fd57e78c9d785a1211ce84bfd5ca1226e6 Mon Sep 17 00:00:00 2001
|
||||
From ac94b6621c2dfa70329fbc89c77ad7a5042f1d5a Mon Sep 17 00:00:00 2001
|
||||
From: Neal Gompa <neal@gompa.dev>
|
||||
Date: Sun, 10 Dec 2023 16:46:01 -0500
|
||||
Date: Sun, 10 Dec 2023 18:03:30 -0500
|
||||
Subject: [PATCH] wlheadless: Add support for kwin
|
||||
|
||||
---
|
||||
README.md | 5 +--
|
||||
man/wlheadless-run.man | 2 +-
|
||||
meson_options.txt | 2 +-
|
||||
src/wlheadless/kwin.py | 76 ++++++++++++++++++++++++++++++++++++++++++
|
||||
4 files changed, 81 insertions(+), 4 deletions(-)
|
||||
README.md | 5 ++-
|
||||
man/wlheadless-run.man | 2 +-
|
||||
meson_options.txt | 2 +-
|
||||
src/wlheadless/kwin.py | 76 ++++++++++++++++++++++++++++++++++++++
|
||||
src/wlheadless/meson.build | 1 +
|
||||
5 files changed, 82 insertions(+), 4 deletions(-)
|
||||
create mode 100644 src/wlheadless/kwin.py
|
||||
|
||||
diff --git a/README.md b/README.md
|
||||
@ -146,6 +147,18 @@ index 0000000..e529229
|
||||
+ # Just save the given args for when we shall actually spawn the compositor.
|
||||
+ self.compositor_args = compositor_args
|
||||
+ return 0
|
||||
diff --git a/src/wlheadless/meson.build b/src/wlheadless/meson.build
|
||||
index cdf650c..e6fbfce 100644
|
||||
--- a/src/wlheadless/meson.build
|
||||
+++ b/src/wlheadless/meson.build
|
||||
@@ -2,6 +2,7 @@ python_sources = [
|
||||
'__init__.py',
|
||||
'cage.py',
|
||||
'gnome-kiosk.py',
|
||||
+ 'kwin.py',
|
||||
'mutter.py',
|
||||
'weston.py',
|
||||
'wlheadless_common.py',
|
||||
--
|
||||
2.43.0
|
||||
|
||||
|
@ -1,6 +1,6 @@
|
||||
Name: xwayland-run
|
||||
Version: 0.0.2
|
||||
Release: 1%{?dist}
|
||||
Release: 2%{?dist}
|
||||
Summary: Set of utilities to run headless X/Wayland clients
|
||||
|
||||
License: GPL-2.0-or-later
|
||||
@ -18,6 +18,10 @@ BuildRequires: python3-devel
|
||||
Requires: (weston or kwin-wayland or mutter or cage or gnome-kiosk)
|
||||
Requires: xorg-x11-server-Xwayland
|
||||
|
||||
# Provide names of the other utilities included
|
||||
Provides: wlheadless-run = %{version}-%{release}
|
||||
Provides: xwfb-run = %{version}-%{release}
|
||||
|
||||
%description
|
||||
xwayland-run contains a set of small utilities revolving around running
|
||||
Xwayland and various Wayland compositor headless.
|
||||
@ -50,5 +54,9 @@ Xwayland and various Wayland compositor headless.
|
||||
|
||||
|
||||
%changelog
|
||||
* Sun Dec 10 2023 Neal Gompa <ngompa@fedoraproject.org> - 0.0.2-2
|
||||
- Refresh kwin support patch
|
||||
- Add provides for other included utilities
|
||||
|
||||
* Sun Dec 10 2023 Neal Gompa <ngompa@fedoraproject.org> - 0.0.2-1
|
||||
- Initial package
|
||||
|
Loading…
Reference in New Issue
Block a user