- update to 242
- use upstream default value for modifyFunctionKeys resource - remove png suffix from icon name in desktop file
This commit is contained in:
parent
a035a7ad32
commit
ab625cfcda
@ -1,2 +1,2 @@
|
|||||||
16colors.txt
|
16colors.txt
|
||||||
xterm-238.tgz
|
xterm-242.tgz
|
||||||
|
2
sources
2
sources
@ -1,2 +1,2 @@
|
|||||||
6093439b8d79089f4ff1cdfed358b401 16colors.txt
|
6093439b8d79089f4ff1cdfed358b401 16colors.txt
|
||||||
754f670723eb9a20f9f90d7c5f4a5bad xterm-238.tgz
|
663fa3aac8e30e4c2d4bf07c0aee4dca xterm-242.tgz
|
||||||
|
@ -1,14 +0,0 @@
|
|||||||
--- xterm-223/XTerm.ad.redhat-resources 2006-06-24 16:34:45.000000000 +0200
|
|
||||||
+++ xterm-223/XTerm.ad 2007-01-08 18:13:38.000000000 +0100
|
|
||||||
@@ -186,3 +186,11 @@
|
|
||||||
!
|
|
||||||
! Alternatively,
|
|
||||||
!*on2Clicks: regex [[:alpha:]]+://([[:alnum:]!#+,./=?@_~-]|(%[[:xdigit:]][[:xdigit:]]))+
|
|
||||||
+
|
|
||||||
+! Red Hat Defaults:
|
|
||||||
+*VT100*eightBitInput: 0
|
|
||||||
+*VT100*metaSendsEscape: 1
|
|
||||||
+*VT100*backarrowKey: 0
|
|
||||||
+*VT100*scrollBar: 1
|
|
||||||
+*VT100*utf8Title: 1
|
|
||||||
+*VT100*modifyFunctionKeys: 0
|
|
@ -1,37 +0,0 @@
|
|||||||
diff -up xterm-238/charproc.c.windowfontops xterm-238/charproc.c
|
|
||||||
--- xterm-238/charproc.c.windowfontops 2009-01-06 12:10:30.000000000 +0100
|
|
||||||
+++ xterm-238/charproc.c 2009-01-06 12:15:57.000000000 +0100
|
|
||||||
@@ -389,10 +389,10 @@ static XtActionsRec actionsList[] = {
|
|
||||||
static XtResource resources[] =
|
|
||||||
{
|
|
||||||
Bres(XtNallowSendEvents, XtCAllowSendEvents, screen.allowSendEvent0, False),
|
|
||||||
- Bres(XtNallowFontOps, XtCAllowFontOps, screen.allowFontOp0, True),
|
|
||||||
+ Bres(XtNallowFontOps, XtCAllowFontOps, screen.allowFontOp0, False),
|
|
||||||
Bres(XtNallowTcapOps, XtCAllowTcapOps, screen.allowTcapOp0, True),
|
|
||||||
Bres(XtNallowTitleOps, XtCAllowTitleOps, screen.allowTitleOp0, True),
|
|
||||||
- Bres(XtNallowWindowOps, XtCAllowWindowOps, screen.allowWindowOp0, True),
|
|
||||||
+ Bres(XtNallowWindowOps, XtCAllowWindowOps, screen.allowWindowOp0, False),
|
|
||||||
Bres(XtNaltIsNotMeta, XtCAltIsNotMeta, screen.alt_is_not_meta, False),
|
|
||||||
Bres(XtNaltSendsEscape, XtCAltSendsEscape, screen.alt_sends_esc, False),
|
|
||||||
Bres(XtNalwaysBoldMode, XtCAlwaysBoldMode, screen.always_bold_mode, False),
|
|
||||||
diff -up xterm-238/xterm.man.windowfontops xterm-238/xterm.man
|
|
||||||
--- xterm-238/xterm.man.windowfontops 2009-01-06 12:10:30.000000000 +0100
|
|
||||||
+++ xterm-238/xterm.man 2009-01-06 12:11:39.000000000 +0100
|
|
||||||
@@ -1448,7 +1448,7 @@ The default is ``false.''
|
|
||||||
.TP
|
|
||||||
.B "allowFontOps (\fPclass\fB AllowFontOps)"
|
|
||||||
Specifies whether control sequences that set/query the font should be allowed.
|
|
||||||
-The default is ``true.''
|
|
||||||
+The default is ``false.''
|
|
||||||
.TP 8
|
|
||||||
.B "allowSendEvents (\fPclass\fB AllowSendEvents)"
|
|
||||||
Specifies whether or not synthetic key and button events (generated using
|
|
||||||
@@ -1472,7 +1472,7 @@ The default is ``true.''
|
|
||||||
.B "allowWindowOps (\fPclass\fB AllowWindowOps)"
|
|
||||||
Specifies whether extended window control sequences (as used in dtterm)
|
|
||||||
should be allowed.
|
|
||||||
-The default is ``true.''
|
|
||||||
+The default is ``false.''
|
|
||||||
.TP 8
|
|
||||||
.B "altIsNotMeta (\fPclass\fB AltIsNotMeta\fP)"
|
|
||||||
If ``true'', treat the Alt-key as if it were the Meta-key.
|
|
16
xterm-242-resources.patch
Normal file
16
xterm-242-resources.patch
Normal file
@ -0,0 +1,16 @@
|
|||||||
|
diff -up xterm-242/XTerm.ad.resources xterm-242/XTerm.ad
|
||||||
|
--- xterm-242/XTerm.ad.resources 2009-02-13 01:14:13.000000000 +0100
|
||||||
|
+++ xterm-242/XTerm.ad 2009-02-18 15:00:23.000000000 +0100
|
||||||
|
@@ -210,3 +210,12 @@
|
||||||
|
!*allowTcapOps: false
|
||||||
|
!*allowTitleOps: false
|
||||||
|
!*allowWindowOps: false
|
||||||
|
+
|
||||||
|
+! Red Hat Defaults:
|
||||||
|
+*allowFontOps: false
|
||||||
|
+*allowWindowOps: false
|
||||||
|
+*VT100*eightBitInput: false
|
||||||
|
+*VT100*metaSendsEscape: true
|
||||||
|
+*VT100*backarrowKey: false
|
||||||
|
+*VT100*scrollBar: true
|
||||||
|
+*VT100*utf8Title: true
|
@ -4,7 +4,7 @@ Name=xterm Terminal
|
|||||||
GenericName=Terminal
|
GenericName=Terminal
|
||||||
Comment=Terminal emulator for the X Window System
|
Comment=Terminal emulator for the X Window System
|
||||||
Exec=xterm
|
Exec=xterm
|
||||||
Icon=gnome-xterm.png
|
Icon=gnome-xterm
|
||||||
Type=Application
|
Type=Application
|
||||||
Categories=System;TerminalEmulator;
|
Categories=System;TerminalEmulator;
|
||||||
NoDisplay=true
|
NoDisplay=true
|
||||||
|
13
xterm.spec
13
xterm.spec
@ -1,6 +1,6 @@
|
|||||||
Summary: Terminal emulator for the X Window System
|
Summary: Terminal emulator for the X Window System
|
||||||
Name: xterm
|
Name: xterm
|
||||||
Version: 238
|
Version: 242
|
||||||
Release: 1%{?dist}
|
Release: 1%{?dist}
|
||||||
URL: http://dickey.his.com/xterm
|
URL: http://dickey.his.com/xterm
|
||||||
License: MIT
|
License: MIT
|
||||||
@ -13,10 +13,9 @@ Source0: ftp://invisible-island.net/xterm/%{name}-%{version}.tgz
|
|||||||
Source1: ftp://invisible-island.net/xterm/16colors.txt
|
Source1: ftp://invisible-island.net/xterm/16colors.txt
|
||||||
Source2: %{name}.desktop
|
Source2: %{name}.desktop
|
||||||
|
|
||||||
Patch1: xterm-223-resources.patch
|
Patch1: xterm-242-resources.patch
|
||||||
Patch2: xterm-222-can-2003-0063.patch
|
Patch2: xterm-222-can-2003-0063.patch
|
||||||
Patch3: xterm-226-man-page_paths.patch
|
Patch3: xterm-226-man-page_paths.patch
|
||||||
Patch4: xterm-238-windowfontops.patch
|
|
||||||
|
|
||||||
%bcond_with trace
|
%bcond_with trace
|
||||||
|
|
||||||
@ -30,10 +29,9 @@ programs that can't use the window system directly.
|
|||||||
%prep
|
%prep
|
||||||
%setup -q
|
%setup -q
|
||||||
|
|
||||||
%patch1 -p1 -b .redhat-resources
|
%patch1 -p1 -b .resources
|
||||||
%patch2 -p1 -b .can-2003-0063
|
%patch2 -p1 -b .can-2003-0063
|
||||||
%patch3 -p1 -b .man-page_paths
|
%patch3 -p1 -b .man-page_paths
|
||||||
%patch4 -p1 -b .windowfontops
|
|
||||||
|
|
||||||
%build
|
%build
|
||||||
%configure \
|
%configure \
|
||||||
@ -84,6 +82,11 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{x11_app_defaults_dir}/XTerm-color
|
%{x11_app_defaults_dir}/XTerm-color
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Feb 18 2009 Miroslav Lichvar <mlichvar@redhat.com> 242-1
|
||||||
|
- update to 242
|
||||||
|
- use upstream default value for modifyFunctionKeys resource
|
||||||
|
- remove png suffix from icon name in desktop file
|
||||||
|
|
||||||
* Tue Jan 06 2009 Miroslav Lichvar <mlichvar@redhat.com> 238-1
|
* Tue Jan 06 2009 Miroslav Lichvar <mlichvar@redhat.com> 238-1
|
||||||
- update to 238 (#479000, CVE-2008-2383)
|
- update to 238 (#479000, CVE-2008-2383)
|
||||||
- set default values of allowWindowOps and allowFontOps resources to false
|
- set default values of allowWindowOps and allowFontOps resources to false
|
||||||
|
Loading…
Reference in New Issue
Block a user