- update to 245
This commit is contained in:
parent
e2cb12e757
commit
a092d5e5d7
@ -1,2 +1,2 @@
|
||||
16colors.txt
|
||||
xterm-242.tgz
|
||||
xterm-245.tgz
|
||||
|
2
sources
2
sources
@ -1,2 +1,2 @@
|
||||
6093439b8d79089f4ff1cdfed358b401 16colors.txt
|
||||
663fa3aac8e30e4c2d4bf07c0aee4dca xterm-242.tgz
|
||||
ad87d0a641da70a3c1196a209c8db70e xterm-245.tgz
|
||||
|
@ -1,40 +0,0 @@
|
||||
# patch by Thomas E. Dickey <dickey@invisible-island.net>
|
||||
# created Sat Feb 28 16:00:38 UTC 2009
|
||||
# ------------------------------------------------------------------------------
|
||||
# misc.c | 16 +++++++---------
|
||||
# version.h | 4 ++--
|
||||
# xterm.log.html | 10 +++++++++-
|
||||
# 3 files changed, 18 insertions(+), 12 deletions(-)
|
||||
# ------------------------------------------------------------------------------
|
||||
Index: misc.c
|
||||
--- xterm-242+/misc.c 2009-02-13 23:39:29.000000000 +0000
|
||||
+++ xterm-242a/misc.c 2009-02-28 15:37:30.000000000 +0000
|
||||
@@ -1,4 +1,4 @@
|
||||
-/* $XTermId: misc.c,v 1.405 2009/02/13 23:39:29 tom Exp $ */
|
||||
+/* $XTermId: misc.c,v 1.406 2009/02/28 15:37:30 tom Exp $ */
|
||||
|
||||
/*
|
||||
*
|
||||
@@ -821,16 +821,14 @@
|
||||
void
|
||||
xtermBell(XtermWidget xw, int which, int percent)
|
||||
{
|
||||
- if (percent > 0) {
|
||||
- TScreen *screen = TScreenOf(xw);
|
||||
+ TScreen *screen = TScreenOf(xw);
|
||||
#if defined(HAVE_XKB_BELL_EXT)
|
||||
- Atom tony = AtomBell(xw, which);
|
||||
- if (tony != None) {
|
||||
- XkbBell(screen->display, VShellWindow, percent, tony);
|
||||
- } else
|
||||
+ Atom tony = AtomBell(xw, which);
|
||||
+ if (tony != None) {
|
||||
+ XkbBell(screen->display, VShellWindow, percent, tony);
|
||||
+ } else
|
||||
#endif
|
||||
- XBell(screen->display, percent);
|
||||
- }
|
||||
+ XBell(screen->display, percent);
|
||||
}
|
||||
|
||||
void
|
@ -1,13 +1,14 @@
|
||||
diff -up xterm-242/XTerm.ad.resources xterm-242/XTerm.ad
|
||||
--- xterm-242/XTerm.ad.resources 2009-02-13 01:14:13.000000000 +0100
|
||||
+++ xterm-242/XTerm.ad 2009-02-18 15:00:23.000000000 +0100
|
||||
@@ -210,3 +210,12 @@
|
||||
diff -up xterm-245/XTerm.ad.resources xterm-245/XTerm.ad
|
||||
--- xterm-245/XTerm.ad.resources 2009-02-13 01:14:13.000000000 +0100
|
||||
+++ xterm-245/XTerm.ad 2009-08-13 12:28:59.000000000 +0200
|
||||
@@ -210,3 +210,13 @@
|
||||
!*allowTcapOps: false
|
||||
!*allowTitleOps: false
|
||||
!*allowWindowOps: false
|
||||
+
|
||||
+! Red Hat Defaults:
|
||||
+*allowFontOps: false
|
||||
+*allowTcapOps: false
|
||||
+*allowWindowOps: false
|
||||
+*VT100*eightBitInput: false
|
||||
+*VT100*metaSendsEscape: true
|
15
xterm.spec
15
xterm.spec
@ -1,7 +1,7 @@
|
||||
Summary: Terminal emulator for the X Window System
|
||||
Name: xterm
|
||||
Version: 242
|
||||
Release: 4%{?dist}
|
||||
Version: 245
|
||||
Release: 1%{?dist}
|
||||
URL: http://dickey.his.com/xterm
|
||||
License: MIT
|
||||
Group: User Interface/X
|
||||
@ -13,10 +13,9 @@ Source0: ftp://invisible-island.net/xterm/%{name}-%{version}.tgz
|
||||
Source1: ftp://invisible-island.net/xterm/16colors.txt
|
||||
Source2: %{name}.desktop
|
||||
|
||||
Patch1: xterm-242-resources.patch
|
||||
Patch1: xterm-245-resources.patch
|
||||
Patch2: xterm-222-can-2003-0063.patch
|
||||
Patch3: xterm-226-man-page_paths.patch
|
||||
Patch4: xterm-242-xbell.patch
|
||||
|
||||
%bcond_with trace
|
||||
|
||||
@ -33,16 +32,13 @@ programs that can't use the window system directly.
|
||||
%patch1 -p1 -b .resources
|
||||
%patch2 -p1 -b .can-2003-0063
|
||||
%patch3 -p1 -b .man-page_paths
|
||||
%patch4 -p1 -b .xbell
|
||||
|
||||
%build
|
||||
%configure \
|
||||
--enable-256-color \
|
||||
--enable-exec-xterm \
|
||||
--enable-luit \
|
||||
%if %{with trace}
|
||||
--enable-trace \
|
||||
%endif
|
||||
%{?with_trace: --enable-trace} \
|
||||
--enable-warnings \
|
||||
--enable-wide-chars \
|
||||
--with-app-defaults=%{x11_app_defaults_dir} \
|
||||
@ -84,6 +80,9 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{x11_app_defaults_dir}/XTerm-color
|
||||
|
||||
%changelog
|
||||
* Thu Aug 13 2009 Miroslav Lichvar <mlichvar@redhat.com> 245-1
|
||||
- update to 245
|
||||
|
||||
* Mon Jul 27 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 242-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user