import xsom-0-19.20110809svn.module+el8.1.0+3366+6dfb954c
This commit is contained in:
commit
cfbeeb77cd
2
.gitignore
vendored
Normal file
2
.gitignore
vendored
Normal file
@ -0,0 +1,2 @@
|
|||||||
|
SOURCES/lcm.xsd
|
||||||
|
SOURCES/xsom-20110809svn.tar.gz
|
2
.xsom.metadata
Normal file
2
.xsom.metadata
Normal file
@ -0,0 +1,2 @@
|
|||||||
|
af5d00d0e5d05851dd06501cfd36ea2027d916d2 SOURCES/lcm.xsd
|
||||||
|
af862a98a0d67645d2c6cb37417560a98d54f2e9 SOURCES/xsom-20110809svn.tar.gz
|
38
SOURCES/xsom-20110809svn-pom.patch
Normal file
38
SOURCES/xsom-20110809svn-pom.patch
Normal file
@ -0,0 +1,38 @@
|
|||||||
|
diff -Naur xsom-20110809/pom.xml xsom-20110809-work/pom.xml
|
||||||
|
--- xsom-20110809/pom.xml 2011-08-09 09:26:44.000000000 -0400
|
||||||
|
+++ xsom-20110809-work/pom.xml 2012-01-19 10:26:49.613983857 -0500
|
||||||
|
@@ -49,11 +49,6 @@
|
||||||
|
<url>http://xsom.java.net/</url>
|
||||||
|
<version>20110809</version>
|
||||||
|
<packaging>jar</packaging>
|
||||||
|
- <parent>
|
||||||
|
- <groupId>net.java</groupId>
|
||||||
|
- <artifactId>jvnet-parent</artifactId>
|
||||||
|
- <version>1</version>
|
||||||
|
- </parent>
|
||||||
|
<licenses>
|
||||||
|
<license>
|
||||||
|
<name>CDDL v1.1 / GPL v2 dual license</name>
|
||||||
|
@@ -146,12 +141,6 @@
|
||||||
|
<phase>generate-sources</phase>
|
||||||
|
<configuration>
|
||||||
|
<tasks>
|
||||||
|
- <taskdef name="licence" classname="com.sun.tools.LicenceTask">
|
||||||
|
- <classpath>
|
||||||
|
- <pathelement path="lib/lic.jar" />
|
||||||
|
- </classpath>
|
||||||
|
- </taskdef>
|
||||||
|
-
|
||||||
|
<mkdir dir="build/automata" />
|
||||||
|
|
||||||
|
<!-- delete old files to avoid corruption -->
|
||||||
|
@@ -164,9 +153,6 @@
|
||||||
|
<arg path="build/src/com/sun/xml/xsom/impl/parser/state" />
|
||||||
|
<arg path="src/xmlschema.rng" />
|
||||||
|
</java>
|
||||||
|
- <licence licence="licenceheader.txt">
|
||||||
|
- <fileset dir="build/src/" includes="com/sun/xml/xsom/impl/parser/state/*.java" />
|
||||||
|
- </licence>
|
||||||
|
</tasks>
|
||||||
|
</configuration>
|
||||||
|
<goals>
|
129
SPECS/xsom.spec
Normal file
129
SPECS/xsom.spec
Normal file
@ -0,0 +1,129 @@
|
|||||||
|
%global checkout 20110809
|
||||||
|
|
||||||
|
Name: xsom
|
||||||
|
Version: 0
|
||||||
|
Release: 19.%{checkout}svn%{?dist}
|
||||||
|
Summary: XML Schema Object Model (XSOM)
|
||||||
|
License: CDDL-1.1 or GPLv2 with exceptions
|
||||||
|
URL: http://xsom.java.net
|
||||||
|
|
||||||
|
# svn export https://svn.java.net/svn/xsom~sources/tags/xsom-20110809 xsom-20110809svn
|
||||||
|
# find xsom-20110809svn/ -name '*.class' -delete
|
||||||
|
# find xsom-20110809svn/ -name '*.class' -delete
|
||||||
|
# tar czf xsom-20110809svn.tar.gz xsom-20110809svn
|
||||||
|
Source0: %{name}-%{checkout}svn.tar.gz
|
||||||
|
|
||||||
|
# We need this because one of the original tests tries to download
|
||||||
|
# it from the website, but that doesn't work in Koji:
|
||||||
|
Source1: http://docs.oasis-open.org/regrep/v3.0/schema/lcm.xsd
|
||||||
|
|
||||||
|
Patch0: %{name}-%{checkout}svn-pom.patch
|
||||||
|
|
||||||
|
BuildRequires: maven-local
|
||||||
|
BuildRequires: mvn(junit:junit)
|
||||||
|
BuildRequires: mvn(org.apache.maven.plugins:maven-antrun-plugin)
|
||||||
|
BuildRequires: mvn(org.codehaus.mojo:build-helper-maven-plugin)
|
||||||
|
BuildRequires: mvn(relaxngDatatype:relaxngDatatype)
|
||||||
|
BuildRequires: relaxngcc
|
||||||
|
|
||||||
|
BuildArch: noarch
|
||||||
|
|
||||||
|
%description
|
||||||
|
XML Schema Object Model (XSOM) is a Java library that allows applications to
|
||||||
|
easily parse XML Schema documents and inspect information in them. It is
|
||||||
|
expected to be useful for applications that need to take XML Schema as an
|
||||||
|
input. The library is a straight-forward implement of "schema components" as
|
||||||
|
defined in the XML Schema spec part 1. Refer to this specification of how this
|
||||||
|
object model works.
|
||||||
|
|
||||||
|
%package javadoc
|
||||||
|
Summary: Javadoc for %{name}
|
||||||
|
|
||||||
|
%description javadoc
|
||||||
|
This package contains javadoc for %{name}.
|
||||||
|
|
||||||
|
%prep
|
||||||
|
%setup -q -n %{name}-%{checkout}svn
|
||||||
|
%patch0 -p1
|
||||||
|
|
||||||
|
# Replace the URL of the XSD file used by the tests with its
|
||||||
|
# absolute filesystem location:
|
||||||
|
sed -i \
|
||||||
|
's|http://docs.oasis-open.org/regrep/v3.0/schema/lcm.xsd|file://%{SOURCE1}|' \
|
||||||
|
test/XSOMParserTest.java
|
||||||
|
|
||||||
|
pushd lib
|
||||||
|
ln -sf `build-classpath relaxngcc` relaxngcc.jar
|
||||||
|
popd
|
||||||
|
|
||||||
|
%build
|
||||||
|
%mvn_build -- -Dproject.build.sourceEncoding=UTF-8
|
||||||
|
|
||||||
|
%install
|
||||||
|
%mvn_install
|
||||||
|
|
||||||
|
%files -f .mfiles
|
||||||
|
%doc license.txt
|
||||||
|
|
||||||
|
%files javadoc -f .mfiles-javadoc
|
||||||
|
%doc license.txt
|
||||||
|
|
||||||
|
%changelog
|
||||||
|
* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0-19.20110809svn
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Nov 09 2017 Michael Simacek <msimacek@redhat.com> - 0-18.20110809svn
|
||||||
|
- Specify CDDL license version
|
||||||
|
|
||||||
|
* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0-17.20110809svn
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0-16.20110809svn
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri Feb 05 2016 Fedora Release Engineering <releng@fedoraproject.org> - 0-15.20110809svn
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri Jun 19 2015 Michal Srb <msrb@redhat.com> - 0-14.20110809svn
|
||||||
|
- Fix FTBFS
|
||||||
|
|
||||||
|
* Fri Jun 19 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0-13.20110809svn
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||||
|
|
||||||
|
* Mon Aug 04 2014 Yaakov Selkowitz <yselkowi@redhat.com> - 0-12.20110809svn
|
||||||
|
- Fix junit BRs (#1107359)
|
||||||
|
- Fix FTBFS due to F21 XMvn changes
|
||||||
|
|
||||||
|
* Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0-11.20110809svn
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||||
|
|
||||||
|
* Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0-10.20110809svn
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||||
|
|
||||||
|
* Fri Feb 22 2013 Juan Hernandez <juan.hernandez@redhat.com> - 0-9.20110809svn
|
||||||
|
- Add build dependency on maven-shared (rhbz 914590)
|
||||||
|
|
||||||
|
* Fri Feb 15 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0-8.20110809svn
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
||||||
|
|
||||||
|
* Wed Feb 06 2013 Java SIG <java-devel@lists.fedoraproject.org> - 0-7.20110809svn
|
||||||
|
- Update for https://fedoraproject.org/wiki/Fedora_19_Maven_Rebuild
|
||||||
|
- Replace maven BuildRequires with maven-local
|
||||||
|
|
||||||
|
* Sun Jul 22 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0-6.20110809svn
|
||||||
|
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||||
|
|
||||||
|
* Thu Feb 23 2012 Juan Hernandez <juan.hernandez@redhat.com> 0-5.20110809svn
|
||||||
|
- Update the release tag
|
||||||
|
|
||||||
|
* Thu Feb 23 2012 Juan Hernandez <juan.hernandez@redhat.com> 0-4.20110809svn
|
||||||
|
- Avoid downloading XSD files during the build process
|
||||||
|
|
||||||
|
* Wed Feb 22 2012 Juan Hernandez <juan.hernandez@redhat.com> 0-3.20110809svn
|
||||||
|
- Put the date tag in the release instead of in the version
|
||||||
|
|
||||||
|
* Tue Feb 14 2012 Juan Hernandez <juan.hernandez@redhat.com> 0-2.20110809svn
|
||||||
|
- Cleanup of the spec file
|
||||||
|
|
||||||
|
* Sat Jan 21 2012 Marek Goldmann <mgoldman@redhat.com> 0-1.20110809svn
|
||||||
|
- Initial packaging
|
Loading…
Reference in New Issue
Block a user