106 lines
4.4 KiB
Diff
106 lines
4.4 KiB
Diff
diff -up xsane-0.997/configure.in.off-root-build xsane-0.997/configure.in
|
|
--- xsane-0.997/configure.in.off-root-build 2009-07-21 20:37:20.000000000 +0200
|
|
+++ xsane-0.997/configure.in 2010-06-23 10:52:32.072734684 +0200
|
|
@@ -312,4 +312,4 @@ echo "* --------------------------------
|
|
echo "* ... PLEASE READ SANE DOCUMENTATION BEFORE STARTING XSANE ... *"
|
|
echo "* ------------------------------------------------------------ *"
|
|
echo "****************************************************************"
|
|
-cat xsane.NEWS
|
|
+cat ${srcdir}/xsane.NEWS
|
|
diff -up xsane-0.997/doc/Makefile.in.off-root-build xsane-0.997/doc/Makefile.in
|
|
--- xsane-0.997/doc/Makefile.in.off-root-build 2006-01-01 14:08:11.000000000 +0100
|
|
+++ xsane-0.997/doc/Makefile.in 2010-06-23 11:07:26.792736949 +0200
|
|
@@ -57,14 +57,14 @@ install: $(MANPAGES)
|
|
$(MKINSTALLDIRS) $(DESTDIR)$(datadir)
|
|
|
|
$(MKINSTALLDIRS) $(DESTDIR)$(xsanedocdir)
|
|
- @for page in *.html; do\
|
|
+ @for page in $(notdir $(wildcard $(srcdir)/*.html)); do \
|
|
echo installing $${page} in $(DESTDIR)$(xsanedocdir)/$${page}...; \
|
|
- $(INSTALL_DATA) $${page} $(DESTDIR)$(xsanedocdir)/$${page} || exit 1; \
|
|
+ $(INSTALL_DATA) $(srcdir)/$${page} $(DESTDIR)$(xsanedocdir)/$${page} || exit 1; \
|
|
done
|
|
|
|
- @for image in *.jpg; do\
|
|
+ @for image in $(notdir $(wildcard $(srcdir)/*.jpg)); do \
|
|
echo installing $${image} in $(DESTDIR)$(xsanedocdir)/$${image}...; \
|
|
- $(INSTALL_DATA) $${image} $(DESTDIR)$(xsanedocdir)/$${image} || exit 1; \
|
|
+ $(INSTALL_DATA) $(srcdir)/$${image} $(DESTDIR)$(xsanedocdir)/$${image} || exit 1; \
|
|
done
|
|
|
|
uninstall:
|
|
@@ -73,12 +73,12 @@ uninstall:
|
|
rm -f $(DESTDIR)$(mandir)/man1/$${page} || exit 1; \
|
|
done
|
|
|
|
- @for page in *.html; do\
|
|
+ @for page in $(notdir $(wildcard $(srcdir)/*.html)); do \
|
|
echo uninstalling $(DESTDIR)$(xsanedocdir)/$${page}...; \
|
|
rm -f $(DESTDIR)$(xsanedocdir)/$${page} || exit 1; \
|
|
done
|
|
|
|
- @for image in *.jpg; do\
|
|
+ @for image in $(notdir $(wildcard $(srcdir)/*.jpg)); do \
|
|
echo uninstalling $${image} in $(DESTDIR)$(xsanedocdir)/$${image}...; \
|
|
rm -f $(DESTDIR)$(xsanedocdir)/$${image} || exit 1; \
|
|
done
|
|
diff -up xsane-0.997/include/Makefile.in.off-root-build xsane-0.997/include/Makefile.in
|
|
diff -up xsane-0.997/intl/Makefile.in.off-root-build xsane-0.997/intl/Makefile.in
|
|
diff -up xsane-0.997/lib/Makefile.in.off-root-build xsane-0.997/lib/Makefile.in
|
|
--- xsane-0.997/lib/Makefile.in.off-root-build 2003-11-22 10:51:42.000000000 +0100
|
|
+++ xsane-0.997/lib/Makefile.in 2010-06-23 11:03:23.760737284 +0200
|
|
@@ -30,7 +30,7 @@ RANLIB = @RANLIB@
|
|
|
|
CC = @CC@
|
|
INCLUDES = -I. -I$(srcdir) \
|
|
- -I$(top_builddir)/include/sane -I$(top_srcdir)/include
|
|
+ -I$(top_builddir)/include/sane -I$(top_builddir)/include -I$(top_srcdir)/include
|
|
CPPFLAGS = @CPPFLAGS@
|
|
CFLAGS = @CFLAGS@
|
|
LDFLAGS = @LDFLAGS@
|
|
@@ -68,7 +68,7 @@ uninstall:
|
|
check:
|
|
|
|
depend:
|
|
- makedepend -I. -I../include *.c
|
|
+ makedepend -I. -I../include $(srcdir)/*.c
|
|
|
|
clean:
|
|
rm -f *.out *.o *.lo *~ *.a *.bak $(TESTPROGRAMS)
|
|
diff -up xsane-0.997/Makefile.in.off-root-build xsane-0.997/Makefile.in
|
|
diff -up xsane-0.997/po/Makefile.in.off-root-build xsane-0.997/po/Makefile.in
|
|
diff -up xsane-0.997/src/Makefile.in.off-root-build xsane-0.997/src/Makefile.in
|
|
--- xsane-0.997/src/Makefile.in.off-root-build 2008-03-29 10:51:00.000000000 +0100
|
|
+++ xsane-0.997/src/Makefile.in 2010-06-23 11:01:27.031779998 +0200
|
|
@@ -77,10 +77,10 @@ install: $(PROGRAMS)
|
|
$(INSTALL_DATA) $(srcdir)/xsane-eula.txt $(DESTDIR)$(sanedatadir)/xsane/xsane-eula.txt
|
|
$(INSTALL_DATA) $(srcdir)/xsane.desktop $(DESTDIR)$(desktopappdir)/xsane.desktop
|
|
$(INSTALL_DATA) $(srcdir)/xsane.xpm $(DESTDIR)$(pixmapdir)/xsane.xpm
|
|
- @for logo in *-logo.xpm; do \
|
|
+ @for logo in $(notdir $(wildcard $(srcdir)/*-logo.xpm)); do \
|
|
echo installing $(DESTDIR)$(sanedatadir)/xsane/$${logo}; \
|
|
$(INSTALL_DATA) $(srcdir)/$${logo} $(DESTDIR)$(sanedatadir)/xsane/$${logo}; \
|
|
- done
|
|
+ done
|
|
|
|
uninstall:
|
|
@for program in $(BINPROGS); do \
|
|
@@ -99,7 +99,7 @@ uninstall:
|
|
rm -f $(DESTDIR)$(desktopappdir)/xsane.desktop
|
|
echo uninstalling $(DESTDIR)$(pixmapdir)/xsane.xpm
|
|
rm -f $(DESTDIR)$(pixmapdir)/xsane.xpm
|
|
- @for logo in *-logo.xpm; do \
|
|
+ @for logo in $(notdir $(wildcard $(srcdir)/*-logo.xpm)); do \
|
|
echo uninstalling $(DESTDIR)$(sanedatadir)/xsane/$${logo}; \
|
|
rm -f $(DESTDIR)$(sanedatadir)/xsane/$${logo}; \
|
|
done
|
|
@@ -119,7 +119,7 @@ distclean: clean
|
|
rm -f Makefile $(PROGRAMS)
|
|
|
|
depend:
|
|
- makedepend $(INCLUDES) *.c
|
|
+ makedepend $(INCLUDES) $(srcdir)/*.c
|
|
|
|
.PHONY: all install depend clean distclean
|
|
|