- 0.95.
- No longer need badcode patch. - Enable translations again. - New method of installing GIMP plug-in due to Nils Philippsen.
This commit is contained in:
parent
ce3f8caf70
commit
b39eaac3a0
@ -1 +1,2 @@
|
||||
xsane-0.92.tar.gz
|
||||
xsane-0.95.tar.gz
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
a5504d63cc5c9edb9ec484bd74581177 xsane-0.92.tar.gz
|
||||
164b7491ce833300903e38ac38c7d177 xsane-0.95.tar.gz
|
||||
|
@ -1,11 +1,11 @@
|
||||
--- xsane-0.90/src/xsane.h.htmlview 2003-04-09 17:48:52.000000000 +0100
|
||||
+++ xsane-0.90/src/xsane.h 2003-04-09 17:49:04.000000000 +0100
|
||||
@@ -354,7 +354,7 @@
|
||||
#define OCROUTFDOPT "-x"
|
||||
#define OCRPROGRESSKEY ""
|
||||
#define DOCVIEWER_NETSCAPE "netscape"
|
||||
-#define DOCVIEWER DOCVIEWER_NETSCAPE
|
||||
+#define DOCVIEWER "htmlview"
|
||||
--- xsane-0.95/src/xsane.h.htmlview 2004-08-13 08:48:06.000000000 +0100
|
||||
+++ xsane-0.95/src/xsane.h 2004-12-03 14:39:05.854256418 +0000
|
||||
@@ -205,7 +205,7 @@
|
||||
# elif defined(HAVE_OS2_H)
|
||||
# define DEFAULT_BROWSER "netscape"
|
||||
# else
|
||||
-# define DEFAULT_BROWSER "netscape"
|
||||
+# define DEFAULT_BROWSER "htmlview"
|
||||
# endif
|
||||
#endif
|
||||
|
||||
#define XSANE_MEDIUM_CALIB_BRIGHTNESS_MIN -1000.0
|
||||
#define XSANE_MEDIUM_CALIB_BRIGHTNESS_MAX 1000.0
|
||||
|
19133
xsane-0.92_gimp2.0.patch
19133
xsane-0.92_gimp2.0.patch
File diff suppressed because it is too large
Load Diff
49
xsane.spec
49
xsane.spec
@ -1,10 +1,10 @@
|
||||
Name: xsane
|
||||
Summary: An X Window System front-end for the SANE scanner interface.
|
||||
Version: 0.92
|
||||
Release: 13
|
||||
Source: http://www.xsane.org/download/%{name}-%{version}.tar.gz
|
||||
Version: 0.95
|
||||
Release: 1
|
||||
Source0: http://www.xsane.org/download/%{name}-%{version}.tar.gz
|
||||
Source1: xsane-install-gimp-plugin
|
||||
Patch0: xsane-0.90-htmlview.patch
|
||||
Patch1: xsane-0.91-badcode.patch
|
||||
Patch2: xsane-0.92_gimp2.0.patch
|
||||
License: GPL
|
||||
URL: http://www.xsane.org/
|
||||
@ -35,12 +35,11 @@ installed to use this package.
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
%setup -q
|
||||
%patch0 -p1 -b .htmlview
|
||||
%patch1 -p1 -b .badcode
|
||||
%patch2 -p1 -b .gimp2.0
|
||||
|
||||
%build
|
||||
%{expand:%%define optflags %{optflags} -DGIMP_ENABLE_COMPAT_CRUFT=1}
|
||||
aclocal
|
||||
aclocal -I m4
|
||||
autoconf
|
||||
%configure --with-install-root=%{buildroot}
|
||||
make LDFLAGS=
|
||||
@ -58,15 +57,16 @@ rm -rf $RPM_BUILD_ROOT
|
||||
install src/xsane-gimp %{buildroot}%{_bindir}
|
||||
|
||||
mkdir -p %{buildroot}/etc/X11/applnk/Graphics
|
||||
mkdir -p %{buildroot}%{_sbindir}
|
||||
install -m 0755 %SOURCE1 %{buildroot}%{_sbindir}/xsane-install-gimp-plugin
|
||||
|
||||
#%find_lang %{name}
|
||||
%find_lang %{name}
|
||||
|
||||
|
||||
%clean
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
#%files -f %{name}.lang
|
||||
%files
|
||||
%files -f %{name}.lang
|
||||
%defattr(-,root,root)
|
||||
%doc xsane.[A-Z]*
|
||||
%{_bindir}/xsane
|
||||
@ -76,35 +76,28 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%files gimp
|
||||
%defattr(-,root,root)
|
||||
%{_bindir}/xsane-gimp
|
||||
%{_sbindir}/xsane-install-gimp-plugin
|
||||
%%dir %{_datadir}/sane
|
||||
%%dir %{_datadir}/sane/xsane
|
||||
%{_datadir}/sane/xsane/*eula*
|
||||
|
||||
%post gimp
|
||||
if [ -x /usr/bin/gimp-config ]; then
|
||||
GIMPPLUGINDIR=`/usr/bin/gimp-config --gimpplugindir`
|
||||
elif [ -x /usr/bin/gimptool-* ]; then
|
||||
GIMPPLUGINDIR=`/usr/bin/gimptool-* --gimpplugindir`
|
||||
fi
|
||||
if [ -z "$GIMPPLUGINDIR" ]; then
|
||||
GIMPPLUGINDIR=%{_libdir}/gimp/1.3
|
||||
fi
|
||||
RELPATH=`echo $GIMPPLUGINDIR | awk '
|
||||
BEGIN { FS="/"; i = 1} {while (i < NF) { printf("../"); i = i + 1} }'`
|
||||
if [ ! -s $GIMPPLUGINDIR/plug-ins/xsane ]; then
|
||||
ln -s $RELPATH/bin/xsane-gimp $GIMPPLUGINDIR/plug-ins/xsane
|
||||
fi
|
||||
%{_sbindir}/xsane-install-gimp-plugin --install
|
||||
exit 0
|
||||
|
||||
|
||||
%postun gimp
|
||||
%preun gimp
|
||||
if [ $1 = 0 ]; then
|
||||
rm -f %{_libdir}/gimp/1.3/plug-ins/xsane
|
||||
rm -f %{_libdir}/gimp/1.2/plug-ins/xsane
|
||||
rm -f %{_libdir}/gimp/1.1/plug-ins/xsane
|
||||
rm -f %{_libdir}/gimp/1.0/plug-ins/xsane
|
||||
%{_sbindir}/xsane-install-gimp-plugin --uninstall
|
||||
fi
|
||||
exit 0
|
||||
|
||||
%changelog
|
||||
* Fri Dec 3 2004 Tim Waugh <twaugh@redhat.com> 0.95-1
|
||||
- 0.95.
|
||||
- No longer need badcode patch.
|
||||
- Enable translations again.
|
||||
- New method of installing GIMP plug-in due to Nils Philippsen.
|
||||
|
||||
* Mon Jun 28 2004 Tim Waugh <twaugh@redhat.com> 0.92-13
|
||||
- Build requires libtiff-devel (bug #126564).
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user