version 0.999
- remove obsolete patches - update/fix patch comments
This commit is contained in:
parent
7469bd0420
commit
59ce0c3532
2
.gitignore
vendored
2
.gitignore
vendored
@ -3,3 +3,5 @@ xsane-0.997-5-autoconf.patch.bz2
|
||||
/xsane-0.998.tar.gz
|
||||
/xsane-0.998-1-autoconf.patch.bz2
|
||||
/xsane-256x256.png
|
||||
/xsane-0.999-1-autoconf.patch.bz2
|
||||
/xsane-0.999.tar.gz
|
||||
|
4
sources
4
sources
@ -1,3 +1,3 @@
|
||||
936f1cc76b37caa8f285e1e15ac7e0aa xsane-0.998.tar.gz
|
||||
ccd4da2bfd19ba9e778a278ad6ca4472 xsane-0.998-1-autoconf.patch.bz2
|
||||
bd62603e67d7472b93cee42f57ae14b8 xsane-256x256.png
|
||||
837d97ed5f05054a1ba95b275fd08c13 xsane-0.999-1-autoconf.patch.bz2
|
||||
9927f21e1ab6ba96315e7f0e30746deb xsane-0.999.tar.gz
|
||||
|
@ -1,48 +0,0 @@
|
||||
From 38ae9448edd4375ee02b4b9e4b0b10464b699aa6 Mon Sep 17 00:00:00 2001
|
||||
From: Nils Philippsen <nils@redhat.com>
|
||||
Date: Mon, 3 Sep 2012 16:16:15 +0200
|
||||
Subject: [PATCH] patch: man
|
||||
|
||||
Squashed commit of the following:
|
||||
|
||||
commit 949c90a0b4debad8f78889e693fc01d43a7b802a
|
||||
Author: John Bradshaw <john@johnbradshaw.org>
|
||||
Date: Sat Feb 5 17:06:37 2011 +0000
|
||||
|
||||
correct man page
|
||||
---
|
||||
doc/xsane.man | 6 +++---
|
||||
1 file changed, 3 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/doc/xsane.man b/doc/xsane.man
|
||||
index d4907f7..ee363a8 100644
|
||||
--- a/doc/xsane.man
|
||||
+++ b/doc/xsane.man
|
||||
@@ -126,13 +126,13 @@ or
|
||||
.B -v
|
||||
flag is given xsane prints a version information, some
|
||||
information about gtk+ and gimp version it is compiled
|
||||
-against and lists the supported fileformats, then it exits.
|
||||
+against and lists the supported file formats, then it exits.
|
||||
.PP
|
||||
when the
|
||||
.B --license
|
||||
or
|
||||
.B -l
|
||||
-flag is igven xsane prints license information and exits.
|
||||
+flag is given xsane prints license information and exits.
|
||||
.PP
|
||||
The
|
||||
.B --device-settings
|
||||
@@ -176,7 +176,7 @@ The
|
||||
.B --no-mode-selection
|
||||
or
|
||||
.B -n
|
||||
-flag disables the menu for xsane mode selection (viwer, save, copy, fax, mail).
|
||||
+flag disables the menu for xsane mode selection (viewer, save, copy, fax, mail).
|
||||
.PP
|
||||
If the
|
||||
.B --Fixed
|
||||
--
|
||||
1.7.11.4
|
||||
|
@ -1,44 +0,0 @@
|
||||
From 7b47e322551f1c2ffe38e2f6f8cfde1b9de084ec Mon Sep 17 00:00:00 2001
|
||||
From: Nils Philippsen <nils@redhat.com>
|
||||
Date: Fri, 17 May 2013 14:14:55 +0200
|
||||
Subject: [PATCH] patch: null-preview-crash
|
||||
|
||||
Squashed commit of the following:
|
||||
|
||||
commit c9b1ee0aaf9701f6d3bd14b32354fa5b2bcd1433
|
||||
Author: Nils Philippsen <nils@redhat.com>
|
||||
Date: Fri May 17 14:14:28 2013 +0200
|
||||
|
||||
don't dereference xsane.preview if it is NULL
|
||||
---
|
||||
src/xsane-front-gtk.c | 7 +++++--
|
||||
1 file changed, 5 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/src/xsane-front-gtk.c b/src/xsane-front-gtk.c
|
||||
index 08761a0..8502c03 100644
|
||||
--- a/src/xsane-front-gtk.c
|
||||
+++ b/src/xsane-front-gtk.c
|
||||
@@ -1713,7 +1713,7 @@ void xsane_update_param(void *arg)
|
||||
gtk_label_set(GTK_LABEL(xsane.info_label), buf);
|
||||
|
||||
|
||||
- if (xsane.preview->surface_unit == SANE_UNIT_MM)
|
||||
+ if (xsane.preview && xsane.preview->surface_unit == SANE_UNIT_MM)
|
||||
{
|
||||
double dx, dy;
|
||||
|
||||
@@ -1728,7 +1728,10 @@ void xsane_update_param(void *arg)
|
||||
|
||||
xsane_update_histogram(TRUE /* update raw */);
|
||||
|
||||
- preview_display_valid(xsane.preview);
|
||||
+ if (xsane.preview)
|
||||
+ {
|
||||
+ preview_display_valid(xsane.preview);
|
||||
+ }
|
||||
}
|
||||
|
||||
/* ---------------------------------------------------------------------------------------------------------------------- */
|
||||
--
|
||||
1.8.1.4
|
||||
|
@ -1,56 +0,0 @@
|
||||
From d25c926e1354ea8d6c4b4636503d7548a50cbd7e Mon Sep 17 00:00:00 2001
|
||||
From: Nils Philippsen <nils@redhat.com>
|
||||
Date: Mon, 3 Sep 2012 16:07:44 +0200
|
||||
Subject: [PATCH] patch: preview-window-size
|
||||
|
||||
Squashed commit of the following:
|
||||
|
||||
commit 9fa241f0f4a21623e0ae5be871d885f6b082dd38
|
||||
Author: Nils Philippsen <nils@redhat.com>
|
||||
Date: Mon Sep 3 16:00:35 2012 +0200
|
||||
|
||||
calculate minimum window size better for multi-head setups
|
||||
---
|
||||
src/xsane-preview.c | 19 +++++++++++++++++--
|
||||
1 file changed, 17 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/src/xsane-preview.c b/src/xsane-preview.c
|
||||
index 264c775..634a4e2 100644
|
||||
--- a/src/xsane-preview.c
|
||||
+++ b/src/xsane-preview.c
|
||||
@@ -4665,6 +4665,9 @@ void preview_update_surface(Preview *p, int surface_changed)
|
||||
SANE_Unit unit;
|
||||
double min, max;
|
||||
int expand_surface = 0;
|
||||
+ gint min_width, min_height;
|
||||
+ GdkScreen *screen;
|
||||
+ GdkRectangle geometry;
|
||||
|
||||
DBG(DBG_proc, "preview_update_surface\n");
|
||||
|
||||
@@ -4848,8 +4851,20 @@ void preview_update_surface(Preview *p, int surface_changed)
|
||||
{
|
||||
DBG(DBG_info, "preview_update_surface: defining size of preview window\n");
|
||||
|
||||
- p->preview_window_width = 0.3 * gdk_screen_width();
|
||||
- p->preview_window_height = 0.5 * gdk_screen_height();
|
||||
+ /* ensure preview window fits on displays, account for multi-head */
|
||||
+ min_width = gdk_screen_width();
|
||||
+ min_height = gdk_screen_height();
|
||||
+
|
||||
+ screen = gdk_screen_get_default();
|
||||
+ for (i = 0; i < gdk_screen_get_n_monitors(screen); i++)
|
||||
+ {
|
||||
+ gdk_screen_get_monitor_geometry(screen, i, &geometry);
|
||||
+ min_width = MIN(min_width, geometry.width);
|
||||
+ min_height = MIN(min_height, geometry.height);
|
||||
+ }
|
||||
+
|
||||
+ p->preview_window_width = 0.3 * min_width;
|
||||
+ p->preview_window_height = 0.5 * min_height;
|
||||
preview_area_correct(p); /* calculate preview_width and height */
|
||||
gtk_widget_set_size_request(GTK_WIDGET(p->window), p->preview_width, p->preview_height);
|
||||
}
|
||||
--
|
||||
1.7.11.4
|
||||
|
45
xsane.spec
45
xsane.spec
@ -19,16 +19,18 @@
|
||||
|
||||
Name: xsane
|
||||
Summary: X Window System front-end for the SANE scanner interface
|
||||
Version: 0.998
|
||||
Release: 21%{?dist}
|
||||
Version: 0.999
|
||||
Release: 1%{?dist}
|
||||
Source0: http://www.xsane.org/download/%{name}-%{version}.tar.gz
|
||||
Source1: xsane-256x256.png
|
||||
# distro-specific: use "xdg-open" instead of "netscape" to launch help browser
|
||||
# use "xdg-open" instead of "netscape" to launch help browser
|
||||
# submitted to upstream (Oliver Rauch) via email, 2013-06-04
|
||||
Patch0: xsane-0.995-xdg-open.patch
|
||||
# submitted to upstream (Oliver Rauch) via email, 2009-08-18
|
||||
Patch1: xsane-0.995-close-fds.patch
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=504344
|
||||
# distro-specific, upstream won't accept it: "don't show license dialog"
|
||||
# distro-specific(?), upstream won't accept it: "don't show license dialog"
|
||||
# submitted to upstream (Oliver Rauch) anyway via email, 2013-06-04
|
||||
Patch2: xsane-0.996-no-eula.patch
|
||||
# enable off-root building
|
||||
# submitted to upstream (Oliver Rauch) via email, 2010-06-23
|
||||
@ -43,28 +45,19 @@ Patch5: xsane-0.997-ipv6.patch
|
||||
# fix from: https://bugs.launchpad.net/ubuntu/+source/xsane/+bug/370818
|
||||
# submitted to upstream (Oliver Rauch) via email, 2011-06-01
|
||||
Patch6: xsane-0.998-preview-selection.patch
|
||||
# build with libpng-1.5
|
||||
# fix building with libpng >= 1.5
|
||||
# submitted to upstream (Oliver Rauch) via email, 2011-11-21
|
||||
Patch7: xsane-0.998-libpng.patch
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=795085
|
||||
# distro-specific: set program name/wmclass so GNOME shell picks appropriate
|
||||
# high resolution icon file
|
||||
# set program name/wmclass so GNOME shell picks appropriate high resolution
|
||||
# icon file
|
||||
# submitted to upstream (Oliver Rauch) via email, 2013-06-04
|
||||
Patch8: xsane-0.998-wmclass.patch
|
||||
# calculate minimum window size better for multi-head setups
|
||||
# submitted to upstream (Oliver Rauch) via email, 2012-09-03
|
||||
Patch9: xsane-0.998-preview-window-size.patch
|
||||
# correct some typos in the man page, original patch by John Bradshaw
|
||||
# submitted to upstream (Oliver Rauch) via email, 2012-09-03
|
||||
Patch10: xsane-0.998-man.patch
|
||||
# distro-specific: customize desktop file
|
||||
Patch11: xsane-0.998-desktop-file.patch
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=693224
|
||||
# https://bugzilla.redhat.com/show_bug.cgi?id=963696
|
||||
# submitted to upstream (Oliver Rauch) via email, 2011-04-04 and (updated
|
||||
# patch) 2013-05-17
|
||||
Patch12: xsane-0.998-null-preview-crash.patch
|
||||
# partly distro-specific: customize desktop file
|
||||
# submitted to upstream (Oliver Rauch) via email, 2013-06-04
|
||||
Patch9: xsane-0.998-desktop-file.patch
|
||||
# autoconf-generated files
|
||||
Patch100: xsane-0.998-1-autoconf.patch.bz2
|
||||
Patch100: xsane-0.999-1-autoconf.patch.bz2
|
||||
License: GPLv2+
|
||||
URL: http://www.xsane.org/
|
||||
Group: Applications/Multimedia
|
||||
@ -124,10 +117,7 @@ done
|
||||
%patch6 -p1 -b .preview-selection.patch
|
||||
%patch7 -p1 -b .libpng
|
||||
%patch8 -p1 -b .wmclass
|
||||
%patch9 -p1 -b .preview-window-size
|
||||
%patch10 -p1 -b .man
|
||||
%patch11 -p1 -b .desktop-file
|
||||
%patch12 -p1 -b .null-preview-crash
|
||||
%patch9 -p1 -b .desktop-file
|
||||
|
||||
%patch100 -p1 -b .autoconf
|
||||
|
||||
@ -232,6 +222,11 @@ fi
|
||||
%{_datadir}/sane/xsane
|
||||
|
||||
%changelog
|
||||
* Tue Jun 04 2013 Nils Philippsen <nils@redhat.com> - 0.999-1
|
||||
- version 0.999
|
||||
- remove obsolete patches
|
||||
- update/fix patch comments
|
||||
|
||||
* Fri May 17 2013 Nils Philippsen <nils@redhat.com> - 0.998-21
|
||||
- don't dereference NULL preview objects when quitting (#963696)
|
||||
- fix vendor tag logic in a prettier way
|
||||
|
Loading…
Reference in New Issue
Block a user