103 lines
3.7 KiB
Diff
103 lines
3.7 KiB
Diff
From 0ba7fc8472f1227fd1cd51bd58048f164b8ea1ab Mon Sep 17 00:00:00 2001
|
|
From: Alan Coopersmith <alan.coopersmith@oracle.com>
|
|
Date: Tue, 12 Nov 2013 14:46:04 -0800
|
|
Subject: [PATCH 5/9] Stop including inline assembly .il file for Solaris
|
|
Studio builds
|
|
|
|
Since all the inb/outb/etc. use in the X server itself (except for
|
|
xf86SlowBcopy) has been replaced by calls to libpciaccess, we no
|
|
longer need to pass inline assembly files to replace the gcc inline
|
|
assembly from hw/xfree86/common/compiler.h when building Xorg itself.
|
|
|
|
The .il files are still generated and installed in the SDK for the
|
|
benefit of drivers who may use them.
|
|
|
|
Binary diff of before and after showed that xf86SlowBcopy was the
|
|
only function changed across the Xorg binary and all modules built
|
|
in the Xserver build, it just calls the outb() function now instead
|
|
of having the outb instructions inlined, making it a slightly slower
|
|
bcopy.
|
|
|
|
Signed-off-by: Alan Coopersmith <alan.coopersmith@oracle.com>
|
|
Reviewed-by: Keith Packard <keithp@keithp.com>
|
|
Signed-off-by: Keith Packard <keithp@keithp.com>
|
|
---
|
|
configure.ac | 9 ---------
|
|
exa/Makefile.am | 4 ----
|
|
hw/xfree86/Makefile.am | 11 -----------
|
|
3 files changed, 24 deletions(-)
|
|
|
|
diff --git a/configure.ac b/configure.ac
|
|
index 4be8fcb..1e6f813 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -1879,9 +1879,6 @@ if test "x$XORG" = xyes; then
|
|
if test "${OS_MINOR}" -lt 8 ; then
|
|
AC_MSG_ERROR([This release no longer supports Solaris versions older than Solaris 8.])
|
|
fi
|
|
- if test "x$SUNCC" = "xyes"; then
|
|
- solaris_asm_inline="yes"
|
|
- fi
|
|
AC_CHECK_DECL([_LP64], [SOLARIS_64="yes"], [SOLARIS_64="no"])
|
|
|
|
case $host_cpu in
|
|
@@ -1902,11 +1899,6 @@ if test "x$XORG" = xyes; then
|
|
xorg@lists.freedesktop.org.]) ;;
|
|
esac
|
|
AC_SUBST([SOLARIS_INOUT_ARCH])
|
|
- if test x$solaris_asm_inline = xyes ; then
|
|
- SOLARIS_ASM_CFLAGS='$(top_srcdir)/hw/xfree86/os-support/solaris/solaris-$(SOLARIS_INOUT_ARCH).il'
|
|
- XORG_CFLAGS="${XORG_CFLAGS} "'$(SOLARIS_ASM_CFLAGS)'
|
|
- fi
|
|
- AC_SUBST([SOLARIS_ASM_CFLAGS])
|
|
;;
|
|
gnu*)
|
|
XORG_OS_SUBDIR="hurd"
|
|
@@ -2012,7 +2004,6 @@ AM_CONDITIONAL([XORG_BUS_SPARC], [test "x$xorg_bus_sparc" = xyes])
|
|
AM_CONDITIONAL([LINUX_ALPHA], [test "x$linux_alpha" = xyes])
|
|
AM_CONDITIONAL([LNXACPI], [test "x$linux_acpi" = xyes])
|
|
AM_CONDITIONAL([LNXAPM], [test "x$linux_apm" = xyes])
|
|
-AM_CONDITIONAL([SOLARIS_ASM_INLINE], [test "x$solaris_asm_inline" = xyes])
|
|
AM_CONDITIONAL([SOLARIS_VT], [test "x$solaris_vt" = xyes])
|
|
AM_CONDITIONAL([DGA], [test "x$DGA" = xyes])
|
|
AM_CONDITIONAL([XF86VIDMODE], [test "x$XF86VIDMODE" = xyes])
|
|
diff --git a/exa/Makefile.am b/exa/Makefile.am
|
|
index c1f1e86..6a09966 100644
|
|
--- a/exa/Makefile.am
|
|
+++ b/exa/Makefile.am
|
|
@@ -1,9 +1,5 @@
|
|
noinst_LTLIBRARIES = libexa.la
|
|
|
|
-# Override these since EXA doesn't need them and the needed files aren't
|
|
-# built (in hw/xfree86/os-support/solaris) until after EXA is built
|
|
-SOLARIS_ASM_CFLAGS=""
|
|
-
|
|
if XORG
|
|
sdk_HEADERS = exa.h
|
|
endif
|
|
diff --git a/hw/xfree86/Makefile.am b/hw/xfree86/Makefile.am
|
|
index 485386f..15670d0 100644
|
|
--- a/hw/xfree86/Makefile.am
|
|
+++ b/hw/xfree86/Makefile.am
|
|
@@ -80,17 +80,6 @@ BUILT_SOURCES = xorg.conf.example
|
|
DISTCLEANFILES = xorg.conf.example
|
|
EXTRA_DIST = xorgconf.cpp
|
|
|
|
-if SOLARIS_ASM_INLINE
|
|
-# Needs to be built before any files are compiled when using Sun compilers
|
|
-# so in*/out* inline definitions are properly processed.
|
|
-
|
|
-BUILT_SOURCES += os-support/solaris/solaris-@SOLARIS_INOUT_ARCH@.il
|
|
-
|
|
-os-support/solaris/solaris-@SOLARIS_INOUT_ARCH@.il:
|
|
- cd os-support/solaris ; \
|
|
- $(MAKE) $(AM_MAKEFLAGS) solaris-@SOLARIS_INOUT_ARCH@.il
|
|
-endif
|
|
-
|
|
# Without logdir, X will post an error on the terminal and will not start
|
|
install-data-local:
|
|
$(AM_V_GEN)$(MKDIR_P) $(DESTDIR)$(logdir)
|
|
--
|
|
1.8.3.1
|
|
|