30 lines
813 B
Diff
30 lines
813 B
Diff
From 8fcf82cbf015609e00b3feb9bc567133c7aee5cf Mon Sep 17 00:00:00 2001
|
|
From: Keith Packard <keithp@keithp.com>
|
|
Date: Tue, 5 Nov 2013 18:39:11 -0800
|
|
Subject: [PATCH 5/5] Use $GL_LIBS instead of -lGL for linking
|
|
|
|
-lGL presumes that the GL library is in the system path, while
|
|
$GL_LIBS is auto-detected.
|
|
|
|
Signed-off-by: Keith Packard <keithp@keithp.com>
|
|
---
|
|
configure.ac | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/configure.ac b/configure.ac
|
|
index feeae04..6925df8 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -1075,7 +1075,7 @@ if test "x$GLX" = xyes; then
|
|
AC_SUBST(XLIB_CFLAGS)
|
|
AC_DEFINE(GLXEXT, 1, [Build GLX extension])
|
|
GLX_LIBS='$(top_builddir)/glx/libglx.la'
|
|
- GLX_SYS_LIBS="$GLX_SYS_LIBS -lGL"
|
|
+ GLX_SYS_LIBS="$GLX_SYS_LIBS $GL_LIBS"
|
|
else
|
|
GLX=no
|
|
fi
|
|
--
|
|
1.8.3.1
|
|
|