41 lines
1.1 KiB
Diff
41 lines
1.1 KiB
Diff
From 903a058370645ea075ea98d380fd565efb6160c9 Mon Sep 17 00:00:00 2001
|
|
From: Keith Packard <keithp@keithp.com>
|
|
Date: Mon, 4 Nov 2013 19:01:26 -0800
|
|
Subject: [PATCH 2/5] hw/xfree86: Link libdri3 only when DRI3 is defined
|
|
|
|
Don't attempt to link non-existant libraries...
|
|
|
|
Signed-off-by: Keith Packard <keithp@keithp.com>
|
|
---
|
|
hw/xfree86/Makefile.am | 7 ++++++-
|
|
1 file changed, 6 insertions(+), 1 deletion(-)
|
|
|
|
diff --git a/hw/xfree86/Makefile.am b/hw/xfree86/Makefile.am
|
|
index eea16a8..485386f 100644
|
|
--- a/hw/xfree86/Makefile.am
|
|
+++ b/hw/xfree86/Makefile.am
|
|
@@ -9,6 +9,11 @@ DRI2_SUBDIR = dri2
|
|
DRI2_LIB = dri2/libdri2.la
|
|
endif
|
|
|
|
+if DRI3
|
|
+DRI3_BUILDDIR = $(top_builddir)/dri3
|
|
+DRI3_LIB = $(DRI3_BUILDDIR)/libdri3.la
|
|
+endif
|
|
+
|
|
if XF86UTILS
|
|
XF86UTILS_SUBDIR = utils
|
|
endif
|
|
@@ -59,7 +64,7 @@ LOCAL_LIBS = \
|
|
dixmods/libxorgxkb.la \
|
|
$(DRI_LIB) \
|
|
$(DRI2_LIB) \
|
|
- $(top_builddir)/dri3/libdri3.la \
|
|
+ $(DRI3_LIB) \
|
|
$(top_builddir)/miext/sync/libsync.la \
|
|
$(top_builddir)/mi/libmi.la \
|
|
$(top_builddir)/os/libos.la
|
|
--
|
|
1.8.3.1
|
|
|