39 lines
1.3 KiB
Diff
39 lines
1.3 KiB
Diff
From d8d3c78b6ebdf63836951d2dbd2d3d621ff26da2 Mon Sep 17 00:00:00 2001
|
|
From: =?UTF-8?q?Andreas=20M=C3=BCller?= <schnitzeltony@googlemail.com>
|
|
Date: Tue, 16 Apr 2013 14:30:43 +0200
|
|
Subject: [PATCH] dixstruct.h: fix segfaults - char is unsigned for ARM and
|
|
PowerPC architectures
|
|
MIME-Version: 1.0
|
|
Content-Type: text/plain; charset=UTF-8
|
|
Content-Transfer-Encoding: 8bit
|
|
|
|
see ARM related bug reports [1-3]
|
|
|
|
[1] https://github.com/archlinuxarm/PKGBUILDs/issues/446I
|
|
[2] http://www.raspberrypi.org/phpBB3/viewtopic.php?t=38568&p=321673
|
|
[3] http://lists.linuxtogo.org/pipermail/openembedded-core/2013-April/037805.html
|
|
|
|
Signed-off-by: Andreas Müller <schnitzeltony@googlemail.com>
|
|
Reviewed-by: Mark Kettenis <kettenis@openbsd.org>
|
|
Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
|
|
---
|
|
include/dixstruct.h | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/include/dixstruct.h b/include/dixstruct.h
|
|
index 6784819..aef822c 100644
|
|
--- a/include/dixstruct.h
|
|
+++ b/include/dixstruct.h
|
|
@@ -96,7 +96,7 @@ typedef struct _Client {
|
|
unsigned int clientGone:1;
|
|
unsigned int closeDownMode:2;
|
|
unsigned int clientState:2;
|
|
- char smart_priority;
|
|
+ signed char smart_priority;
|
|
short noClientException; /* this client died or needs to be killed */
|
|
int priority;
|
|
ReplySwapPtr pSwapReplyFunc;
|
|
--
|
|
1.8.2.1
|
|
|