48dc8f4c68
- Re-disable int10 on arm
47 lines
1.4 KiB
Diff
47 lines
1.4 KiB
Diff
From c7d56befef2111c82e6720643824b9a46ae36670 Mon Sep 17 00:00:00 2001
|
|
From: Daniel Stone <daniel@fooishbar.org>
|
|
Date: Wed, 7 Nov 2012 17:15:13 +1100
|
|
Subject: [PATCH 18/38] XWayland: Don't hardcode DRM libs and -lwayland-client
|
|
|
|
Take -lwayland-client from configure.ac, and only use DRM if we've
|
|
actually asked for it.
|
|
|
|
Signed-off-by: Daniel Stone <daniel@fooishbar.org>
|
|
---
|
|
hw/xfree86/xwayland/Makefile.am | 8 +++++---
|
|
1 file changed, 5 insertions(+), 3 deletions(-)
|
|
|
|
diff --git a/hw/xfree86/xwayland/Makefile.am b/hw/xfree86/xwayland/Makefile.am
|
|
index b739145..22ab154 100644
|
|
--- a/hw/xfree86/xwayland/Makefile.am
|
|
+++ b/hw/xfree86/xwayland/Makefile.am
|
|
@@ -7,13 +7,13 @@ AM_CPPFLAGS = \
|
|
-I$(srcdir)/../modes
|
|
|
|
libxwayland_la_LTLIBRARIES = libxwayland.la
|
|
-libxwayland_la_CFLAGS = \
|
|
+AM_CFLAGS = \
|
|
-DHAVE_XORG_CONFIG_H \
|
|
- @DIX_CFLAGS@ @XORG_CFLAGS@ @LIBDRM_CFLAGS@ \
|
|
+ @DIX_CFLAGS@ @XORG_CFLAGS@ @XWAYLAND_CFLAGS@ \
|
|
-I$(top_srcdir)/hw/xfree86/common \
|
|
-I$(top_srcdir)/hw/xfree86/os-support/bus
|
|
|
|
-libxwayland_la_LDFLAGS = -module -avoid-version @LIBDRM_LIBS@ -lwayland-client
|
|
+libxwayland_la_LDFLAGS = -module -avoid-version @XWAYLAND_LIBS@
|
|
libxwayland_ladir = $(moduledir)/extensions
|
|
libxwayland_la_SOURCES = \
|
|
xwayland.c \
|
|
@@ -28,6 +28,8 @@ libxwayland_la_SOURCES = \
|
|
xserver-protocol.c
|
|
|
|
if DRM
|
|
+AM_CFLAGS += @LIBDRM_CFLAGS@
|
|
+libxwayland_la_LDFLAGS += @LIBDRM_LIBS@
|
|
libxwayland_la_SOURCES += xwayland-drm.c
|
|
endif
|
|
|
|
--
|
|
1.8.4.2
|
|
|