Fix building with new libglvnd provided gl.pc
This commit is contained in:
parent
3ae2631a52
commit
f1f3380dc7
64
0001-build-glx-Lower-gl-version-to-work-with-libglvnd.patch
Normal file
64
0001-build-glx-Lower-gl-version-to-work-with-libglvnd.patch
Normal file
@ -0,0 +1,64 @@
|
||||
From e6ef2b12404dfec7f23592a3524d2a63d9d25802 Mon Sep 17 00:00:00 2001
|
||||
From: Marvin Schmidt <marv@exherbo.org>
|
||||
Date: Tue, 24 Sep 2019 09:58:43 +0200
|
||||
Subject: [PATCH xserver] build: glx: Lower gl version to work with libglvnd
|
||||
|
||||
When using mesa with libglvnd support, mesa will no longer install the
|
||||
gl, glx, egl pkg-config files but instead let libglvnd provide them.
|
||||
libglvnd maintainers decided to change the versioning as it was
|
||||
mesa-specific previously. Now the libraries have versions of the API
|
||||
they expose[1].
|
||||
This causes problems when building the X server:
|
||||
|
||||
checking for glproto >= 1.4.17 gl >= 9.2.0... no
|
||||
configure: error: Package requirements (glproto >= 1.4.17 gl >= 9.2.0) were not met:
|
||||
|
||||
Requested 'gl >= 9.2.0' but version of gl is 1.2
|
||||
|
||||
Lower the version requirement to 1.2 to allow building against libglvnd
|
||||
provided libraries
|
||||
|
||||
[1] https://github.com/NVIDIA/libglvnd/commit/0dfaea2bcb7cdcc785f95e244223bd004a2d7fba
|
||||
---
|
||||
configure.ac | 4 ++--
|
||||
glx/meson.build | 2 +-
|
||||
2 files changed, 3 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 03c2e367c..969090b94 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -760,7 +760,7 @@ LIBDRI="dri >= 7.8.0"
|
||||
LIBDRM="libdrm >= 2.4.89"
|
||||
LIBEGL="egl"
|
||||
LIBGBM="gbm >= 10.2.0"
|
||||
-LIBGL="gl >= 7.1.0"
|
||||
+LIBGL="gl >= 1.2"
|
||||
LIBXEXT="xext >= 1.0.99.4"
|
||||
LIBXFONT="xfont2 >= 2.0.0"
|
||||
LIBXI="xi >= 1.2.99.1"
|
||||
@@ -1115,7 +1115,7 @@ case "$DRI2,$HAVE_DRI2PROTO" in
|
||||
yes,yes | auto,yes)
|
||||
AC_DEFINE(DRI2, 1, [Build DRI2 extension])
|
||||
DRI2=yes
|
||||
- LIBGL="gl >= 9.2.0"
|
||||
+ LIBGL="gl >= 1.2"
|
||||
SDK_REQUIRED_MODULES="$SDK_REQUIRED_MODULES $DRI2PROTO"
|
||||
;;
|
||||
esac
|
||||
diff --git a/glx/meson.build b/glx/meson.build
|
||||
index 7f9e549f0..745814336 100644
|
||||
--- a/glx/meson.build
|
||||
+++ b/glx/meson.build
|
||||
@@ -39,7 +39,7 @@ if build_glx
|
||||
common_dep,
|
||||
dl_dep,
|
||||
dependency('glproto', version: '>= 1.4.17'),
|
||||
- dependency('gl', version: '>= 9.2.0'),
|
||||
+ dependency('gl', version: '>= 1.2'),
|
||||
],
|
||||
c_args: [
|
||||
glx_align64,
|
||||
--
|
||||
2.23.0
|
||||
|
@ -46,7 +46,7 @@
|
||||
Summary: X.Org X11 X server
|
||||
Name: xorg-x11-server
|
||||
Version: 1.20.5
|
||||
Release: 8%{?gitdate:.%{gitdate}}%{?dist}
|
||||
Release: 9%{?gitdate:.%{gitdate}}%{?dist}
|
||||
URL: http://www.x.org
|
||||
License: MIT
|
||||
|
||||
@ -156,6 +156,9 @@ Patch61: 0015-xwayland-Call-xwl_window_check_resolution_change_emu.patch
|
||||
Patch62: 0016-xwayland-Fix-setting-of-_XWAYLAND_RANDR_EMU_MONITOR_.patch
|
||||
Patch63: 0017-xwayland-Remove-unnecessary-xwl_window_is_toplevel-c.patch
|
||||
|
||||
# Fix building with new libglvnd provided gl.pc
|
||||
Patch64: 0001-build-glx-Lower-gl-version-to-work-with-libglvnd.patch
|
||||
|
||||
BuildRequires: systemtap-sdt-devel
|
||||
BuildRequires: git
|
||||
BuildRequires: automake autoconf libtool pkgconfig
|
||||
@ -580,6 +583,9 @@ find %{inst_srcdir}/hw/xfree86 -name \*.c -delete
|
||||
|
||||
|
||||
%changelog
|
||||
* Mon Nov 4 2019 Hans de Goede <hdegoede@redhat.com> - 1.20.5-9
|
||||
- Fix building with new libglvnd provided gl.pc
|
||||
|
||||
* Mon Nov 4 2019 Hans de Goede <hdegoede@redhat.com> - 1.20.5-8
|
||||
- Backport Xwayland randr resolution change emulation support
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user