From b38b008371ca27f418bcca537e02366d1e07e044 Mon Sep 17 00:00:00 2001
From: Soren Sandmann Pedersen <ssp@fedoraproject.org>
Date: Thu, 11 Sep 2008 13:31:53 +0000
Subject: [PATCH] Make room for a 1280 wide projector in the default screen
 limits

---
 xorg-x11-server.spec                  |  7 ++++++-
 xserver-1.5.0-projector-fb-size.patch | 25 +++++++++++++++++++++++++
 2 files changed, 31 insertions(+), 1 deletion(-)
 create mode 100644 xserver-1.5.0-projector-fb-size.patch

diff --git a/xorg-x11-server.spec b/xorg-x11-server.spec
index 459d57e..db853a0 100644
--- a/xorg-x11-server.spec
+++ b/xorg-x11-server.spec
@@ -19,7 +19,7 @@
 Summary:   X.Org X11 X server
 Name:      xorg-x11-server
 Version:   1.5.0
-Release:   2%{?dist}
+Release:   3%{?dist}
 URL:       http://www.x.org
 License:   MIT
 Group:     User Interface/X
@@ -54,6 +54,7 @@ Patch1005:  xserver-1.4.99-builtin-fonts.patch
 Patch1010:  xserver-1.3.0-no-prerelease-warning.patch
 
 Patch2013:  xserver-1.4.99-document-fontpath-correctly.patch
+Patch2014:  xserver-1.5.0-projector-fb-size.patch
 
 # Trivial things to never merge upstream ever
 # Don't merge this without protecting the gccisms.
@@ -498,6 +499,10 @@ rm -rf $RPM_BUILD_ROOT
 
 
 %changelog
+* Thu Sep 11 2008 Soren Sandmann <sandmann@redhat.com> 1.5.0-3
+- Change the default screen limits to include room for a 1280 wide
+  projector.
+
 * Wed Sep 10 2008 Dave Airlie <airlied@redhat.com> 1.5.0-2
 - bring master exa back
 
diff --git a/xserver-1.5.0-projector-fb-size.patch b/xserver-1.5.0-projector-fb-size.patch
new file mode 100644
index 0000000..9df0c12
--- /dev/null
+++ b/xserver-1.5.0-projector-fb-size.patch
@@ -0,0 +1,25 @@
+From ef49675e8d7dc829032bf6e586d55f9985d06844 Mon Sep 17 00:00:00 2001
+From: Fedora X Ninjas <x@fedoraproject.org>
+Date: Thu, 11 Sep 2008 09:25:18 -0400
+Subject: [PATCH] Make room for a 1280 wide projector in the default screen limits
+
+---
+ hw/xfree86/modes/xf86Crtc.c |    2 ++
+ 1 files changed, 2 insertions(+), 0 deletions(-)
+
+diff --git a/hw/xfree86/modes/xf86Crtc.c b/hw/xfree86/modes/xf86Crtc.c
+index 4de7e05..ee7e412 100644
+--- a/hw/xfree86/modes/xf86Crtc.c
++++ b/hw/xfree86/modes/xf86Crtc.c
+@@ -987,6 +987,8 @@ xf86DefaultScreenLimits (ScrnInfoPtr scrn, int *widthp, int *heightp,
+ 	if (crtc_height > height)
+ 	    height = crtc_height;
+     }
++    /* Make room for a projector */
++    width += 1280;
+     if (config->maxWidth && width > config->maxWidth) width = config->maxWidth;
+     if (config->maxHeight && height > config->maxHeight) height = config->maxHeight;
+     if (config->minWidth && width < config->minWidth) width = config->minWidth;
+-- 
+1.6.0.1
+