* Wed Oct 31 2007 Adam Jackson <ajax@redhat.com> 1.4.99.1-0.2
- BuildRequires: git. - Manage the source directory as a git repo. - Use git-am(1) to apply patches instead of %patch. - Reformat a bunch of patches to conform to git-am's rules. - Add wfb to file manifest. - Drop afb, sorry Amiga users. - Delete the SecurityPolicy man page from the buildroot, until we have a xorg-x11-server-common. - Update to today's snapshot.
This commit is contained in:
parent
64becd95f5
commit
afcbbe25e6
@ -1 +1 @@
|
||||
xorg-server-20071030.tar.bz2
|
||||
xorg-server-20071031.tar.bz2
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
03b50471e9199c56f408e034542d5e36 xorg-server-20071030.tar.bz2
|
||||
730466f1d01714e40a1153cda0c15d25 xorg-server-20071031.tar.bz2
|
||||
|
@ -1,13 +1,16 @@
|
||||
Patch by krh@redhat.com:
|
||||
From: Kristian Høgsberg <krh@redhat.com>
|
||||
Date: Sun, 28 Oct 2007 09:37:52 +0100
|
||||
Subject: [PATCH] Fix crash in xf86InitOrigins()
|
||||
|
||||
In a multihead setup, if only the first screen can be
|
||||
initialized, but the second screen is mentioned first in the
|
||||
ServerLayout section, the xf86InitOrigins() function will crash
|
||||
because the screen referred to in the e.g. "RightOf" part is
|
||||
non-existent.
|
||||
In a multihead setup, if only the first screen can be
|
||||
initialized, but the second screen is mentioned first in the
|
||||
ServerLayout section, the xf86InitOrigins() function will crash
|
||||
because the screen referred to in the e.g. "RightOf" part is
|
||||
non-existent.
|
||||
|
||||
--- hw/xfree86/common/xf86Cursor.c.init-origins-fix 2004-10-18 22:22:42.675899006 -0400
|
||||
+++ hw/xfree86/common/xf86Cursor.c 2004-10-18 22:21:42.540867549 -0400
|
||||
---
|
||||
--- a/hw/xfree86/common/xf86Cursor.c.init-origins-fix 2004-10-18 22:22:42.675899006 -0400
|
||||
+++ b/hw/xfree86/common/xf86Cursor.c 2004-10-18 22:21:42.540867549 -0400
|
||||
@@ -566,6 +566,14 @@
|
||||
|
||||
screen = &xf86ConfigLayout.screens[i];
|
||||
@ -18,7 +21,7 @@ Patch by krh@redhat.com:
|
||||
+ xf86Msg(X_WARNING, "Not including screen \"%s\" in origins calculation.\n",
|
||||
+ screen->screen->id);
|
||||
+ continue;
|
||||
+ }
|
||||
+ }
|
||||
+
|
||||
switch(screen->where) {
|
||||
case PosObsolete:
|
||||
|
@ -1,9 +1,14 @@
|
||||
From: Adam Jackson <ajax@redhat.com>
|
||||
Date: Sun, 28 Oct 2007 09:37:52 +0100
|
||||
Subject: [PATCH] Send less damage for manually redirected windows.
|
||||
|
||||
Disable damage notifications on move for manually redirected windows.
|
||||
The automatic compositor needs damage notification on move, but a
|
||||
compositing manager doesn't.
|
||||
|
||||
--- ./composite/compwindow.c.spiffiffity 2006-03-29 12:51:53.000000000 -0500
|
||||
+++ ./composite/compwindow.c 2006-04-13 23:18:42.000000000 -0400
|
||||
---
|
||||
--- a/composite/compwindow.c.spiffiffity 2006-03-29 12:51:53.000000000 -0500
|
||||
+++ b/composite/compwindow.c 2006-04-13 23:18:42.000000000 -0400
|
||||
@@ -571,12 +571,15 @@
|
||||
}
|
||||
else
|
||||
|
@ -1,3 +1,11 @@
|
||||
From: Adam Jackson <ajax@redhat.com>
|
||||
Date: Sun, 28 Oct 2007 09:37:52 +0100
|
||||
Subject: [PATCH] Don't filter modes away during VBE mode list construction.
|
||||
|
||||
Pass all VBE modes back up to the driver, on the assumption that it
|
||||
knows how to filter modes intelligently.
|
||||
|
||||
---
|
||||
--- xorg-server-1.1.1/hw/xfree86/vbe/vbeModes.c.jx 2006-07-05 14:31:42.000000000 -0400
|
||||
+++ xorg-server-1.1.1/hw/xfree86/vbe/vbeModes.c 2006-09-22 15:29:34.000000000 -0400
|
||||
@@ -153,34 +153,6 @@
|
||||
|
@ -1,3 +1,8 @@
|
||||
From: Adam Jackson <ajax@redhat.com>
|
||||
Date: Sun, 28 Oct 2007 09:37:52 +0100
|
||||
Subject: [PATCH] Disable explicit commenting in Monitor section.
|
||||
|
||||
---
|
||||
--- xorg-server-1.2.0/hw/xfree86/parser/Monitor.c.comment-less 2007-01-22 22:13:15.000000000 -0500
|
||||
+++ xorg-server-1.2.0/hw/xfree86/parser/Monitor.c 2007-01-23 12:32:48.000000000 -0500
|
||||
@@ -674,8 +674,6 @@
|
||||
|
@ -1,3 +1,8 @@
|
||||
From: Adam Jackson <ajax@redhat.com>
|
||||
Date: Sun, 28 Oct 2007 09:37:52 +0100
|
||||
Subject: [PATCH] Add more stuff to extramodes
|
||||
|
||||
---
|
||||
--- xorg-server-1.2.0/hw/xfree86/common/extramodes.Red-Hat-extramodes 2007-01-22 22:13:15.000000000 -0500
|
||||
+++ xorg-server-1.2.0/hw/xfree86/common/extramodes 2007-02-05 18:26:19.000000000 -0500
|
||||
@@ -3,21 +3,162 @@
|
||||
|
@ -1,16 +1,27 @@
|
||||
# F8 TODO list:
|
||||
# This package is an experiment in active integration of upstream SCM with
|
||||
# Fedora packaging. It works something like this:
|
||||
#
|
||||
# The "pristine" source is actually a git repo (with no working checkout).
|
||||
# The first step of %%prep is to check it out and switch to a "fedora" branch.
|
||||
# If you need to add a patch to the server, just do it like a normal git
|
||||
# operation, dump it with git-format-patch to a file in the standard naming
|
||||
# format, and add a PatchN: line. If you want to push something upstream,
|
||||
# check out the master branch, pull, cherry-pick, and push. FIXME describe
|
||||
# rebasing, add convenience 'make' targets maybe.
|
||||
|
||||
# F9 TODO list:
|
||||
#
|
||||
# Fix rhpxl to no longer need vesamodes/extramodes
|
||||
# RHEL5 bugfix sync
|
||||
# --enable-kdrive just for Xephyr is overkill, should fix that upstream
|
||||
|
||||
%define pkgname xorg-server
|
||||
%define gitdate 20071030
|
||||
%define gitdate 20071031
|
||||
|
||||
Summary: X.Org X11 X server
|
||||
Name: xorg-x11-server
|
||||
Version: 1.4.99.1
|
||||
Release: 0.1%{?dist}
|
||||
Release: 0.2%{?dist}
|
||||
URL: http://www.x.org
|
||||
License: MIT
|
||||
Group: User Interface/X
|
||||
@ -18,9 +29,10 @@ BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
|
||||
%if 0%{gitdate}
|
||||
# git snapshot. to recreate, run:
|
||||
# ./make-git-snapshot.sh 2338d5c9914e2a43c3a4f7ee0f4355ad0a1ad9e7
|
||||
# ./make-git-snapshot.sh `cat commitid`
|
||||
Source0: xorg-server-%{gitdate}.tar.bz2
|
||||
Source1: make-git-snapshot.sh
|
||||
Source2: commitid
|
||||
%else
|
||||
Source0: ftp://ftp.x.org/pub/individual/xserver/%{pkgname}-%{version}.tar.bz2
|
||||
%endif
|
||||
@ -28,72 +40,72 @@ Source100: comment-header-modefiles.txt
|
||||
|
||||
# general bug fixes
|
||||
Patch0: xorg-x11-server-0.99.3-init-origins-fix.patch
|
||||
Patch5: xorg-x11-server-libxf86config-dont-write-empty-sections.patch
|
||||
Patch6: xorg-x11-server-1.1.1-builderstring.patch
|
||||
Patch7: xorg-x11-server-1.1.1-xkb-in-xnest.patch
|
||||
#Patch5: xorg-x11-server-libxf86config-dont-write-empty-sections.patch
|
||||
#Patch6: xorg-x11-server-1.1.1-builderstring.patch
|
||||
#Patch7: xorg-x11-server-1.1.1-xkb-in-xnest.patch
|
||||
Patch10: xorg-x11-server-1.1.1-vbe-filter-less.patch
|
||||
Patch11: xorg-x11-server-1.1.1-vt-activate-is-a-terrible-api.patch
|
||||
Patch12: xorg-x11-server-1.1.1-graphics-expose.patch
|
||||
Patch15: xorg-x11-server-1.1.1-automake-1.10-fixes.patch
|
||||
#Patch11: xorg-x11-server-1.1.1-vt-activate-is-a-terrible-api.patch
|
||||
#Patch12: xorg-x11-server-1.1.1-graphics-expose.patch
|
||||
#Patch15: xorg-x11-server-1.1.1-automake-1.10-fixes.patch
|
||||
Patch19: xserver-1.3.0-xnest-exposures.patch
|
||||
Patch20: xserver-1.3.0-x86emu-imul-int64.patch
|
||||
Patch21: xserver-1.3.0-xkb-and-loathing.patch
|
||||
#Patch20: xserver-1.3.0-x86emu-imul-int64.patch
|
||||
#Patch21: xserver-1.3.0-xkb-and-loathing.patch
|
||||
Patch22: xserver-1.3.0-fbdevhw-magic-numbers.patch
|
||||
Patch23: xserver-1.3.0-ramdac-export.patch
|
||||
Patch24: xserver-1.3.0-reput-video.patch
|
||||
Patch25: xserver-1.3.0-xrandr-timestamp-buglet.patch
|
||||
#Patch23: xserver-1.3.0-ramdac-export.patch
|
||||
#Patch24: xserver-1.3.0-reput-video.patch
|
||||
#Patch25: xserver-1.3.0-xrandr-timestamp-buglet.patch
|
||||
|
||||
# OpenGL compositing manager feature/optimization patches.
|
||||
Patch100: xorg-x11-server-1.1.0-no-move-damage.patch
|
||||
Patch101: xorg-x11-server-1.1.0-dont-backfill-bg-none.patch
|
||||
Patch105: xorg-x11-server-1.2.0-enable-composite.patch
|
||||
Patch106: xorg-x11-server-1.1.1-no-composite-in-xnest.patch
|
||||
Patch108: xserver-1.3.0-no-pseudocolor-composite.patch
|
||||
##Patch101: xorg-x11-server-1.1.0-dont-backfill-bg-none.patch
|
||||
##Patch105: xorg-x11-server-1.2.0-enable-composite.patch
|
||||
##Patch106: xorg-x11-server-1.1.1-no-composite-in-xnest.patch
|
||||
#Patch108: xserver-1.3.0-no-pseudocolor-composite.patch
|
||||
|
||||
# Red Hat specific tweaking, not intended for upstream
|
||||
# XXX move these to the end of the list
|
||||
Patch1001: xorg-x11-server-Red-Hat-extramodes.patch
|
||||
Patch1002: xorg-x11-server-1.2.0-xephyr-only.patch
|
||||
Patch1003: xorg-x11-server-1.0.1-fpic-libxf86config.patch
|
||||
Patch1004: xorg-x11-server-1.2.0-selinux-awareness.patch
|
||||
Patch1005: xorg-x11-server-1.1.1-builtin-fonts.patch
|
||||
Patch1006: xorg-x11-server-1.1.1-no-scanpci.patch
|
||||
Patch1007: xorg-x11-server-1.1.1-spurious-libxf1bpp-link.patch
|
||||
##Patch1002: xorg-x11-server-1.2.0-xephyr-only.patch
|
||||
##Patch1003: xorg-x11-server-1.0.1-fpic-libxf86config.patch
|
||||
##Patch1004: xorg-x11-server-1.2.0-selinux-awareness.patch
|
||||
##Patch1005: xorg-x11-server-1.1.1-builtin-fonts.patch
|
||||
##Patch1006: xorg-x11-server-1.1.1-no-scanpci.patch
|
||||
#Patch1007: xorg-x11-server-1.1.1-spurious-libxf1bpp-link.patch
|
||||
Patch1008: xorg-x11-server-1.2.0-xf86config-comment-less.patch
|
||||
Patch1010: xserver-1.3.0-no-prerelease-warning.patch
|
||||
Patch1011: xserver-1.3.0-composite-version.patch
|
||||
Patch1012: xserver-1.3.0-mesa7.patch
|
||||
Patch1013: xserver-1.3.0-exaupgrade.patch
|
||||
Patch1014: xserver-1.3.0-newglx-offscreen-pixmaps.patch
|
||||
Patch1015: xserver-1.3.0-randr-updates.patch
|
||||
##Patch1011: xserver-1.3.0-composite-version.patch
|
||||
#Patch1012: xserver-1.3.0-mesa7.patch
|
||||
#Patch1013: xserver-1.3.0-exaupgrade.patch
|
||||
##Patch1014: xserver-1.3.0-newglx-offscreen-pixmaps.patch
|
||||
#Patch1015: xserver-1.3.0-randr-updates.patch
|
||||
Patch1022: xserver-1.3.0-default-dpi.patch
|
||||
Patch1023: xserver-1.3.0-randr-preferred-mode-fix.patch
|
||||
#Patch1023: xserver-1.3.0-randr-preferred-mode-fix.patch
|
||||
Patch1024: xserver-1.3.0-avoid-ps2-probe.patch
|
||||
|
||||
Patch2001: xserver-1.2.0-geode-mmx.patch
|
||||
Patch2002: xserver-1.2.0-xephyr-keysym-madness.patch
|
||||
Patch2003: xserver-1.2.0-vfprintf.patch
|
||||
##Patch2001: xserver-1.2.0-geode-mmx.patch
|
||||
##Patch2002: xserver-1.2.0-xephyr-keysym-madness.patch
|
||||
#Patch2003: xserver-1.2.0-vfprintf.patch
|
||||
Patch2004: xserver-1.3.0-honor-displaysize.patch
|
||||
Patch2007: xserver-1.3.0-randr12-config-hack.patch
|
||||
Patch2008: xserver-1.3.0-randrama-no-zero-screens.patch
|
||||
Patch2009: xserver-1.3.0-arm-iopl.patch
|
||||
Patch2010: xserver-1.3.0-idletime.patch
|
||||
Patch2012: xserver-1.3.0-add-really-slow-bcopy.patch
|
||||
#Patch2008: xserver-1.3.0-randrama-no-zero-screens.patch
|
||||
#Patch2009: xserver-1.3.0-arm-iopl.patch
|
||||
#Patch2010: xserver-1.3.0-idletime.patch
|
||||
#Patch2012: xserver-1.3.0-add-really-slow-bcopy.patch
|
||||
Patch2013: xserver-1.3.0-document-fontpath-correctly.patch
|
||||
Patch2014: xserver-1.3.0-intel-by-default.patch
|
||||
#Patch2014: xserver-1.3.0-intel-by-default.patch
|
||||
Patch2015: xserver-1.3.0-accidental-abi.patch
|
||||
Patch2016: xserver-1.3.0-xorg-conf-man-randr-update.patch
|
||||
Patch2017: xserver-1.3.0-update-quirks.patch
|
||||
#Patch2016: xserver-1.3.0-xorg-conf-man-randr-update.patch
|
||||
#Patch2017: xserver-1.3.0-update-quirks.patch
|
||||
|
||||
# assorted PCI layer shenanigans. oh the pain.
|
||||
Patch2500: xorg-x11-server-1.2.99-unbreak-domain.patch
|
||||
Patch2501: xserver-1.3.0-pci-bus-count.patch
|
||||
Patch2502: xserver-1.3.0-mmap-failure-check.patch
|
||||
Patch2503: xserver-1.3.0-rom-search.patch
|
||||
Patch2504: xserver-1.3.0-domain-obiwan.patch
|
||||
Patch2505: xserver-1.3.0-pci-device-enable.patch
|
||||
##Patch2500: xorg-x11-server-1.2.99-unbreak-domain.patch
|
||||
##Patch2501: xserver-1.3.0-pci-bus-count.patch
|
||||
##Patch2502: xserver-1.3.0-mmap-failure-check.patch
|
||||
##Patch2503: xserver-1.3.0-rom-search.patch
|
||||
##Patch2504: xserver-1.3.0-domain-obiwan.patch
|
||||
##Patch2505: xserver-1.3.0-pci-device-enable.patch
|
||||
|
||||
Patch9999: xserver-1.3.0-late-sigusr1.patch
|
||||
#Patch9999: xserver-1.3.0-late-sigusr1.patch
|
||||
|
||||
%define moduledir %{_libdir}/xorg/modules
|
||||
%define drimoduledir %{_libdir}/dri
|
||||
@ -116,6 +128,7 @@ Patch9999: xserver-1.3.0-late-sigusr1.patch
|
||||
# FIXME: Temporary Build deps on autotools, as needed...
|
||||
BuildRequires: automake autoconf libtool
|
||||
|
||||
BuildRequires: git
|
||||
BuildRequires: pkgconfig
|
||||
BuildRequires: xorg-x11-util-macros >= 1.1.5
|
||||
|
||||
@ -300,76 +313,16 @@ Xserver source code needed to build VNC server (Xvnc)
|
||||
%setup -q -n %{pkgname}-%{?gitdate:%{gitdate}}%{!?gitdate:%{version}}
|
||||
|
||||
%if 0%{gitdate}
|
||||
git-checkout master
|
||||
git checkout -b fedora-%{version}-%{release}
|
||||
# make it something you can push to.
|
||||
sed -i 's/git/&+ssh/' .git/config
|
||||
%else
|
||||
git-init-db
|
||||
%endif
|
||||
|
||||
# one # means can be dropped. two means needs rebase.
|
||||
|
||||
%patch0 -p0 -b .init-origins-fix
|
||||
#patch5 -p0 -b .libxf86config-dont-write-empty-sections
|
||||
#patch6 -p1 -b .builderstring
|
||||
#patch8 -p1 -b .xkb-in-xnest
|
||||
%patch10 -p1 -b .vbe-filter
|
||||
#patch11 -p1 -b .vt-activate
|
||||
#patch12 -p1 -b .graphics-expose
|
||||
#patch15 -p1 -b .automake-1.10
|
||||
%patch19 -p1 -b .xnest-expose
|
||||
#patch20 -p1 -b .x86emu-imul
|
||||
#patch21 -p1 -b .xkb-signal-loathing
|
||||
%patch22 -p1 -b .magic-numbers
|
||||
#patch23 -p1 -b .ramdac
|
||||
#patch24 -p1 -b .reput
|
||||
#patch25 -p1 -b .xrandr-timestamp
|
||||
|
||||
%patch100 -p0 -b .no-move-damage
|
||||
##patch101 -p0 -b .dont-backfill-bg-none
|
||||
##patch105 -p1 -b .enable-composite
|
||||
##patch106 -p1 -b .no-xnest-composite
|
||||
%patch108 -p1 -b .composite-paranoia
|
||||
|
||||
%patch1001 -p1 -b .Red-Hat-extramodes
|
||||
##patch1002 -p1 -b .xephyr
|
||||
##patch1003 -p1 -b .fpic
|
||||
##patch1004 -p1 -b .selinux-awareness
|
||||
##patch1005 -p0 -b .builtin-fonts
|
||||
##patch1006 -p1 -b .no-scanpci
|
||||
#patch1007 -p1 -b .xf1bpp
|
||||
%patch1008 -p1 -b .comment-less
|
||||
%patch1010 -p1 -b .prerelease-warning
|
||||
##patch1011 -p1 -b .composite-version
|
||||
#patch1012 -p1 -b .newmesa
|
||||
#patch1013 -p1 -b .newexa
|
||||
%patch1014 -p1 -b .offscreen-pixmaps
|
||||
#patch1015 -p1 -b .randr-update
|
||||
%patch1022 -p1 -b .dpi
|
||||
##patch1023 -p1 -b .randr-preferred
|
||||
%patch1024 -p1 -b .ps2-probe
|
||||
|
||||
##patch2001 -p1 -b .geode-mmx
|
||||
##patch2002 -p1 -b .xephyr-keysym
|
||||
#patch2003 -p1 -b .vfprintf
|
||||
%patch2004 -p1 -b .displaysize
|
||||
%patch2007 -p1 -b .randrconfig
|
||||
#patch2008 -p1 -b .randrama-zero-screens
|
||||
#patch2009 -p1 -b .arm
|
||||
#patch2010 -p1 -b .idletime
|
||||
#patch2012 -p1 -b .slow-bcopy
|
||||
%patch2013 -p1 -b .fontpath-doc
|
||||
#patch2014 -p1 -b .intel
|
||||
%patch2015 -p1 -b .accidental-abi
|
||||
#patch2016 -p1 -b .document-randr
|
||||
#patch2017 -p1 -b .update-quirk
|
||||
|
||||
##patch2500 -p1 -b .unbreak-domains
|
||||
##patch2501 -p1 -b .pci-bus-count
|
||||
##patch2503 -p1 -b .mmap-check
|
||||
##patch2503 -p1 -b .rom-search
|
||||
##patch2504 -p1 -b .domain-obiwan
|
||||
##patch2505 -p1 -b .device-enable
|
||||
|
||||
##patch9999 -p1 -b .jx
|
||||
for i in $(awk '/^Patch.*:/ { print $2 }' ../xorg-x11-server.spec) ; do
|
||||
git-am -p1 ../$i
|
||||
done
|
||||
|
||||
%build
|
||||
|
||||
@ -395,6 +348,7 @@ autoreconf -v --install || exit 1
|
||||
--disable-kdrive --disable-xephyr \
|
||||
--disable-static \
|
||||
--with-pic \
|
||||
--disable-afb \
|
||||
--enable-composite \
|
||||
--enable-xtrap \
|
||||
--enable-xcsecurity \
|
||||
@ -460,6 +414,7 @@ xargs tar cf - | (cd %{inst_srcdir} && tar xf -)
|
||||
rm -f $RPM_BUILD_ROOT%{_bindir}/out?
|
||||
rm -f $RPM_BUILD_ROOT%{_bindir}/pcitweak
|
||||
rm -f $RPM_BUILD_ROOT%{_mandir}/man1/pcitweak.1*
|
||||
rm -f $RPM_BUILD_ROOT%{_mandir}/man5/SecurityPolicy.5*
|
||||
find $RPM_BUILD_ROOT -type f -name '*.la' | xargs rm -f -- || :
|
||||
|
||||
%ifarch s390 s390x
|
||||
@ -551,7 +506,6 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{_libdir}/xorg/modules/multimedia/tda9850_drv.so
|
||||
%{_libdir}/xorg/modules/multimedia/tda9885_drv.so
|
||||
%{_libdir}/xorg/modules/multimedia/uda1380_drv.so
|
||||
%{_libdir}/xorg/modules/libafb.so
|
||||
%{_libdir}/xorg/modules/libcfb.so
|
||||
%{_libdir}/xorg/modules/libcfb32.so
|
||||
%{_libdir}/xorg/modules/libexa.so
|
||||
@ -563,6 +517,7 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{_libdir}/xorg/modules/libshadowfb.so
|
||||
%{_libdir}/xorg/modules/libvbe.so
|
||||
%{_libdir}/xorg/modules/libvgahw.so
|
||||
%{_libdir}/xorg/modules/libwfb.so
|
||||
%{_libdir}/xorg/modules/libxaa.so
|
||||
%{_libdir}/xorg/modules/libxf1bpp.so
|
||||
%{_libdir}/xorg/modules/libxf4bpp.so
|
||||
@ -643,6 +598,17 @@ rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
|
||||
%changelog
|
||||
* Wed Oct 31 2007 Adam Jackson <ajax@redhat.com> 1.4.99.1-0.2
|
||||
- BuildRequires: git.
|
||||
- Manage the source directory as a git repo.
|
||||
- Use git-am(1) to apply patches instead of %patch.
|
||||
- Reformat a bunch of patches to conform to git-am's rules.
|
||||
- Add wfb to file manifest.
|
||||
- Drop afb, sorry Amiga users.
|
||||
- Delete the SecurityPolicy man page from the buildroot, until we have a
|
||||
xorg-x11-server-common.
|
||||
- Update to today's snapshot.
|
||||
|
||||
* Wed Oct 31 2007 Adam Jackson <ajax@redhat.com> 1.4.99.1-0.1
|
||||
- Begin rebasing to git master. It almost builds, assuming you disable
|
||||
glx, kdrive, and dmx, and remove like half the patches.
|
||||
|
@ -1,3 +1,11 @@
|
||||
From: Adam Jackson <ajax@redhat.com>
|
||||
Date: Sun, 28 Oct 2007 09:37:52 +0100
|
||||
Subject: [PATCH] Fix accidental ABI usage in RANDR 1.2 drivers.
|
||||
|
||||
Due to RANDR 1.2, xf86findOptionValue and xf86nameCompare are now ABI.
|
||||
Make sure they're exported from the server.
|
||||
|
||||
---
|
||||
diff -up xorg-server-1.3.0.0/hw/xfree86/parser/Flags.c.jx xorg-server-1.3.0.0/hw/xfree86/parser/Flags.c
|
||||
--- xorg-server-1.3.0.0/hw/xfree86/parser/Flags.c.jx 2006-09-18 02:04:18.000000000 -0400
|
||||
+++ xorg-server-1.3.0.0/hw/xfree86/parser/Flags.c 2007-10-03 11:08:01.000000000 -0400
|
||||
|
@ -1,26 +1,12 @@
|
||||
diff -up xorg-server-1.3.0.0/hw/xfree86/loader/loadmod.c.jx xorg-server-1.3.0.0/hw/xfree86/loader/loadmod.c
|
||||
--- xorg-server-1.3.0.0/hw/xfree86/loader/loadmod.c.jx 2007-04-16 12:37:51.000000000 -0400
|
||||
+++ xorg-server-1.3.0.0/hw/xfree86/loader/loadmod.c 2007-10-10 19:13:47.000000000 -0400
|
||||
@@ -408,7 +408,8 @@ FindModuleInSubdir(const char *dirpath,
|
||||
while ((direntry = readdir(dir))) {
|
||||
if (direntry->d_name[0] == '.')
|
||||
continue;
|
||||
- if ((stat(direntry->d_name, &stat_buf) == 0) && S_ISDIR(stat_buf.st_mode)) {
|
||||
+
|
||||
+ if (direntry->d_type == DT_DIR) {
|
||||
snprintf(tmpBuf, PATH_MAX, "%s/%s", dirpath, direntry->d_name);
|
||||
if ((ret = FindModuleInSubdir(tmpBuf, module)))
|
||||
break;
|
||||
@@ -525,8 +526,7 @@ LoaderListDirs(const char **subdirlist,
|
||||
if (dirlen + strlen(dp->d_name) > PATH_MAX)
|
||||
continue;
|
||||
strcpy(fp, dp->d_name);
|
||||
- if (!(stat(buf, &stat_buf) == 0 &&
|
||||
- S_ISREG(stat_buf.st_mode)))
|
||||
+ if (dp->d_type == DT_REG)
|
||||
continue;
|
||||
for (p = patterns; p->pattern; p++) {
|
||||
if (regexec(&p->rex, dp->d_name, 2, match, 0) == 0 &&
|
||||
From: Adam Jackson <ajax@redhat.com>
|
||||
Date: Sun, 28 Oct 2007 09:37:52 +0100
|
||||
Subject: [PATCH] Avoid PS/2 protocol probing for /dev/input/mice
|
||||
|
||||
The kernel will always upconvert to ExplorerPS/2 for all readers of
|
||||
/dev/input/mice, so don't waste time on startup trying to figure
|
||||
that out.
|
||||
|
||||
---
|
||||
diff -up xorg-server-1.3.0.0/hw/xfree86/os-support/linux/lnx_mouse.c.jx xorg-server-1.3.0.0/hw/xfree86/os-support/linux/lnx_mouse.c
|
||||
--- xorg-server-1.3.0.0/hw/xfree86/os-support/linux/lnx_mouse.c.jx 2006-09-18 02:04:18.000000000 -0400
|
||||
+++ xorg-server-1.3.0.0/hw/xfree86/os-support/linux/lnx_mouse.c 2007-10-11 09:53:33.000000000 -0400
|
||||
@ -80,7 +66,7 @@ diff -up xorg-server-1.3.0.0/hw/xfree86/os-support/linux/lnx_mouse.c.jx xorg-ser
|
||||
xf86Msg(X_INFO,
|
||||
- "%s: GuessProtocol: "
|
||||
- "setting mouse protocol to \"%s\"\n",
|
||||
+ "%s: Setting mouse protocol to \"%s\"\n",
|
||||
+ "%s: Setting mouse protocol to \"%s\"\n",
|
||||
pInfo->name, devproto[i].name);
|
||||
return devproto[i].name;
|
||||
}
|
||||
|
@ -1,3 +1,10 @@
|
||||
From: Adam Jackson <ajax@redhat.com>
|
||||
Date: Sun, 28 Oct 2007 09:37:52 +0100
|
||||
Subject: [PATCH] Crank the default DPI to 100.
|
||||
|
||||
1986 called, they want their monitor back.
|
||||
|
||||
---
|
||||
diff -up xorg-server-1.3.0.0/hw/xfree86/common/xf86Priv.h.jx xorg-server-1.3.0.0/hw/xfree86/common/xf86Priv.h
|
||||
--- xorg-server-1.3.0.0/hw/xfree86/common/xf86Priv.h.jx 2006-11-16 13:01:24.000000000 -0500
|
||||
+++ xorg-server-1.3.0.0/hw/xfree86/common/xf86Priv.h 2007-08-09 16:55:02.000000000 -0400
|
||||
|
@ -1,3 +1,8 @@
|
||||
From: Adam Jackson <ajax@redhat.com>
|
||||
Date: Sun, 28 Oct 2007 09:37:52 +0100
|
||||
Subject: [PATCH] Document default font path correctly.
|
||||
|
||||
---
|
||||
diff -up xorg-server-1.3.0.0/hw/xfree86/doc/man/xorg.conf.man.pre.jx xorg-server-1.3.0.0/hw/xfree86/doc/man/xorg.conf.man.pre
|
||||
--- xorg-server-1.3.0.0/hw/xfree86/doc/man/xorg.conf.man.pre.jx 2006-12-22 03:06:49.000000000 -0500
|
||||
+++ xorg-server-1.3.0.0/hw/xfree86/doc/man/xorg.conf.man.pre 2007-08-23 15:27:47.000000000 -0400
|
||||
|
@ -1,5 +1,14 @@
|
||||
--- xorg-server-1.3.0.0/./hw/xfree86/fbdevhw/fbdevhw.c.jx 2007-03-26 23:32:36.000000000 -0400
|
||||
+++ xorg-server-1.3.0.0/./hw/xfree86/fbdevhw/fbdevhw.c 2007-05-11 15:10:05.000000000 -0400
|
||||
From: Adam Jackson <ajax@redhat.com>
|
||||
Date: Sun, 28 Oct 2007 09:37:52 +0100
|
||||
Subject: [PATCH] Fix magic number in fbdevhw
|
||||
|
||||
The transformation between fbdev and xfree86 mode timings needs to be
|
||||
invertible, otherwise Xen and other framebuffers that don't have real
|
||||
pixel clocks won't initialize.
|
||||
|
||||
---
|
||||
--- xorg-server-1.3.0.0/hw/xfree86/fbdevhw/fbdevhw.c.jx 2007-03-26 23:32:36.000000000 -0400
|
||||
+++ xorg-server-1.3.0.0/hw/xfree86/fbdevhw/fbdevhw.c 2007-05-11 15:10:05.000000000 -0400
|
||||
@@ -258,7 +258,7 @@
|
||||
static void
|
||||
fbdev2xfree_timing(struct fb_var_screeninfo *var, DisplayModePtr mode)
|
||||
|
@ -1,3 +1,8 @@
|
||||
From: Adam Jackson <ajax@redhat.com>
|
||||
Date: Sun, 28 Oct 2007 09:37:52 +0100
|
||||
Subject: [PATCH] Honor the Monitor section's DisplaySize directive.
|
||||
|
||||
---
|
||||
diff -up xorg-server-1.3.0.0/hw/xfree86/modes/xf86EdidModes.c.da xorg-server-1.3.0.0/hw/xfree86/modes/xf86EdidModes.c
|
||||
--- xorg-server-1.3.0.0/hw/xfree86/modes/xf86EdidModes.c.da 2007-09-26 17:04:02.000000000 +1000
|
||||
+++ xorg-server-1.3.0.0/hw/xfree86/modes/xf86EdidModes.c 2007-09-26 17:04:27.000000000 +1000
|
||||
|
@ -1,3 +1,13 @@
|
||||
From: Adam Jackson <ajax@redhat.com>
|
||||
Date: Sun, 28 Oct 2007 09:37:52 +0100
|
||||
Subject: [PATCH] Add pixmap eviction for XAA.
|
||||
|
||||
DRI drivers without zero-copy EXT_texture_from_pixmap need to copy the
|
||||
texture image out of video memory to bind it. Ick. Add a hack to
|
||||
evict XAA pixmaps and disable the pixmap cache when the first texture
|
||||
is bound.
|
||||
|
||||
---
|
||||
diff -up xorg-server-1.3.0.0/hw/xfree86/xaa/xaaInit.c.offscreen-pixmaps xorg-server-1.3.0.0/hw/xfree86/xaa/xaaInit.c
|
||||
--- xorg-server-1.3.0.0/hw/xfree86/xaa/xaaInit.c.offscreen-pixmaps 2007-08-13 10:27:45.000000000 +1000
|
||||
+++ xorg-server-1.3.0.0/hw/xfree86/xaa/xaaInit.c 2007-08-13 10:28:35.000000000 +1000
|
||||
|
@ -1,3 +1,8 @@
|
||||
From: Adam Jackson <ajax@redhat.com>
|
||||
Date: Sun, 28 Oct 2007 09:37:52 +0100
|
||||
Subject: [PATCH] Disable pre-release warning.
|
||||
|
||||
---
|
||||
--- xorg-server-1.2.99.905/hw/xfree86/common/xf86Init.c.jx 2007-01-31 19:55:51.000000000 -0500
|
||||
+++ xorg-server-1.2.99.905/hw/xfree86/common/xf86Init.c 2007-04-11 12:32:24.000000000 -0400
|
||||
@@ -1770,7 +1770,7 @@
|
||||
|
@ -1,3 +1,8 @@
|
||||
From: Adam Jackson <ajax@redhat.com>
|
||||
Date: Sun, 28 Oct 2007 09:37:52 +0100
|
||||
Subject: [PATCH] Disable Composite on 8bpp displays.
|
||||
|
||||
---
|
||||
diff --git a/composite/compext.c b/composite/compext.c
|
||||
index 4c25cc7..af05b4a 100644
|
||||
--- a/composite/compext.c
|
||||
|
@ -1,3 +1,8 @@
|
||||
From: Adam Jackson <ajax@redhat.com>
|
||||
Date: Sun, 28 Oct 2007 09:37:52 +0100
|
||||
Subject: [PATCH] Use the global Modes list when determining preferred mode.
|
||||
|
||||
---
|
||||
diff -up xorg-server-1.3.0.0/hw/xfree86/modes/xf86Crtc.c.da xorg-server-1.3.0.0/hw/xfree86/modes/xf86Crtc.c
|
||||
--- xorg-server-1.3.0.0/hw/xfree86/modes/xf86Crtc.c.da 2007-09-26 17:12:44.000000000 +1000
|
||||
+++ xorg-server-1.3.0.0/hw/xfree86/modes/xf86Crtc.c 2007-09-26 17:14:44.000000000 +1000
|
||||
|
@ -1,3 +1,8 @@
|
||||
From: Adam Jackson <ajax@redhat.com>
|
||||
Date: Sun, 28 Oct 2007 09:37:52 +0100
|
||||
Subject: [PATCH] Fix exposure generation in Xnest
|
||||
|
||||
---
|
||||
--- xorg-server-1.2.99.905/hw/xnest/Events.c.jx 2007-01-31 19:55:51.000000000 -0500
|
||||
+++ xorg-server-1.2.99.905/hw/xnest/Events.c 2007-04-09 18:42:51.000000000 -0400
|
||||
@@ -85,7 +85,7 @@
|
||||
|
Loading…
Reference in New Issue
Block a user