Today's rawhide grenade. Now with more selinux!

This commit is contained in:
Adam Jackson 2008-01-08 20:48:31 +00:00
parent e6e366c9ca
commit 9e07a0fa17
10 changed files with 33 additions and 227 deletions

View File

@ -1 +1 @@
xorg-server-20071127.tar.bz2 xorg-server-20080107.tar.bz2

View File

@ -1,38 +0,0 @@
From 28e1a9e912b70a2f3a0ad988e6ffc37a351bc90e Mon Sep 17 00:00:00 2001
From: Adam Jackson <ajax@redhat.com>
Date: Wed, 14 Nov 2007 13:04:17 -0500
Subject: [PATCH] Add pixman cflags to xorg-server.pc
---
configure.ac | 3 +++
xorg-server.pc.in | 2 +-
2 files changed, 4 insertions(+), 1 deletions(-)
diff --git a/configure.ac b/configure.ac
index a16b46a..8b786d3 100644
--- a/configure.ac
+++ b/configure.ac
@@ -1073,6 +1073,9 @@ CORE_INCS='-I$(top_srcdir)/include -I$(top_builddir)/include'
PKG_CHECK_MODULES([XSERVERCFLAGS], [$REQUIRED_MODULES $REQUIRED_LIBS])
PKG_CHECK_MODULES([XSERVERLIBS], [$REQUIRED_LIBS])
+PKG_CHECK_MODULES([PIXMAN], [pixman-1])
+AC_SUBST([PIXMAN_CFLAGS])
+
# Autotools has some unfortunate issues with library handling. In order to
# get a server to rebuild when a dependency in the tree is changed, it must
# be listed in SERVERNAME_DEPENDENCIES. However, no system libraries may be
diff --git a/xorg-server.pc.in b/xorg-server.pc.in
index c1cdb7d..32c64f4 100644
--- a/xorg-server.pc.in
+++ b/xorg-server.pc.in
@@ -9,5 +9,5 @@ Name: xorg-server
Description: Modular X.Org X Server
Version: @PACKAGE_VERSION@
Requires: pixman-1
-Cflags: -I${sdkdir}
+Cflags: -I${sdkdir} @PIXMAN_CFLAGS@
Libs: -L${libdir}
--
1.5.3.4

View File

@ -1,16 +0,0 @@
//
// IMPORTANT NOTE: DO NOT HAND EDIT THIS FILE
//
// The "vesamodes" and "extramodes" files in this directory are read-only,
// and are provided for the Red Hat config tools to have access to the list
// of video modes which are hard coded into the Xorg X server at compile
// time. Do not add video modes to these files, as the X server does not
// read them, so any modes added will be ignored, and will potentially
// confuse the config tools, or cause them to generate non-working config
// files. If you wish to add custom modelines to the X server, you can
// do so in the X server config file "xorg.conf".
//
///////////////////////////////////////////////////////////////////////////

View File

@ -1 +1 @@
23b8ca8a373d919225de9739af7b064f650eceec 260505e3c5a18044e97d31ea3bcc0955e46335c8

View File

@ -1 +1 @@
43e5d239d6255fb9b8abe4e3bf4eecb9 xorg-server-20071127.tar.bz2 42ce248a3546e26c5f4a0a1e71d949e8 xorg-server-20080107.tar.bz2

View File

@ -15,12 +15,12 @@
# RHEL5 bugfix sync # RHEL5 bugfix sync
%define pkgname xorg-server %define pkgname xorg-server
%define gitdate 20071127 %define gitdate 20080107
Summary: X.Org X11 X server Summary: X.Org X11 X server
Name: xorg-x11-server Name: xorg-x11-server
Version: 1.4.99.1 Version: 1.4.99.1
Release: 0.14%{?dist} Release: 0.15.%{?gitdate}%{?dist}
URL: http://www.x.org URL: http://www.x.org
License: MIT License: MIT
Group: User Interface/X Group: User Interface/X
@ -35,7 +35,6 @@ Source2: commitid
%else %else
Source0: ftp://ftp.x.org/pub/individual/xserver/%{pkgname}-%{version}.tar.bz2 Source0: ftp://ftp.x.org/pub/individual/xserver/%{pkgname}-%{version}.tar.bz2
%endif %endif
Source100: comment-header-modefiles.txt
# general bug fixes # general bug fixes
Patch19: xserver-1.3.0-xnest-exposures.patch Patch19: xserver-1.3.0-xnest-exposures.patch
@ -61,11 +60,9 @@ Patch2013: xserver-1.4.99-document-fontpath-correctly.patch
#Patch3000: #Patch3000:
# Trivial things to maybe merge upstream at next rebase # Trivial things to maybe merge upstream at next rebase
Patch4003: argh-pixman.patch #Patch4003: argh-pixman.patch #fixme
Patch4004: xserver-1.4.99-xephyr-dri.patch Patch4004: xserver-1.4.99-xephyr-dri.patch
Patch4005: xserver-1.4.99-openchrome.patch Patch4005: xserver-1.4.99-openchrome.patch
Patch4006: xserver-1.3.0-randr-fix-set-rotations-xinerama.patch
Patch4007: xserver-1.3.0-ignore-extra-entity.patch
# Trivial things to never merge upstream ever # Trivial things to never merge upstream ever
# This should be fixed in the kernel. # This should be fixed in the kernel.
@ -131,7 +128,7 @@ BuildRequires: libdrm-devel >= 2.4.0
Requires: libdrm >= 2.4.0 Requires: libdrm >= 2.4.0
%endif %endif
BuildRequires: libselinux-devel BuildRequires: libselinux-devel audit-libs-devel
# Make sure libXfont has the catalogue FPE # Make sure libXfont has the catalogue FPE
Conflicts: libXfont < 1.2.9 Conflicts: libXfont < 1.2.9
@ -286,7 +283,7 @@ git-init-db
%endif %endif
if [ -z "$GIT_COMMITTER_NAME" ]; then if [ -z "$GIT_COMMITTER_NAME" ]; then
export GIT_COMMITTER_NAME="Fedora X Strike Force" export GIT_COMMITTER_NAME="Fedora X Ninjas"
fi fi
@ -313,7 +310,7 @@ autoreconf -v --install || exit 1
--disable-xorgcfg \ --disable-xorgcfg \
--enable-install-libxf86config \ --enable-install-libxf86config \
--with-mesa-source=%{_datadir}/mesa/source \ --with-mesa-source=%{_datadir}/mesa/source \
--enable-dri \ --enable-xselinux \
--with-dri-driver-path=%{drimoduledir} \ --with-dri-driver-path=%{drimoduledir} \
${CONFIGURE} ${CONFIGURE}
@ -323,18 +320,13 @@ make %{?_smp_mflags}
rm -rf $RPM_BUILD_ROOT rm -rf $RPM_BUILD_ROOT
make install DESTDIR=$RPM_BUILD_ROOT moduledir=%{moduledir} make install DESTDIR=$RPM_BUILD_ROOT moduledir=%{moduledir}
%if %{with_hw_servers} %if %{with_hw_servers}
mkdir -p $RPM_BUILD_ROOT%{_libdir}/xorg/modules/{drivers,input} mkdir -p $RPM_BUILD_ROOT%{_libdir}/xorg/modules/{drivers,input}
# Install the vesamodes and extramodes files to let our install/config tools # Install the vesamodes and extramodes files to let our install/config tools
# be able to parse the same modelist as the X server uses (rhpxl). # be able to parse the same modelist as the X server uses (rhpxl).
mkdir -p $RPM_BUILD_ROOT%{_datadir}/xorg mkdir -p $RPM_BUILD_ROOT%{_datadir}/xorg
for each in vesamodes extramodes ; do install -m 0444 hw/xfree86/common/{vesa,extra}modes $RPM_BUILD_ROOT%{_datadir}/xorg/
install -m 0644 %{SOURCE100} $RPM_BUILD_ROOT%{_datadir}/xorg/$each
cat hw/xfree86/common/$each >> $RPM_BUILD_ROOT%{_datadir}/xorg/$each
chmod 0444 $RPM_BUILD_ROOT%{_datadir}/xorg/$each
done
%endif %endif
# Make the source package # Make the source package
@ -342,7 +334,6 @@ done
%define inst_srcdir %{buildroot}/%{xserver_source_dir} %define inst_srcdir %{buildroot}/%{xserver_source_dir}
mkdir -p %{inst_srcdir}/{Xext,xkb,GL,hw/xfree86/{common,utils/xorgconfig}} mkdir -p %{inst_srcdir}/{Xext,xkb,GL,hw/xfree86/{common,utils/xorgconfig}}
cp cpprules.in %{inst_srcdir} cp cpprules.in %{inst_srcdir}
cp Xext/SecurityPolicy %{inst_srcdir}/Xext
cp xkb/README.compiled %{inst_srcdir}/xkb cp xkb/README.compiled %{inst_srcdir}/xkb
cp GL/symlink-mesa.sh %{inst_srcdir}/GL cp GL/symlink-mesa.sh %{inst_srcdir}/GL
cp hw/xfree86/{xorgconf.cpp,Options} %{inst_srcdir}/hw/xfree86 cp hw/xfree86/{xorgconf.cpp,Options} %{inst_srcdir}/hw/xfree86
@ -389,25 +380,15 @@ rm -rf $RPM_BUILD_ROOT
{ {
pushd /etc/X11 pushd /etc/X11
for configfile in XF86Config XF86Config-4 ; do
if [ -r $configfile ]; then
if [ -r xorg.conf ]; then
mv -f $configfile $configfile.obsoleted
else
mv -f $configfile xorg.conf
fi
fi
done
[ -e xorg.conf ] || return 0 [ -e xorg.conf ] || return 0
perl -p -i -e 's/^.*Load.*"(pex5|xie|xtt).*\n$"//gi' xorg.conf sed -i 's/^.*Load.*"(pex5|xie|xtt).*\n$"//gi' xorg.conf
perl -p -i -e 's/^\s*Driver(.*)"keyboard"/Driver\1"kbd"/gi' xorg.conf sed -i 's/^\s*Driver(.*)"keyboard"/Driver\1"kbd"/gi' xorg.conf
perl -p -i -e 's/^.*Option.*"XkbRules".*"(xfree86|xorg)".*\n$//gi' xorg.conf sed -i 's/^.*Option.*"XkbRules".*"(xfree86|xorg)".*\n$//gi' xorg.conf
perl -p -i -e 's#^\s*RgbPath.*$##gi' xorg.conf sed -i 's#^\s*RgbPath.*$##gi' xorg.conf
# lame, the nvidia driver needs to override this # lame, the nvidia driver needs to override this
if ! grep -q 'ModulePath.*nvidia' xorg.conf ; then if ! grep -q 'ModulePath.*nvidia' xorg.conf ; then
perl -p -i -e 's#^\s*ModulePath.*$##gi' xorg.conf sed -i 's#^\s*ModulePath.*$##gi' xorg.conf
fi fi
popd popd
@ -417,9 +398,7 @@ rm -rf $RPM_BUILD_ROOT
%files common %files common
%defattr(-,root,root,-) %defattr(-,root,root,-)
%{_mandir}/man1/Xserver.1* %{_mandir}/man1/Xserver.1*
%{_mandir}/man5/SecurityPolicy.5* %{_libdir}/xorg/protocol.txt
%dir %{_libdir}/xserver
%{_libdir}/xserver/SecurityPolicy
%dir %{_localstatedir}/lib/xkb %dir %{_localstatedir}/lib/xkb
%{_localstatedir}/lib/xkb/README.compiled %{_localstatedir}/lib/xkb/README.compiled
@ -531,6 +510,11 @@ rm -rf $RPM_BUILD_ROOT
%changelog %changelog
* Mon Jan 07 2008 Adam Jackson <ajax@redhat.com> 1.4.99.1-0.15
- Today's git snapshot. X-SELinux!
- Drop the code to migrate from /etc/X11/XF86Config*.
- s/perl -p -i -e/sed -i/g
* Mon Jan 07 2008 Adam Jackson <ajax@redhat.com> 1.4.99.1-0.14 * Mon Jan 07 2008 Adam Jackson <ajax@redhat.com> 1.4.99.1-0.14
- Sync with F8 bugfixes: - Sync with F8 bugfixes:
- xorg-x11-server-Red-Hat-extramodes.patch: Don't supply non-CVT-R timings - xorg-x11-server-Red-Hat-extramodes.patch: Don't supply non-CVT-R timings

View File

@ -1,21 +0,0 @@
From: Adam Jackson <ajax@redhat.com>
Date: Sun, 28 Oct 2007 09:37:52 +0100
Subject: [PATCH] Ignore non-sharable entities instead of crashing.
---
diff -up xorg-server-1.3.0.0/hw/xfree86/common/xf86Bus.c.da xorg-server-1.3.0.0/hw/xfree86/common/xf86Bus.c
--- xorg-server-1.3.0.0/hw/xfree86/common/xf86Bus.c.da 2007-11-29 15:42:04.000000000 +1000
+++ xorg-server-1.3.0.0/hw/xfree86/common/xf86Bus.c 2007-11-29 15:42:11.000000000 +1000
@@ -341,8 +341,10 @@ xf86AddEntityToScreen(ScrnInfoPtr pScrn,
if (entityIndex == -1)
return;
if (xf86Entities[entityIndex]->inUse &&
- !(xf86Entities[entityIndex]->entityProp & IS_SHARED_ACCEL))
- FatalError("Requested Entity already in use!\n");
+ !(xf86Entities[entityIndex]->entityProp & IS_SHARED_ACCEL)) {
+ ErrorF("Requested Entity already in use!\n");
+ return;
+ }
pScrn->numEntities++;
pScrn->entityList = xnfrealloc(pScrn->entityList,

View File

@ -1,102 +0,0 @@
From: Adam Jackson <ajax@redhat.com>
Date: Sun, 28 Oct 2007 09:37:52 +0100
Subject: [PATCH] Xinerama shouldn't segfault RANDR 1.2
---
diff --git a/hw/xfree86/modes/xf86RandR12.c b/hw/xfree86/modes/xf86RandR12.c
index 61a7db3..bb7f945 100644
--- a/hw/xfree86/modes/xf86RandR12.c
+++ b/hw/xfree86/modes/xf86RandR12.c
@@ -59,7 +59,7 @@ static Bool xf86RandR12Init12 (ScreenPtr pScreen);
static Bool xf86RandR12CreateScreenResources12 (ScreenPtr pScreen);
#endif
-static int xf86RandR12Index;
+static int xf86RandR12Index = -1;
static int xf86RandR12Generation;
#define XF86RANDRINFO(p) \
@@ -340,10 +340,12 @@ xf86RandR12ScreenSetSize (ScreenPtr pScreen,
PixmapPtr pScrnPix = (*pScreen->GetScreenPixmap)(pScreen);
Bool ret = FALSE;
- if (randrp->virtualX == -1 || randrp->virtualY == -1)
- {
- randrp->virtualX = pScrn->virtualX;
- randrp->virtualY = pScrn->virtualY;
+ if (xf86RandR12Index != -1) {
+ if (randrp->virtualX == -1 || randrp->virtualY == -1)
+ {
+ randrp->virtualX = pScrn->virtualX;
+ randrp->virtualY = pScrn->virtualY;
+ }
}
if (pRoot && pScrn->vtSema)
(*pScrn->EnableDisableFBAccess) (pScreen->myNum, FALSE);
@@ -366,7 +368,7 @@ finish:
if (pRoot && pScrn->vtSema)
(*pScrn->EnableDisableFBAccess) (pScreen->myNum, TRUE);
#if RANDR_12_INTERFACE
- if (WindowTable[pScreen->myNum] && ret)
+ if ((xf86RandR12Index != -1) && WindowTable[pScreen->myNum] && ret)
RRScreenSizeNotify (pScreen);
#endif
return ret;
@@ -466,6 +468,9 @@ xf86RandR12CreateScreenResources (ScreenPtr pScreen)
mmHeight);
}
+ if (xf86RandR12Index == -1)
+ return TRUE;
+
if (randrp->virtualX == -1 || randrp->virtualY == -1)
{
randrp->virtualX = pScrn->virtualX;
@@ -533,12 +538,18 @@ xf86RandR12Init (ScreenPtr pScreen)
_X_EXPORT void
xf86RandR12SetRotations (ScreenPtr pScreen, Rotation rotations)
{
- XF86RandRInfoPtr randrp = XF86RANDRINFO(pScreen);
+ XF86RandRInfoPtr randrp;
#if RANDR_12_INTERFACE
ScrnInfoPtr pScrn = xf86Screens[pScreen->myNum];
int c;
xf86CrtcConfigPtr config = XF86_CRTC_CONFIG_PTR(pScrn);
+#endif
+ if (xf86RandR12Index == -1)
+ return;
+
+ randrp = XF86RANDRINFO(pScreen);
+#if RANDR_12_INTERFACE
for (c = 0; c < config->num_crtc; c++) {
xf86CrtcPtr crtc = config->crtc[c];
@@ -1065,9 +1076,11 @@ xf86RandR12CreateScreenResources12 (ScreenPtr pScreen)
ScrnInfoPtr pScrn = xf86Screens[pScreen->myNum];
xf86CrtcConfigPtr config = XF86_CRTC_CONFIG_PTR(pScrn);
+ if (xf86RandR12Index == -1)
+ return TRUE;
+
for (c = 0; c < config->num_crtc; c++)
- xf86RandR12CrtcNotify (config->crtc[c]->randr_crtc);
-
+ xf86RandR12CrtcNotify (config->crtc[c]->randr_crtc);
RRScreenSetSizeRange (pScreen, config->minWidth, config->minHeight,
config->maxWidth, config->maxHeight);
@@ -1084,11 +1097,11 @@ xf86RandR12TellChanged (ScreenPtr pScreen)
{
ScrnInfoPtr pScrn = xf86Screens[pScreen->myNum];
xf86CrtcConfigPtr config = XF86_CRTC_CONFIG_PTR(pScrn);
- XF86RandRInfoPtr randrp = XF86RANDRINFO(pScreen);
int c;
- if (!randrp)
+ if (xf86RandR12Index == -1)
return;
+
xf86RandR12SetInfo12 (pScreen);
for (c = 0; c < config->num_crtc; c++)
xf86RandR12CrtcNotify (config->crtc[c]->randr_crtc);

View File

@ -1,6 +1,6 @@
From 0706a26b4ddbcd2ca495e05403ffc161e299a2c8 Mon Sep 17 00:00:00 2001 From d4112defb9ab2b099c67a0a7c2ae7ac772d67751 Mon Sep 17 00:00:00 2001
From: Adam Jackson <ajax@redhat.com> From: Adam Jackson <ajax@redhat.com>
Date: Tue, 27 Nov 2007 13:52:40 -0500 Date: Mon, 7 Jan 2008 15:41:22 -0500
Subject: [PATCH] Link GL subsystem against libselinux. Subject: [PATCH] Link GL subsystem against libselinux.
--- ---
@ -9,24 +9,24 @@ Subject: [PATCH] Link GL subsystem against libselinux.
2 files changed, 4 insertions(+), 2 deletions(-) 2 files changed, 4 insertions(+), 2 deletions(-)
diff --git a/configure.ac b/configure.ac diff --git a/configure.ac b/configure.ac
index 5150c18..b5c9e48 100644 index 0742040..ed6d062 100644
--- a/configure.ac --- a/configure.ac
+++ b/configure.ac +++ b/configure.ac
@@ -350,6 +350,8 @@ case $host_cpu in @@ -360,6 +360,8 @@ case $host_cpu in
;;
esac esac
AC_SUBST(GLX_ARCH_DEFINES)
+SYS_LIBS="${SYS_LIBS} -lselinux" +SYS_LIBS="${SYS_LIBS} -lselinux"
+ +
dnl BSD *_video.c selection dnl BSD *_video.c selection
AM_CONDITIONAL(ALPHA_VIDEO, [test "x$ALPHA_VIDEO" = xyes]) AM_CONDITIONAL(ALPHA_VIDEO, [test "x$ALPHA_VIDEO" = xyes])
AM_CONDITIONAL(ARM_VIDEO, [test "x$ARM_VIDEO" = xyes]) AM_CONDITIONAL(ARM_VIDEO, [test "x$ARM_VIDEO" = xyes])
@@ -1181,7 +1183,7 @@ AC_MSG_RESULT([$XNEST]) @@ -1211,7 +1213,7 @@ AC_MSG_RESULT([$XNEST])
AM_CONDITIONAL(XNEST, [test "x$XNEST" = xyes]) AM_CONDITIONAL(XNEST, [test "x$XNEST" = xyes])
if test "x$XNEST" = xyes; then if test "x$XNEST" = xyes; then
- XNEST_LIBS="$FB_LIB $FIXES_LIB $MI_LIB $XEXT_LIB $DBE_LIB $XTRAP_LIB $RECORD_LIB $GLX_LIBS $RENDER_LIB $RANDR_LIB $DAMAGE_LIB $MIEXT_DAMAGE_LIB $MIEXT_SHADOW_LIB $XI_LIB $XKB_LIB $XKB_STUB_LIB $COMPOSITE_LIB $XPSTUBS_LIB $CWRAP_LIB $DIX_LIB $OS_LIB $CONFIG_LIB" - XNEST_LIBS="$FB_LIB $FIXES_LIB $MI_LIB $XEXT_LIB $DBE_LIB $XTRAP_LIB $RECORD_LIB $GLX_LIBS $RENDER_LIB $RANDR_LIB $DAMAGE_LIB $MIEXT_DAMAGE_LIB $MIEXT_SHADOW_LIB $XI_LIB $XKB_LIB $XKB_STUB_LIB $COMPOSITE_LIB $XPSTUBS_LIB $DIX_LIB $OS_LIB $CONFIG_LIB"
+ XNEST_LIBS="$FB_LIB $FIXES_LIB $MI_LIB $XEXT_LIB $DBE_LIB $XTRAP_LIB $RECORD_LIB $GLX_LIBS $RENDER_LIB $RANDR_LIB $DAMAGE_LIB $MIEXT_DAMAGE_LIB $MIEXT_SHADOW_LIB $XI_LIB $XKB_LIB $XKB_STUB_LIB $COMPOSITE_LIB $XPSTUBS_LIB $CWRAP_LIB $DIX_LIB $OS_LIB $CONFIG_LIB $XSERVER_LIBS" + XNEST_LIBS="$FB_LIB $FIXES_LIB $MI_LIB $XEXT_LIB $DBE_LIB $XTRAP_LIB $RECORD_LIB $GLX_LIBS $RENDER_LIB $RANDR_LIB $DAMAGE_LIB $MIEXT_DAMAGE_LIB $MIEXT_SHADOW_LIB $XI_LIB $XKB_LIB $XKB_STUB_LIB $COMPOSITE_LIB $XPSTUBS_LIB $DIX_LIB $OS_LIB $CONFIG_LIB $XSERVER_LIBS"
XNEST_SYS_LIBS="$XNESTMODULES_LIBS" XNEST_SYS_LIBS="$XNESTMODULES_LIBS"
AC_SUBST([XNEST_LIBS]) AC_SUBST([XNEST_LIBS])
AC_SUBST([XNEST_SYS_LIBS]) AC_SUBST([XNEST_SYS_LIBS])
@ -44,5 +44,5 @@ index efc5f4a..1b9ecfd 100644
libafb_la_LDFLAGS = -avoid-version libafb_la_LDFLAGS = -avoid-version
-- --
1.5.3.4 1.5.3.7

View File

@ -16,7 +16,7 @@ diff --git a/GL/glx/glxdri.c b/GL/glx/glxdri.c
index c0da07b..6c4faed 100644 index c0da07b..6c4faed 100644
--- a/GL/glx/glxdri.c --- a/GL/glx/glxdri.c
+++ b/GL/glx/glxdri.c +++ b/GL/glx/glxdri.c
@@ -360,6 +360,22 @@ __glXDRIbindTexImage(__GLXcontext *baseContext, @@ -360,6 +360,22 @@
pixmap = (PixmapPtr) glxPixmap->pDraw; pixmap = (PixmapPtr) glxPixmap->pDraw;
@ -40,10 +40,9 @@ index c0da07b..6c4faed 100644
__GLXDRIdrawable **texOffsetOverride = screen->texOffsetOverride; __GLXDRIdrawable **texOffsetOverride = screen->texOffsetOverride;
int i, firstEmpty = 16; int i, firstEmpty = 16;
diff --git a/hw/xfree86/xaa/xaaInit.c b/hw/xfree86/xaa/xaaInit.c diff --git a/hw/xfree86/xaa/xaaInit.c b/hw/xfree86/xaa/xaaInit.c
index 4222425..602b525 100644
--- a/hw/xfree86/xaa/xaaInit.c --- a/hw/xfree86/xaa/xaaInit.c
+++ b/hw/xfree86/xaa/xaaInit.c +++ b/hw/xfree86/xaa/xaaInit.c
@@ -88,6 +88,30 @@ XAADestroyInfoRec(XAAInfoRecPtr infoRec) @@ -88,6 +88,30 @@
xfree(infoRec); xfree(infoRec);
} }
@ -61,7 +60,7 @@ index 4222425..602b525 100644
+ pScreen = screenInfo.screens[i]; + pScreen = screenInfo.screens[i];
+ infoRec = GET_XAAINFORECPTR_FROM_SCREEN(pScreen); + infoRec = GET_XAAINFORECPTR_FROM_SCREEN(pScreen);
+ +
+ pScreenPriv = pScreen->devPrivates[XAAScreenIndex].ptr; + pScreenPriv = dixLookupPrivate(&pScreen->devPrivates, XAAScreenKey);
+ infoRec = pScreenPriv->AccelInfoRec; + infoRec = pScreenPriv->AccelInfoRec;
+ +
+ infoRec->offscreenDepths = 0; + infoRec->offscreenDepths = 0;