Git snapshot 98cde254acb9b98337ddecf64c138d38c14ec2bf
xserver-1.11.99-optionstr.patch: drop 0001-Xext-don-t-swap-CARD8-in-SProcSELinuxQueryVersion.patch: drop
This commit is contained in:
parent
95edefe066
commit
9aad602913
1
.gitignore
vendored
1
.gitignore
vendored
@ -8,3 +8,4 @@ xorg-server-1.9.1.tar.bz2
|
||||
/xorg-server-1.11.0.tar.bz2
|
||||
/xorg-server-1.11.1.tar.bz2
|
||||
/xorg-server-20111109.tar.xz
|
||||
/xorg-server-20120103.tar.xz
|
||||
|
@ -1,37 +0,0 @@
|
||||
From f8bd07745954d0e164b2f4dfcb667a269c842e71 Mon Sep 17 00:00:00 2001
|
||||
From: Peter Hutterer <peter.hutterer@who-t.net>
|
||||
Date: Wed, 9 Nov 2011 15:31:10 +1000
|
||||
Subject: [PATCH] Xext: don't swap CARD8 in SProcSELinuxQueryVersion
|
||||
|
||||
xselinux_ext.c: In function 'SELinuxSendItemsToClient':
|
||||
xselinux_ext.c:340:16: warning: unused variable 'n' [-Wunused-variable]
|
||||
xselinux_ext.c: In function 'SProcSELinuxQueryVersion':
|
||||
xselinux_ext.c:532:62: error: call to 'wrong_size' declared with attribute
|
||||
error: wrong sized variable passed to swap
|
||||
xselinux_ext.c:533:62: error: call to 'wrong_size' declared with attribute
|
||||
error: wrong sized variable passed to swap
|
||||
|
||||
Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
|
||||
---
|
||||
Xext/xselinux_ext.c | 5 -----
|
||||
1 files changed, 0 insertions(+), 5 deletions(-)
|
||||
|
||||
diff --git a/Xext/xselinux_ext.c b/Xext/xselinux_ext.c
|
||||
index 56f2d1f..641368a 100644
|
||||
--- a/Xext/xselinux_ext.c
|
||||
+++ b/Xext/xselinux_ext.c
|
||||
@@ -526,11 +526,6 @@ ProcSELinuxDispatch(ClientPtr client)
|
||||
static int
|
||||
SProcSELinuxQueryVersion(ClientPtr client)
|
||||
{
|
||||
- REQUEST(SELinuxQueryVersionReq);
|
||||
-
|
||||
- REQUEST_SIZE_MATCH(SELinuxQueryVersionReq);
|
||||
- swaps(&stuff->client_major);
|
||||
- swaps(&stuff->client_minor);
|
||||
return ProcSELinuxQueryVersion(client);
|
||||
}
|
||||
|
||||
--
|
||||
1.7.7
|
||||
|
2
commitid
2
commitid
@ -1 +1 @@
|
||||
f0d50cc6651dce3a8a3cd3fb84210aa92b139763
|
||||
98cde254acb9b98337ddecf64c138d38c14ec2bf
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
36962a81cacca200673a687651865dcc xorg-server-20111109.tar.xz
|
||||
1d57316232fb6d617b844639456239a6 xorg-server-20120103.tar.xz
|
||||
|
@ -9,7 +9,7 @@
|
||||
# check out the master branch, pull, cherry-pick, and push. FIXME describe
|
||||
# rebasing, add convenience 'make' targets maybe.
|
||||
|
||||
%define gitdate 20111109
|
||||
%define gitdate 20120103
|
||||
%define stable_abi 0
|
||||
|
||||
%if !0%{?gitdate} || %{stable_abi}
|
||||
@ -47,8 +47,8 @@
|
||||
|
||||
Summary: X.Org X11 X server
|
||||
Name: xorg-x11-server
|
||||
Version: 1.11.99.1
|
||||
Release: 11%{?gitdate:.%{gitdate}}%{dist}
|
||||
Version: 1.11.99.901
|
||||
Release: 1%{?gitdate:.%{gitdate}}%{dist}
|
||||
URL: http://www.x.org
|
||||
License: MIT
|
||||
Group: User Interface/X
|
||||
@ -98,12 +98,6 @@ Patch6030: xserver-1.6.99-right-of.patch
|
||||
# tests require Xorg
|
||||
Patch7007: xserver-1.10.99.1-test.patch
|
||||
|
||||
# Fix selinux build error
|
||||
Patch7010: 0001-Xext-don-t-swap-CARD8-in-SProcSELinuxQueryVersion.patch
|
||||
|
||||
# missing file needed to build other stuff
|
||||
Patch7011: xserver-1.11.99-optionstr.patch
|
||||
|
||||
# always install xaa headers even though we don't build the module
|
||||
Patch7012: xserver-1.12-xaa-sdk-headers.patch
|
||||
|
||||
@ -562,6 +556,11 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{xserver_source_dir}
|
||||
|
||||
%changelog
|
||||
* Tue Jan 03 2012 Peter Hutterer <peter.hutterer@redhat.com> 1.11.99.901-1.20120103
|
||||
- Git snapshot 98cde254acb9b98337ddecf64c138d38c14ec2bf
|
||||
- xserver-1.11.99-optionstr.patch: drop
|
||||
- 0001-Xext-don-t-swap-CARD8-in-SProcSELinuxQueryVersion.patch: drop
|
||||
|
||||
* Fri Dec 16 2011 Adam Jackson <ajax@redhat.com> 1.11.99.1-11
|
||||
- Always install XAA SDK headers so drivers still build
|
||||
|
||||
|
@ -1,27 +0,0 @@
|
||||
From 795fbe3e6e440f023e52c452106f4c266c13d36c Mon Sep 17 00:00:00 2001
|
||||
From: Keith Packard <keithp@keithp.com>
|
||||
Date: Sun, 20 Nov 2011 13:33:12 -0800
|
||||
Subject: [PATCH] Add 'optionstr.h' to include/Makefile.am
|
||||
|
||||
This makes sure it gets distributed
|
||||
|
||||
Signed-off-by: Keith Packard <keithp@keithp.com>
|
||||
---
|
||||
include/Makefile.am | 1 +
|
||||
1 files changed, 1 insertions(+), 0 deletions(-)
|
||||
|
||||
diff --git a/include/Makefile.am b/include/Makefile.am
|
||||
index 6f63c76..972f403 100644
|
||||
--- a/include/Makefile.am
|
||||
+++ b/include/Makefile.am
|
||||
@@ -32,6 +32,7 @@ sdk_HEADERS = \
|
||||
misc.h \
|
||||
miscstruct.h \
|
||||
opaque.h \
|
||||
+ optionstr.h \
|
||||
os.h \
|
||||
pixmap.h \
|
||||
pixmapstr.h \
|
||||
--
|
||||
1.7.7.3
|
||||
|
@ -1,7 +1,7 @@
|
||||
From f14a89c627d9c4d790cc6785dd6628c9bda1c317 Mon Sep 17 00:00:00 2001
|
||||
From 47d4a39c0c82d45b8e0eada36d14c233dbb1cff2 Mon Sep 17 00:00:00 2001
|
||||
From: Adam Jackson <ajax@redhat.com>
|
||||
Date: Thu, 18 Jun 2009 16:56:41 +1000
|
||||
Subject: [PATCH 3/9] displayfd hack
|
||||
Subject: [PATCH] displayfd hack
|
||||
|
||||
---
|
||||
dix/globals.c | 1 +
|
||||
@ -35,7 +35,7 @@ index 5c70717..f23203f 100644
|
||||
extern _X_EXPORT int defaultBackingStore;
|
||||
extern _X_EXPORT Bool disableBackingStore;
|
||||
diff --git a/os/connection.c b/os/connection.c
|
||||
index 0c580ab..1acdb7f 100644
|
||||
index 8a677a7..fea227a 100644
|
||||
--- a/os/connection.c
|
||||
+++ b/os/connection.c
|
||||
@@ -145,6 +145,7 @@ Bool AnyClientsWriteBlocked; /* true if some client blocked on write */
|
||||
@ -63,7 +63,7 @@ index 0c580ab..1acdb7f 100644
|
||||
+{
|
||||
+ char port[20];
|
||||
+
|
||||
+ sprintf(port, "%d", num);
|
||||
+ snprintf (port, sizeof(port), "%d", num);
|
||||
+
|
||||
+ return _XSERVTransMakeAllCOTSServerListeners(port, partial,
|
||||
+ &ListenTransCount,
|
||||
@ -85,7 +85,7 @@ index 0c580ab..1acdb7f 100644
|
||||
|
||||
FD_ZERO (&WellKnownConnections);
|
||||
|
||||
- sprintf (port, "%d", atoi (display));
|
||||
- snprintf (port, sizeof(port), "%d", atoi (display));
|
||||
-
|
||||
- if ((_XSERVTransMakeAllCOTSServerListeners (port, &partial,
|
||||
- &ListenTransCount, &ListenTransConns) >= 0) &&
|
||||
@ -149,10 +149,10 @@ index 0c580ab..1acdb7f 100644
|
||||
}
|
||||
|
||||
diff --git a/os/utils.c b/os/utils.c
|
||||
index 36cb46f..6338860 100644
|
||||
index 6461ed5..17860df 100644
|
||||
--- a/os/utils.c
|
||||
+++ b/os/utils.c
|
||||
@@ -660,6 +660,17 @@ ProcessCommandLine(int argc, char *argv[])
|
||||
@@ -661,6 +661,17 @@ ProcessCommandLine(int argc, char *argv[])
|
||||
else
|
||||
UseMsg();
|
||||
}
|
||||
@ -171,5 +171,5 @@ index 36cb46f..6338860 100644
|
||||
else if ( strcmp( argv[i], "dpms") == 0)
|
||||
/* ignored for compatibility */ ;
|
||||
--
|
||||
1.7.4.4
|
||||
1.7.7.4
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user