auto-import xorg-x11-server-1.2.0-1.fc7 on branch devel from xorg-x11-server-1.2.0-1.fc7.src.rpm
This commit is contained in:
parent
0d03177819
commit
99319d217b
@ -1 +1 @@
|
|||||||
xorg-server-1.1.1.tar.bz2
|
xorg-server-1.2.0.tar.bz2
|
||||||
|
2
sources
2
sources
@ -1 +1 @@
|
|||||||
a8ed678677af8ebb2fba5624602f6b2e xorg-server-1.1.1.tar.bz2
|
849131833c15c049135f1f309f5f9197 xorg-server-1.2.0.tar.bz2
|
||||||
|
11
xorg-x11-server-1.2.0-enable-composite.patch
Normal file
11
xorg-x11-server-1.2.0-enable-composite.patch
Normal file
@ -0,0 +1,11 @@
|
|||||||
|
--- xorg-server-1.2.0/os/utils.c.enable-composite 2007-01-22 22:13:16.000000000 -0500
|
||||||
|
+++ xorg-server-1.2.0/os/utils.c 2007-01-23 12:26:04.000000000 -0500
|
||||||
|
@@ -138,7 +138,7 @@
|
||||||
|
#ifdef COMPOSITE
|
||||||
|
/* COMPOSITE is disabled by default for now until the
|
||||||
|
* interface is stable */
|
||||||
|
- #define COMPOSITE_DEFAULT FALSE
|
||||||
|
+ #define COMPOSITE_DEFAULT TRUE
|
||||||
|
_X_EXPORT Bool noCompositeExtension = !COMPOSITE_DEFAULT;
|
||||||
|
#endif
|
||||||
|
|
76
xorg-x11-server-1.2.0-maxpixclock-option.patch
Normal file
76
xorg-x11-server-1.2.0-maxpixclock-option.patch
Normal file
@ -0,0 +1,76 @@
|
|||||||
|
--- xorg-server-1.2.0/hw/xfree86/ddc/ddcProperty.c.maxpixclock 2007-01-22 22:13:15.000000000 -0500
|
||||||
|
+++ xorg-server-1.2.0/hw/xfree86/ddc/ddcProperty.c 2007-01-23 12:35:00.000000000 -0500
|
||||||
|
@@ -303,7 +303,7 @@
|
||||||
|
{
|
||||||
|
DisplayModePtr Modes = NULL, Mode;
|
||||||
|
int i, clock;
|
||||||
|
- Bool have_hsync = FALSE, have_vrefresh = FALSE;
|
||||||
|
+ Bool have_hsync = FALSE, have_vrefresh = FALSE, have_maxpixclock = FALSE;
|
||||||
|
int preferred;
|
||||||
|
|
||||||
|
if (!Monitor || !DDC)
|
||||||
|
@@ -332,6 +332,7 @@
|
||||||
|
/* Skip EDID ranges if they were specified in the config file */
|
||||||
|
have_hsync = (Monitor->nHsync != 0);
|
||||||
|
have_vrefresh = (Monitor->nVrefresh != 0);
|
||||||
|
+ have_maxpixclock = (Monitor->maxPixClock != 0);
|
||||||
|
|
||||||
|
/* Go through the detailed monitor sections */
|
||||||
|
for (i = 0; i < DET_TIMINGS; i++)
|
||||||
|
@@ -366,7 +367,7 @@
|
||||||
|
}
|
||||||
|
|
||||||
|
clock = DDC->det_mon[i].section.ranges.max_clock * 1000;
|
||||||
|
- if (clock > Monitor->maxPixClock)
|
||||||
|
+ if (!have_maxpixclock && clock > Monitor->maxPixClock)
|
||||||
|
Monitor->maxPixClock = clock;
|
||||||
|
|
||||||
|
break;
|
||||||
|
--- xorg-server-1.2.0/hw/xfree86/common/xf86Mode.c.maxpixclock 2007-01-22 22:13:15.000000000 -0500
|
||||||
|
+++ xorg-server-1.2.0/hw/xfree86/common/xf86Mode.c 2007-01-23 12:33:41.000000000 -0500
|
||||||
|
@@ -1408,6 +1408,12 @@
|
||||||
|
scrp->monitor->vrefresh[i].lo,
|
||||||
|
scrp->monitor->vrefresh[i].hi);
|
||||||
|
}
|
||||||
|
+ if (scrp->monitor->maxPixClock) {
|
||||||
|
+ xf86DrvMsg(scrp->scrnIndex, X_INFO,
|
||||||
|
+ "%s: Using maximum pixel clock of %.2f MHz\n",
|
||||||
|
+ scrp->monitor->id,
|
||||||
|
+ (float)scrp->monitor->maxPixClock / 1000.0);
|
||||||
|
+ }
|
||||||
|
}
|
||||||
|
|
||||||
|
/*
|
||||||
|
--- xorg-server-1.2.0/hw/xfree86/common/xf86Config.c.maxpixclock 2007-01-22 22:13:15.000000000 -0500
|
||||||
|
+++ xorg-server-1.2.0/hw/xfree86/common/xf86Config.c 2007-01-23 12:33:41.000000000 -0500
|
||||||
|
@@ -2211,12 +2211,15 @@
|
||||||
|
}
|
||||||
|
|
||||||
|
typedef enum {
|
||||||
|
- MON_REDUCEDBLANKING
|
||||||
|
+ MON_REDUCEDBLANKING,
|
||||||
|
+ MON_MAX_PIX_CLOCK,
|
||||||
|
} MonitorValues;
|
||||||
|
|
||||||
|
static OptionInfoRec MonitorOptions[] = {
|
||||||
|
{ MON_REDUCEDBLANKING, "ReducedBlanking", OPTV_BOOLEAN,
|
||||||
|
{0}, FALSE },
|
||||||
|
+ { MON_MAX_PIX_CLOCK, "MaxPixClock", OPTV_FREQ,
|
||||||
|
+ {0}, FALSE },
|
||||||
|
{ -1, NULL, OPTV_NONE,
|
||||||
|
{0}, FALSE },
|
||||||
|
};
|
||||||
|
@@ -2363,11 +2366,11 @@
|
||||||
|
return FALSE;
|
||||||
|
}
|
||||||
|
|
||||||
|
- /* Check wether this Monitor accepts Reduced Blanking modelines */
|
||||||
|
xf86ProcessOptions(-1, monitorp->options, MonitorOptions);
|
||||||
|
-
|
||||||
|
xf86GetOptValBool(MonitorOptions, MON_REDUCEDBLANKING,
|
||||||
|
&monitorp->reducedblanking);
|
||||||
|
+ xf86GetOptValFreq(MonitorOptions, MON_MAX_PIX_CLOCK, OPTUNITS_KHZ,
|
||||||
|
+ &monitorp->maxPixClock);
|
||||||
|
return TRUE;
|
||||||
|
}
|
||||||
|
|
31
xorg-x11-server-1.2.0-selinux-awareness.patch
Normal file
31
xorg-x11-server-1.2.0-selinux-awareness.patch
Normal file
@ -0,0 +1,31 @@
|
|||||||
|
--- xorg-server-1.2.0/hw/xfree86/dixmods/Makefile.am.selinux-awareness 2007-01-22 22:13:15.000000000 -0500
|
||||||
|
+++ xorg-server-1.2.0/hw/xfree86/dixmods/Makefile.am 2007-01-23 12:29:54.000000000 -0500
|
||||||
|
@@ -42,7 +42,7 @@
|
||||||
|
-I$(top_srcdir)/GL/glx
|
||||||
|
|
||||||
|
libGLcore_la_LDFLAGS = -avoid-version
|
||||||
|
-libGLcore_la_LIBADD = $(top_builddir)/GL/mesa/libGLcore.la
|
||||||
|
+libGLcore_la_LIBADD = $(top_builddir)/GL/mesa/libGLcore.la -lselinux
|
||||||
|
libGLcore_la_SOURCES = GLcoremodule.c
|
||||||
|
|
||||||
|
libafb_la_LDFLAGS = -avoid-version
|
||||||
|
--- xorg-server-1.2.0/configure.ac.selinux-awareness 2007-01-23 12:29:54.000000000 -0500
|
||||||
|
+++ xorg-server-1.2.0/configure.ac 2007-01-23 12:31:30.000000000 -0500
|
||||||
|
@@ -237,6 +237,8 @@
|
||||||
|
;;
|
||||||
|
esac
|
||||||
|
|
||||||
|
+SYS_LIBS="${SYS_LIBS} -lselinux"
|
||||||
|
+
|
||||||
|
dnl BSD *_video.c selection
|
||||||
|
AM_CONDITIONAL(ALPHA_VIDEO, [test "x$ALPHA_VIDEO" = xyes])
|
||||||
|
AM_CONDITIONAL(ARM_VIDEO, [test "x$ARM_VIDEO" = xyes])
|
||||||
|
@@ -1009,7 +1011,7 @@
|
||||||
|
AM_CONDITIONAL(XNEST, [test "x$XNEST" = xyes])
|
||||||
|
|
||||||
|
if test "x$XNEST" = xyes; then
|
||||||
|
- XNEST_LIBS="$FB_LIB $MI_LIB $FIXES_LIB $XEXT_LIB $DBE_LIB $XTRAP_LIB $RECORD_LIB $GLX_LIBS $RENDER_LIB $RANDR_LIB $DAMAGE_LIB $MIEXT_DAMAGE_LIB $MIEXT_SHADOW_LIB $XI_LIB $XKB_LIB $XKB_STUB_LIB $COMPOSITE_LIB $XPSTUBS_LIB $CWRAP_LIB $OS_LIB"
|
||||||
|
+ XNEST_LIBS="$FB_LIB $MI_LIB $FIXES_LIB $XEXT_LIB $DBE_LIB $XTRAP_LIB $RECORD_LIB $GLX_LIBS $RENDER_LIB $RANDR_LIB $DAMAGE_LIB $MIEXT_DAMAGE_LIB $MIEXT_SHADOW_LIB $XI_LIB $XKB_LIB $XKB_STUB_LIB $COMPOSITE_LIB $XPSTUBS_LIB $CWRAP_LIB $OS_LIB $XSERVER_LIBS"
|
||||||
|
AC_SUBST([XNEST_LIBS])
|
||||||
|
fi
|
||||||
|
|
32
xorg-x11-server-1.2.0-xephyr-only.patch
Normal file
32
xorg-x11-server-1.2.0-xephyr-only.patch
Normal file
@ -0,0 +1,32 @@
|
|||||||
|
--- xorg-server-1.2.0/hw/kdrive/Makefile.am.xephyr 2007-01-22 22:13:14.000000000 -0500
|
||||||
|
+++ xorg-server-1.2.0/hw/kdrive/Makefile.am 2007-01-23 12:28:32.000000000 -0500
|
||||||
|
@@ -1,16 +1,3 @@
|
||||||
|
-if KDRIVEVESA
|
||||||
|
-VESA_SUBDIRS = vesa ati chips epson i810 mach64 mga neomagic nvidia pm2 r128 \
|
||||||
|
- smi via
|
||||||
|
-endif
|
||||||
|
-
|
||||||
|
-if KDRIVEFBDEV
|
||||||
|
-FBDEV_SUBDIRS = fbdev
|
||||||
|
-endif
|
||||||
|
-
|
||||||
|
-if XSDLSERVER
|
||||||
|
-XSDL_SUBDIRS = sdl
|
||||||
|
-endif
|
||||||
|
-
|
||||||
|
if XEPHYR
|
||||||
|
XEPHYR_SUBDIRS = ephyr
|
||||||
|
endif
|
||||||
|
@@ -22,11 +9,7 @@
|
||||||
|
SUBDIRS = \
|
||||||
|
src \
|
||||||
|
$(LINUX_SUBDIRS) \
|
||||||
|
- $(XSDL_SUBDIRS) \
|
||||||
|
- $(FBDEV_SUBDIRS) \
|
||||||
|
- $(VESA_SUBDIRS) \
|
||||||
|
- $(XEPHYR_SUBDIRS) \
|
||||||
|
- fake
|
||||||
|
+ $(XEPHYR_SUBDIRS)
|
||||||
|
|
||||||
|
DIST_SUBDIRS = vesa ati chips epson i810 mach64 mga neomagic nvidia pm2 r128 \
|
||||||
|
smi via fbdev sdl ephyr src linux fake sis300
|
11
xorg-x11-server-1.2.0-xf86config-comment-less.patch
Normal file
11
xorg-x11-server-1.2.0-xf86config-comment-less.patch
Normal file
@ -0,0 +1,11 @@
|
|||||||
|
--- xorg-server-1.2.0/hw/xfree86/parser/Monitor.c.comment-less 2007-01-22 22:13:15.000000000 -0500
|
||||||
|
+++ xorg-server-1.2.0/hw/xfree86/parser/Monitor.c 2007-01-23 12:32:48.000000000 -0500
|
||||||
|
@@ -674,8 +674,6 @@
|
||||||
|
fprintf (cf, "\tDisplaySize %d\t%d\n",
|
||||||
|
ptr->mon_width,
|
||||||
|
ptr->mon_height);
|
||||||
|
- if ( ptr->mon_n_hsync || ptr->mon_n_vrefresh )
|
||||||
|
- fprintf(cf," ### Comment all HorizSync and VertRefresh values to use DDC:\n");
|
||||||
|
for (i = 0; i < ptr->mon_n_hsync; i++)
|
||||||
|
{
|
||||||
|
fprintf (cf, "\tHorizSync %2.1f - %2.1f\n",
|
@ -7,8 +7,8 @@
|
|||||||
|
|
||||||
Summary: X.Org X11 X server
|
Summary: X.Org X11 X server
|
||||||
Name: xorg-x11-server
|
Name: xorg-x11-server
|
||||||
Version: 1.1.1
|
Version: 1.2.0
|
||||||
Release: 57%{?dist}
|
Release: 1%{?dist}
|
||||||
URL: http://www.x.org
|
URL: http://www.x.org
|
||||||
License: MIT/X11
|
License: MIT/X11
|
||||||
Group: User Interface/X
|
Group: User Interface/X
|
||||||
@ -19,60 +19,34 @@ Source100: comment-header-modefiles.txt
|
|||||||
|
|
||||||
# general bug fixes
|
# general bug fixes
|
||||||
Patch0: xorg-x11-server-0.99.3-init-origins-fix.patch
|
Patch0: xorg-x11-server-0.99.3-init-origins-fix.patch
|
||||||
# https://bugs.freedesktop.org/show_bug.cgi?id=5093
|
|
||||||
Patch3: xserver-1.0.0-parser-add-missing-headers-to-sdk.patch
|
|
||||||
Patch4: xorg-x11-server-1.0.1-composite-fastpath-fdo4320.patch
|
|
||||||
Patch5: xorg-x11-server-libxf86config-dont-write-empty-sections.patch
|
Patch5: xorg-x11-server-libxf86config-dont-write-empty-sections.patch
|
||||||
Patch6: xorg-x11-server-1.1.1-builderstring.patch
|
Patch6: xorg-x11-server-1.1.1-builderstring.patch
|
||||||
Patch7: xorg-x11-server-1.1.1-xkb-in-xnest.patch
|
Patch7: xorg-x11-server-1.1.1-xkb-in-xnest.patch
|
||||||
Patch8: xorg-x11-server-1.1.1-xvfb-composite-crash.patch
|
|
||||||
Patch9: xorg-x11-server-1.1.1-pclose-confusion.patch
|
|
||||||
Patch10: xorg-x11-server-1.1.1-vbe-filter-less.patch
|
Patch10: xorg-x11-server-1.1.1-vbe-filter-less.patch
|
||||||
Patch11: xorg-x11-server-1.1.1-vt-activate-is-a-terrible-api.patch
|
Patch11: xorg-x11-server-1.1.1-vt-activate-is-a-terrible-api.patch
|
||||||
Patch12: xorg-x11-server-1.1.1-graphics-expose.patch
|
Patch12: xorg-x11-server-1.1.1-graphics-expose.patch
|
||||||
Patch13: xorg-x11-server-1.1.1-ia64-int10.patch
|
|
||||||
Patch14: xorg-x11-server-1.1.1-ia64-pci-chipsets.patch
|
|
||||||
Patch15: xorg-x11-server-1.1.1-automake-1.10-fixes.patch
|
Patch15: xorg-x11-server-1.1.1-automake-1.10-fixes.patch
|
||||||
Patch16: xorg-x11-server-1.1.1-xkb-vidmode-switch.patch
|
|
||||||
Patch17: xorg-x11-server-1.1.1-lid-close-crash.patch
|
|
||||||
Patch18: xorg-x11-server-1.1.1-glcore-visual-matching.patch
|
Patch18: xorg-x11-server-1.1.1-glcore-visual-matching.patch
|
||||||
|
|
||||||
# http://xorg.freedesktop.org/releases/X11R7.1/patches/xorg-xserver-1.1.0-dbe-render.diff
|
|
||||||
Patch50: xorg-xserver-1.1.0-dbe-render.diff
|
|
||||||
|
|
||||||
# OpenGL compositing manager feature/optimization patches.
|
# OpenGL compositing manager feature/optimization patches.
|
||||||
Patch100: xorg-x11-server-1.1.0-no-move-damage.patch
|
Patch100: xorg-x11-server-1.1.0-no-move-damage.patch
|
||||||
Patch101: xorg-x11-server-1.1.0-dont-backfill-bg-none.patch
|
Patch101: xorg-x11-server-1.1.0-dont-backfill-bg-none.patch
|
||||||
Patch103: xorg-x11-server-1.1.0-tfp-damage.patch
|
Patch105: xorg-x11-server-1.2.0-enable-composite.patch
|
||||||
Patch104: xorg-x11-server-1.1.0-mesa-copy-sub-buffer.patch
|
|
||||||
Patch105: xorg-x11-server-1.1.1-enable-composite.patch
|
|
||||||
Patch106: xorg-x11-server-1.1.1-no-composite-in-xnest.patch
|
Patch106: xorg-x11-server-1.1.1-no-composite-in-xnest.patch
|
||||||
Patch107: xorg-x11-server-1.1.1-offscreen-pixmaps.patch
|
Patch107: xorg-x11-server-1.1.1-offscreen-pixmaps.patch
|
||||||
Patch108: xorg-x11-server-1.1.1-mesa-6.5.1.patch
|
|
||||||
Patch109: xorg-x11-server-1.1.1-aiglx-happy-vt-switch.patch
|
|
||||||
Patch110: xorg-x11-server-1.1.1-mesa-6.5.2.patch
|
|
||||||
|
|
||||||
# Red Hat specific tweaking, not intended for upstream
|
# Red Hat specific tweaking, not intended for upstream
|
||||||
# XXX move these to the end of the list
|
# XXX move these to the end of the list
|
||||||
Patch1001: xorg-x11-server-Red-Hat-extramodes.patch
|
Patch1001: xorg-x11-server-Red-Hat-extramodes.patch
|
||||||
Patch1002: xorg-x11-server-1.1.0-redhat-xephyr-only-hack.patch
|
Patch1002: xorg-x11-server-1.2.0-xephyr-only.patch
|
||||||
Patch1003: xorg-x11-server-1.0.1-fpic-libxf86config.patch
|
Patch1003: xorg-x11-server-1.0.1-fpic-libxf86config.patch
|
||||||
Patch1004: xorg-x11-server-1.1.1-selinux-awareness.patch
|
Patch1004: xorg-x11-server-1.2.0-selinux-awareness.patch
|
||||||
Patch1005: xorg-x11-server-1.1.1-builtin-fonts.patch
|
Patch1005: xorg-x11-server-1.1.1-builtin-fonts.patch
|
||||||
Patch1006: xorg-x11-server-1.1.1-no-scanpci.patch
|
Patch1006: xorg-x11-server-1.1.1-no-scanpci.patch
|
||||||
Patch1007: xorg-x11-server-1.1.1-spurious-libxf1bpp-link.patch
|
Patch1007: xorg-x11-server-1.1.1-spurious-libxf1bpp-link.patch
|
||||||
Patch1008: xorg-x11-server-1.1.1-xf86config-comment-less.patch
|
Patch1008: xorg-x11-server-1.2.0-xf86config-comment-less.patch
|
||||||
|
|
||||||
# Backports of post-1.1 stuff.
|
Patch3001: xorg-x11-server-1.2.0-maxpixclock-option.patch
|
||||||
Patch2001: xorg-x11-server-1.1.0-pci-scan-fixes.patch
|
|
||||||
Patch2004: xorg-x11-server-1.1.0-no-zlib.patch
|
|
||||||
Patch2005: xorg-x11-server-1.1.1-Xdmx-render-fix-fdo7482.patch
|
|
||||||
Patch2006: xorg-x11-server-1.1.1-revert-xkb-change.patch
|
|
||||||
Patch2007: xorg-x11-server-1.1.1-aiglx-locking.patch
|
|
||||||
Patch2008: xorg-x11-server-1.1.1-edid-hex-dump.patch
|
|
||||||
|
|
||||||
Patch3000: xorg-x11-server-1.1.1-autoconfig.patch
|
|
||||||
Patch3001: xorg-x11-server-1.1.1-maxpixclock-option.patch
|
|
||||||
|
|
||||||
%define moduledir %{_libdir}/xorg/modules
|
%define moduledir %{_libdir}/xorg/modules
|
||||||
%define drimoduledir %{_libdir}/dri
|
%define drimoduledir %{_libdir}/dri
|
||||||
@ -125,11 +99,8 @@ BuildRequires: libXdmcp-devel
|
|||||||
BuildRequires: libX11-devel
|
BuildRequires: libX11-devel
|
||||||
# libXext-devel needed for Xdmx, Xnest, Xephyr
|
# libXext-devel needed for Xdmx, Xnest, Xephyr
|
||||||
BuildRequires: libXext-devel
|
BuildRequires: libXext-devel
|
||||||
#
|
# XXX Really? Why would we need this, Xfont should hide it.
|
||||||
BuildRequires: freetype-devel >= 2.1.9-1
|
BuildRequires: freetype-devel >= 2.1.9-1
|
||||||
# FIXME: Disabling zlib-devel dep as we are applying the xorg-x11-server-1.1.0-no-zlib.patch
|
|
||||||
# patch which should remove any dependency on zlib anyway.
|
|
||||||
#BuildRequires: zlib-devel
|
|
||||||
|
|
||||||
# FIXME: libXt-devel should be wrapped in with_dmx_server - for Xdmxconfig,
|
# FIXME: libXt-devel should be wrapped in with_dmx_server - for Xdmxconfig,
|
||||||
# probably should only be needed for DMX builds, but the build explodes with
|
# probably should only be needed for DMX builds, but the build explodes with
|
||||||
@ -138,16 +109,13 @@ BuildRequires: libXt-devel
|
|||||||
|
|
||||||
|
|
||||||
%if %{with_dmx_server}
|
%if %{with_dmx_server}
|
||||||
# libdmx-devel needed for Xdmx
|
|
||||||
BuildRequires: libdmx-devel
|
BuildRequires: libdmx-devel
|
||||||
# libXmu-devel needed for Xdmx
|
|
||||||
BuildRequires: libXmu-devel
|
BuildRequires: libXmu-devel
|
||||||
# libXrender-devel needed for Xdmx
|
|
||||||
BuildRequires: libXrender-devel
|
BuildRequires: libXrender-devel
|
||||||
# libXi-devel needed for Xdmx
|
|
||||||
BuildRequires: libXi-devel
|
BuildRequires: libXi-devel
|
||||||
BuildRequires: libXpm-devel
|
BuildRequires: libXpm-devel
|
||||||
BuildRequires: libXaw-devel
|
BuildRequires: libXaw-devel
|
||||||
|
BuildRequires: libXfixes-devel
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
# To query fontdir from fontutil.pc
|
# To query fontdir from fontutil.pc
|
||||||
@ -156,7 +124,8 @@ BuildRequires: xorg-x11-font-utils >= 1.0.0-1
|
|||||||
%if %{with_dri}
|
%if %{with_dri}
|
||||||
BuildRequires: mesa-libGL-devel >= 6.5.1
|
BuildRequires: mesa-libGL-devel >= 6.5.1
|
||||||
BuildRequires: mesa-source >= 6.5.1
|
BuildRequires: mesa-source >= 6.5.1
|
||||||
BuildRequires: libdrm-devel >= 2.0-1
|
BuildRequires: libdrm-devel >= 2.3.0
|
||||||
|
Requires: libdrm >= 2.3.0
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
BuildRequires: libselinux-devel
|
BuildRequires: libselinux-devel
|
||||||
@ -331,34 +300,20 @@ drivers, input drivers, or other X modules should install this package.
|
|||||||
%prep
|
%prep
|
||||||
%setup -q -n %{pkgname}-%{version}
|
%setup -q -n %{pkgname}-%{version}
|
||||||
%patch0 -p0 -b .init-origins-fix
|
%patch0 -p0 -b .init-origins-fix
|
||||||
%patch3 -p0 -b .parser-add-missing-headers-to-sdk
|
|
||||||
%patch5 -p0 -b .libxf86config-dont-write-empty-sections
|
%patch5 -p0 -b .libxf86config-dont-write-empty-sections
|
||||||
%patch6 -p1 -b .builderstring
|
%patch6 -p1 -b .builderstring
|
||||||
%patch7 -p1 -b .xkb-in-xnest
|
%patch7 -p1 -b .xkb-in-xnest
|
||||||
%patch8 -p1 -b .xvfb-render-fix
|
|
||||||
%patch9 -p1 -b .pclose
|
|
||||||
%patch10 -p1 -b .vbe-filter
|
%patch10 -p1 -b .vbe-filter
|
||||||
%patch11 -p1 -b .vt-activate
|
%patch11 -p1 -b .vt-activate
|
||||||
%patch12 -p1 -b .graphics-expose
|
%patch12 -p1 -b .graphics-expose
|
||||||
%patch13 -p1 -b .ia64-int10
|
|
||||||
%patch14 -p1 -b .ia64-pci-chipsets
|
|
||||||
%patch15 -p1 -b .automake-1.10
|
%patch15 -p1 -b .automake-1.10
|
||||||
%patch16 -p1 -b .xkb-vidmode-switch
|
|
||||||
%patch17 -p1 -b .lid-close-crash
|
|
||||||
%patch18 -p1 -b .glcore-visual
|
%patch18 -p1 -b .glcore-visual
|
||||||
|
|
||||||
%patch50 -p1 -b .alloca
|
|
||||||
|
|
||||||
%patch100 -p0 -b .no-move-damage
|
%patch100 -p0 -b .no-move-damage
|
||||||
%patch101 -p0 -b .dont-backfill-bg-none
|
%patch101 -p0 -b .dont-backfill-bg-none
|
||||||
%patch103 -p0 -b .tfp-damage
|
%patch105 -p1 -b .enable-composite
|
||||||
%patch104 -p0 -b .mesa-copy-sub-buffer
|
|
||||||
%patch105 -p0 -b .enable-composite
|
|
||||||
%patch106 -p1 -b .no-xnest-composite
|
%patch106 -p1 -b .no-xnest-composite
|
||||||
%patch107 -p1 -b .offscreen-pixmaps
|
%patch107 -p1 -b .offscreen-pixmaps
|
||||||
%patch108 -p1 -b .mesa-651
|
|
||||||
%patch109 -p1 -b .aiglx-happy-vt-switch
|
|
||||||
%patch110 -p1 -b .mesa-652
|
|
||||||
|
|
||||||
%patch1001 -p1 -b .Red-Hat-extramodes
|
%patch1001 -p1 -b .Red-Hat-extramodes
|
||||||
%patch1002 -p1 -b .xephyr
|
%patch1002 -p1 -b .xephyr
|
||||||
@ -368,15 +323,6 @@ drivers, input drivers, or other X modules should install this package.
|
|||||||
%patch1006 -p1 -b .no-scanpci
|
%patch1006 -p1 -b .no-scanpci
|
||||||
%patch1007 -p1 -b .xf1bpp
|
%patch1007 -p1 -b .xf1bpp
|
||||||
%patch1008 -p1 -b .comment-less
|
%patch1008 -p1 -b .comment-less
|
||||||
|
|
||||||
%patch2001 -p1 -b .pci-scan
|
|
||||||
%patch2004 -p1 -b .zlib
|
|
||||||
%patch2005 -p1 -b .Xdmx
|
|
||||||
%patch2006 -p1 -b .revert-xkb-change
|
|
||||||
%patch2007 -p1 -b .aiglx-locking
|
|
||||||
%patch2008 -p1 -b .hexdump
|
|
||||||
|
|
||||||
%patch3000 -p1 -b .autoconfig
|
|
||||||
%patch3001 -p1 -b .maxpixclock
|
%patch3001 -p1 -b .maxpixclock
|
||||||
|
|
||||||
%build
|
%build
|
||||||
@ -563,13 +509,9 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{_libdir}/xorg/modules/extensions/libxtrap.so
|
%{_libdir}/xorg/modules/extensions/libxtrap.so
|
||||||
%dir %{_libdir}/xorg/modules/input
|
%dir %{_libdir}/xorg/modules/input
|
||||||
%dir %{_libdir}/xorg/modules/fonts
|
%dir %{_libdir}/xorg/modules/fonts
|
||||||
%{_libdir}/xorg/modules/fonts/libbitmap.so
|
|
||||||
%{_libdir}/xorg/modules/fonts/libfreetype.so
|
%{_libdir}/xorg/modules/fonts/libfreetype.so
|
||||||
%{_libdir}/xorg/modules/fonts/libtype1.so
|
%{_libdir}/xorg/modules/fonts/libtype1.so
|
||||||
%dir %{_libdir}/xorg/modules/linux
|
%dir %{_libdir}/xorg/modules/linux
|
||||||
%if %{with_dri}
|
|
||||||
%{_libdir}/xorg/modules/linux/libdrm.so
|
|
||||||
%endif
|
|
||||||
%{_libdir}/xorg/modules/linux/libfbdevhw.so
|
%{_libdir}/xorg/modules/linux/libfbdevhw.so
|
||||||
%dir %{_libdir}/xorg/modules/multimedia
|
%dir %{_libdir}/xorg/modules/multimedia
|
||||||
%{_libdir}/xorg/modules/multimedia/bt829_drv.so
|
%{_libdir}/xorg/modules/multimedia/bt829_drv.so
|
||||||
@ -581,7 +523,6 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{_libdir}/xorg/modules/multimedia/uda1380_drv.so
|
%{_libdir}/xorg/modules/multimedia/uda1380_drv.so
|
||||||
%{_libdir}/xorg/modules/libafb.so
|
%{_libdir}/xorg/modules/libafb.so
|
||||||
%{_libdir}/xorg/modules/libcfb.so
|
%{_libdir}/xorg/modules/libcfb.so
|
||||||
%{_libdir}/xorg/modules/libcfb16.so
|
|
||||||
%{_libdir}/xorg/modules/libcfb32.so
|
%{_libdir}/xorg/modules/libcfb32.so
|
||||||
%{_libdir}/xorg/modules/libddc.so
|
%{_libdir}/xorg/modules/libddc.so
|
||||||
%{_libdir}/xorg/modules/libexa.so
|
%{_libdir}/xorg/modules/libexa.so
|
||||||
@ -590,7 +531,6 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{_libdir}/xorg/modules/libint10.so
|
%{_libdir}/xorg/modules/libint10.so
|
||||||
%{_libdir}/xorg/modules/libmfb.so
|
%{_libdir}/xorg/modules/libmfb.so
|
||||||
%{_libdir}/xorg/modules/libpcidata.so
|
%{_libdir}/xorg/modules/libpcidata.so
|
||||||
%{_libdir}/xorg/modules/librac.so
|
|
||||||
%{_libdir}/xorg/modules/libramdac.so
|
%{_libdir}/xorg/modules/libramdac.so
|
||||||
%{_libdir}/xorg/modules/libshadow.so
|
%{_libdir}/xorg/modules/libshadow.so
|
||||||
%{_libdir}/xorg/modules/libshadowfb.so
|
%{_libdir}/xorg/modules/libshadowfb.so
|
||||||
@ -611,6 +551,7 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
#%dir %{_mandir}/man4x
|
#%dir %{_mandir}/man4x
|
||||||
#%{_mandir}/man4/fbdevhw.4*
|
#%{_mandir}/man4/fbdevhw.4*
|
||||||
%{_mandir}/man4/fbdevhw.4*
|
%{_mandir}/man4/fbdevhw.4*
|
||||||
|
%{_mandir}/man4/exa.4*
|
||||||
#%dir %{_mandir}/man5x
|
#%dir %{_mandir}/man5x
|
||||||
%{_mandir}/man5/xorg.conf.5*
|
%{_mandir}/man5/xorg.conf.5*
|
||||||
%dir %{_localstatedir}/lib/xkb
|
%dir %{_localstatedir}/lib/xkb
|
||||||
@ -692,6 +633,9 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
# -------------------------------------------------------------------
|
# -------------------------------------------------------------------
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Tue Jan 23 2007 Adam Jackson <ajax@redhat.com> 1.2.0-1
|
||||||
|
- Xorg server 1.2.0.
|
||||||
|
|
||||||
* Tue Jan 09 2007 Adam Jackson <ajax@redhat.com> 1.1.1-57
|
* Tue Jan 09 2007 Adam Jackson <ajax@redhat.com> 1.1.1-57
|
||||||
- xorg-xserver-1.1.0-dbe-render.diff: CVE #2006-6101
|
- xorg-xserver-1.1.0-dbe-render.diff: CVE #2006-6101
|
||||||
- xorg-x11-server-1.1.0-redhat-xephyr-only-hack.patch: Skip building the
|
- xorg-x11-server-1.1.0-redhat-xephyr-only-hack.patch: Skip building the
|
||||||
|
Loading…
Reference in New Issue
Block a user