today's rebase
This commit is contained in:
parent
9eb4ebc93c
commit
8d95713759
@ -1 +1 @@
|
||||
xorg-server-20071102.tar.bz2
|
||||
xorg-server-20071127.tar.bz2
|
||||
|
38
argh-pixman.patch
Normal file
38
argh-pixman.patch
Normal file
@ -0,0 +1,38 @@
|
||||
From 28e1a9e912b70a2f3a0ad988e6ffc37a351bc90e Mon Sep 17 00:00:00 2001
|
||||
From: Adam Jackson <ajax@redhat.com>
|
||||
Date: Wed, 14 Nov 2007 13:04:17 -0500
|
||||
Subject: [PATCH] Add pixman cflags to xorg-server.pc
|
||||
|
||||
---
|
||||
configure.ac | 3 +++
|
||||
xorg-server.pc.in | 2 +-
|
||||
2 files changed, 4 insertions(+), 1 deletions(-)
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index a16b46a..8b786d3 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -1073,6 +1073,9 @@ CORE_INCS='-I$(top_srcdir)/include -I$(top_builddir)/include'
|
||||
PKG_CHECK_MODULES([XSERVERCFLAGS], [$REQUIRED_MODULES $REQUIRED_LIBS])
|
||||
PKG_CHECK_MODULES([XSERVERLIBS], [$REQUIRED_LIBS])
|
||||
|
||||
+PKG_CHECK_MODULES([PIXMAN], [pixman-1])
|
||||
+AC_SUBST([PIXMAN_CFLAGS])
|
||||
+
|
||||
# Autotools has some unfortunate issues with library handling. In order to
|
||||
# get a server to rebuild when a dependency in the tree is changed, it must
|
||||
# be listed in SERVERNAME_DEPENDENCIES. However, no system libraries may be
|
||||
diff --git a/xorg-server.pc.in b/xorg-server.pc.in
|
||||
index c1cdb7d..32c64f4 100644
|
||||
--- a/xorg-server.pc.in
|
||||
+++ b/xorg-server.pc.in
|
||||
@@ -9,5 +9,5 @@ Name: xorg-server
|
||||
Description: Modular X.Org X Server
|
||||
Version: @PACKAGE_VERSION@
|
||||
Requires: pixman-1
|
||||
-Cflags: -I${sdkdir}
|
||||
+Cflags: -I${sdkdir} @PIXMAN_CFLAGS@
|
||||
Libs: -L${libdir}
|
||||
--
|
||||
1.5.3.4
|
||||
|
2
commitid
2
commitid
@ -1 +1 @@
|
||||
7a0555e9bb59d02816803a1100f807d2d29f31d4
|
||||
23b8ca8a373d919225de9739af7b064f650eceec
|
||||
|
@ -1,26 +0,0 @@
|
||||
From 2c53e4d6fcb16784548bd755827de1ee5ddddeb8 Mon Sep 17 00:00:00 2001
|
||||
From: Adam Jackson <ajax@redhat.com>
|
||||
Date: Thu, 8 Nov 2007 15:33:08 -0500
|
||||
Subject: [PATCH] Speed up DDC probe.
|
||||
|
||||
---
|
||||
hw/xfree86/ddc/xf86DDC.c | 3 +++
|
||||
1 files changed, 3 insertions(+), 0 deletions(-)
|
||||
|
||||
diff --git a/hw/xfree86/ddc/xf86DDC.c b/hw/xfree86/ddc/xf86DDC.c
|
||||
index e47b8b8..9d38aab 100644
|
||||
--- a/hw/xfree86/ddc/xf86DDC.c
|
||||
+++ b/hw/xfree86/ddc/xf86DDC.c
|
||||
@@ -148,6 +148,9 @@ xf86DoEDID_DDC2(int scrnIndex, I2CBusPtr pBus)
|
||||
if (noddc || noddc2)
|
||||
return NULL;
|
||||
|
||||
+ if (!xf86I2CProbeAddress(pBus, 0xA1))
|
||||
+ return NULL;
|
||||
+
|
||||
EDID_block = EDID1Read_DDC2(scrnIndex,pBus);
|
||||
|
||||
if (EDID_block){
|
||||
--
|
||||
1.5.3.4
|
||||
|
@ -1,25 +0,0 @@
|
||||
From a45daf5bf587c584b0b6f1e1a7e1f0d5c983cf4f Mon Sep 17 00:00:00 2001
|
||||
From: Adam Jackson <ajax@redhat.com>
|
||||
Date: Thu, 8 Nov 2007 17:25:36 -0500
|
||||
Subject: [PATCH] Don't sleep(1) at server exit.
|
||||
|
||||
---
|
||||
hw/xfree86/common/xf86Init.c | 2 +-
|
||||
1 files changed, 1 insertions(+), 1 deletions(-)
|
||||
|
||||
diff --git a/hw/xfree86/common/xf86Init.c b/hw/xfree86/common/xf86Init.c
|
||||
index 2f6e4dd..63df108 100644
|
||||
--- a/hw/xfree86/common/xf86Init.c
|
||||
+++ b/hw/xfree86/common/xf86Init.c
|
||||
@@ -1307,7 +1307,7 @@ AbortDDX()
|
||||
/*
|
||||
* try to restore the original video state
|
||||
*/
|
||||
-#ifdef HAS_USL_VTS
|
||||
+#if defined(HAS_USL_VTS) && !defined(linux)
|
||||
/* Need the sleep when starting X from within another X session */
|
||||
sleep(1);
|
||||
#endif
|
||||
--
|
||||
1.5.3.4
|
||||
|
@ -1,27 +0,0 @@
|
||||
From 5c62bc4a182f0e7810f442e418bb84cd964a7e22 Mon Sep 17 00:00:00 2001
|
||||
From: Adam Jackson <ajax@redhat.com>
|
||||
Date: Fri, 9 Nov 2007 13:55:32 -0500
|
||||
Subject: [PATCH] Add -pogo option for init/teardown performance testing.
|
||||
|
||||
---
|
||||
os/utils.c | 4 ++++
|
||||
1 files changed, 4 insertions(+), 0 deletions(-)
|
||||
|
||||
diff --git a/os/utils.c b/os/utils.c
|
||||
index 6fc1f7d..69803ae 100644
|
||||
--- a/os/utils.c
|
||||
+++ b/os/utils.c
|
||||
@@ -941,6 +941,10 @@ ProcessCommandLine(int argc, char *argv[])
|
||||
else
|
||||
UseMsg();
|
||||
}
|
||||
+ else if (strcmp(argv[i], "-pogo") == 0)
|
||||
+ {
|
||||
+ dispatchException = DE_TERMINATE;
|
||||
+ }
|
||||
else if ( strcmp( argv[i], "-pn") == 0)
|
||||
PartialNetwork = TRUE;
|
||||
else if ( strcmp( argv[i], "-nopn") == 0)
|
||||
--
|
||||
1.5.3.4
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
c2ebed7ea33f8795883c19b18397c2c7 xorg-server-20071102.tar.bz2
|
||||
43e5d239d6255fb9b8abe4e3bf4eecb9 xorg-server-20071127.tar.bz2
|
||||
|
@ -15,12 +15,12 @@
|
||||
# RHEL5 bugfix sync
|
||||
|
||||
%define pkgname xorg-server
|
||||
%define gitdate 20071102
|
||||
%define gitdate 20071127
|
||||
|
||||
Summary: X.Org X11 X server
|
||||
Name: xorg-x11-server
|
||||
Version: 1.4.99.1
|
||||
Release: 0.10%{?dist}
|
||||
Release: 0.11%{?dist}
|
||||
URL: http://www.x.org
|
||||
License: MIT
|
||||
Group: User Interface/X
|
||||
@ -52,17 +52,18 @@ Patch1004: xserver-1.4.99-selinux-awareness.patch
|
||||
Patch1005: xserver-1.4.99-builtin-fonts.patch
|
||||
Patch1010: xserver-1.3.0-no-prerelease-warning.patch
|
||||
Patch1014: xserver-1.4.99-xaa-evict-pixmaps.patch
|
||||
Patch1022: xserver-1.3.0-default-dpi.patch
|
||||
|
||||
Patch2004: xserver-1.3.0-honor-displaysize.patch
|
||||
Patch2007: xserver-1.3.0-randr12-config-hack.patch
|
||||
Patch2013: xserver-1.3.0-document-fontpath-correctly.patch
|
||||
Patch2013: xserver-1.4.99-document-fontpath-correctly.patch
|
||||
|
||||
# Trivial things to merge upstream at next rebase
|
||||
Patch4000: ddc-faster-plz.patch
|
||||
Patch4001: no-sleep-at-exit.patch
|
||||
Patch4002: pogo-stick.patch
|
||||
# Trivial things, already merged
|
||||
#Patch3000:
|
||||
|
||||
# Trivial things to maybe merge upstream at next rebase
|
||||
Patch4003: argh-pixman.patch
|
||||
Patch4004: xserver-1.4.99-xephyr-dri.patch
|
||||
Patch4005: xserver-1.4.99-openchrome.patch
|
||||
|
||||
%define moduledir %{_libdir}/xorg/modules
|
||||
%define drimoduledir %{_libdir}/dri
|
||||
@ -83,7 +84,7 @@ Patch4002: pogo-stick.patch
|
||||
%define kdrive --enable-kdrive --enable-xephyr --disable-xsdl --disable-xfake --disable-xfbdev --disable-kdrive-vesa
|
||||
%define xservers --enable-xvfb --enable-xnest %{kdrive} %{enable_xorg} --enable-dmx
|
||||
|
||||
BuildRequires: git
|
||||
BuildRequires: git-core
|
||||
BuildRequires: automake autoconf libtool pkgconfig
|
||||
BuildRequires: xorg-x11-util-macros >= 1.1.5
|
||||
|
||||
@ -113,7 +114,7 @@ BuildRequires: libXv-devel
|
||||
# openssl? really?
|
||||
BuildRequires: pixman-devel libpciaccess-devel openssl-devel byacc flex
|
||||
BuildRequires: mesa-libGL-devel >= 7.1
|
||||
BuildRequires: mesa-source >= 7.1
|
||||
BuildRequires: mesa-source >= 7.1-0.5
|
||||
# XXX silly...
|
||||
BuildRequires: libdrm-devel >= 2.4.0
|
||||
%if %{with_hw_servers}
|
||||
@ -456,6 +457,7 @@ rm -rf $RPM_BUILD_ROOT
|
||||
%{_libdir}/xorg/modules/libvgahw.so
|
||||
%{_libdir}/xorg/modules/libwfb.so
|
||||
%{_libdir}/xorg/modules/libxaa.so
|
||||
%{_libdir}/xorg/modules/libxf8_16bpp.so
|
||||
%{_mandir}/man1/gtf.1*
|
||||
%{_mandir}/man1/Xorg.1*
|
||||
%{_mandir}/man1/cvt.1*
|
||||
@ -519,6 +521,13 @@ rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
|
||||
%changelog
|
||||
* Wed Nov 28 2007 Adam Jackson <ajax@redhat.com> 1.4.99.1-0.11
|
||||
- Today's rebase.
|
||||
- BR on git-core instead of git.
|
||||
- Bump mesa-source BR to cope with extended CreatePixmap signature.
|
||||
- xserver-1.4.99-openchrome.patch: Use openchrome not via when running
|
||||
without a config file.
|
||||
|
||||
* Tue Nov 13 2007 Adam Jackson <ajax@redhat.com> 1.4.99.1-0.10
|
||||
- -devel Requires: pixman-devel and libpciaccess-devel.
|
||||
|
||||
|
@ -1,19 +0,0 @@
|
||||
From: Adam Jackson <ajax@redhat.com>
|
||||
Date: Sun, 28 Oct 2007 09:37:52 +0100
|
||||
Subject: [PATCH] Crank the default DPI to 100.
|
||||
|
||||
1986 called, they want their monitor back.
|
||||
|
||||
---
|
||||
diff -up xorg-server-1.3.0.0/hw/xfree86/common/xf86Priv.h.jx xorg-server-1.3.0.0/hw/xfree86/common/xf86Priv.h
|
||||
--- xorg-server-1.3.0.0/hw/xfree86/common/xf86Priv.h.jx 2006-11-16 13:01:24.000000000 -0500
|
||||
+++ xorg-server-1.3.0.0/hw/xfree86/common/xf86Priv.h 2007-08-09 16:55:02.000000000 -0400
|
||||
@@ -120,7 +120,7 @@ extern RootWinPropPtr *xf86RegisteredPro
|
||||
#define DEFAULT_LOG_VERBOSE 3
|
||||
#endif
|
||||
#ifndef DEFAULT_DPI
|
||||
-#define DEFAULT_DPI 75
|
||||
+#define DEFAULT_DPI 100
|
||||
#endif
|
||||
|
||||
#define DEFAULT_UNRESOLVED TRUE
|
@ -1,48 +0,0 @@
|
||||
From: Adam Jackson <ajax@redhat.com>
|
||||
Date: Sun, 28 Oct 2007 09:37:52 +0100
|
||||
Subject: [PATCH] Document default font path correctly.
|
||||
|
||||
---
|
||||
diff -up xorg-server-1.3.0.0/hw/xfree86/doc/man/xorg.conf.man.pre.jx xorg-server-1.3.0.0/hw/xfree86/doc/man/xorg.conf.man.pre
|
||||
--- xorg-server-1.3.0.0/hw/xfree86/doc/man/xorg.conf.man.pre.jx 2006-12-22 03:06:49.000000000 -0500
|
||||
+++ xorg-server-1.3.0.0/hw/xfree86/doc/man/xorg.conf.man.pre 2007-08-23 15:27:47.000000000 -0400
|
||||
@@ -308,11 +308,11 @@ font path elements:
|
||||
.PP
|
||||
.RS 4
|
||||
.nf
|
||||
-.I __projectroot__/lib/X11/fonts/misc/
|
||||
-.I __projectroot__/lib/X11/fonts/TTF/
|
||||
-.I __projectroot__/lib/X11/fonts/Type1/
|
||||
-.I __projectroot__/lib/X11/fonts/75dpi/
|
||||
-.I __projectroot__/lib/X11/fonts/100dpi/
|
||||
+.I __projectroot__/share/X11/fonts/misc/
|
||||
+.I __projectroot__/share/X11/fonts/TTF/
|
||||
+.I __projectroot__/share/X11/fonts/Type1/
|
||||
+.I __projectroot__/share/X11/fonts/75dpi/
|
||||
+.I __projectroot__/share/X11/fonts/100dpi/
|
||||
.fi
|
||||
.RE
|
||||
.PP
|
||||
@@ -320,14 +320,14 @@ The recommended font path contains the f
|
||||
.PP
|
||||
.RS 4
|
||||
.nf
|
||||
-.I __projectroot__/lib/X11/fonts/local/
|
||||
-.I __projectroot__/lib/X11/fonts/misc/
|
||||
-.I __projectroot__/lib/X11/fonts/75dpi/:unscaled
|
||||
-.I __projectroot__/lib/X11/fonts/100dpi/:unscaled
|
||||
-.I __projectroot__/lib/X11/fonts/Type1/
|
||||
-.I __projectroot__/lib/X11/fonts/Speedo/
|
||||
-.I __projectroot__/lib/X11/fonts/75dpi/
|
||||
-.I __projectroot__/lib/X11/fonts/100dpi/
|
||||
+.I __projectroot__/share/X11/fonts/local/
|
||||
+.I __projectroot__/share/X11/fonts/misc/
|
||||
+.I __projectroot__/share/X11/fonts/75dpi/:unscaled
|
||||
+.I __projectroot__/share/X11/fonts/100dpi/:unscaled
|
||||
+.I __projectroot__/share/X11/fonts/Type1/
|
||||
+.I __projectroot__/share/X11/fonts/Speedo/
|
||||
+.I __projectroot__/share/X11/fonts/75dpi/
|
||||
+.I __projectroot__/share/X11/fonts/100dpi/
|
||||
.fi
|
||||
.RE
|
||||
.PP
|
54
xserver-1.4.99-document-fontpath-correctly.patch
Normal file
54
xserver-1.4.99-document-fontpath-correctly.patch
Normal file
@ -0,0 +1,54 @@
|
||||
From 98c7481338e3167058382f27a3e002662553131a Mon Sep 17 00:00:00 2001
|
||||
From: Adam Jackson <ajax@redhat.com>
|
||||
Date: Tue, 27 Nov 2007 16:09:43 -0500
|
||||
Subject: [PATCH] Document default font path correctly.
|
||||
|
||||
---
|
||||
hw/xfree86/doc/man/xorg.conf.man.pre | 24 ++++++++++++------------
|
||||
1 files changed, 12 insertions(+), 12 deletions(-)
|
||||
|
||||
diff --git a/hw/xfree86/doc/man/xorg.conf.man.pre b/hw/xfree86/doc/man/xorg.conf.man.pre
|
||||
index 3c657d0..4b562bd 100644
|
||||
--- a/hw/xfree86/doc/man/xorg.conf.man.pre
|
||||
+++ b/hw/xfree86/doc/man/xorg.conf.man.pre
|
||||
@@ -356,11 +356,11 @@ font path elements (which can be set inside a catalogue directory):
|
||||
.PP
|
||||
.RS 4
|
||||
.nf
|
||||
-.I __projectroot__/lib/X11/fonts/misc/
|
||||
-.I __projectroot__/lib/X11/fonts/TTF/
|
||||
-.I __projectroot__/lib/X11/fonts/Type1/
|
||||
-.I __projectroot__/lib/X11/fonts/75dpi/
|
||||
-.I __projectroot__/lib/X11/fonts/100dpi/
|
||||
+.I __projectroot__/share/X11/fonts/misc/
|
||||
+.I __projectroot__/share/X11/fonts/TTF/
|
||||
+.I __projectroot__/share/X11/fonts/Type1/
|
||||
+.I __projectroot__/share/X11/fonts/75dpi/
|
||||
+.I __projectroot__/share/X11/fonts/100dpi/
|
||||
.fi
|
||||
.RE
|
||||
.PP
|
||||
@@ -368,13 +368,13 @@ The recommended font path contains the following font path elements:
|
||||
.PP
|
||||
.RS 4
|
||||
.nf
|
||||
-.I __projectroot__/lib/X11/fonts/local/
|
||||
-.I __projectroot__/lib/X11/fonts/misc/
|
||||
-.I __projectroot__/lib/X11/fonts/75dpi/:unscaled
|
||||
-.I __projectroot__/lib/X11/fonts/100dpi/:unscaled
|
||||
-.I __projectroot__/lib/X11/fonts/Type1/
|
||||
-.I __projectroot__/lib/X11/fonts/75dpi/
|
||||
-.I __projectroot__/lib/X11/fonts/100dpi/
|
||||
+.I __projectroot__/shared/X11/fonts/local/
|
||||
+.I __projectroot__/shared/X11/fonts/misc/
|
||||
+.I __projectroot__/shared/X11/fonts/75dpi/:unscaled
|
||||
+.I __projectroot__/shared/X11/fonts/100dpi/:unscaled
|
||||
+.I __projectroot__/shared/X11/fonts/Type1/
|
||||
+.I __projectroot__/shared/X11/fonts/75dpi/
|
||||
+.I __projectroot__/shared/X11/fonts/100dpi/
|
||||
.fi
|
||||
.RE
|
||||
.PP
|
||||
--
|
||||
1.5.3.4
|
||||
|
25
xserver-1.4.99-openchrome.patch
Normal file
25
xserver-1.4.99-openchrome.patch
Normal file
@ -0,0 +1,25 @@
|
||||
From 59681e08381f8ca83263a6313b43905909e68583 Mon Sep 17 00:00:00 2001
|
||||
From: Adam Jackson <ajax@redhat.com>
|
||||
Date: Wed, 28 Nov 2007 12:09:16 -0500
|
||||
Subject: [PATCH] via -> openchrome
|
||||
|
||||
---
|
||||
hw/xfree86/common/xf86AutoConfig.c | 2 +-
|
||||
1 files changed, 1 insertions(+), 1 deletions(-)
|
||||
|
||||
diff --git a/hw/xfree86/common/xf86AutoConfig.c b/hw/xfree86/common/xf86AutoConfig.c
|
||||
index c6e1972..da6c3f3 100644
|
||||
--- a/hw/xfree86/common/xf86AutoConfig.c
|
||||
+++ b/hw/xfree86/common/xf86AutoConfig.c
|
||||
@@ -184,7 +184,7 @@ videoPtrToDriverName(struct pci_device *dev)
|
||||
case 0x3d3d: return "glint";
|
||||
case 0x1023: return "trident";
|
||||
case 0x100c: return "tseng";
|
||||
- case 0x1106: return "via";
|
||||
+ case 0x1106: return "openchrome";
|
||||
case 0x15ad: return "vmware";
|
||||
default: break;
|
||||
}
|
||||
--
|
||||
1.5.3.4
|
||||
|
@ -1,6 +1,6 @@
|
||||
From 823a13f90b5619823325ea162ae30d652e448492 Mon Sep 17 00:00:00 2001
|
||||
From 0706a26b4ddbcd2ca495e05403ffc161e299a2c8 Mon Sep 17 00:00:00 2001
|
||||
From: Adam Jackson <ajax@redhat.com>
|
||||
Date: Thu, 1 Nov 2007 10:39:57 -0400
|
||||
Date: Tue, 27 Nov 2007 13:52:40 -0500
|
||||
Subject: [PATCH] Link GL subsystem against libselinux.
|
||||
|
||||
---
|
||||
@ -9,10 +9,10 @@ Subject: [PATCH] Link GL subsystem against libselinux.
|
||||
2 files changed, 4 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index 57132b0..a16b46a 100644
|
||||
index 5150c18..b5c9e48 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -339,6 +339,8 @@ case $host_cpu in
|
||||
@@ -350,6 +350,8 @@ case $host_cpu in
|
||||
;;
|
||||
esac
|
||||
|
||||
@ -21,12 +21,12 @@ index 57132b0..a16b46a 100644
|
||||
dnl BSD *_video.c selection
|
||||
AM_CONDITIONAL(ALPHA_VIDEO, [test "x$ALPHA_VIDEO" = xyes])
|
||||
AM_CONDITIONAL(ARM_VIDEO, [test "x$ARM_VIDEO" = xyes])
|
||||
@@ -1229,7 +1231,7 @@ AC_MSG_RESULT([$XNEST])
|
||||
@@ -1181,7 +1183,7 @@ AC_MSG_RESULT([$XNEST])
|
||||
AM_CONDITIONAL(XNEST, [test "x$XNEST" = xyes])
|
||||
|
||||
if test "x$XNEST" = xyes; then
|
||||
- XNEST_LIBS="$CONFIG_LIB $FB_LIB $FIXES_LIB $XEXT_LIB $DBE_LIB $XTRAP_LIB $RECORD_LIB $GLX_LIBS $RENDER_LIB $RANDR_LIB $DAMAGE_LIB $MIEXT_DAMAGE_LIB $MIEXT_SHADOW_LIB $XI_LIB $XKB_LIB $XKB_STUB_LIB $COMPOSITE_LIB $XPSTUBS_LIB $CWRAP_LIB"
|
||||
+ XNEST_LIBS="$CONFIG_LIB $FB_LIB $FIXES_LIB $XEXT_LIB $DBE_LIB $XTRAP_LIB $RECORD_LIB $GLX_LIBS $RENDER_LIB $RANDR_LIB $DAMAGE_LIB $MIEXT_DAMAGE_LIB $MIEXT_SHADOW_LIB $XI_LIB $XKB_LIB $XKB_STUB_LIB $COMPOSITE_LIB $XPSTUBS_LIB $CWRAP_LIB $XSERVER_LIBS"
|
||||
- XNEST_LIBS="$FB_LIB $FIXES_LIB $MI_LIB $XEXT_LIB $DBE_LIB $XTRAP_LIB $RECORD_LIB $GLX_LIBS $RENDER_LIB $RANDR_LIB $DAMAGE_LIB $MIEXT_DAMAGE_LIB $MIEXT_SHADOW_LIB $XI_LIB $XKB_LIB $XKB_STUB_LIB $COMPOSITE_LIB $XPSTUBS_LIB $CWRAP_LIB $DIX_LIB $OS_LIB $CONFIG_LIB"
|
||||
+ XNEST_LIBS="$FB_LIB $FIXES_LIB $MI_LIB $XEXT_LIB $DBE_LIB $XTRAP_LIB $RECORD_LIB $GLX_LIBS $RENDER_LIB $RANDR_LIB $DAMAGE_LIB $MIEXT_DAMAGE_LIB $MIEXT_SHADOW_LIB $XI_LIB $XKB_LIB $XKB_STUB_LIB $COMPOSITE_LIB $XPSTUBS_LIB $CWRAP_LIB $DIX_LIB $OS_LIB $CONFIG_LIB $XSERVER_LIBS"
|
||||
XNEST_SYS_LIBS="$XNESTMODULES_LIBS"
|
||||
AC_SUBST([XNEST_LIBS])
|
||||
AC_SUBST([XNEST_SYS_LIBS])
|
||||
|
43
xserver-1.4.99-xephyr-dri.patch
Normal file
43
xserver-1.4.99-xephyr-dri.patch
Normal file
@ -0,0 +1,43 @@
|
||||
From 694c5c5528b13128cbd0857351d041a6c06e2607 Mon Sep 17 00:00:00 2001
|
||||
From: Adam Jackson <ajax@redhat.com>
|
||||
Date: Tue, 27 Nov 2007 15:14:20 -0500
|
||||
Subject: [PATCH] Ugly hack to fix xephyr dri.
|
||||
|
||||
---
|
||||
hw/kdrive/ephyr/XF86dri.c | 6 +++---
|
||||
1 files changed, 3 insertions(+), 3 deletions(-)
|
||||
|
||||
diff --git a/hw/kdrive/ephyr/XF86dri.c b/hw/kdrive/ephyr/XF86dri.c
|
||||
index c11da06..506d7be 100644
|
||||
--- a/hw/kdrive/ephyr/XF86dri.c
|
||||
+++ b/hw/kdrive/ephyr/XF86dri.c
|
||||
@@ -385,7 +385,7 @@ Bool XF86DRICreateContext(dpy, screen, visual, context, hHWContext)
|
||||
context, hHWContext );
|
||||
}
|
||||
|
||||
-Bool XF86DRIDestroyContext( __DRInativeDisplay * ndpy, int screen, __DRIid context)
|
||||
+GLboolean XF86DRIDestroyContext( __DRInativeDisplay * ndpy, int screen, __DRIid context)
|
||||
{
|
||||
Display * const dpy = (Display *) ndpy;
|
||||
XExtDisplayInfo *info = find_display (dpy);
|
||||
@@ -406,7 +406,7 @@ Bool XF86DRIDestroyContext( __DRInativeDisplay * ndpy, int screen, __DRIid conte
|
||||
return True;
|
||||
}
|
||||
|
||||
-Bool
|
||||
+GLboolean
|
||||
XF86DRICreateDrawable (__DRInativeDisplay * ndpy, int screen,
|
||||
__DRIid drawable, drm_drawable_t * hHWDrawable)
|
||||
{
|
||||
@@ -437,7 +437,7 @@ XF86DRICreateDrawable (__DRInativeDisplay * ndpy, int screen,
|
||||
return True;
|
||||
}
|
||||
|
||||
-Bool XF86DRIDestroyDrawable( __DRInativeDisplay * ndpy, int screen,
|
||||
+GLboolean XF86DRIDestroyDrawable( __DRInativeDisplay * ndpy, int screen,
|
||||
__DRIid drawable )
|
||||
{
|
||||
Display * const dpy = (Display *) ndpy;
|
||||
--
|
||||
1.5.3.4
|
||||
|
Loading…
Reference in New Issue
Block a user