* Mon Jan 12 2009 Peter Hutterer <peter.hutterer@redhat.com> 1.5.99.3-5
- rebase to today's server-1.6-enterleave branch, current 1.6 plus enterleave patches. - drop xserver-1.5.99.3-offscreen-pixmaps.patch - merged upstream - fix up git checkout in make-git-snapshot.sh to allow a remote branch to be specified as $1.
This commit is contained in:
parent
9c43ce8ec4
commit
66e1b5f9d0
@ -1 +1 @@
|
||||
xorg-server-20081222.tar.bz2
|
||||
xorg-server-20090112.tar.bz2
|
||||
|
2
commitid
2
commitid
@ -1 +1 @@
|
||||
32e81074b967716865aef08b66ec29caf0fec2c5
|
||||
02c059ea99a791b9e3643b4fb131af01306b1c23
|
||||
|
@ -8,7 +8,7 @@ cd $DIRNAME
|
||||
if [ -z "$1" ]; then
|
||||
git log | head -1
|
||||
else
|
||||
git checkout $1
|
||||
git checkout -b $1 origin/$1
|
||||
fi
|
||||
git log | head -1 | awk '{ print $2 }' > ../commitid
|
||||
git repack -a -d
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
45e1a7b1104de5044477901b4cb12e62 xorg-server-20081222.tar.bz2
|
||||
c3b4a1c33dae3aba6fd544c73bd4f6dc xorg-server-20090112.tar.bz2
|
||||
|
@ -14,12 +14,12 @@
|
||||
# Fix rhpxl to no longer need vesamodes/extramodes
|
||||
|
||||
%define pkgname xorg-server
|
||||
%define gitdate 20081222
|
||||
%define gitdate 20090112
|
||||
|
||||
Summary: X.Org X11 X server
|
||||
Name: xorg-x11-server
|
||||
Version: 1.5.99.3
|
||||
Release: 8%{?dist}
|
||||
Release: 9%{?dist}
|
||||
URL: http://www.x.org
|
||||
License: MIT
|
||||
Group: User Interface/X
|
||||
@ -75,7 +75,6 @@ Patch6002: xserver-1.5.1-mode-debug.patch
|
||||
Patch6004: xserver-1.5.99.3-dmx-xcalloc.patch
|
||||
# 6005 should be in 1.5.99.4
|
||||
Patch6005: xserver-1.5.99.3-ddx-rules.patch
|
||||
Patch6006: xserver-1.5.99.3-offscreen-pixmaps.patch
|
||||
# hack around broken mtrr.h. drop me as soon as possible.
|
||||
Patch6007: xserver-1.5.99.3-broken-mtrr-header.patch
|
||||
|
||||
@ -495,6 +494,13 @@ rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
|
||||
%changelog
|
||||
* Mon Jan 12 2009 Peter Hutterer <peter.hutterer@redhat.com> 1.5.99.3-5
|
||||
- rebase to today's server-1.6-enterleave branch, current 1.6 plus enterleave
|
||||
patches.
|
||||
- drop xserver-1.5.99.3-offscreen-pixmaps.patch - merged upstream
|
||||
- fix up git checkout in make-git-snapshot.sh to allow a remote branch to be
|
||||
specified as $1.
|
||||
|
||||
* Thu Jan 08 2009 Adam Jackson <ajax@redhat.com> 1.5.99.3-8
|
||||
- xserver-1.5.99.3-broken-mtrr-header.patch: Unbreak broken mtrr.h.
|
||||
|
||||
|
@ -1,13 +1,23 @@
|
||||
From 270e016f8d24ef4bd99f26084100581d2ea97a19 Mon Sep 17 00:00:00 2001
|
||||
From: Adam Tkac <atkac@redhat.com>
|
||||
Subject: Workaround for RH bug #449944
|
||||
Date: Mon, 12 Jan 2009 10:29:10 +1000
|
||||
Subject: [PATCH] Workaround for RH bug #449944
|
||||
|
||||
AC_C_BIGENDIAN macro in autoconf 2.62 is badly broken. See
|
||||
https://bugzilla.redhat.com/show_bug.cgi?id=449944 for more information.
|
||||
|
||||
diff -up xorg-server-20080612/configure.ac.endian xorg-server-20080612/configure.ac
|
||||
--- xorg-server-20080612/configure.ac.endian 2008-06-19 13:31:03.000000000 +0200
|
||||
+++ xorg-server-20080612/configure.ac 2008-06-19 13:42:27.000000000 +0200
|
||||
@@ -103,7 +103,6 @@ AC_CHECK_HEADERS([fcntl.h stdlib.h strin
|
||||
Forward-ported to 1.6 prerelease.
|
||||
---
|
||||
configure.ac | 10 +++++++++-
|
||||
include/dix-config.h.in | 8 ++++++++
|
||||
include/xorg-server.h.in | 8 ++++++++
|
||||
3 files changed, 25 insertions(+), 1 deletions(-)
|
||||
|
||||
diff --git a/configure.ac b/configure.ac
|
||||
index c222c95..e40a1a2 100644
|
||||
--- a/configure.ac
|
||||
+++ b/configure.ac
|
||||
@@ -103,7 +103,6 @@ AC_CHECK_HEADERS([fcntl.h stdlib.h string.h unistd.h])
|
||||
|
||||
dnl Checks for typedefs, structures, and compiler characteristics.
|
||||
AC_C_CONST
|
||||
@ -15,78 +25,60 @@ diff -up xorg-server-20080612/configure.ac.endian xorg-server-20080612/configure
|
||||
|
||||
AC_CHECK_SIZEOF([unsigned long])
|
||||
if test "$ac_cv_sizeof_unsigned_long" = 8; then
|
||||
@@ -1197,18 +1196,14 @@ AC_DEFINE([SVR4],1,[Define to 1 on syste
|
||||
@@ -1182,6 +1181,15 @@ AC_DEFINE([SVR4],1,[Define to 1 on systems derived from System V Release 4])
|
||||
AC_MSG_RESULT([yes])], AC_MSG_RESULT([no]))
|
||||
|
||||
XSERVER_CFLAGS="$XSERVER_CFLAGS $CORE_INCS $XEXT_INC $COMPOSITE_INC $DAMAGE_INC $FIXES_INC $XI_INC $MI_INC $MIEXT_SHADOW_INC $MIEXT_LAYER_INC $MIEXT_DAMAGE_INC $RENDER_INC $RANDR_INC $FB_INC"
|
||||
-AC_DEFINE_UNQUOTED(_X_BYTE_ORDER,[$ENDIAN],[Endian order])
|
||||
AH_VERBATIM([X_BYTE_ORDER],[
|
||||
-/* Deal with multiple architecture compiles on Mac OS X */
|
||||
-#ifndef __APPLE_CC__
|
||||
-#define X_BYTE_ORDER _X_BYTE_ORDER
|
||||
-#else
|
||||
+AH_VERBATIM([X_BYTE_ORDER],[
|
||||
+/* Define endian order */
|
||||
#ifdef __BIG_ENDIAN__
|
||||
-#define X_BYTE_ORDER X_BIG_ENDIAN
|
||||
+#ifdef __BIG_ENDIAN__
|
||||
+#define _X_BYTE_ORDER X_BIG_ENDIAN
|
||||
#else
|
||||
-#define X_BYTE_ORDER X_LITTLE_ENDIAN
|
||||
-#endif
|
||||
+#else
|
||||
+#define _X_BYTE_ORDER X_LITTLE_ENDIAN
|
||||
#endif
|
||||
+#endif
|
||||
+#define X_BYTE_ORDER _X_BYTE_ORDER
|
||||
])
|
||||
+])
|
||||
|
||||
dnl ---------------------------------------------------------------------------
|
||||
diff -up xorg-server-20080612/include/dix-config.h.in.endian xorg-server-20080612/include/dix-config.h.in
|
||||
--- xorg-server-20080612/include/dix-config.h.in.endian 2008-06-19 13:44:07.000000000 +0200
|
||||
+++ xorg-server-20080612/include/dix-config.h.in 2008-06-19 13:44:35.000000000 +0200
|
||||
@@ -445,18 +445,13 @@
|
||||
dnl DDX section.
|
||||
diff --git a/include/dix-config.h.in b/include/dix-config.h.in
|
||||
index 977bff3..a3ce66c 100644
|
||||
--- a/include/dix-config.h.in
|
||||
+++ b/include/dix-config.h.in
|
||||
@@ -363,6 +363,14 @@
|
||||
/* Vendor name */
|
||||
#undef XVENDORNAME
|
||||
|
||||
-/* Endian order */
|
||||
-#undef _X_BYTE_ORDER
|
||||
-/* Deal with multiple architecture compiles on Mac OS X */
|
||||
-#ifndef __APPLE_CC__
|
||||
-#define X_BYTE_ORDER _X_BYTE_ORDER
|
||||
-#else
|
||||
+/* Define endian order */
|
||||
#ifdef __BIG_ENDIAN__
|
||||
-#define X_BYTE_ORDER X_BIG_ENDIAN
|
||||
+#ifdef __BIG_ENDIAN__
|
||||
+#define _X_BYTE_ORDER X_BIG_ENDIAN
|
||||
#else
|
||||
-#define X_BYTE_ORDER X_LITTLE_ENDIAN
|
||||
-#endif
|
||||
+#else
|
||||
+#define _X_BYTE_ORDER X_LITTLE_ENDIAN
|
||||
#endif
|
||||
+#endif
|
||||
+#define X_BYTE_ORDER _X_BYTE_ORDER
|
||||
|
||||
+
|
||||
/* Enable GNU and other extensions to the C environment for GLIBC */
|
||||
#undef _GNU_SOURCE
|
||||
diff -up xorg-server-20080612/include/xorg-server.h.in.endian xorg-server-20080612/include/xorg-server.h.in
|
||||
--- xorg-server-20080612/include/xorg-server.h.in.endian 2008-06-19 13:44:41.000000000 +0200
|
||||
+++ xorg-server-20080612/include/xorg-server.h.in 2008-06-19 13:44:51.000000000 +0200
|
||||
@@ -178,18 +178,13 @@
|
||||
|
||||
diff --git a/include/xorg-server.h.in b/include/xorg-server.h.in
|
||||
index 4cf1bbf..f041c7c 100644
|
||||
--- a/include/xorg-server.h.in
|
||||
+++ b/include/xorg-server.h.in
|
||||
@@ -145,6 +145,14 @@
|
||||
/* Vendor name */
|
||||
#undef XVENDORNAME
|
||||
|
||||
-/* Endian order */
|
||||
-#undef _X_BYTE_ORDER
|
||||
-/* Deal with multiple architecture compiles on Mac OS X */
|
||||
-#ifndef __APPLE_CC__
|
||||
-#define X_BYTE_ORDER _X_BYTE_ORDER
|
||||
-#else
|
||||
+/* Define endian order */
|
||||
#ifdef __BIG_ENDIAN__
|
||||
-#define X_BYTE_ORDER X_BIG_ENDIAN
|
||||
+#ifdef __BIG_ENDIAN__
|
||||
+#define _X_BYTE_ORDER X_BIG_ENDIAN
|
||||
#else
|
||||
-#define X_BYTE_ORDER X_LITTLE_ENDIAN
|
||||
-#endif
|
||||
+#else
|
||||
+#define _X_BYTE_ORDER X_LITTLE_ENDIAN
|
||||
#endif
|
||||
+#endif
|
||||
+#define X_BYTE_ORDER _X_BYTE_ORDER
|
||||
|
||||
+
|
||||
/* BSD-compliant source */
|
||||
#undef _BSD_SOURCE
|
||||
|
||||
--
|
||||
1.6.0.6
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user