* Fri Nov 02 2007 Adam Jackson <ajax@redhat.com> 1.4.99.1-0.6

- Merge a bunch of the more trivial patches upstream.
- New git snapshot containing the merged bits.
- Remove unused patches.
- Drop the XFree86 obsoletes.
This commit is contained in:
Adam Jackson 2007-11-12 20:39:39 +00:00
parent f56a9fd2aa
commit 5fadc5e2d2
8 changed files with 107 additions and 21 deletions

View File

@ -1 +1 @@
xorg-server-20071031.tar.bz2
xorg-server-20071102.tar.bz2

1
commitid Normal file
View File

@ -0,0 +1 @@
7a0555e9bb59d02816803a1100f807d2d29f31d4

26
ddc-faster-plz.patch Normal file
View File

@ -0,0 +1,26 @@
From 2c53e4d6fcb16784548bd755827de1ee5ddddeb8 Mon Sep 17 00:00:00 2001
From: Adam Jackson <ajax@redhat.com>
Date: Thu, 8 Nov 2007 15:33:08 -0500
Subject: [PATCH] Speed up DDC probe.
---
hw/xfree86/ddc/xf86DDC.c | 3 +++
1 files changed, 3 insertions(+), 0 deletions(-)
diff --git a/hw/xfree86/ddc/xf86DDC.c b/hw/xfree86/ddc/xf86DDC.c
index e47b8b8..9d38aab 100644
--- a/hw/xfree86/ddc/xf86DDC.c
+++ b/hw/xfree86/ddc/xf86DDC.c
@@ -148,6 +148,9 @@ xf86DoEDID_DDC2(int scrnIndex, I2CBusPtr pBus)
if (noddc || noddc2)
return NULL;
+ if (!xf86I2CProbeAddress(pBus, 0xA1))
+ return NULL;
+
EDID_block = EDID1Read_DDC2(scrnIndex,pBus);
if (EDID_block){
--
1.5.3.4

17
make-git-snapshot.sh Executable file
View File

@ -0,0 +1,17 @@
#!/bin/sh
DIRNAME=xorg-server-$( date +%Y%m%d )
rm -rf $DIRNAME
git clone -n git://git.freedesktop.org/git/xorg/xserver $DIRNAME
cd $DIRNAME
if [ -z "$1" ]; then
git log | head -1
else
git checkout $1
fi
git log | head -1 | awk '{ print $2 }' > ../commitid
git repack -a -d
cd ..
tar jcf $DIRNAME.tar.bz2 $DIRNAME
rm -rf $DIRNAME

25
no-sleep-at-exit.patch Normal file
View File

@ -0,0 +1,25 @@
From a45daf5bf587c584b0b6f1e1a7e1f0d5c983cf4f Mon Sep 17 00:00:00 2001
From: Adam Jackson <ajax@redhat.com>
Date: Thu, 8 Nov 2007 17:25:36 -0500
Subject: [PATCH] Don't sleep(1) at server exit.
---
hw/xfree86/common/xf86Init.c | 2 +-
1 files changed, 1 insertions(+), 1 deletions(-)
diff --git a/hw/xfree86/common/xf86Init.c b/hw/xfree86/common/xf86Init.c
index 2f6e4dd..63df108 100644
--- a/hw/xfree86/common/xf86Init.c
+++ b/hw/xfree86/common/xf86Init.c
@@ -1307,7 +1307,7 @@ AbortDDX()
/*
* try to restore the original video state
*/
-#ifdef HAS_USL_VTS
+#if defined(HAS_USL_VTS) && !defined(linux)
/* Need the sleep when starting X from within another X session */
sleep(1);
#endif
--
1.5.3.4

27
pogo-stick.patch Normal file
View File

@ -0,0 +1,27 @@
From 5c62bc4a182f0e7810f442e418bb84cd964a7e22 Mon Sep 17 00:00:00 2001
From: Adam Jackson <ajax@redhat.com>
Date: Fri, 9 Nov 2007 13:55:32 -0500
Subject: [PATCH] Add -pogo option for init/teardown performance testing.
---
os/utils.c | 4 ++++
1 files changed, 4 insertions(+), 0 deletions(-)
diff --git a/os/utils.c b/os/utils.c
index 6fc1f7d..69803ae 100644
--- a/os/utils.c
+++ b/os/utils.c
@@ -941,6 +941,10 @@ ProcessCommandLine(int argc, char *argv[])
else
UseMsg();
}
+ else if (strcmp(argv[i], "-pogo") == 0)
+ {
+ dispatchException = DE_TERMINATE;
+ }
else if ( strcmp( argv[i], "-pn") == 0)
PartialNetwork = TRUE;
else if ( strcmp( argv[i], "-nopn") == 0)
--
1.5.3.4

View File

@ -1 +1 @@
730466f1d01714e40a1153cda0c15d25 xorg-server-20071031.tar.bz2
c2ebed7ea33f8795883c19b18397c2c7 xorg-server-20071102.tar.bz2

View File

@ -20,7 +20,7 @@
Summary: X.Org X11 X server
Name: xorg-x11-server
Version: 1.4.99.1
Release: 0.6%{?dist}
Release: 0.7%{?dist}
URL: http://www.x.org
License: MIT
Group: User Interface/X
@ -58,6 +58,11 @@ Patch2004: xserver-1.3.0-honor-displaysize.patch
Patch2007: xserver-1.3.0-randr12-config-hack.patch
Patch2013: xserver-1.3.0-document-fontpath-correctly.patch
# Trivial things to merge upstream at next rebase
Patch4000: ddc-faster-plz.patch
Patch4001: no-sleep-at-exit.patch
Patch4002: pogo-stick.patch
%define moduledir %{_libdir}/xorg/modules
%define drimoduledir %{_libdir}/dri
@ -78,10 +83,8 @@ Patch2013: xserver-1.3.0-document-fontpath-correctly.patch
%define kdrive --enable-kdrive --enable-xephyr --disable-xsdl --disable-xfake --disable-xfbdev --disable-kdrive-vesa
%define xservers --enable-xvfb --enable-xnest %{kdrive} %{enable_xorg} --enable-dmx
# FIXME: Temporary Build deps on autotools, as needed...
BuildRequires: automake autoconf libtool
BuildRequires: git pkgconfig
BuildRequires: git
BuildRequires: automake autoconf libtool pkgconfig
BuildRequires: xorg-x11-util-macros >= 1.1.5
BuildRequires: xorg-x11-proto-devel >= 7.1-11
@ -265,22 +268,12 @@ sed -i 's/git/&+ssh/' .git/config
git-init-db
%endif
# Apply all the patches.
# Apply all the patches. Hold your nose...
git-am -p1 $(awk '/^Patch.*:/ { print "../"$2 }' ../%{name}.spec)
%build
if [ -z "${SRSLY}" ]; then
# This is a work in progress. You probably do not want to build
# it locally. You definitely should not build it into Koji.
false
fi
%if %{fedora} == 7
%define default_font_path "unix/:7100,catalogue:/etc/X11/fontpath.d,built-ins"
%else
%define default_font_path "catalogue:/etc/X11/fontpath.d,built-ins"
%endif
# --with-rgb-path should be superfluous now ?
# --with-pie ?
@ -298,10 +291,8 @@ autoreconf -v --install || exit 1
--disable-xorgcfg \
--enable-install-libxf86config \
--with-mesa-source=%{_datadir}/mesa/source \
%if %{with_hw_servers}
--enable-dri \
--with-dri-driver-path=%{drimoduledir} \
%endif
${CONFIGURE}
make -s %{?_smp_mflags}
@ -411,7 +402,6 @@ rm -rf $RPM_BUILD_ROOT
%{_localstatedir}/lib/xkb/README.compiled
# XXX xf8_16bpp disappears with --disable-cfb, for no reason.
%if %{with_hw_servers}
%files Xorg
%defattr(-,root,root,-)