* Fri Nov 02 2007 Adam Jackson <ajax@redhat.com> 1.4.99.1-0.5
- New git snapshot that fixes Xdmx build. - Reenable Xdmx build. - Rebase (or drop) the rest of our patches outside the PCI code. - Add -common subpackage for shared files. - Rename -sdk to -devel for verisimilitude. - Simplify the %configure line a bit.
This commit is contained in:
parent
3941e59277
commit
494b014eed
3
Makefile
3
Makefile
@ -20,8 +20,11 @@ endif
|
|||||||
|
|
||||||
include $(MAKEFILE_COMMON)
|
include $(MAKEFILE_COMMON)
|
||||||
|
|
||||||
|
ifeq ($(MAKECMDGOALS),me a sandwich)
|
||||||
|
.PHONY :: me a sandwich
|
||||||
me a:
|
me a:
|
||||||
@:
|
@:
|
||||||
|
|
||||||
sandwich:
|
sandwich:
|
||||||
@[ `id -u` -ne 0 ] && echo "What? Make it yourself." || echo Okay.
|
@[ `id -u` -ne 0 ] && echo "What? Make it yourself." || echo Okay.
|
||||||
|
endif
|
||||||
|
@ -1,3 +1,8 @@
|
|||||||
|
From: Adam Jackson <ajax@redhat.com>
|
||||||
|
Date: Sun, 28 Oct 2007 09:37:52 +0100
|
||||||
|
Subject: [PATCH] Build libxf86config with -fPIC
|
||||||
|
|
||||||
|
---
|
||||||
--- xorg-server-1.0.1/hw/xfree86/parser/Makefile.am.xf86configfpic 2006-03-06 13:57:45.000000000 -0500
|
--- xorg-server-1.0.1/hw/xfree86/parser/Makefile.am.xf86configfpic 2006-03-06 13:57:45.000000000 -0500
|
||||||
+++ xorg-server-1.0.1/hw/xfree86/parser/Makefile.am 2006-03-06 13:59:11.000000000 -0500
|
+++ xorg-server-1.0.1/hw/xfree86/parser/Makefile.am 2006-03-06 13:59:11.000000000 -0500
|
||||||
@@ -23,7 +23,7 @@
|
@@ -23,7 +23,7 @@
|
||||||
|
@ -1,3 +1,7 @@
|
|||||||
|
From: Adam Jackson <ajax@redhat.com>
|
||||||
|
Date: Sun, 28 Oct 2007 09:37:52 +0100
|
||||||
|
Subject: [PATCH] Don't backfill windows with bg=none
|
||||||
|
|
||||||
Disable backfilling of windows created with bg=none, which otherwise
|
Disable backfilling of windows created with bg=none, which otherwise
|
||||||
would force a framebuffer readback.
|
would force a framebuffer readback.
|
||||||
|
|
||||||
@ -9,8 +13,9 @@ is fixed (which it is in upstream git as of
|
|||||||
|
|
||||||
f98dfec79dadb70fa7bba84e7335f92b3a73dc02
|
f98dfec79dadb70fa7bba84e7335f92b3a73dc02
|
||||||
|
|
||||||
--- ./composite/compalloc.c.spiffiffity 2006-03-13 16:59:55.000000000 -0500
|
---
|
||||||
+++ ./composite/compalloc.c 2006-04-12 16:37:50.000000000 -0400
|
--- a/composite/compalloc.c.spiffiffity 2006-03-13 16:59:55.000000000 -0500
|
||||||
|
+++ b/composite/compalloc.c 2006-04-12 16:37:50.000000000 -0400
|
||||||
@@ -478,6 +478,7 @@
|
@@ -478,6 +478,7 @@
|
||||||
* Copy bits from the parent into the new pixmap so that it will
|
* Copy bits from the parent into the new pixmap so that it will
|
||||||
* have "reasonable" contents in case for background None areas.
|
* have "reasonable" contents in case for background None areas.
|
||||||
|
@ -1,3 +1,8 @@
|
|||||||
|
From: Adam Jackson <ajax@redhat.com>
|
||||||
|
Date: Sun, 28 Oct 2007 09:37:52 +0100
|
||||||
|
Subject: [PATCH] Enable builtin font FPE.
|
||||||
|
|
||||||
|
---
|
||||||
--- ./dix/dixfonts.c.builtin-fonts 2006-09-06 16:45:20.000000000 -0400
|
--- ./dix/dixfonts.c.builtin-fonts 2006-09-06 16:45:20.000000000 -0400
|
||||||
+++ ./dix/dixfonts.c 2006-09-06 16:45:31.000000000 -0400
|
+++ ./dix/dixfonts.c 2006-09-06 16:45:31.000000000 -0400
|
||||||
@@ -1904,9 +1904,7 @@
|
@@ -1904,9 +1904,7 @@
|
||||||
|
@ -1,3 +1,8 @@
|
|||||||
|
From: Adam Jackson <ajax@redhat.com>
|
||||||
|
Date: Sun, 28 Oct 2007 09:37:52 +0100
|
||||||
|
Subject: [PATCH] Disable Composite in Xnest.
|
||||||
|
|
||||||
|
---
|
||||||
--- xorg-server-1.1.1/hw/xnest/Args.c.no-xnest-composite 2006-07-05 14:31:42.000000000 -0400
|
--- xorg-server-1.1.1/hw/xnest/Args.c.no-xnest-composite 2006-07-05 14:31:42.000000000 -0400
|
||||||
+++ xorg-server-1.1.1/hw/xnest/Args.c 2006-07-25 14:02:33.000000000 -0400
|
+++ xorg-server-1.1.1/hw/xnest/Args.c 2006-07-25 14:02:33.000000000 -0400
|
||||||
@@ -51,9 +51,12 @@
|
@@ -51,9 +51,12 @@
|
||||||
|
@ -1,3 +1,8 @@
|
|||||||
|
From: Adam Jackson <ajax@redhat.com>
|
||||||
|
Date: Sun, 28 Oct 2007 09:37:52 +0100
|
||||||
|
Subject: [PATCH] Enable the Composite extension by default
|
||||||
|
|
||||||
|
---
|
||||||
--- xorg-server-1.2.0/os/utils.c.enable-composite 2007-01-22 22:13:16.000000000 -0500
|
--- xorg-server-1.2.0/os/utils.c.enable-composite 2007-01-22 22:13:16.000000000 -0500
|
||||||
+++ xorg-server-1.2.0/os/utils.c 2007-01-23 12:26:04.000000000 -0500
|
+++ xorg-server-1.2.0/os/utils.c 2007-01-23 12:26:04.000000000 -0500
|
||||||
@@ -138,7 +138,7 @@
|
@@ -138,7 +138,7 @@
|
||||||
|
@ -15,12 +15,12 @@
|
|||||||
# RHEL5 bugfix sync
|
# RHEL5 bugfix sync
|
||||||
|
|
||||||
%define pkgname xorg-server
|
%define pkgname xorg-server
|
||||||
%define gitdate 20071031
|
%define gitdate 20071101
|
||||||
|
|
||||||
Summary: X.Org X11 X server
|
Summary: X.Org X11 X server
|
||||||
Name: xorg-x11-server
|
Name: xorg-x11-server
|
||||||
Version: 1.4.99.1
|
Version: 1.4.99.1
|
||||||
Release: 0.4%{?dist}
|
Release: 0.5%{?dist}
|
||||||
URL: http://www.x.org
|
URL: http://www.x.org
|
||||||
License: MIT
|
License: MIT
|
||||||
Group: User Interface/X
|
Group: User Interface/X
|
||||||
@ -45,44 +45,25 @@ Patch22: xserver-1.3.0-fbdevhw-magic-numbers.patch
|
|||||||
|
|
||||||
# OpenGL compositing manager feature/optimization patches.
|
# OpenGL compositing manager feature/optimization patches.
|
||||||
Patch100: xorg-x11-server-1.1.0-no-move-damage.patch
|
Patch100: xorg-x11-server-1.1.0-no-move-damage.patch
|
||||||
##Patch101: xorg-x11-server-1.1.0-dont-backfill-bg-none.patch
|
Patch101: xserver-1.4.99-dont-backfill-bg-none.patch
|
||||||
##Patch105: xorg-x11-server-1.2.0-enable-composite.patch
|
|
||||||
##Patch106: xorg-x11-server-1.1.1-no-composite-in-xnest.patch
|
|
||||||
#Patch108: xserver-1.3.0-no-pseudocolor-composite.patch
|
|
||||||
|
|
||||||
# Red Hat specific tweaking, not intended for upstream
|
# Red Hat specific tweaking, not intended for upstream
|
||||||
# XXX move these to the end of the list
|
# XXX move these to the end of the list
|
||||||
Patch1001: xorg-x11-server-Red-Hat-extramodes.patch
|
Patch1001: xorg-x11-server-Red-Hat-extramodes.patch
|
||||||
##Patch1003: xorg-x11-server-1.0.1-fpic-libxf86config.patch
|
Patch1003: xserver-1.4.99-pic-libxf86config.patch
|
||||||
Patch1004: xserver-1.4.99-selinux-awareness.patch
|
Patch1004: xserver-1.4.99-selinux-awareness.patch
|
||||||
##Patch1005: xorg-x11-server-1.1.1-builtin-fonts.patch
|
Patch1005: xserver-1.4.99-builtin-fonts.patch
|
||||||
##Patch1006: xorg-x11-server-1.1.1-no-scanpci.patch
|
|
||||||
#Patch1007: xorg-x11-server-1.1.1-spurious-libxf1bpp-link.patch
|
|
||||||
Patch1008: xorg-x11-server-1.2.0-xf86config-comment-less.patch
|
Patch1008: xorg-x11-server-1.2.0-xf86config-comment-less.patch
|
||||||
Patch1010: xserver-1.3.0-no-prerelease-warning.patch
|
Patch1010: xserver-1.3.0-no-prerelease-warning.patch
|
||||||
##Patch1011: xserver-1.3.0-composite-version.patch
|
Patch1014: xserver-1.4.99-xaa-evict-pixmaps.patch
|
||||||
#Patch1012: xserver-1.3.0-mesa7.patch
|
|
||||||
#Patch1013: xserver-1.3.0-exaupgrade.patch
|
|
||||||
##Patch1014: xserver-1.3.0-newglx-offscreen-pixmaps.patch
|
|
||||||
#Patch1015: xserver-1.3.0-randr-updates.patch
|
|
||||||
Patch1022: xserver-1.3.0-default-dpi.patch
|
Patch1022: xserver-1.3.0-default-dpi.patch
|
||||||
#Patch1023: xserver-1.3.0-randr-preferred-mode-fix.patch
|
|
||||||
Patch1024: xserver-1.3.0-avoid-ps2-probe.patch
|
Patch1024: xserver-1.3.0-avoid-ps2-probe.patch
|
||||||
|
|
||||||
##Patch2001: xserver-1.2.0-geode-mmx.patch
|
|
||||||
##Patch2002: xserver-1.2.0-xephyr-keysym-madness.patch
|
|
||||||
#Patch2003: xserver-1.2.0-vfprintf.patch
|
|
||||||
Patch2004: xserver-1.3.0-honor-displaysize.patch
|
Patch2004: xserver-1.3.0-honor-displaysize.patch
|
||||||
Patch2007: xserver-1.3.0-randr12-config-hack.patch
|
Patch2007: xserver-1.3.0-randr12-config-hack.patch
|
||||||
#Patch2008: xserver-1.3.0-randrama-no-zero-screens.patch
|
|
||||||
#Patch2009: xserver-1.3.0-arm-iopl.patch
|
|
||||||
#Patch2010: xserver-1.3.0-idletime.patch
|
|
||||||
#Patch2012: xserver-1.3.0-add-really-slow-bcopy.patch
|
|
||||||
Patch2013: xserver-1.3.0-document-fontpath-correctly.patch
|
Patch2013: xserver-1.3.0-document-fontpath-correctly.patch
|
||||||
#Patch2014: xserver-1.3.0-intel-by-default.patch
|
|
||||||
Patch2015: xserver-1.3.0-accidental-abi.patch
|
Patch2015: xserver-1.3.0-accidental-abi.patch
|
||||||
#Patch2016: xserver-1.3.0-xorg-conf-man-randr-update.patch
|
Patch2016: xserver-1.4.99-late-sigusr1.patch
|
||||||
#Patch2017: xserver-1.3.0-update-quirks.patch
|
|
||||||
|
|
||||||
# assorted PCI layer shenanigans. oh the pain.
|
# assorted PCI layer shenanigans. oh the pain.
|
||||||
##Patch2500: xorg-x11-server-1.2.99-unbreak-domain.patch
|
##Patch2500: xorg-x11-server-1.2.99-unbreak-domain.patch
|
||||||
@ -92,7 +73,6 @@ Patch2015: xserver-1.3.0-accidental-abi.patch
|
|||||||
##Patch2504: xserver-1.3.0-domain-obiwan.patch
|
##Patch2504: xserver-1.3.0-domain-obiwan.patch
|
||||||
##Patch2505: xserver-1.3.0-pci-device-enable.patch
|
##Patch2505: xserver-1.3.0-pci-device-enable.patch
|
||||||
|
|
||||||
#Patch9999: xserver-1.3.0-late-sigusr1.patch
|
|
||||||
|
|
||||||
%define moduledir %{_libdir}/xorg/modules
|
%define moduledir %{_libdir}/xorg/modules
|
||||||
%define drimoduledir %{_libdir}/dri
|
%define drimoduledir %{_libdir}/dri
|
||||||
@ -110,9 +90,8 @@ Patch2015: xserver-1.3.0-accidental-abi.patch
|
|||||||
%define enable_xorg --disable-xorg
|
%define enable_xorg --disable-xorg
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
# XXX reenable dmx
|
|
||||||
%define kdrive --enable-kdrive --enable-xephyr --disable-xsdl --disable-xfake --disable-xfbdev --disable-kdrive-vesa
|
%define kdrive --enable-kdrive --enable-xephyr --disable-xsdl --disable-xfake --disable-xfbdev --disable-kdrive-vesa
|
||||||
%define xservers --enable-xvfb --enable-xnest %{kdrive} --enable-xephyr --disable-dmx
|
%define xservers --enable-xvfb --enable-xnest %{kdrive} --enable-dmx
|
||||||
|
|
||||||
# FIXME: Temporary Build deps on autotools, as needed...
|
# FIXME: Temporary Build deps on autotools, as needed...
|
||||||
BuildRequires: automake autoconf libtool
|
BuildRequires: automake autoconf libtool
|
||||||
@ -167,6 +146,13 @@ Conflicts: mesa-libGL < 6.5.1-2.fc6
|
|||||||
%description
|
%description
|
||||||
X.Org X11 X server
|
X.Org X11 X server
|
||||||
|
|
||||||
|
%package common
|
||||||
|
Summary: Xorg server common files
|
||||||
|
Group: User Interface/X
|
||||||
|
|
||||||
|
%description common
|
||||||
|
Common files shared among all X servers.
|
||||||
|
|
||||||
%if %{with_hw_servers}
|
%if %{with_hw_servers}
|
||||||
%package Xorg
|
%package Xorg
|
||||||
Summary: Xorg X server
|
Summary: Xorg X server
|
||||||
@ -178,7 +164,7 @@ Requires: xorg-x11-drv-mouse xorg-x11-drv-keyboard xorg-x11-drv-vesa
|
|||||||
Requires: xorg-x11-drv-void xorg-x11-drv-evdev
|
Requires: xorg-x11-drv-void xorg-x11-drv-evdev
|
||||||
# virtuals. XXX fix the xkbcomp fork() upstream.
|
# virtuals. XXX fix the xkbcomp fork() upstream.
|
||||||
Requires: xkbdata xkbcomp
|
Requires: xkbdata xkbcomp
|
||||||
Obsoletes: XFree86 xorg-x11
|
Requires: xorg-x11-server-common >= %{version}-%{release}
|
||||||
# These drivers were dropped in F7 for being broken, so uninstall them.
|
# These drivers were dropped in F7 for being broken, so uninstall them.
|
||||||
Obsoletes: xorg-x11-drv-elo2300 <= 1.1.0-2.fc7
|
Obsoletes: xorg-x11-drv-elo2300 <= 1.1.0-2.fc7
|
||||||
Obsoletes: xorg-x11-drv-joystick <= 1.1.0-2.fc7
|
Obsoletes: xorg-x11-drv-joystick <= 1.1.0-2.fc7
|
||||||
@ -195,6 +181,7 @@ upon.
|
|||||||
Summary: A nested server.
|
Summary: A nested server.
|
||||||
Group: User Interface/X
|
Group: User Interface/X
|
||||||
Obsoletes: XFree86-Xnest, xorg-x11-Xnest
|
Obsoletes: XFree86-Xnest, xorg-x11-Xnest
|
||||||
|
Requires: xorg-x11-server-common >= %{version}-%{release}
|
||||||
Provides: Xnest
|
Provides: Xnest
|
||||||
|
|
||||||
%description Xnest
|
%description Xnest
|
||||||
@ -209,6 +196,7 @@ applications without running them on their real X server.
|
|||||||
Summary: Distributed Multihead X Server and utilities
|
Summary: Distributed Multihead X Server and utilities
|
||||||
Group: User Interface/X
|
Group: User Interface/X
|
||||||
Obsoletes: xorg-x11-Xdmx
|
Obsoletes: xorg-x11-Xdmx
|
||||||
|
Requires: xorg-x11-server-common >= %{version}-%{release}
|
||||||
Provides: Xdmx
|
Provides: Xdmx
|
||||||
|
|
||||||
%description Xdmx
|
%description Xdmx
|
||||||
@ -226,6 +214,7 @@ application for Xdmx would be to unify a 4 by 4 grid of 1280x1024 displays
|
|||||||
Summary: A X Windows System virtual framebuffer X server.
|
Summary: A X Windows System virtual framebuffer X server.
|
||||||
Group: User Interface/X
|
Group: User Interface/X
|
||||||
Obsoletes: XFree86-Xvfb xorg-x11-Xvfb
|
Obsoletes: XFree86-Xvfb xorg-x11-Xvfb
|
||||||
|
Requires: xorg-x11-server-common >= %{version}-%{release}
|
||||||
Provides: Xvfb
|
Provides: Xvfb
|
||||||
|
|
||||||
%description Xvfb
|
%description Xvfb
|
||||||
@ -239,6 +228,7 @@ is normally used for testing servers.
|
|||||||
%package Xephyr
|
%package Xephyr
|
||||||
Summary: A nested server.
|
Summary: A nested server.
|
||||||
Group: User Interface/X
|
Group: User Interface/X
|
||||||
|
Requires: xorg-x11-server-common >= %{version}-%{release}
|
||||||
Provides: Xephyr
|
Provides: Xephyr
|
||||||
|
|
||||||
%description Xephyr
|
%description Xephyr
|
||||||
@ -253,17 +243,19 @@ Render and Composite.
|
|||||||
|
|
||||||
|
|
||||||
%if %{with_hw_servers}
|
%if %{with_hw_servers}
|
||||||
%package sdk
|
%package devel
|
||||||
Summary: SDK for X server driver module development
|
Summary: SDK for X server driver module development
|
||||||
Group: User Interface/X
|
Group: User Interface/X
|
||||||
Obsoletes: XFree86-sdk xorg-x11-sdk
|
Obsoletes: XFree86-sdk xorg-x11-sdk xorg-x11-server-sdk
|
||||||
Requires: xorg-x11-util-macros
|
Requires: xorg-x11-util-macros
|
||||||
Requires: xorg-x11-proto-devel
|
Requires: xorg-x11-proto-devel
|
||||||
Requires: pkgconfig
|
Requires: pkgconfig
|
||||||
Requires(pre): xorg-x11-filesystem >= 0.99.2-3
|
Requires(pre): xorg-x11-filesystem >= 0.99.2-3
|
||||||
Provides: libxf86config-devel = %{version}-%{release}
|
Provides: libxf86config-devel = %{version}-%{release}
|
||||||
|
# Virtual provide for transition. Delete me someday.
|
||||||
|
Provides: xorg-x11-server-sdk = %{version}-%{release}
|
||||||
|
|
||||||
%description sdk
|
%description devel
|
||||||
The SDK package provides the developmental files which are necessary for
|
The SDK package provides the developmental files which are necessary for
|
||||||
developing X server driver modules, and for compiling driver modules
|
developing X server driver modules, and for compiling driver modules
|
||||||
outside of the standard X11 source code tree. Developers writing video
|
outside of the standard X11 source code tree. Developers writing video
|
||||||
@ -313,10 +305,6 @@ autoreconf -v --install || exit 1
|
|||||||
--disable-static \
|
--disable-static \
|
||||||
--with-pic \
|
--with-pic \
|
||||||
--disable-{a,c,m}fb \
|
--disable-{a,c,m}fb \
|
||||||
--enable-composite \
|
|
||||||
--enable-xtrap \
|
|
||||||
--enable-xcsecurity \
|
|
||||||
--enable-xevie \
|
|
||||||
--with-int10=x86emu \
|
--with-int10=x86emu \
|
||||||
--with-default-font-path=%{default_font_path} \
|
--with-default-font-path=%{default_font_path} \
|
||||||
--with-module-dir=%{moduledir} \
|
--with-module-dir=%{moduledir} \
|
||||||
@ -378,18 +366,15 @@ xargs tar cf - | (cd %{inst_srcdir} && tar xf -)
|
|||||||
rm -f $RPM_BUILD_ROOT%{_bindir}/out?
|
rm -f $RPM_BUILD_ROOT%{_bindir}/out?
|
||||||
rm -f $RPM_BUILD_ROOT%{_bindir}/pcitweak
|
rm -f $RPM_BUILD_ROOT%{_bindir}/pcitweak
|
||||||
rm -f $RPM_BUILD_ROOT%{_mandir}/man1/pcitweak.1*
|
rm -f $RPM_BUILD_ROOT%{_mandir}/man1/pcitweak.1*
|
||||||
rm -f $RPM_BUILD_ROOT%{_mandir}/man5/SecurityPolicy.5*
|
|
||||||
find $RPM_BUILD_ROOT -type f -name '*.la' | xargs rm -f -- || :
|
find $RPM_BUILD_ROOT -type f -name '*.la' | xargs rm -f -- || :
|
||||||
|
|
||||||
%ifarch s390 s390x
|
%if !%{with_hw_servers}
|
||||||
# FIXME: The following files get installed on s390/s390x and we don't
|
# These get installed regardless of whether you're building Xorg.
|
||||||
# want some of them on s390 at all, and others should be in a -common
|
# XXX Re-check this list.
|
||||||
# subpackage, but it's not worth doing that for 3 files right now.
|
|
||||||
# error: Installed (but unpackaged) file(s) found:
|
# error: Installed (but unpackaged) file(s) found:
|
||||||
# /randrstr.h
|
# /randrstr.h
|
||||||
# /usr/lib/pkgconfig/xorg-server.pc
|
# /usr/lib/pkgconfig/xorg-server.pc
|
||||||
# /usr/share/aclocal/xorg-server.m4
|
# /usr/share/aclocal/xorg-server.m4
|
||||||
# /usr/share/man/man1/Xserver.1x.gz
|
|
||||||
# /var/lib/xkb/README.compiled
|
# /var/lib/xkb/README.compiled
|
||||||
|
|
||||||
rm -f $RPM_BUILD_ROOT/randrstr.h
|
rm -f $RPM_BUILD_ROOT/randrstr.h
|
||||||
@ -432,8 +417,15 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
} &> /dev/null || :
|
} &> /dev/null || :
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
# The Xserver.1 manpage is intentionally present in multiple subpackages.
|
%files common
|
||||||
# It could reasonably form part of a -common subpackage though.
|
%defattr(-,root,root,-)
|
||||||
|
%{_mandir}/man1/Xserver.1*
|
||||||
|
%{_mandir}/man5/SecurityPolicy.5*
|
||||||
|
%dir %{_libdir}/xserver
|
||||||
|
%{_libdir}/xserver/SecurityPolicy
|
||||||
|
%dir %{_localstatedir}/lib/xkb
|
||||||
|
%{_localstatedir}/lib/xkb/README.compiled
|
||||||
|
|
||||||
|
|
||||||
# XXX xf8_16bpp disappears with --disable-cfb, for no reason.
|
# XXX xf8_16bpp disappears with --disable-cfb, for no reason.
|
||||||
%if %{with_hw_servers}
|
%if %{with_hw_servers}
|
||||||
@ -479,17 +471,12 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{_libdir}/xorg/modules/libvgahw.so
|
%{_libdir}/xorg/modules/libvgahw.so
|
||||||
%{_libdir}/xorg/modules/libwfb.so
|
%{_libdir}/xorg/modules/libwfb.so
|
||||||
%{_libdir}/xorg/modules/libxaa.so
|
%{_libdir}/xorg/modules/libxaa.so
|
||||||
%dir %{_libdir}/xserver
|
|
||||||
%{_libdir}/xserver/SecurityPolicy
|
|
||||||
%{_mandir}/man1/gtf.1*
|
%{_mandir}/man1/gtf.1*
|
||||||
%{_mandir}/man1/Xorg.1*
|
%{_mandir}/man1/Xorg.1*
|
||||||
%{_mandir}/man1/Xserver.1*
|
|
||||||
%{_mandir}/man1/cvt.1*
|
%{_mandir}/man1/cvt.1*
|
||||||
%{_mandir}/man4/fbdevhw.4*
|
%{_mandir}/man4/fbdevhw.4*
|
||||||
%{_mandir}/man4/exa.4*
|
%{_mandir}/man4/exa.4*
|
||||||
%{_mandir}/man5/xorg.conf.5*
|
%{_mandir}/man5/xorg.conf.5*
|
||||||
%dir %{_localstatedir}/lib/xkb
|
|
||||||
%{_localstatedir}/lib/xkb/README.compiled
|
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
|
|
||||||
@ -497,7 +484,6 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%defattr(-,root,root,-)
|
%defattr(-,root,root,-)
|
||||||
%{_bindir}/Xnest
|
%{_bindir}/Xnest
|
||||||
%{_mandir}/man1/Xnest.1*
|
%{_mandir}/man1/Xnest.1*
|
||||||
%{_mandir}/man1/Xserver.1*
|
|
||||||
|
|
||||||
|
|
||||||
%files Xdmx
|
%files Xdmx
|
||||||
@ -518,28 +504,21 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{_mandir}/man1/dmxtodmx.1*
|
%{_mandir}/man1/dmxtodmx.1*
|
||||||
%{_mandir}/man1/vdltodmx.1*
|
%{_mandir}/man1/vdltodmx.1*
|
||||||
%{_mandir}/man1/xdmxconfig.1*
|
%{_mandir}/man1/xdmxconfig.1*
|
||||||
%{_mandir}/man1/Xserver.1*
|
|
||||||
|
|
||||||
|
|
||||||
%files Xvfb
|
%files Xvfb
|
||||||
%defattr(-,root,root,-)
|
%defattr(-,root,root,-)
|
||||||
%{_bindir}/Xvfb
|
%{_bindir}/Xvfb
|
||||||
%{_mandir}/man1/Xvfb.1*
|
%{_mandir}/man1/Xvfb.1*
|
||||||
%{_mandir}/man1/Xserver.1*
|
|
||||||
%if !%{with_hw_servers}
|
|
||||||
%dir %{_libdir}/xserver
|
|
||||||
%{_libdir}/xserver/SecurityPolicy
|
|
||||||
%endif
|
|
||||||
|
|
||||||
|
|
||||||
%files Xephyr
|
%files Xephyr
|
||||||
%defattr(-,root,root,-)
|
%defattr(-,root,root,-)
|
||||||
%{_bindir}/Xephyr
|
%{_bindir}/Xephyr
|
||||||
%{_mandir}/man1/Xserver.1*
|
|
||||||
|
|
||||||
|
|
||||||
%if %{with_hw_servers}
|
%if %{with_hw_servers}
|
||||||
%files sdk
|
%files devel
|
||||||
%defattr(-,root,root,-)
|
%defattr(-,root,root,-)
|
||||||
%{_libdir}/libxf86config.a
|
%{_libdir}/libxf86config.a
|
||||||
%{_libdir}/pkgconfig/xorg-server.pc
|
%{_libdir}/pkgconfig/xorg-server.pc
|
||||||
@ -548,12 +527,21 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
%{_datadir}/aclocal/xorg-server.m4
|
%{_datadir}/aclocal/xorg-server.m4
|
||||||
%endif
|
%endif
|
||||||
|
|
||||||
|
|
||||||
%files source
|
%files source
|
||||||
%defattr(-, root, root, -)
|
%defattr(-, root, root, -)
|
||||||
%{xserver_source_dir}
|
%{xserver_source_dir}
|
||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Fri Nov 02 2007 Adam Jackson <ajax@redhat.com> 1.4.99.1-0.5
|
||||||
|
- New git snapshot that fixes Xdmx build.
|
||||||
|
- Reenable Xdmx build.
|
||||||
|
- Rebase (or drop) the rest of our patches outside the PCI code.
|
||||||
|
- Add -common subpackage for shared files.
|
||||||
|
- Rename -sdk to -devel for verisimilitude.
|
||||||
|
- Simplify the %%configure line a bit.
|
||||||
|
|
||||||
* Thu Nov 01 2007 Adam Jackson <ajax@redhat.com> 1.4.99.1-0.4
|
* Thu Nov 01 2007 Adam Jackson <ajax@redhat.com> 1.4.99.1-0.4
|
||||||
- Update mesa and libdrm buildreqs.
|
- Update mesa and libdrm buildreqs.
|
||||||
- Reenable Xephyr build.
|
- Reenable Xephyr build.
|
||||||
|
@ -1,3 +1,8 @@
|
|||||||
|
From: Adam Jackson <ajax@redhat.com>
|
||||||
|
Date: Sun, 28 Oct 2007 09:37:52 +0100
|
||||||
|
Subject: [PATCH] Fix MMX detection for AMD Geode processors.
|
||||||
|
|
||||||
|
---
|
||||||
--- a/fb/fbpict.c
|
--- a/fb/fbpict.c
|
||||||
+++ a/fb/fbpict.c
|
+++ a/fb/fbpict.c
|
||||||
@@ -1516,7 +1516,9 @@ static unsigned int detectCPUFeatures(void) {
|
@@ -1516,7 +1516,9 @@ static unsigned int detectCPUFeatures(void) {
|
||||||
|
@ -1,3 +1,8 @@
|
|||||||
|
From: Adam Jackson <ajax@redhat.com>
|
||||||
|
Date: Sun, 28 Oct 2007 09:37:52 +0100
|
||||||
|
Subject: [PATCH] Fix keysym typedef in Xephyr.
|
||||||
|
|
||||||
|
---
|
||||||
--- xorg-server-1.2.0/hw/kdrive/ephyr/hostx.c.xephyr-keysym 2007-01-22 22:13:14.000000000 -0500
|
--- xorg-server-1.2.0/hw/kdrive/ephyr/hostx.c.xephyr-keysym 2007-01-22 22:13:14.000000000 -0500
|
||||||
+++ xorg-server-1.2.0/hw/kdrive/ephyr/hostx.c 2007-01-29 17:58:00.000000000 -0500
|
+++ xorg-server-1.2.0/hw/kdrive/ephyr/hostx.c 2007-01-29 17:58:00.000000000 -0500
|
||||||
@@ -77,9 +77,10 @@
|
@@ -77,9 +77,10 @@
|
||||||
|
@ -1,3 +1,16 @@
|
|||||||
|
From: Adam Jackson <ajax@redhat.com>
|
||||||
|
Date: Sun, 28 Oct 2007 09:37:52 +0100
|
||||||
|
Subject: [PATCH] Move SIGUSR1 notification as late as possible.
|
||||||
|
|
||||||
|
If we inherited a signal mask from the parent process that ignores SIGUSR1,
|
||||||
|
then we will send SIGUSR1 to the parent to indicate when we're ready to
|
||||||
|
accept connections. Unfortunately, we send this notification way too
|
||||||
|
early, right after creating the sockets rather than just before entering
|
||||||
|
the main loop.
|
||||||
|
|
||||||
|
Move it to just before Dispatch() so we're not lying quite so much.
|
||||||
|
|
||||||
|
---
|
||||||
diff -up xorg-server-1.3.0.0/dix/main.c.jx xorg-server-1.3.0.0/dix/main.c
|
diff -up xorg-server-1.3.0.0/dix/main.c.jx xorg-server-1.3.0.0/dix/main.c
|
||||||
--- xorg-server-1.3.0.0/dix/main.c.jx 2006-11-16 13:01:23.000000000 -0500
|
--- xorg-server-1.3.0.0/dix/main.c.jx 2006-11-16 13:01:23.000000000 -0500
|
||||||
+++ xorg-server-1.3.0.0/dix/main.c 2007-10-15 14:37:13.000000000 -0400
|
+++ xorg-server-1.3.0.0/dix/main.c 2007-10-15 14:37:13.000000000 -0400
|
||||||
|
Loading…
Reference in New Issue
Block a user