* Wed Mar 12 2008 Adam Jackson <ajax@redhat.com> 1.4.99.901-5.20080310
- xserver-1.5.0-unselinux.patch: Disable selinux extension for now. - xserver-1.5.0-ia64.patch: Fix ia64 PCI support. (#429878)
This commit is contained in:
parent
ef7113ffa0
commit
06d6788684
@ -20,7 +20,7 @@
|
|||||||
Summary: X.Org X11 X server
|
Summary: X.Org X11 X server
|
||||||
Name: xorg-x11-server
|
Name: xorg-x11-server
|
||||||
Version: 1.4.99.901
|
Version: 1.4.99.901
|
||||||
Release: 4.%{gitdate}%{?dist}
|
Release: 5.%{gitdate}%{?dist}
|
||||||
URL: http://www.x.org
|
URL: http://www.x.org
|
||||||
License: MIT
|
License: MIT
|
||||||
Group: User Interface/X
|
Group: User Interface/X
|
||||||
@ -61,6 +61,9 @@ Patch5001: xserver-1.4.99-alloca-poison.patch
|
|||||||
Patch5002: xserver-1.4.99-ssh-isnt-local.patch
|
Patch5002: xserver-1.4.99-ssh-isnt-local.patch
|
||||||
|
|
||||||
Patch5003: xserver-1.5.0-x86emu.patch
|
Patch5003: xserver-1.5.0-x86emu.patch
|
||||||
|
Patch5004: xserver-1.5.0-wfs.patch
|
||||||
|
Patch5005: xserver-1.5.0-unselinux.patch
|
||||||
|
Patch5006: xserver-1.5.0-ia64.patch
|
||||||
|
|
||||||
%define moduledir %{_libdir}/xorg/modules
|
%define moduledir %{_libdir}/xorg/modules
|
||||||
%define drimoduledir %{_libdir}/dri
|
%define drimoduledir %{_libdir}/dri
|
||||||
@ -509,6 +512,10 @@ rm -rf $RPM_BUILD_ROOT
|
|||||||
|
|
||||||
|
|
||||||
%changelog
|
%changelog
|
||||||
|
* Wed Mar 12 2008 Adam Jackson <ajax@redhat.com> 1.4.99.901-5.20080310
|
||||||
|
- xserver-1.5.0-unselinux.patch: Disable selinux extension for now.
|
||||||
|
- xserver-1.5.0-ia64.patch: Fix ia64 PCI support. (#429878)
|
||||||
|
|
||||||
* Tue Mar 11 2008 Kristian Høgsberg <krh@redhat.com> 1.4.99.901-4.20080310
|
* Tue Mar 11 2008 Kristian Høgsberg <krh@redhat.com> 1.4.99.901-4.20080310
|
||||||
- Checkout the tip of the git snapshot so we get the most recent DRI2
|
- Checkout the tip of the git snapshot so we get the most recent DRI2
|
||||||
texture from pixmap changes in the build. Bump mesa build requires.
|
texture from pixmap changes in the build. Bump mesa build requires.
|
||||||
|
137
xserver-1.5.0-ia64.patch
Normal file
137
xserver-1.5.0-ia64.patch
Normal file
@ -0,0 +1,137 @@
|
|||||||
|
From 9053cba9d766be78d150226aa4adf61e5a6717d2 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Adam Jackson <ajax@benzedrine.nwnk.net>
|
||||||
|
Date: Wed, 12 Mar 2008 19:52:50 -0400
|
||||||
|
Subject: [PATCH] Fix ia64 PCI support.
|
||||||
|
|
||||||
|
---
|
||||||
|
hw/xfree86/os-support/bus/Makefile.am | 12 -------
|
||||||
|
hw/xfree86/os-support/bus/Pci.h | 3 +-
|
||||||
|
hw/xfree86/os-support/linux/Makefile.am | 2 +-
|
||||||
|
hw/xfree86/os-support/shared/ia64Pci.c | 55 -------------------------------
|
||||||
|
4 files changed, 2 insertions(+), 70 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/hw/xfree86/os-support/bus/Makefile.am b/hw/xfree86/os-support/bus/Makefile.am
|
||||||
|
index 381b992..5a15430 100644
|
||||||
|
--- a/hw/xfree86/os-support/bus/Makefile.am
|
||||||
|
+++ b/hw/xfree86/os-support/bus/Makefile.am
|
||||||
|
@@ -27,18 +27,6 @@ if LINUX_ALPHA
|
||||||
|
PCI_SOURCES += axpPci.c
|
||||||
|
endif
|
||||||
|
|
||||||
|
-if LINUX_IA64
|
||||||
|
-PLATFORM_PCI_SOURCES = \
|
||||||
|
- 460gxPCI.c \
|
||||||
|
- 460gxPCI.h \
|
||||||
|
- altixPCI.c \
|
||||||
|
- altixPCI.h \
|
||||||
|
- e8870PCI.c \
|
||||||
|
- e8870PCI.h \
|
||||||
|
- zx1PCI.c \
|
||||||
|
- zx1PCI.h
|
||||||
|
-endif
|
||||||
|
-
|
||||||
|
if XORG_BUS_SPARC
|
||||||
|
PLATFORM_SOURCES = Sbus.c
|
||||||
|
sdk_HEADERS += xf86Sbus.h
|
||||||
|
diff --git a/hw/xfree86/os-support/bus/Pci.h b/hw/xfree86/os-support/bus/Pci.h
|
||||||
|
index 0abb34f..ebac090 100644
|
||||||
|
--- a/hw/xfree86/os-support/bus/Pci.h
|
||||||
|
+++ b/hw/xfree86/os-support/bus/Pci.h
|
||||||
|
@@ -207,9 +207,8 @@
|
||||||
|
# endif
|
||||||
|
#elif defined(__ia64__)
|
||||||
|
# if defined(linux)
|
||||||
|
-# define ARCH_PCI_INIT ia64linuxPciInit
|
||||||
|
+# define ARCH_PCI_INIT linuxPciInit
|
||||||
|
# endif
|
||||||
|
-# define XF86SCANPCI_WRAPPER ia64ScanPCIWrapper
|
||||||
|
#elif defined(__i386__) || defined(__i386)
|
||||||
|
# if defined(linux)
|
||||||
|
# define ARCH_PCI_INIT linuxPciInit
|
||||||
|
diff --git a/hw/xfree86/os-support/linux/Makefile.am b/hw/xfree86/os-support/linux/Makefile.am
|
||||||
|
index 5a52ffd..beaae3d 100644
|
||||||
|
--- a/hw/xfree86/os-support/linux/Makefile.am
|
||||||
|
+++ b/hw/xfree86/os-support/linux/Makefile.am
|
||||||
|
@@ -1,7 +1,7 @@
|
||||||
|
noinst_LTLIBRARIES = liblinux.la
|
||||||
|
|
||||||
|
if LINUX_IA64
|
||||||
|
-PLATFORM_PCI_SUPPORT = $(srcdir)/lnx_ia64.c $(srcdir)/../shared/ia64Pci.c
|
||||||
|
+PLATFORM_PCI_SUPPORT = $(srcdir)/../shared/ia64Pci.c
|
||||||
|
PLATFORM_DEFINES = -DOS_PROBE_PCI_CHIPSET=lnxProbePciChipset
|
||||||
|
PLATFORM_INCLUDES = -I$(srcdir)/../shared
|
||||||
|
endif
|
||||||
|
diff --git a/hw/xfree86/os-support/shared/ia64Pci.c b/hw/xfree86/os-support/shared/ia64Pci.c
|
||||||
|
index 45522e9..6f6924b 100644
|
||||||
|
--- a/hw/xfree86/os-support/shared/ia64Pci.c
|
||||||
|
+++ b/hw/xfree86/os-support/shared/ia64Pci.c
|
||||||
|
@@ -42,12 +42,7 @@
|
||||||
|
#include <linux/pci.h>
|
||||||
|
|
||||||
|
#include "compiler.h"
|
||||||
|
-#include "460gxPCI.h"
|
||||||
|
-#include "e8870PCI.h"
|
||||||
|
-#include "zx1PCI.h"
|
||||||
|
-#include "altixPCI.h"
|
||||||
|
#include "Pci.h"
|
||||||
|
-#include "ia64Pci.h"
|
||||||
|
|
||||||
|
/*
|
||||||
|
* We use special in/out routines here since Altix platforms require the
|
||||||
|
@@ -191,53 +186,3 @@ _X_EXPORT unsigned int inl(unsigned long port)
|
||||||
|
return val;
|
||||||
|
}
|
||||||
|
|
||||||
|
-void
|
||||||
|
-ia64ScanPCIWrapper(scanpciWrapperOpt flags)
|
||||||
|
-{
|
||||||
|
- static IA64Chipset chipset = NONE_CHIPSET;
|
||||||
|
-
|
||||||
|
- if (flags == SCANPCI_INIT) {
|
||||||
|
-
|
||||||
|
- /* PCI configuration space probes should be done first */
|
||||||
|
- if (xorgProbe460GX(flags)) {
|
||||||
|
- chipset = I460GX_CHIPSET;
|
||||||
|
- xf86PreScan460GX();
|
||||||
|
- return;
|
||||||
|
- } else if (xorgProbeE8870(flags)) {
|
||||||
|
- chipset = E8870_CHIPSET;
|
||||||
|
- xf86PreScanE8870();
|
||||||
|
- return;
|
||||||
|
- }
|
||||||
|
-#ifdef OS_PROBE_PCI_CHIPSET
|
||||||
|
- chipset = OS_PROBE_PCI_CHIPSET(flags);
|
||||||
|
- switch (chipset) {
|
||||||
|
- case ZX1_CHIPSET:
|
||||||
|
- xf86PreScanZX1();
|
||||||
|
- return;
|
||||||
|
- case ALTIX_CHIPSET:
|
||||||
|
- xf86PreScanAltix();
|
||||||
|
- return;
|
||||||
|
- default:
|
||||||
|
- return;
|
||||||
|
- }
|
||||||
|
-#endif
|
||||||
|
- } else /* if (flags == SCANPCI_TERM) */ {
|
||||||
|
-
|
||||||
|
- switch (chipset) {
|
||||||
|
- case I460GX_CHIPSET:
|
||||||
|
- xf86PostScan460GX();
|
||||||
|
- return;
|
||||||
|
- case E8870_CHIPSET:
|
||||||
|
- xf86PostScanE8870();
|
||||||
|
- return;
|
||||||
|
- case ZX1_CHIPSET:
|
||||||
|
- xf86PostScanZX1();
|
||||||
|
- return;
|
||||||
|
- case ALTIX_CHIPSET:
|
||||||
|
- xf86PostScanAltix();
|
||||||
|
- return;
|
||||||
|
- default:
|
||||||
|
- return;
|
||||||
|
- }
|
||||||
|
- }
|
||||||
|
-}
|
||||||
|
--
|
||||||
|
1.5.4.3
|
||||||
|
|
27
xserver-1.5.0-unselinux.patch
Normal file
27
xserver-1.5.0-unselinux.patch
Normal file
@ -0,0 +1,27 @@
|
|||||||
|
From 39ac27c473816c66faa43ae00b4fd34b6688ff12 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Adam Jackson <ajax@benzedrine.nwnk.net>
|
||||||
|
Date: Wed, 12 Mar 2008 19:33:37 -0400
|
||||||
|
Subject: [PATCH] Disable the selinux extension for now.
|
||||||
|
|
||||||
|
We'll still build the infrastructure but not turn on the extension. This
|
||||||
|
wants a better solution, please don't ship me like this.
|
||||||
|
---
|
||||||
|
hw/xfree86/dixmods/extmod/modinit.c | 2 +-
|
||||||
|
1 files changed, 1 insertions(+), 1 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/hw/xfree86/dixmods/extmod/modinit.c b/hw/xfree86/dixmods/extmod/modinit.c
|
||||||
|
index d0d892a..5fa5456 100644
|
||||||
|
--- a/hw/xfree86/dixmods/extmod/modinit.c
|
||||||
|
+++ b/hw/xfree86/dixmods/extmod/modinit.c
|
||||||
|
@@ -38,7 +38,7 @@ static MODULESETUPPROTO(extmodSetup);
|
||||||
|
* Array describing extensions to be initialized
|
||||||
|
*/
|
||||||
|
static ExtensionModule extensionModules[] = {
|
||||||
|
-#ifdef XSELINUX
|
||||||
|
+#if 0
|
||||||
|
{
|
||||||
|
SELinuxExtensionInit,
|
||||||
|
SELINUX_EXTENSION_NAME,
|
||||||
|
--
|
||||||
|
1.5.4.3
|
||||||
|
|
30
xserver-1.5.0-wfs.patch
Normal file
30
xserver-1.5.0-wfs.patch
Normal file
@ -0,0 +1,30 @@
|
|||||||
|
From 2939645164d6825f571c83c419e3ec61a7dc6279 Mon Sep 17 00:00:00 2001
|
||||||
|
From: Adam Jackson <ajax@benzedrine.nwnk.net>
|
||||||
|
Date: Wed, 12 Mar 2008 19:21:08 -0400
|
||||||
|
Subject: [PATCH] Additional input readiness check in WaitForSomething.
|
||||||
|
|
||||||
|
---
|
||||||
|
os/WaitFor.c | 2 --
|
||||||
|
1 files changed, 0 insertions(+), 2 deletions(-)
|
||||||
|
|
||||||
|
diff --git a/os/WaitFor.c b/os/WaitFor.c
|
||||||
|
index 36e01ca..0203d6e 100644
|
||||||
|
--- a/os/WaitFor.c
|
||||||
|
+++ b/os/WaitFor.c
|
||||||
|
@@ -332,13 +332,11 @@ WaitForSomething(int *pClientsReady)
|
||||||
|
|
||||||
|
if (XFD_ANYSET (&devicesReadable) || XFD_ANYSET (&clientsReadable))
|
||||||
|
break;
|
||||||
|
-#ifdef WIN32
|
||||||
|
/* Windows keyboard and mouse events are added to the input queue
|
||||||
|
in Block- and WakupHandlers. There is no device to check if
|
||||||
|
data is ready. So check here if new input is available */
|
||||||
|
if (*checkForInput[0] != *checkForInput[1])
|
||||||
|
return 0;
|
||||||
|
-#endif
|
||||||
|
}
|
||||||
|
}
|
||||||
|
|
||||||
|
--
|
||||||
|
1.5.4.3
|
||||||
|
|
Loading…
Reference in New Issue
Block a user