Prune obsolete/unused utilities (#1954355)

Clean up the .gitignore file

Resolves: rhbz#1954355
This commit is contained in:
Peter Hutterer 2021-05-04 12:58:34 +10:00
parent 09dc36229d
commit 1d42ba4cef
4 changed files with 29 additions and 390 deletions

86
.gitignore vendored
View File

@ -1,74 +1,12 @@
iceauth-1.0.2.tar.bz2
rgb-1.0.1.tar.bz2
sessreg-1.0.4.tar.bz2
xcmsdb-1.0.1.tar.bz2
xhost-1.0.2.tar.bz2
xmodmap-1.0.3.tar.bz2
xsetpointer-1.0.1.tar.bz2
xsetroot-1.0.2.tar.bz2
xstdcmap-1.0.1.tar.bz2
xvidtune-1.0.1.tar.bz2
iceauth-1.0.3.tar.bz2
sessreg-1.0.5.tar.bz2
xmodmap-1.0.4.tar.bz2
rgb-1.0.3.tar.bz2
xhost-1.0.3.tar.bz2
xsetroot-1.0.3.tar.bz2
xrandr-1.3.3.tar.bz2
/iceauth-1.0.4.tar.bz2
/rgb-1.0.4.tar.bz2
/sessreg-1.0.5.tar.bz2
/xhost-1.0.4.tar.bz2
/xmodmap-1.0.5.tar.bz2
/xrandr-1.3.4.tar.bz2
/xsetpointer-1.0.1.tar.bz2
/xsetroot-1.1.0.tar.bz2
/xstdcmap-1.0.2.tar.bz2
xrdb-1.0.7.tar.bz2
xrefresh-1.0.4.tar.bz2
xset-1.2.1.tar.bz2
xgamma-1.0.4.tar.bz2
/xrdb-1.0.9.tar.bz2
/xset-1.2.2.tar.bz2
/iceauth-1.0.5.tar.bz2
/sessreg-1.0.6.tar.bz2
/xrandr-1.3.5.tar.bz2
/xinput-1.5.3.tar.bz2
/xkill-1.0.3.tar.bz2
/xinput-1.5.4.tar.bz2
/xinput-1.5.99.901.tar.bz2
/xinput-1.6.0.tar.bz2
/xrandr-1.4.0.tar.bz2
/rgb-1.0.5.tar.bz2
/sessreg-1.0.8.tar.bz2
/xgamma-1.0.5.tar.bz2
/xhost-1.0.5.tar.bz2
/xmodmap-1.0.7.tar.bz2
/xsetroot-1.1.1.tar.bz2
/xstdcmap-1.0.3.tar.bz2
/xrdb-1.1.0.tar.bz2
/xmodmap-1.0.8.tar.bz2
/xkill-1.0.4.tar.bz2
/xinput-1.6.1.tar.bz2
/iceauth-1.0.6.tar.bz2
/xhost-1.0.6.tar.bz2
/xrandr-1.4.2.tar.bz2
/xrefresh-1.0.5.tar.bz2
/xset-1.2.3.tar.bz2
/xrandr-1.4.3.tar.bz2
/rgb-1.0.6.tar.bz2
/iceauth-1.0.7.tar.bz2
/sessreg-1.1.0.tar.bz2
/xmodmap-1.0.9.tar.bz2
/xgamma-1.0.6.tar.bz2
/xhost-1.0.7.tar.bz2
/xinput-1.6.2.tar.bz2
/xrandr-1.5.0.tar.bz2
/iceauth-1.0.8.tar.bz2
/xkill-1.0.5.tar.bz2
/xrdb-1.1.1.tar.bz2
/xrefresh-1.0.6.tar.bz2
/xset-1.2.4.tar.bz2
/xsetroot-1.1.2.tar.bz2
/xinput-1.6.3.tar.bz2
/xisxwayland-1.tar.xz
/rgb-.*.tar.bz2
/xmodmap-.*.tar.bz2
/xgamma-.*.tar.bz2
/xhost-.*.tar.bz2
/xinput-.*.tar.bz2
/xrandr-.*.tar.bz2
/xkill-.*.tar.bz2
/xrdb-.*.tar.bz2
/xset-.*.tar.bz2
/xsetroot-.*.tar.bz2
/xinput-.*.tar.bz2
/xisxwayland-.*.tar.xz

View File

@ -1,104 +0,0 @@
From eb22398e59ae2d17bfc444400cb688c82448cb92 Mon Sep 17 00:00:00 2001
From: Peter Hutterer <peter.hutterer@who-t.net>
Date: Wed, 12 Sep 2018 14:46:05 +1000
Subject: [PATCH app/sessreg] Replace strncpy calls with a sane version that
always terminates
Fixes coverity complaints about potentially unterminated strings
---
sessreg.c | 26 +++++++++++++++++---------
1 file changed, 17 insertions(+), 9 deletions(-)
diff --git a/sessreg.c b/sessreg.c
index 0a8fdb2..53b30b0 100644
--- a/sessreg.c
+++ b/sessreg.c
@@ -192,6 +192,14 @@ sysnerr (int x, const char *s)
return x;
}
+static void
+safe_strncpy(char *dest, const char *src, size_t n)
+{
+ (void)strncpy(dest, src, n);
+ if (n > 0)
+ dest[n - 1] = '\0';
+}
+
int
main (int argc, char **argv)
{
@@ -406,9 +414,9 @@ main (int argc, char **argv)
memset(&ll, 0, sizeof(ll));
ll.ll_time = current_time;
if (line)
- (void) strncpy (ll.ll_line, line, sizeof (ll.ll_line));
+ safe_strncpy (ll.ll_line, line, sizeof (ll.ll_line));
if (host_name)
- (void) strncpy (ll.ll_host, host_name, sizeof (ll.ll_host));
+ safe_strncpy (ll.ll_host, host_name, sizeof (ll.ll_host));
sysnerr (write (llog, (char *) &ll, sizeof (ll))
== sizeof (ll), "write lastlog entry");
@@ -429,11 +437,11 @@ set_utmp (struct utmp *u, char *line, char *user, char *host, time_t date, int a
{
memset (u, 0, sizeof (*u));
if (line)
- (void) strncpy (u->ut_line, line, sizeof (u->ut_line));
+ safe_strncpy (u->ut_line, line, sizeof (u->ut_line));
else
memset (u->ut_line, 0, sizeof (u->ut_line));
if (addp && user)
- (void) strncpy (u->ut_name, user, sizeof (u->ut_name));
+ safe_strncpy (u->ut_name, user, sizeof (u->ut_name));
else
memset (u->ut_name, 0, sizeof (u->ut_name));
#ifdef HAVE_STRUCT_UTMP_UT_ID
@@ -451,7 +459,7 @@ set_utmp (struct utmp *u, char *line, char *user, char *host, time_t date, int a
i -= sizeof (u->ut_id);
else
i = 0;
- (void) strncpy (u->ut_id, line + i, sizeof (u->ut_id));
+ safe_strncpy (u->ut_id, line + i, sizeof (u->ut_id));
} else
memset (u->ut_id, 0, sizeof (u->ut_id));
#endif
@@ -469,7 +477,7 @@ set_utmp (struct utmp *u, char *line, char *user, char *host, time_t date, int a
#endif
#ifdef HAVE_STRUCT_UTMP_UT_HOST
if (addp && host)
- (void) strncpy (u->ut_host, host, sizeof (u->ut_host));
+ safe_strncpy (u->ut_host, host, sizeof (u->ut_host));
else
memset (u->ut_host, 0, sizeof (u->ut_host));
#endif
@@ -513,7 +521,7 @@ set_utmpx (struct utmpx *u, const char *line, const char *user,
if(strcmp(line, ":0") == 0)
(void) strcpy(u->ut_line, "console");
else
- (void) strncpy (u->ut_line, line, sizeof (u->ut_line));
+ safe_strncpy (u->ut_line, line, sizeof (u->ut_line));
strncpy(u->ut_host, line, sizeof(u->ut_host));
#ifdef HAVE_STRUCT_UTMPX_UT_SYSLEN
@@ -523,7 +531,7 @@ set_utmpx (struct utmpx *u, const char *line, const char *user,
else
memset (u->ut_line, 0, sizeof (u->ut_line));
if (addp && user)
- (void) strncpy (u->ut_user, user, sizeof (u->ut_user));
+ safe_strncpy (u->ut_user, user, sizeof (u->ut_user));
else
memset (u->ut_user, 0, sizeof (u->ut_user));
@@ -541,7 +549,7 @@ set_utmpx (struct utmpx *u, const char *line, const char *user,
i -= sizeof (u->ut_id);
else
i = 0;
- (void) strncpy (u->ut_id, line + i, sizeof (u->ut_id));
+ safe_strncpy (u->ut_id, line + i, sizeof (u->ut_id));
/* make sure there is no entry using identical ut_id */
if (!UtmpxIdOpen(u->ut_id) && addp) {
--
2.17.1

View File

@ -1,168 +0,0 @@
diff -Naur sessreg-1.1.0.old/man/filenames.sed.c sessreg-1.1.0/man/filenames.sed.c
--- sessreg-1.1.0.old/man/filenames.sed.c 2015-04-30 13:58:47.780569645 +0200
+++ sessreg-1.1.0/man/filenames.sed.c 1970-01-01 01:00:00.000000000 +0100
@@ -1,36 +0,0 @@
-#include "sessreg.h"
-
-#ifdef UTMPX_FILE
-# define UTF UTMPX_FILE
-# define UTM utmpx
-/* delete utmp-only content */
-/__BEGIN_UTMP_ONLY__/,/__END_UTMP_ONLY__/ d
-#else
-# define UTF UTMP_FILE
-# define UTM utmp
-/* delete utmpx-only content */
-/__BEGIN_UTMPX_ONLY__/,/__END_UTMPX_ONLY__/ d
-#endif
-
-#ifdef WTMPX_FILE
-# define WTF WTMPX_FILE
-# define WTM wtmpx
-#else
-# define WTF WTMP_FILE
-# define WTM wtmp
-#endif
-
-#ifndef TTYS_FILE
-# define TTYS_FILE "/etc/ttys"
-#endif
-
-#ifndef LLOG_FILE
-# define LLOG_FILE "/var/log/lastlog"
-#endif
-
-s|__utmp_manpage__|UTM|g
-s|__utmp_file__|UTF|g
-s|__wtmp_manpage__|WTM|g
-s|__wtmp_file__|WTF|g
-s|__ttys_file__|TTYS_FILE|g
-s|__lastlog_file__|LLOG_FILE|g
diff -Naur sessreg-1.1.0.old/man/Makefile.am sessreg-1.1.0/man/Makefile.am
--- sessreg-1.1.0.old/man/Makefile.am 2015-04-30 13:58:47.780569645 +0200
+++ sessreg-1.1.0/man/Makefile.am 2015-04-30 14:10:41.420249238 +0200
@@ -3,20 +3,11 @@
appman_PRE = sessreg.man
appman_DATA = $(appman_PRE:man=$(APP_MAN_SUFFIX))
-EXTRA_DIST = $(appman_PRE) filenames.sed.c
-CLEANFILES = $(appman_DATA) filenames.sed
+EXTRA_DIST = $(appman_PRE)
+CLEANFILES = $(appman_DATA)
SUFFIXES = .$(APP_MAN_SUFFIX) .man
AM_CPPFLAGS = -I$(top_builddir) -I$(top_srcdir)
-filenames.sed: filenames.sed.c
- $(AM_V_GEN)$(CPP) $(DEFS) $(DEFAULT_INCLUDES) $(INCLUDES) \
- $(AM_CPPFLAGS) $(CPPFLAGS) $(srcdir)/filenames.sed.c | \
- $(SED) -n -e '/s|__/ p' -e '/^\/__/ p' > $@
-
-# String replacements in MAN_SUBSTS now come from xorg-macros.m4 via configure
-MAN_SUBSTS += -f filenames.sed
-
-sessreg.$(APP_MAN_SUFFIX): filenames.sed
.man.$(APP_MAN_SUFFIX):
$(AM_V_GEN)$(SED) $(MAN_SUBSTS) < $< > $@
diff -Naur sessreg-1.1.0.old/man/sessreg.man sessreg-1.1.0/man/sessreg.man
--- sessreg-1.1.0.old/man/sessreg.man 2015-04-30 13:58:47.780569645 +0200
+++ sessreg-1.1.0/man/sessreg.man 2015-04-30 14:11:47.134127555 +0200
@@ -24,11 +24,11 @@
.\"
.TH SESSREG __appmansuffix__ __xorgversion__
.SH NAME
-sessreg \- manage __utmp_manpage__/__wtmp_manpage__ entries for non-init clients
+sessreg \- manage utmp (__filemansuffix__)/wtmp (__filemansuffix__) entries for non-init clients
.SH SYNOPSIS
.B sessreg
-[-w \fI__wtmp_manpage__-file\fP]
-[-u \fI__utmp_manpage__-file\fP]
+[-w \fIwtmp (__filemansuffix__)-file\fP]
+[-u \fIutmp (__filemansuffix__)-file\fP]
[-L \fIlastlog-file\fP]
[-l \fIline-name\fP]
[-h \fIhost-name\fP]
@@ -41,25 +41,25 @@
\fIuser-name\fP
.SH DESCRIPTION
.PP
-\fISessreg\fP is a simple program for managing __utmp_manpage__/__wtmp_manpage__ and lastlog
+\fISessreg\fP is a simple program for managing utmp (__filemansuffix__)/wtmp (__filemansuffix__) and lastlog
entries for xdm sessions.
.\" __BEGIN_UTMP_ONLY__
.PP
System V has a better interface to utmp than BSD; it
dynamically allocates entries in the file, instead of writing them at fixed
positions indexed by position in
-.BR __ttys_file__ .
+.BR /etc/ttys .
.PP
To manage BSD-style utmp files, \fIsessreg\fP has two strategies. In
conjunction with xdm, the -x option counts the number of lines in
-.B __ttys_file__
+.B /etc/ttys
and then adds to that the number of the line in the Xservers file which
specifies the display. The display name must be specified as the
"line-name" using the -l option. This sum is used as the "slot-number" in
the utmp file that this entry will be written at. In the more general case,
the -s option specifies the slot-number directly. If for some strange reason
your system uses a file other than
-.B __ttys_file__
+.B /etc/ttys
to manage init, the -t option can direct
\fIsessreg\fP to look elsewhere for a count of terminal sessions.
.PP
@@ -95,17 +95,17 @@
sessreg -d -l $DISPLAY -x /etc/X11/xdm/Xservers $USER
.fi
.SH OPTIONS
-.IP "\fB-w\fP \fI__wtmp_manpage__-file\fP"
-This specifies an alternate __wtmp_manpage__ file, instead of
-.BR __wtmp_file__ .
-The special name "none" disables writing records to the __wtmp_manpage__ file.
-.IP "\fB-u\fP \fI__utmp_manpage__-file\fP"
-This specifies an alternate __utmp_manpage__ file, instead of
-.BR __utmp_file__ .
-The special name "none" disables writing records to the __utmp_manpage__ file.
+.IP "\fB-w\fP \fIwtmp (__filemansuffix__)-file\fP"
+This specifies an alternate wtmp (__filemansuffix__) file, instead of
+.BR /var/log/wtmp .
+The special name "none" disables writing records to the wtmp (__filemansuffix__) file.
+.IP "\fB-u\fP \fIutmp (__filemansuffix__)-file\fP"
+This specifies an alternate utmp (__filemansuffix__) file, instead of
+.BR /var/run/utmp .
+The special name "none" disables writing records to the utmp (__filemansuffix__) file.
.IP "\fB-L\fP \fIlastlog-file\fP"
This specifies an alternate lastlog file, instead of
-.BR __lastlog_file__ ,
+.BR /var/log/lastlog ,
if the platform supports lastlog files.
The special name "none" disables writing records to the lastlog file.
.IP "\fB-l\fP \fIline-name\fP"
@@ -122,7 +122,7 @@
.\" __BEGIN_UTMP_ONLY__
Each potential session has a unique slot number in BSD systems, most are
identified by the position of the \fIline-name\fP in the
-.BR __ttys_file__ file.
+.BR /etc/ttys file.
This option overrides the default position determined with ttyslot(__libmansuffix__).
This option is inappropriate for use with xdm, the -x option is more useful.
.\" __END_UTMP_ONLY__
@@ -153,13 +153,13 @@
.IP "\fB-V\fP"
This option causes the command to print its version and exit.
.IP "\fB-a\fP"
-This session should be added to __utmp_manpage__/__wtmp_manpage__.
+This session should be added to utmp/wtmp.
.IP "\fB-d\fP"
-This session should be deleted from __utmp_manpage__/__wtmp_manpage__. One of -a/-d must
+This session should be deleted from utmp/wtmp. One of -a/-d must
be specified.
.SH "SEE ALSO"
.BR xdm (__appmansuffix__),
-.BR __utmp_manpage__ (__filemansuffix__),
-.BR __wtmp_manpage__ (__filemansuffix__)
+.BR utmp (__filemansuffix__),
+.BR wtmp (__filemansuffix__)
.SH AUTHOR
Keith Packard, MIT X Consortium

View File

@ -2,9 +2,7 @@
%global with_xkeystone 0
# Component versions
%global iceauth 1.0.8
%global rgb 1.0.6
%global sessreg 1.1.0
%global xgamma 1.0.6
%global xhost 1.0.7
%global xinput 1.6.3
@ -12,39 +10,29 @@
%global xmodmap 1.0.9
%global xrandr 1.5.0
%global xrdb 1.1.1
%global xrefresh 1.0.6
%global xset 1.2.4
%global xsetpointer 1.0.1
%global xsetroot 1.1.2
%global xstdcmap 1.0.3
%global xisxwayland 1
Summary: X.Org X11 X server utilities
Name: xorg-x11-server-utils
Version: 7.7
Release: 41%{?dist}
Release: 42%{?dist}
License: MIT
URL: http://www.x.org
Source0: https://www.x.org/pub/individual/app/iceauth-%{iceauth}.tar.bz2
Source1: https://www.x.org/pub/individual/app/rgb-%{rgb}.tar.bz2
Source2: https://www.x.org/pub/individual/app/sessreg-%{sessreg}.tar.bz2
Source3: https://www.x.org/pub/individual/app/xgamma-%{xgamma}.tar.bz2
Source4: https://www.x.org/pub/individual/app/xhost-%{xhost}.tar.bz2
Source5: https://www.x.org/pub/individual/app/xinput-%{xinput}.tar.bz2
Source6: https://www.x.org/pub/individual/app/xkill-%{xkill}.tar.bz2
Source7: https://www.x.org/pub/individual/app/xmodmap-%{xmodmap}.tar.bz2
Source8: https://www.x.org/pub/individual/app/xrandr-%{xrandr}.tar.bz2
Source9: https://www.x.org/pub/individual/app/xrdb-%{xrdb}.tar.bz2
Source10: https://www.x.org/pub/individual/app/xrefresh-%{xrefresh}.tar.bz2
Source11: https://www.x.org/pub/individual/app/xset-%{xset}.tar.bz2
Source13: https://www.x.org/pub/individual/app/xsetpointer-%{xsetpointer}.tar.bz2
Source14: https://www.x.org/pub/individual/app/xsetroot-%{xsetroot}.tar.bz2
Source15: https://www.x.org/pub/individual/app/xstdcmap-%{xstdcmap}.tar.bz2
Source16: https://www.x.org/pub/individual/app/xisxwayland-%{xisxwayland}.tar.xz
Source0: https://www.x.org/pub/individual/app/rgb-%{rgb}.tar.bz2
Source1: https://www.x.org/pub/individual/app/xgamma-%{xgamma}.tar.bz2
Source2: https://www.x.org/pub/individual/app/xhost-%{xhost}.tar.bz2
Source3: https://www.x.org/pub/individual/app/xinput-%{xinput}.tar.bz2
Source4: https://www.x.org/pub/individual/app/xkill-%{xkill}.tar.bz2
Source5: https://www.x.org/pub/individual/app/xmodmap-%{xmodmap}.tar.bz2
Source6: https://www.x.org/pub/individual/app/xrandr-%{xrandr}.tar.bz2
Source7: https://www.x.org/pub/individual/app/xrdb-%{xrdb}.tar.bz2
Source8: https://www.x.org/pub/individual/app/xset-%{xset}.tar.bz2
Source9: https://www.x.org/pub/individual/app/xsetroot-%{xsetroot}.tar.bz2
Source10: https://www.x.org/pub/individual/app/xisxwayland-%{xisxwayland}.tar.xz
Patch0: sessreg-1.1.0-get-rid-of-sed.patch
Patch2: 0001-sessreg-Replace-strncpy-calls-with-a-sane-version-that-alway.patch
Patch3: 0001-xrandr-suppress-misleading-indentation-warning.patch
Patch4: 0001-xrandr-init-the-name-to-0.patch
@ -67,8 +55,6 @@ BuildRequires: pkgconfig(xxf86vm)
BuildRequires: libtool
BuildRequires: meson
Provides: iceauth = %{iceauth}
Provides: sessreg = %{sessreg}
Provides: xgamma = %{xgamma}
Provides: xhost = %{xhost}
Provides: xinput = %{xinput}
@ -76,11 +62,8 @@ Provides: xkill = %{xkill}
Provides: xmodmap = %{xmodmap}
Provides: xrandr = %{xrandr}
Provides: xrdb = %{xrdb}
Provides: xrefresh = %{xrefresh}
Provides: xset = %{xset}
Provides: xsetpointer = %{xsetpointer}
Provides: xsetroot = %{xsetroot}
Provides: xstdcmap = %{xstdcmap}
Provides: xisxwayland = %{xisxwayland}
%description
@ -108,11 +91,7 @@ Utility to perform keystone adjustments on X screens.
%endif
%prep
%setup -q -c %{name}-%{version} -a1 -a2 -a3 -a4 -a5 -a6 -a7 -a8 -a9 -a10 -a11 -a13 -a14 -a15 -a16
%patch0
pushd sessreg-%{sessreg}
%patch2 -p1
popd
%setup -q -c %{name}-%{version} -a1 -a2 -a3 -a4 -a5 -a6 -a7 -a8 -a9 -a10
pushd xrandr-%{xrandr}
%patch3 -p1
%patch4 -p1
@ -162,8 +141,6 @@ rm -f $RPM_BUILD_ROOT%{_bindir}/xkeystone
%files
%doc
%{_bindir}/iceauth
%{_bindir}/sessreg
%{_bindir}/xgamma
%{_bindir}/xhost
%{_bindir}/xinput
@ -172,13 +149,8 @@ rm -f $RPM_BUILD_ROOT%{_bindir}/xkeystone
%{_bindir}/xmodmap
%{_bindir}/xrandr
%{_bindir}/xrdb
%{_bindir}/xrefresh
%{_bindir}/xset
%{_bindir}/xsetpointer
%{_bindir}/xsetroot
%{_bindir}/xstdcmap
%{_mandir}/man1/iceauth.1*
%{_mandir}/man1/sessreg.1*
%{_mandir}/man1/xgamma.1*
%{_mandir}/man1/xhost.1*
%{_mandir}/man1/xinput.1*
@ -187,11 +159,8 @@ rm -f $RPM_BUILD_ROOT%{_bindir}/xkeystone
%{_mandir}/man1/xmodmap.1*
%{_mandir}/man1/xrandr.1*
%{_mandir}/man1/xrdb.1*
%{_mandir}/man1/xrefresh.1*
%{_mandir}/man1/xset.1*
%{_mandir}/man1/xsetpointer.1*
%{_mandir}/man1/xsetroot.1*
%{_mandir}/man1/xstdcmap.1*
%files -n rgb
%{_bindir}/showrgb
@ -204,6 +173,10 @@ rm -f $RPM_BUILD_ROOT%{_bindir}/xkeystone
%endif
%changelog
* Tue May 04 2021 Peter Hutterer <peter.hutterer@redhat.com> 7.7-42
- Prune obsolete/unused utilities (#1954355)
- Clean up the .gitignore file
* Thu Apr 29 2021 Peter Hutterer <peter.hutterer@redhat.com> 7.7-41
- Drop mcpp from xrdb (#1954350)