d657a11d77
Resolves: #2042521
29 lines
835 B
Diff
29 lines
835 B
Diff
From ffbba91546bb1493a4701cc591cdd7343025a508 Mon Sep 17 00:00:00 2001
|
|
From: Olivier Fourdan <ofourdan@redhat.com>
|
|
Date: Fri, 21 Jan 2022 11:31:53 +0100
|
|
Subject: [PATCH xserver] meson: -Werror=no-array-bounds
|
|
|
|
gcc 12 would raise a false positive here.
|
|
|
|
Signed-off-by: Olivier Fourdan <ofourdan@redhat.com>
|
|
---
|
|
meson.build | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/meson.build b/meson.build
|
|
index d4cad9d48..ee3d225da 100644
|
|
--- a/meson.build
|
|
+++ b/meson.build
|
|
@@ -41,7 +41,7 @@ if cc.get_id() == 'gcc' or cc.get_id() == 'clang'
|
|
'-Werror=sequence-point',
|
|
'-Werror=return-type',
|
|
'-Werror=trigraphs',
|
|
- '-Werror=array-bounds',
|
|
+ '-Werror=no-array-bounds',
|
|
'-Werror=write-strings',
|
|
'-Werror=address',
|
|
'-Werror=int-to-pointer-cast',
|
|
--
|
|
2.34.1
|
|
|