xwayland 23.2.3

CVE fix for: CVE-2023-6377, CVE-2023-6478
This commit is contained in:
Peter Hutterer 2023-12-13 12:24:16 +10:00
parent 29ae3ba9ce
commit 49ef59f8b7
3 changed files with 7 additions and 68 deletions

View File

@ -1,62 +0,0 @@
From 411a61f571aa1dde54d52b0200a4e1a9d0def336 Mon Sep 17 00:00:00 2001
From: Olivier Fourdan <ofourdan@redhat.com>
Date: Fri, 17 Nov 2023 11:54:54 +0100
Subject: [PATCH xserver] build: Allow for custom server config directory
Most X servers, even those which do not have specific configuration
files, can use the directory specified by SERVER_MISC_CONFIG_PATH when
they have either the XSECURITY or XSELINUX extensions enabled, or when
support for DTRACE is enabled at build time, because this is also where
the "protocol.txt" file is searched for at runtime.
Unfortunately, the SERVER_MISC_CONFIG_PATH is set from serverconfigdir
which is hardcoded in the build system to "$prefix/$libdir/xorg", and
all X server builds share the same path.
That makes it harder for different X servers such as Xwayland to install
in the same path without sharing the same server configuration path
(and hence the same "protocol.txt" file).
Allow for the customization of server configuration path from the build
options so that different X servers can use completely different and
independent paths.
Signed-off-by: Olivier Fourdan <ofourdan@redhat.com>
Reviewed-by: Peter Hutterer <peter.hutterer@who-t.net>
---
meson.build | 5 ++++-
meson_options.txt | 2 ++
2 files changed, 6 insertions(+), 1 deletion(-)
diff --git a/meson.build b/meson.build
index 0279ea211..6a695d182 100644
--- a/meson.build
+++ b/meson.build
@@ -691,7 +691,10 @@ glx_inc = include_directories('glx')
top_dir_inc = include_directories('.')
-serverconfigdir = join_paths(get_option('prefix'), get_option('libdir'), 'xorg')
+serverconfigdir = get_option('serverconfigdir')
+if serverconfigdir == ''
+ serverconfigdir = join_paths(get_option('prefix'), get_option('libdir'), 'xorg')
+endif
manpage_config = configuration_data()
manpage_config.set('vendorversion', '"xorg-server @0@" "X Version 11"'.format(meson.project_version()))
diff --git a/meson_options.txt b/meson_options.txt
index e972717b9..7872d1d20 100644
--- a/meson_options.txt
+++ b/meson_options.txt
@@ -29,6 +29,8 @@ option('module_dir', type: 'string', value: 'xorg/modules',
option('default_font_path', type: 'string')
option('fontrootdir', type: 'string',
description: 'Root directory for legacy fonts. Default: from font-utils.pc or $datadir/fonts/X11')
+option('serverconfigdir', type: 'string',
+ description: 'Miscellaneous server configuration files path. Default: $libdir/xorg')
option('glx', type: 'boolean', value: true)
option('xdmcp', type: 'boolean', value: true)
--
2.42.0

View File

@ -1 +1 @@
SHA512 (xwayland-23.2.2.tar.xz) = f5b319fdace7d7c078544730ecd26afeb63b1a0c779fb097455147945df85af32d9e91501ebdb70209d48e8a3ead3b23be31e9d5118358ac17e699abb4b6ac07
SHA512 (xwayland-23.2.3.tar.xz) = 37198aa2f06313a0cb2add51cc78f81b26a42f2c9d55a0d3eecf958777107ea5560961c128f2d0af055f7460ba10fadb1b9050251c2c50f2251b40ab517e79cd

View File

@ -8,8 +8,8 @@
Summary: Xwayland
Name: xorg-x11-server-Xwayland
Version: 23.2.2
Release: 2%{?gitdate:.%{gitdate}git%{shortcommit}}%{?dist}
Version: 23.2.3
Release: 1%{?gitdate:.%{gitdate}git%{shortcommit}}%{?dist}
URL: http://www.x.org
%if 0%{?gitdate}
@ -18,9 +18,6 @@ Source0: https://gitlab.freedesktop.org/xorg/%{pkgname}/-/archive/%{commit}/%{
Source0: https://www.x.org/pub/individual/xserver/%{pkgname}-%{version}.tar.xz
%endif
# https://gitlab.freedesktop.org/xorg/xserver/-/merge_requests/1203
Patch0: 0001-build-Allow-for-custom-server-config-directory.patch
License: MIT
Requires: xkeyboard-config
@ -140,6 +137,10 @@ desktop-file-validate %{buildroot}%{_datadir}/applications/*.desktop
%{_libdir}/pkgconfig/xwayland.pc
%changelog
* Wed Dec 13 2023 Peter Hutterer <peter.hutterer@redhat.com> - 23.2.3-1
- xwayland 23.2.3
CVE fix for: CVE-2023-6377, CVE-2023-6478
* Fri Nov 24 2023 Olivier Fourdan <ofourdan@redhat.com> - 23.2.2-2
- Drop dependency on xorg-x11-server-common