diff --git a/.gitignore b/.gitignore
index 10ab0df..df10cd9 100644
--- a/.gitignore
+++ b/.gitignore
@@ -7,3 +7,5 @@ font-util-1.2.0.tar.bz2
 /mkfontscale-1.1.0.tar.bz2
 /mkfontdir-1.0.7.tar.bz2
 /bdftopcf-1.0.4.tar.bz2
+/fonttosfnt-1.0.4.tar.bz2
+/mkfontscale-1.1.1.tar.bz2
diff --git a/mkfontscale-man-page-additions.patch b/mkfontscale-man-page-additions.patch
deleted file mode 100644
index 295f43c..0000000
--- a/mkfontscale-man-page-additions.patch
+++ /dev/null
@@ -1,38 +0,0 @@
-From 19e2cb7c6a3ec2c5b1bc0d24866fa685eef0ee13 Mon Sep 17 00:00:00 2001
-From: Peter Hutterer <peter.hutterer@who-t.net>
-Date: Tue, 21 May 2013 15:50:19 +1000
-Subject: [PATCH mkfontscale] Document -u/-U options in man page
-
-Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
-Reviewed-by: Alan Coopersmith <alan.coopersmith@oracle.com>
----
- man/mkfontscale.man | 6 ++++++
- 1 file changed, 6 insertions(+)
-
-diff --git a/man/mkfontscale.man b/man/mkfontscale.man
-index 4ed3d7d..4aa88ab 100644
---- a/man/mkfontscale.man
-+++ b/man/mkfontscale.man
-@@ -36,6 +36,8 @@ mkfontscale \- create an index of scalable font files for X
- .B \-n
- .I prefix
- ] [
-+.B \-u | \-U
-+] [
- .B \-\-
- ] [
- .I directory
-@@ -126,6 +128,10 @@ options.
- do not scan for fonts, do not write font directory files.  This option
- is useful when generating encoding directories only.
- .TP
-+.B \-u, \-U
-+disable (\fI-u\fP) or enable (\fI-U\fP) indexing of ISO 10646:1 font
-+encodings (default: enabled).
-+.TP
- .B \-\-
- end of options.
- .SH SEE ALSO
--- 
-1.8.1.4
-
diff --git a/sources b/sources
index fc0bb69..83e8c00 100644
--- a/sources
+++ b/sources
@@ -1,5 +1,5 @@
-b0ebd86029571239b9d7b0c61191b591  fonttosfnt-1.0.3.tar.bz2
-18c429148c96c2079edda922a2b67632  mkfontdir-1.0.7.tar.bz2
 96a648a332160a7482885800f7a506fa  bdftopcf-1.0.4.tar.bz2
-414fcb053418fb1418e3a39f4a37e0f7  mkfontscale-1.1.0.tar.bz2
 ddfc8a89d597651408369d940d03d06b  font-util-1.3.0.tar.bz2
+07607b26fce3bdc2b204ff3bc43d3ac3  fonttosfnt-1.0.4.tar.bz2
+18c429148c96c2079edda922a2b67632  mkfontdir-1.0.7.tar.bz2
+03de3f15db678e277f5ef9c013aca1ad  mkfontscale-1.1.1.tar.bz2
diff --git a/xorg-x11-font-utils.spec b/xorg-x11-font-utils.spec
index bf3f8d0..ebafb2e 100644
--- a/xorg-x11-font-utils.spec
+++ b/xorg-x11-font-utils.spec
@@ -1,18 +1,21 @@
 %define pkgname font-utils
-%define mkfontscale 1.1.0
+%define mkfontscale 1.1.1
+
+# Must be kept in sync with xorg-x11-fonts !
+%define _x11fontdir		%{_datadir}/X11/fonts
 
 Summary: X.Org X11 font utilities
 Name: xorg-x11-%{pkgname}
 # IMPORTANT: If package ever gets renamed to something else, remove the Epoch line!
 Epoch: 1
 Version: 7.5
-Release: 22%{?dist}
+Release: 23%{?dist}
 License: MIT
 Group: User Interface/X
 URL: http://www.x.org
 
 Source0: ftp://ftp.x.org/pub/individual/app/bdftopcf-1.0.4.tar.bz2
-Source1: ftp://ftp.x.org/pub/individual/app/fonttosfnt-1.0.3.tar.bz2
+Source1: ftp://ftp.x.org/pub/individual/app/fonttosfnt-1.0.4.tar.bz2
 Source2: ftp://ftp.x.org/pub/individual/app/mkfontdir-1.0.7.tar.bz2
 Source3: ftp://ftp.x.org/pub/individual/app/mkfontscale-%{mkfontscale}.tar.bz2
 Source4: ftp://ftp.x.org/pub/individual/font/font-util-1.3.0.tar.bz2
@@ -21,7 +24,6 @@ Source5: xorg-x11-fonts-update-dirs
 Source6: xorg-x11-fonts-update-dirs.1
 
 Patch2: mkfontscale-examine-all-encodings.patch
-Patch3: mkfontscale-man-page-additions.patch
 
 BuildRequires: pkgconfig(xfont) pkgconfig(x11)
 BuildRequires: libfontenc-devel >= 0.99.2-2
@@ -46,7 +48,6 @@ and generation.
 oldpwd=$(pwd)
 cd mkfontscale-%{mkfontscale}
 %patch2 -p1 -b .all-encodings
-%patch3 -p1
 cd ${oldpwd}
 
 %build
@@ -55,9 +56,9 @@ cd ${oldpwd}
    for app in bdftopcf fonttosfnt mkfontdir mkfontscale font-util ; do
       oldpwd=$(pwd)
       cd $app-*
-      # this --with-mapdir should be redundant?
+      # note --with-fontrootdir is only used by font-util
       autoreconf -vif
-      %configure --with-mapdir=%{_datadir}/X11/fonts/util
+      %configure --with-fontrootdir=%{_x11fontdir}
       make
       cd ${oldpwd}
    done
@@ -80,12 +81,6 @@ cd ${oldpwd}
 	done
 }
 
-# Create /usr/share/fonts/X11 symlink to /usr/share/X11/fonts (rhbz#1046341)
-# This is necessary since various xorg apps have this path hardcoded, e.g.
-# luit uses it to find encodings
-mkdir $RPM_BUILD_ROOT%{_datadir}/fonts
-ln -s ../X11/fonts $RPM_BUILD_ROOT%{_datadir}/fonts/X11
-
 install -m 744 %{SOURCE5} ${RPM_BUILD_ROOT}%{_bindir}/xorg-x11-fonts-update-dirs
 sed -i "s:@DATADIR@:%{_datadir}:" ${RPM_BUILD_ROOT}%{_bindir}/xorg-x11-fonts-update-dirs
 
@@ -101,8 +96,6 @@ install -m 744 -p %{SOURCE6} ${RPM_BUILD_ROOT}%{_mandir}/man1/xorg-x11-fonts-upd
 %{_bindir}/mkfontscale
 %{_bindir}/ucs2any
 %{_bindir}/xorg-x11-fonts-update-dirs
-%dir %{_datadir}/fonts
-%{_datadir}/fonts/X11
 %dir %{_datadir}/X11/fonts
 %dir %{_datadir}/X11/fonts/util
 %{_datadir}/X11/fonts/util/map-*
@@ -117,6 +110,13 @@ install -m 744 -p %{SOURCE6} ${RPM_BUILD_ROOT}%{_mandir}/man1/xorg-x11-fonts-upd
 %{_mandir}/man1/xorg-x11-fonts-update-dirs.1*
 
 %changelog
+* Fri Oct 31 2014 Hans de Goede <hdegoede@redhat.com> - 1:7.5-23
+- Drop /usr/share/fonts/X11 symlink, it causes fc-cache to scan all X11
+  fonts, which leads to the wrong fonts being used (rhbz#1158468)
+- Pass --with-fontrootdir to ./configure so that fontutil.pc gets it right
+- Upgrade fonttosfnt to 1.0.4
+- Upgrade mkfontscale to 1.1.1
+
 * Mon Aug 18 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 1:7.5-22
 - Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild