import xorg-x11-drv-vmware-13.2.1-18.el9
This commit is contained in:
commit
f8b0c02918
1
.gitignore
vendored
Normal file
1
.gitignore
vendored
Normal file
@ -0,0 +1 @@
|
||||
SOURCES/xf86-video-vmware-13.2.1.tar.bz2
|
1
.xorg-x11-drv-vmware.metadata
Normal file
1
.xorg-x11-drv-vmware.metadata
Normal file
@ -0,0 +1 @@
|
||||
eb4909a61bb45e1c88ea66f968bc79e55b1239c4 SOURCES/xf86-video-vmware-13.2.1.tar.bz2
|
60
SOURCES/0001-mustard-Disable-the-non-KMS-support.patch
Normal file
60
SOURCES/0001-mustard-Disable-the-non-KMS-support.patch
Normal file
@ -0,0 +1,60 @@
|
||||
From 515aad74707ed978b7ed3744d604b6520df18b3f Mon Sep 17 00:00:00 2001
|
||||
From: Adam Jackson <ajax@redhat.com>
|
||||
Date: Wed, 23 Feb 2022 14:39:43 -0500
|
||||
Subject: [PATCH xf86-video-vmware] mustard: Disable the non-KMS support
|
||||
|
||||
We don't support it in RHEL and should never be able to hit this. That
|
||||
part of the driver is the only part requiring vgahw or shadowfb symbols,
|
||||
neither of which are present at module load time, so the #if 0 work here
|
||||
keeps any of those symbol references from being linked into the final
|
||||
driver, after which we can build this driver with full hardening
|
||||
cflags.
|
||||
---
|
||||
src/vmware.c | 2 ++
|
||||
src/vmware_bootstrap.c | 3 ++-
|
||||
2 files changed, 4 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/vmware.c b/src/vmware.c
|
||||
index 12f12ed..1f6007f 100644
|
||||
--- a/src/vmware.c
|
||||
+++ b/src/vmware.c
|
||||
@@ -1642,6 +1642,7 @@ VMWAREValidMode(SCRN_ARG_TYPE arg, DisplayModePtr mode, Bool verbose, int flags)
|
||||
return MODE_OK;
|
||||
}
|
||||
|
||||
+#if 0
|
||||
void
|
||||
vmwlegacy_hookup(ScrnInfoPtr pScrn)
|
||||
{
|
||||
@@ -1653,6 +1654,7 @@ vmwlegacy_hookup(ScrnInfoPtr pScrn)
|
||||
pScrn->FreeScreen = VMWAREFreeScreen;
|
||||
pScrn->ValidMode = VMWAREValidMode;
|
||||
}
|
||||
+#endif
|
||||
|
||||
#ifdef XFree86LOADER
|
||||
void
|
||||
diff --git a/src/vmware_bootstrap.c b/src/vmware_bootstrap.c
|
||||
index d7ab070..30e6b86 100644
|
||||
--- a/src/vmware_bootstrap.c
|
||||
+++ b/src/vmware_bootstrap.c
|
||||
@@ -239,7 +239,6 @@ VMwarePreinitStub(ScrnInfoPtr pScrn, int flags)
|
||||
#else
|
||||
xf86DrvMsg(pScrn->scrnIndex, X_INFO,
|
||||
"Driver was compiled without KMS- and 3D support.\n");
|
||||
-#endif /* defined(BUILD_VMWGFX) */
|
||||
xf86DrvMsg(pScrn->scrnIndex, X_WARNING,
|
||||
"Disabling 3D support.\n");
|
||||
xf86DrvMsg(pScrn->scrnIndex, X_WARNING,
|
||||
@@ -259,6 +258,8 @@ VMwarePreinitStub(ScrnInfoPtr pScrn, int flags)
|
||||
DEVICE_ID(pciInfo));
|
||||
|
||||
return (*pScrn->PreInit)(pScrn, flags);
|
||||
+#endif /* defined(BUILD_VMWGFX) */
|
||||
+ return FALSE;
|
||||
};
|
||||
|
||||
#if XSERVER_LIBPCIACCESS
|
||||
--
|
||||
2.34.1
|
||||
|
19
SOURCES/0001-mustard-fix-more-stdbool.patch
Normal file
19
SOURCES/0001-mustard-fix-more-stdbool.patch
Normal file
@ -0,0 +1,19 @@
|
||||
diff -up xf86-video-vmware-13.2.1/vmwgfx/vmwgfx_output.c.jx xf86-video-vmware-13.2.1/vmwgfx/vmwgfx_output.c
|
||||
--- xf86-video-vmware-13.2.1/vmwgfx/vmwgfx_output.c.jx 2016-11-15 23:06:33.000000000 -0500
|
||||
+++ xf86-video-vmware-13.2.1/vmwgfx/vmwgfx_output.c 2022-02-23 15:04:31.494921797 -0500
|
||||
@@ -33,7 +33,6 @@
|
||||
|
||||
#include "xorg-server.h"
|
||||
#include <xf86drm.h>
|
||||
-#include <xf86drmMode.h>
|
||||
#include <xf86str.h>
|
||||
#include <randrstr.h>
|
||||
#include <xf86Crtc.h>
|
||||
@@ -48,6 +47,7 @@
|
||||
#endif
|
||||
|
||||
#include "vmwgfx_driver.h"
|
||||
+#include <xf86drmMode.h>
|
||||
|
||||
/**
|
||||
* struct output_prop - Structure representing an output property.
|
32
SOURCES/0001-saa-Build-compatibility-with-xserver-1.20.patch
Normal file
32
SOURCES/0001-saa-Build-compatibility-with-xserver-1.20.patch
Normal file
@ -0,0 +1,32 @@
|
||||
From 7e5237dd08f2a469d0bc699cbcde763cc93c7407 Mon Sep 17 00:00:00 2001
|
||||
From: Adam Jackson <ajax@redhat.com>
|
||||
Date: Tue, 7 Nov 2017 15:42:59 -0500
|
||||
Subject: [PATCH xf86-video-vmware] saa: Build compatibility with xserver 1.20
|
||||
|
||||
fbGetRotatedPixmap went away with 24bpp support, just treat it as NULL
|
||||
and we'll do the right thing.
|
||||
|
||||
Signed-off-by: Adam Jackson <ajax@redhat.com>
|
||||
---
|
||||
saa/saa.c | 5 +++++
|
||||
1 file changed, 5 insertions(+)
|
||||
|
||||
diff --git a/saa/saa.c b/saa/saa.c
|
||||
index be9520e..d956853 100644
|
||||
--- a/saa/saa.c
|
||||
+++ b/saa/saa.c
|
||||
@@ -370,6 +370,11 @@ saa_op_reads_destination(CARD8 op)
|
||||
}
|
||||
}
|
||||
|
||||
+/* compatibility with xserver >= 1.20 */
|
||||
+#ifndef fbGetRotatedPixmap
|
||||
+#define fbGetRotatedPixmap(pGC) NULL
|
||||
+#endif
|
||||
+
|
||||
static void
|
||||
saa_validate_gc(GCPtr pGC, unsigned long changes, DrawablePtr pDrawable)
|
||||
{
|
||||
--
|
||||
2.16.2
|
||||
|
@ -0,0 +1,60 @@
|
||||
From 50ab008cb965dc9e47e0a84a1950e2485bbd3c44 Mon Sep 17 00:00:00 2001
|
||||
From: Martin Krastev <krastevm@vmware.com>
|
||||
Date: Tue, 30 Nov 2021 11:47:39 -0800
|
||||
Subject: [PATCH xf86-video-vmware] vmwgfx: Change header inclusion order to
|
||||
avoid xorg headers catching stdbool.h
|
||||
|
||||
libdrm commit e641e2a632d779f638ac2ba983b9fceb20b3fac4 added
|
||||
stdbool.h to the library headers which conflicts with xorg headers.
|
||||
|
||||
Signed-off-by: Martin Krastev <krastevm@vmware.com>
|
||||
Reviewed-by: Zack Rusin <zackr@vmware.com>
|
||||
Signed-off-by: Zack Rusin <zackr@vmware.com>
|
||||
---
|
||||
vmwgfx/vmwgfx_driver.h | 6 +++---
|
||||
vmwgfx/vmwgfx_saa.c | 2 +-
|
||||
2 files changed, 4 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/vmwgfx/vmwgfx_driver.h b/vmwgfx/vmwgfx_driver.h
|
||||
index fa8e308..467fb21 100644
|
||||
--- a/vmwgfx/vmwgfx_driver.h
|
||||
+++ b/vmwgfx/vmwgfx_driver.h
|
||||
@@ -36,15 +36,15 @@
|
||||
#include <stddef.h>
|
||||
#include <stdint.h>
|
||||
#include <errno.h>
|
||||
-#include <drm.h>
|
||||
-#include <xf86drm.h>
|
||||
-#include <xf86drmMode.h>
|
||||
#include <xorg-server.h>
|
||||
#include <xf86.h>
|
||||
#include <xf86Crtc.h>
|
||||
#include <xf86xv.h>
|
||||
#include <xa_tracker.h>
|
||||
#include <xf86Module.h>
|
||||
+#include <drm.h>
|
||||
+#include <xf86drm.h>
|
||||
+#include <xf86drmMode.h>
|
||||
|
||||
#include "../src/compat-api.h"
|
||||
#ifdef DRI2
|
||||
diff --git a/vmwgfx/vmwgfx_saa.c b/vmwgfx/vmwgfx_saa.c
|
||||
index 0881e2f..457f397 100644
|
||||
--- a/vmwgfx/vmwgfx_saa.c
|
||||
+++ b/vmwgfx/vmwgfx_saa.c
|
||||
@@ -29,11 +29,11 @@
|
||||
#include <xorgVersion.h>
|
||||
#include <mi.h>
|
||||
#include <fb.h>
|
||||
-#include <xf86drmMode.h>
|
||||
#include <xa_context.h>
|
||||
#include "vmwgfx_saa.h"
|
||||
#include "vmwgfx_drmi.h"
|
||||
#include "vmwgfx_saa_priv.h"
|
||||
+#include <xf86drmMode.h>
|
||||
|
||||
/*
|
||||
* Damage to be added as soon as we attach storage to the pixmap.
|
||||
--
|
||||
2.34.1
|
||||
|
366
SPECS/xorg-x11-drv-vmware.spec
Normal file
366
SPECS/xorg-x11-drv-vmware.spec
Normal file
@ -0,0 +1,366 @@
|
||||
%global tarball xf86-video-vmware
|
||||
%global moduledir %(pkg-config xorg-server --variable=moduledir )
|
||||
%global driverdir %{moduledir}/drivers
|
||||
#global gitdate 20150211
|
||||
#global gitversion 8f0cf7c
|
||||
|
||||
%if 0%{?gitdate}
|
||||
%global gver .%{gitdate}git%{gitversion}
|
||||
%endif
|
||||
|
||||
Summary: Xorg X11 vmware video driver
|
||||
Name: xorg-x11-drv-vmware
|
||||
Version: 13.2.1
|
||||
Release: 18%{?gver}%{?dist}
|
||||
URL: http://www.x.org
|
||||
License: MIT
|
||||
|
||||
%if 0%{?gitdate}
|
||||
Source0: %{tarball}-%{gitdate}.tar.bz2
|
||||
%else
|
||||
Source0: ftp://ftp.x.org/pub/individual/driver/%{tarball}-%{version}.tar.bz2
|
||||
%endif
|
||||
|
||||
Patch0: 0001-saa-Build-compatibility-with-xserver-1.20.patch
|
||||
|
||||
# 2044901 - annocheck FAIL: bind-now test (xorg-x11-drv-vmware)
|
||||
Patch10: 0001-vmwgfx-Change-header-inclusion-order-to-avoid-xorg-h.patch
|
||||
Patch11: 0001-mustard-fix-more-stdbool.patch
|
||||
Patch12: 0001-mustard-Disable-the-non-KMS-support.patch
|
||||
|
||||
ExclusiveArch: %{ix86} x86_64 ia64
|
||||
|
||||
BuildRequires: make
|
||||
BuildRequires: autoconf automake libtool
|
||||
BuildRequires: xorg-x11-server-devel >= 1.10.99.902
|
||||
BuildRequires: libdrm-devel pkgconfig(xext) pkgconfig(x11)
|
||||
BuildRequires: mesa-libxatracker-devel >= 8.0.1-4
|
||||
BuildRequires: systemd-devel
|
||||
|
||||
Requires: Xorg %(xserver-sdk-abi-requires ansic)
|
||||
Requires: Xorg %(xserver-sdk-abi-requires videodrv)
|
||||
Requires: libxatracker >= 8.0.1-4
|
||||
|
||||
%description
|
||||
X.Org X11 vmware video driver.
|
||||
|
||||
%prep
|
||||
%setup -q -n %{tarball}-%{?gitdate:%{gitdate}}%{!?gitdate:%{version}}
|
||||
%patch0 -p1
|
||||
%patch10 -p1
|
||||
%patch11 -p1
|
||||
%patch12 -p1
|
||||
|
||||
%build
|
||||
autoreconf -v --install || exit 1
|
||||
%configure --disable-static
|
||||
make %{?_smp_mflags}
|
||||
|
||||
%install
|
||||
%make_install
|
||||
|
||||
# FIXME: Remove all libtool archives (*.la) from modules directory. This
|
||||
# should be fixed in upstream Makefile.am or whatever.
|
||||
find $RPM_BUILD_ROOT -regex ".*\.la$" | xargs rm -f --
|
||||
|
||||
%files
|
||||
%{driverdir}/vmware_drv.so
|
||||
%{_mandir}/man4/vmware.4*
|
||||
|
||||
%changelog
|
||||
* Wed Feb 23 2022 Adam Jackson <ajax@redhat.com> - 13.2.1-18
|
||||
- Disable the non-KMS code so that we can enable the hardened build flags
|
||||
Resolves: rhbz#2044901
|
||||
|
||||
* Tue Aug 10 2021 Mohan Boddu <mboddu@redhat.com> - 13.2.1-17
|
||||
- Rebuilt for IMA sigs, glibc 2.34, aarch64 flags
|
||||
Related: rhbz#1991688
|
||||
|
||||
* Fri Apr 16 2021 Mohan Boddu <mboddu@redhat.com> - 13.2.1-16
|
||||
- Rebuilt for RHEL 9 BETA on Apr 15th 2021. Related: rhbz#1947937
|
||||
|
||||
* Thu Jan 28 2021 Fedora Release Engineering <releng@fedoraproject.org> - 13.2.1-15
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||
|
||||
* Thu Nov 5 10:25:25 AEST 2020 Peter Hutterer <peter.hutterer@redhat.com> - 13.2.1-14
|
||||
- Add BuildRequires for make
|
||||
|
||||
* Sat Aug 01 2020 Fedora Release Engineering <releng@fedoraproject.org> - 13.2.1-13
|
||||
- Second attempt - Rebuilt for
|
||||
https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||
|
||||
* Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 13.2.1-12
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||
|
||||
* Fri Jan 31 2020 Fedora Release Engineering <releng@fedoraproject.org> - 13.2.1-11
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||
|
||||
* Sat Jul 27 2019 Fedora Release Engineering <releng@fedoraproject.org> - 13.2.1-10
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
||||
|
||||
* Sun Feb 03 2019 Fedora Release Engineering <releng@fedoraproject.org> - 13.2.1-9
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
||||
|
||||
* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 13.2.1-8
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||
|
||||
* Mon Apr 02 2018 Adam Jackson <ajax@redhat.com> - 13.2.1-7
|
||||
- Rebuild for xserver 1.20
|
||||
|
||||
* Mon Mar 05 2018 Adam Jackson <ajax@redhat.com> - 13.2.1-6
|
||||
- Build fix for xserver 1.20
|
||||
|
||||
* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 13.2.1-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||
|
||||
* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 13.2.1-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
||||
|
||||
* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 13.2.1-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||
|
||||
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 13.2.1-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||
|
||||
* Mon Jan 9 2017 Hans de Goede <hdegoede@redhat.com> - 13.2.1-1
|
||||
- New upstream bug-fix release 13.2.1
|
||||
|
||||
* Thu Sep 29 2016 Hans de Goede <hdegoede@redhat.com> - 13.0.2-12.20150211git8f0cf7c
|
||||
- Add patches from upstream for use with xserver-1.19
|
||||
- Rebuild against xserver-1.19
|
||||
|
||||
* Fri Feb 05 2016 Fedora Release Engineering <releng@fedoraproject.org> - 13.0.2-11.20150211git8f0cf7c
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||
|
||||
* Wed Jan 20 2016 Peter Hutterer <peter.hutterer@redhat.com>
|
||||
- s/define/global/
|
||||
|
||||
* Wed Jul 29 2015 Dave Airlie <airlied@redhat.com> - 13.0.2-10.20150211git8f0cf7c
|
||||
- 1.15 ABI rebuild
|
||||
|
||||
* Fri Jun 19 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 13.0.2-9.20150211git8f0cf7c
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||
|
||||
* Tue Mar 03 2015 Dave Airlie <airlied@redhat.com> 13.0.2-8
|
||||
- removed hardened build
|
||||
|
||||
* Wed Feb 11 2015 Hans de Goede <hdegoede@redhat.com> - 13.0.2-7.20150211git8f0cf7c
|
||||
- xserver 1.17 ABI rebuild
|
||||
- Update to git snapshot of the day to fix building with xserver 1.17
|
||||
|
||||
* Mon Aug 18 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 13.0.2-6.20140613git82c9b0c
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
|
||||
|
||||
* Mon Jun 16 2014 Hans de Goede <hdegoede@redhat.com> - 13.0.2-5.20140613git82c9b0c
|
||||
- xserver 1.15.99.903 ABI rebuild
|
||||
|
||||
* Fri Jun 13 2014 Hans de Goede <hdegoede@redhat.com> - 13.0.2-4.20140613git82c9b0c
|
||||
- Snapshot from git master to fix render accel not working (rhbz#1077453)
|
||||
|
||||
* Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 13.0.2-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||
|
||||
* Tue May 13 2014 Hans de Goede <hdegoede@redhat.com> - 13.0.2-2
|
||||
- Add server managed fd support
|
||||
|
||||
* Mon Apr 28 2014 Hans de Goede <hdegoede@redhat.com> - 13.0.2-1
|
||||
- vmware 13.0.2
|
||||
|
||||
* Mon Apr 28 2014 Hans de Goede <hdegoede@redhat.com> - 13.0.1-10.20131207gita40cbd7b
|
||||
- xserver 1.15.99-20140428 git snapshot ABI rebuild
|
||||
|
||||
* Mon Jan 13 2014 Adam Jackson <ajax@redhat.com> - 13.0.1-9.20131207gita40cbd7b
|
||||
- 1.15 ABI rebuild
|
||||
|
||||
* Tue Dec 17 2013 Adam Jackson <ajax@redhat.com> - 13.0.1-8.20131207gita40cbd7b
|
||||
- 1.15RC4 ABI rebuild
|
||||
|
||||
* Sat Dec 07 2013 Dave Airlie <airlied@redhat.com> 13.0.1-7
|
||||
- snapshot master to build against latest mesa
|
||||
|
||||
* Wed Nov 20 2013 Adam Jackson <ajax@redhat.com> - 13.0.1-6
|
||||
- 1.15RC2 ABI rebuild
|
||||
|
||||
* Wed Nov 06 2013 Adam Jackson <ajax@redhat.com> - 13.0.1-5
|
||||
- 1.15RC1 ABI rebuild
|
||||
|
||||
* Fri Oct 25 2013 Adam Jackson <ajax@redhat.com> - 13.0.1-4
|
||||
- ABI rebuild
|
||||
|
||||
* Thu Oct 24 2013 Adam Jackson <ajax@redhat.com> 13.0.1-3
|
||||
- xserver 1.15 API compat
|
||||
|
||||
* Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 13.0.1-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||
|
||||
* Tue Apr 23 2013 Peter Hutterer <peter.hutterer@redhat.com> 13.0.1-1
|
||||
- vmware 13.0.1
|
||||
|
||||
* Thu Mar 07 2013 Peter Hutterer <peter.hutterer@redhat.com> - 12.0.99.901-5.20130109gitadf375f3
|
||||
- require xorg-x11-server-devel, not -sdk
|
||||
|
||||
* Thu Mar 07 2013 Peter Hutterer <peter.hutterer@redhat.com> - 12.0.99.901-4.20130109gitadf375f3
|
||||
- ABI rebuild
|
||||
|
||||
* Fri Feb 15 2013 Peter Hutterer <peter.hutterer@redhat.com> - 12.0.99.901-3.20130109gitadf375f3
|
||||
- ABI rebuild
|
||||
|
||||
* Fri Feb 15 2013 Peter Hutterer <peter.hutterer@redhat.com> - 12.0.99.901-2.20130109gitadf375f3
|
||||
- ABI rebuild
|
||||
|
||||
* Wed Jan 09 2013 Adam Jackson <ajax@redhat.com> 12.0.99.901-1
|
||||
- vmware 12.0.99.901
|
||||
|
||||
* Sun Jul 22 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 12.0.2-3.20120718gite5ac80d8f
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||
|
||||
* Wed Jul 18 2012 Dave Airlie <airlied@redhat.com> 12.0.2-1.20120718gite5ac80d8f
|
||||
- snapshot latest git for api changes
|
||||
|
||||
* Fri Apr 20 2012 Adam Jackson <ajax@redhat.com> 12.0.2-1
|
||||
- vmware 12.0.2
|
||||
|
||||
* Mon Mar 19 2012 Adam Jackson <ajax@redhat.com> 12.0.1-2
|
||||
- vmware-12.0.1-vgahw.patch: Fix a different crash at start (#782995)
|
||||
- vmware-12.0.1-git.patch: Backport a garbage-free fix from git.
|
||||
|
||||
* Thu Mar 15 2012 Dave Airlie <airlied@redhat.com> 12.0.1-1
|
||||
- update to latest upstream release
|
||||
|
||||
* Mon Mar 12 2012 Adam Jackson <ajax@redhat.com> 11.0.3-14
|
||||
- vmware-11.0.3-vgahw.patch: Fix crash at start. (#801546)
|
||||
|
||||
* Sat Feb 11 2012 Peter Hutterer <peter.hutterer@redhat.com> - 11.0.3-13
|
||||
- ABI rebuild
|
||||
|
||||
* Fri Feb 10 2012 Peter Hutterer <peter.hutterer@redhat.com> - 11.0.3-12
|
||||
- ABI rebuild
|
||||
|
||||
* Tue Jan 24 2012 Peter Hutterer <peter.hutterer@redhat.com> - 11.0.3-11
|
||||
- ABI rebuild
|
||||
|
||||
* Wed Jan 04 2012 Peter Hutterer <peter.hutterer@redhat.com> - 11.0.3-10
|
||||
- Rebuild for server 1.12
|
||||
|
||||
* Fri Dec 16 2011 Adam Jackson <ajax@redhat.com> - 11.0.3-9
|
||||
- Drop xinf file
|
||||
|
||||
* Wed Nov 16 2011 Adam Jackson <ajax@redhat.com> 11.0.3-8
|
||||
- ABI rebuild
|
||||
- vmware-11.0.3-abi12.patch: Compensate for videoabi 12.
|
||||
- vmware-11.0.3-unbreak-xinerama.patch: Unbreak swapped dispatch in the
|
||||
fake-xinerama code.
|
||||
|
||||
* Wed Nov 09 2011 ajax <ajax@redhat.com> - 11.0.3-7
|
||||
- ABI rebuild
|
||||
|
||||
* Thu Aug 18 2011 Adam Jackson <ajax@redhat.com> - 11.0.3-6
|
||||
- Rebuild for xserver 1.11 ABI
|
||||
|
||||
* Wed May 11 2011 Peter Hutterer <peter.hutterer@redhat.com> - 11.0.3-5
|
||||
- Rebuild for server 1.11
|
||||
|
||||
* Mon Feb 28 2011 Peter Hutterer <peter.hutterer@redhat.com> - 11.0.3-4
|
||||
- Rebuild for server 1.10
|
||||
|
||||
* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 11.0.3-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
||||
|
||||
* Thu Dec 02 2010 Peter Hutterer <peter.hutterer@redhat.com> - 11.0.3-2
|
||||
- Rebuild for server 1.10
|
||||
|
||||
* Tue Nov 09 2010 Adam Jackson <ajax@redhat.com> 11.0.3-1
|
||||
- vmware 11.0.3
|
||||
|
||||
* Wed Oct 27 2010 Adam Jackson <ajax@redhat.com> 11.0.1-2
|
||||
- Add ABI requires magic (#542742)
|
||||
|
||||
* Tue Aug 10 2010 Dave Airlie <airlied@redhat.com> 11.0.1-1
|
||||
- Latest upstream release.
|
||||
|
||||
* Mon Jul 05 2010 Peter Hutterer <peter.hutterer@redhat.com> - 10.16.7-4
|
||||
- rebuild for X Server 1.9
|
||||
|
||||
* Thu Jan 21 2010 Peter Hutterer <peter.hutterer@redhat.com> - 10.16.7-3
|
||||
- Rebuild for server 1.8
|
||||
|
||||
* Fri Aug 07 2009 Adam Jackson <ajax@redhat.com> 10.16.7-2
|
||||
- fix for symbol list removal.
|
||||
|
||||
* Tue Aug 04 2009 Dave Airlie <airlied@redhat.com> 10.16.7-1
|
||||
- vmware 10.16.7 + new abi patch
|
||||
|
||||
* Mon Jul 27 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 10.16.0-5.1
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
|
||||
|
||||
* Wed Jul 15 2009 Adam Jackson <ajax@redhat.com> - 10.16.0-4.1
|
||||
- ABI bump
|
||||
|
||||
* Tue Jun 23 2009 Dave Airlie <airlied@redhat.com> 10.16.0-4
|
||||
- abi.patch: patch for new server ABI
|
||||
|
||||
* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 10.16.0-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
|
||||
|
||||
* Wed Dec 24 2008 Dave Airlie <airlied@redhat.com> 10.16.0-2
|
||||
- bump build for new server API
|
||||
|
||||
* Thu Mar 20 2008 Dave Airlie <airlied@redhat.com> 10.16.0-1
|
||||
- Latest upstream release
|
||||
|
||||
* Wed Feb 20 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 10.15.2-100.1
|
||||
- Autorebuild for GCC 4.3
|
||||
|
||||
* Tue Jan 22 2008 Adam Jackson <ajax@redhat.com> 10.15.2-99.1
|
||||
- Update to git snapshot for pciaccess conversion. (#428613)
|
||||
|
||||
* Thu Oct 11 2007 Adam Jackson <ajax@redhat.com> 10.15.2-1
|
||||
- xf86-video-vmware 10.15.2
|
||||
|
||||
* Mon Sep 24 2007 Adam Jackson <ajax@redhat.com> 10.15.1-1
|
||||
- xf86-video-vmware 10.15.1
|
||||
|
||||
* Fri Aug 24 2007 Adam Jackson <ajax@redhat.com> - 10.14.1-3
|
||||
- Rebuild for build ID
|
||||
|
||||
* Mon Jun 18 2007 Adam Jackson <ajax@redhat.com> 10.14.1-2
|
||||
- Update Requires and BuildRequires. Disown the module directories. Add
|
||||
Requires: hwdata.
|
||||
|
||||
* Fri Jan 05 2007 Adam Jackson <ajax@redhat.com> 10.14.1-1.fc7
|
||||
- Update to 10.14.1
|
||||
|
||||
* Wed Jul 12 2006 Jesse Keating <jkeating@redhat.com> - sh: line 0: fg: no job control
|
||||
- rebuild
|
||||
|
||||
* Tue May 23 2006 Adam Jackson <ajackson@redhat.com> 10.13.0-2
|
||||
- Rebuild for 7.1 ABI fix.
|
||||
|
||||
* Sun Apr 9 2006 Adam Jackson <ajackson@redhat.com> 10.13.0-1
|
||||
- Update to 10.13.0 from 7.1RC1.
|
||||
|
||||
* Tue Feb 07 2006 Jesse Keating <jkeating@redhat.com> - 10.11.1.3-1.1
|
||||
- rebuilt for new gcc4.1 snapshot and glibc changes
|
||||
|
||||
* Wed Jan 18 2006 Mike A. Harris <mharris@redhat.com> 10.11.1.3-1
|
||||
- Updated xorg-x11-drv-vmware to version 10.11.1.3 from X11R7.0
|
||||
|
||||
* Tue Dec 20 2005 Mike A. Harris <mharris@redhat.com> 10.11.1.2-1
|
||||
- Updated xorg-x11-drv-vmware to version 10.11.1.2 from X11R7 RC4
|
||||
- Removed 'x' suffix from manpage dirs to match RC4 upstream.
|
||||
|
||||
* Wed Nov 16 2005 Mike A. Harris <mharris@redhat.com> 10.11.1-1
|
||||
- Updated xorg-x11-drv-vmware to version 10.11.1 from X11R7 RC2
|
||||
|
||||
* Fri Nov 4 2005 Mike A. Harris <mharris@redhat.com> 10.11.0.1-1
|
||||
- Updated xorg-x11-drv-vmware to version 10.11.0.1 from X11R7 RC1
|
||||
- Fix *.la file removal.
|
||||
|
||||
* Tue Oct 4 2005 Mike A. Harris <mharris@redhat.com> 10.10.2-1
|
||||
- Update BuildRoot to use Fedora Packaging Guidelines.
|
||||
- Deglob file manifest.
|
||||
- Limit "ExclusiveArch" to x86, x86_64, ia64
|
||||
|
||||
* Fri Sep 2 2005 Mike A. Harris <mharris@redhat.com> 10.10.2-0
|
||||
- Initial spec file for vmware video driver generated automatically
|
||||
by my xorg-driverspecgen script.
|
Loading…
Reference in New Issue
Block a user