import xorg-x11-drv-qxl-0.1.5-9.el8
This commit is contained in:
commit
5bbabddad6
1
.gitignore
vendored
Normal file
1
.gitignore
vendored
Normal file
@ -0,0 +1 @@
|
||||
SOURCES/xf86-video-qxl-0.1.5.tar.bz2
|
1
.xorg-x11-drv-qxl.metadata
Normal file
1
.xorg-x11-drv-qxl.metadata
Normal file
@ -0,0 +1 @@
|
||||
150bbd8bf2218e33c30ca6e88422870ae08ff1af SOURCES/xf86-video-qxl-0.1.5.tar.bz2
|
57
SOURCES/0001-worst-hack-of-all-time-to-qxl-driver.patch
Normal file
57
SOURCES/0001-worst-hack-of-all-time-to-qxl-driver.patch
Normal file
@ -0,0 +1,57 @@
|
||||
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
|
||||
From: Dave Airlie <airlied@redhat.com>
|
||||
Date: Tue, 26 Nov 2013 10:45:26 +1000
|
||||
Subject: [PATCH] worst hack of all time to qxl driver
|
||||
|
||||
---
|
||||
src/qxl_surface.c | 30 ++++++++++++++++++++++++++++--
|
||||
1 file changed, 28 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/src/qxl_surface.c b/src/qxl_surface.c
|
||||
index 6a7e275..bb59f9e 100644
|
||||
--- a/src/qxl_surface.c
|
||||
+++ b/src/qxl_surface.c
|
||||
@@ -770,8 +770,9 @@ qxl_surface_composite (qxl_surface_t *dest,
|
||||
qxl->bo_funcs->bo_decref(qxl, derefs[i]);
|
||||
}
|
||||
|
||||
-Bool
|
||||
-qxl_surface_put_image (qxl_surface_t *dest,
|
||||
+
|
||||
+static Bool
|
||||
+qxl_surface_put_image_for_reals (qxl_surface_t *dest,
|
||||
int x, int y, int width, int height,
|
||||
const char *src, int src_pitch)
|
||||
{
|
||||
@@ -814,6 +815,31 @@ qxl_surface_put_image (qxl_surface_t *dest,
|
||||
return TRUE;
|
||||
}
|
||||
|
||||
+#define HACK_THE_PLANET 1
|
||||
+Bool
|
||||
+qxl_surface_put_image (qxl_surface_t *dest,
|
||||
+ int x, int y, int width, int height,
|
||||
+ const char *src, int src_pitch)
|
||||
+{
|
||||
+#ifdef HACK_THE_PLANET
|
||||
+ Bool use_hack = FALSE;
|
||||
+
|
||||
+ /* worst heuristic ever - should really block the gnome-shell issue for now */
|
||||
+ if (width == pixman_image_get_width(dest->host_image) && height < pixman_image_get_height(dest->host_image))
|
||||
+ use_hack = TRUE;
|
||||
+
|
||||
+ if (use_hack) {
|
||||
+ int gross = rand() % height;
|
||||
+ int h2 = height - gross;
|
||||
+ if (gross > 0)
|
||||
+ qxl_surface_put_image_for_reals(dest, x, y, width, gross, src, src_pitch);
|
||||
+ qxl_surface_put_image_for_reals(dest, x, y + gross, width, h2, src + (gross * src_pitch), src_pitch);
|
||||
+ return TRUE;
|
||||
+ } else
|
||||
+#endif
|
||||
+ return qxl_surface_put_image_for_reals(dest, x, y, width, height, src, src_pitch);
|
||||
+}
|
||||
+
|
||||
void
|
||||
qxl_get_formats (int bpp, SpiceSurfaceFmt *format, pixman_format_code_t *pformat)
|
||||
{
|
74
SOURCES/0002-Xspice-Use-print-instead-of-print.patch
Normal file
74
SOURCES/0002-Xspice-Use-print-instead-of-print.patch
Normal file
@ -0,0 +1,74 @@
|
||||
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
|
||||
From: Christophe Fergeau <cfergeau@redhat.com>
|
||||
Date: Wed, 8 Feb 2017 15:23:56 +0100
|
||||
Subject: [PATCH] Xspice: Use print("") instead of print ""
|
||||
|
||||
This allows Xspice to run when using python3 instead of python2
|
||||
---
|
||||
scripts/Xspice | 16 ++++++++--------
|
||||
1 file changed, 8 insertions(+), 8 deletions(-)
|
||||
|
||||
diff --git a/scripts/Xspice b/scripts/Xspice
|
||||
index ada99d1..30d10fa 100755
|
||||
--- a/scripts/Xspice
|
||||
+++ b/scripts/Xspice
|
||||
@@ -34,7 +34,7 @@ def which(x):
|
||||
candidate = os.path.join(p, x)
|
||||
if os.path.exists(candidate):
|
||||
return candidate
|
||||
- print 'Warning: failed to find executable %s' % x
|
||||
+ print('Warning: failed to find executable %s' % x)
|
||||
return None
|
||||
|
||||
if 'XSPICE_ENABLE_GDB' in os.environ:
|
||||
@@ -128,10 +128,10 @@ args, xorg_args = parser.parse_known_args(sys.argv[1:])
|
||||
def agents_new_enough(args):
|
||||
for f in [args.vdagent_exec, args.vdagentd_exec]:
|
||||
if not f:
|
||||
- print 'please specify path to vdagent/vdagentd executables'
|
||||
+ print('please specify path to vdagent/vdagentd executables')
|
||||
return False
|
||||
if not os.path.exists(f):
|
||||
- print 'error: file not found ', f
|
||||
+ print('error: file not found ', f)
|
||||
return False
|
||||
|
||||
for f in [args.vdagent_exec, args.vdagentd_exec]:
|
||||
@@ -169,11 +169,11 @@ def tls_files(args):
|
||||
# and it isn't supplied spice will still abort, and Xorg with it.
|
||||
for key, filename in tls_files(args).items():
|
||||
if not os.path.exists(filename):
|
||||
- print "missing %s - %s does not exist" % (key, filename)
|
||||
+ print("missing %s - %s does not exist" % (key, filename))
|
||||
sys.exit(1)
|
||||
|
||||
def error(msg, exit_code=1):
|
||||
- print "Xspice: %s" % msg
|
||||
+ print("Xspice: %s" % msg)
|
||||
sys.exit(exit_code)
|
||||
|
||||
if not args.xorg:
|
||||
@@ -319,7 +319,7 @@ for arg in xorg_args:
|
||||
if arg.startswith(":"):
|
||||
display = arg
|
||||
if not display:
|
||||
- print "Error: missing display on line (i.e. :3)"
|
||||
+ print("Error: missing display on line (i.e. :3)")
|
||||
raise SystemExit
|
||||
os.environ ['DISPLAY'] = display
|
||||
|
||||
@@ -343,7 +343,7 @@ time.sleep(2)
|
||||
|
||||
retpid,rc = os.waitpid(xorg.pid, os.WNOHANG)
|
||||
if retpid != 0:
|
||||
- print "Error: X server is not running"
|
||||
+ print("Error: X server is not running")
|
||||
else:
|
||||
if args.vdagent_enabled and args.vdagent_launch:
|
||||
# XXX use systemd --user for this?
|
||||
@@ -361,4 +361,4 @@ else:
|
||||
xorg.wait()
|
||||
except KeyboardInterrupt:
|
||||
# Catch Ctrl-C as that is the common way of ending this script
|
||||
- print "Keyboard Interrupt"
|
||||
+ print("Keyboard Interrupt")
|
@ -0,0 +1,31 @@
|
||||
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
|
||||
From: Christophe Fergeau <cfergeau@redhat.com>
|
||||
Date: Wed, 8 Feb 2017 17:07:39 +0100
|
||||
Subject: [PATCH] Xspice: Remove extra space before assignment
|
||||
|
||||
---
|
||||
scripts/Xspice | 4 ++--
|
||||
1 file changed, 2 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/scripts/Xspice b/scripts/Xspice
|
||||
index 30d10fa..41fd80c 100755
|
||||
--- a/scripts/Xspice
|
||||
+++ b/scripts/Xspice
|
||||
@@ -211,7 +211,7 @@ signal.signal(signal.SIGTERM, cleanup)
|
||||
atexit.register(cleanup)
|
||||
|
||||
if args.auto:
|
||||
- temp_dir = tempfile.mkdtemp(prefix="Xspice-")
|
||||
+ temp_dir = tempfile.mkdtemp(prefix="Xspice-")
|
||||
cleanup_dirs.append(temp_dir)
|
||||
|
||||
args.config = temp_dir + "/xorg.conf"
|
||||
@@ -275,7 +275,7 @@ if args.vdagent_enabled:
|
||||
os.unlink(f)
|
||||
|
||||
if not temp_dir:
|
||||
- temp_dir = tempfile.mkdtemp(prefix="Xspice-")
|
||||
+ temp_dir = tempfile.mkdtemp(prefix="Xspice-")
|
||||
cleanup_dirs.append(temp_dir)
|
||||
|
||||
# Auto generate temporary files for vdagent
|
26
SOURCES/0004-Xspice-Fix-Python3-str-vs-bytes-confusion.patch
Normal file
26
SOURCES/0004-Xspice-Fix-Python3-str-vs-bytes-confusion.patch
Normal file
@ -0,0 +1,26 @@
|
||||
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
|
||||
From: Christophe Fergeau <cfergeau@redhat.com>
|
||||
Date: Wed, 8 Feb 2017 17:07:56 +0100
|
||||
Subject: [PATCH] Xspice: Fix Python3 str() vs bytes() confusion
|
||||
|
||||
With python3, without universal_newlines=True, Popen().stdout.read()
|
||||
will return a byte array, while find(str) expects to operate on a
|
||||
string.
|
||||
I've checked that this still works with python2 as well.
|
||||
---
|
||||
scripts/Xspice | 2 +-
|
||||
1 file changed, 1 insertion(+), 1 deletion(-)
|
||||
|
||||
diff --git a/scripts/Xspice b/scripts/Xspice
|
||||
index 41fd80c..927dcb1 100755
|
||||
--- a/scripts/Xspice
|
||||
+++ b/scripts/Xspice
|
||||
@@ -135,7 +135,7 @@ def agents_new_enough(args):
|
||||
return False
|
||||
|
||||
for f in [args.vdagent_exec, args.vdagentd_exec]:
|
||||
- if Popen(args=[f, '-h'], stdout=PIPE).stdout.read().find('-S') == -1:
|
||||
+ if Popen(args=[f, '-h'], stdout=PIPE, universal_newlines=True).stdout.read().find('-S') == -1:
|
||||
return False
|
||||
return True
|
||||
|
26
SOURCES/0006-qxl-call-provider-init.patch
Normal file
26
SOURCES/0006-qxl-call-provider-init.patch
Normal file
@ -0,0 +1,26 @@
|
||||
From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
|
||||
From: Dave Airlie <airlied@redhat.com>
|
||||
Date: Wed, 8 Mar 2017 10:50:56 +1000
|
||||
Subject: [PATCH] qxl: call provider init
|
||||
|
||||
This prevents crashes when multiple QXL devices are configured in a VM.
|
||||
|
||||
https://bugzilla.redhat.com/show_bug.cgi?id=1428340
|
||||
---
|
||||
src/qxl_drmmode.c | 3 +++
|
||||
1 file changed, 3 insertions(+)
|
||||
|
||||
diff --git a/src/qxl_drmmode.c b/src/qxl_drmmode.c
|
||||
index 3c288f9..41de92f 100644
|
||||
--- a/src/qxl_drmmode.c
|
||||
+++ b/src/qxl_drmmode.c
|
||||
@@ -937,6 +937,9 @@ Bool drmmode_pre_init(ScrnInfoPtr pScrn, drmmode_ptr drmmode, int cpp)
|
||||
for (i = 0; i < drmmode->mode_res->count_connectors; i++)
|
||||
drmmode_output_init(pScrn, drmmode, i);
|
||||
|
||||
+#if XF86_CRTC_VERSION >= 5
|
||||
+ xf86ProviderSetup(pScrn, NULL, "qxl");
|
||||
+#endif
|
||||
xf86InitialConfiguration(pScrn, TRUE);
|
||||
|
||||
return TRUE;
|
@ -0,0 +1,33 @@
|
||||
From 78abd5221f7efd87383aa357590efff083449aa3 Mon Sep 17 00:00:00 2001
|
||||
From: Adam Jackson <ajax@redhat.com>
|
||||
Date: Tue, 13 Jun 2017 09:29:28 -0400
|
||||
Subject: [PATCH] modesetting: Validate the atom for enum properties
|
||||
|
||||
The client could have said anything here, and if what they said doesn't
|
||||
actually name an atom NameForAtom() will return NULL, and strcmp() will
|
||||
be unhappy about that.
|
||||
|
||||
[copied from xserver d4995a3936ae283b9080fdaa0905daa669ebacfc]
|
||||
|
||||
Signed-off-by: Adam Jackson <ajax@redhat.com>
|
||||
---
|
||||
src/qxl_drmmode.c | 3 ++-
|
||||
1 file changed, 2 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/src/qxl_drmmode.c b/src/qxl_drmmode.c
|
||||
index 3c288f9..ff164cd 100644
|
||||
--- a/src/qxl_drmmode.c
|
||||
+++ b/src/qxl_drmmode.c
|
||||
@@ -622,7 +622,8 @@ drmmode_output_set_property(xf86OutputPtr output, Atom property,
|
||||
if (value->type != XA_ATOM || value->format != 32 || value->size != 1)
|
||||
return FALSE;
|
||||
memcpy(&atom, value->data, 4);
|
||||
- name = NameForAtom(atom);
|
||||
+ if (!(name = NameForAtom(atom)))
|
||||
+ return FALSE;
|
||||
|
||||
/* search for matching name string, then set its value down */
|
||||
for (j = 0; j < p->mode_prop->count_enums; j++) {
|
||||
--
|
||||
2.13.0
|
||||
|
@ -0,0 +1,53 @@
|
||||
From cf2254c13497049a8dbc73a3b031f4cd43403ab1 Mon Sep 17 00:00:00 2001
|
||||
From: Victor Toso <me@victortoso.com>
|
||||
Date: Tue, 23 Oct 2018 13:48:58 +0200
|
||||
Subject: [PATCH] qxl: Initialize prev field while dup surface list
|
||||
MIME-Version: 1.0
|
||||
Content-Type: text/plain; charset=UTF-8
|
||||
Content-Transfer-Encoding: 8bit
|
||||
|
||||
Otherwise we will can hit a segfault qxl_surface_kill()
|
||||
|
||||
│717 void
|
||||
│718 qxl_surface_kill (qxl_surface_t *surface)
|
||||
│719 {
|
||||
│720 struct evacuated_surface_t *ev = surface->evacuated;
|
||||
│721
|
||||
│722 if (ev)
|
||||
│723 {
|
||||
│724 /* server side surface is already destroyed (via reset), don't
|
||||
│725 * resend a destroy. Just mark surface as not to be recreated */
|
||||
│726 ev->pixmap = NULL;│
|
||||
│727 if (ev->image)│
|
||||
│728 pixman_image_unref (ev->image);
|
||||
│729 if (ev->next)
|
||||
│730 ev->next->prev = ev->prev;
|
||||
│731 if (ev->prev)
|
||||
>│732 ev->prev->next = ev->next;
|
||||
│733 free(ev);
|
||||
│734 surface->evacuated = NULL;
|
||||
│735 return;
|
||||
│736 }
|
||||
|
||||
Resolves: https://bugzilla.redhat.com/show_bug.cgi?id=1641793
|
||||
|
||||
Signed-off-by: Victor Toso <victortoso@redhat.com>
|
||||
---
|
||||
src/qxl_surface_ums.c | 1 +
|
||||
1 file changed, 1 insertion(+)
|
||||
|
||||
diff --git a/src/qxl_surface_ums.c b/src/qxl_surface_ums.c
|
||||
index 2c16ede..19cbd36 100644
|
||||
--- a/src/qxl_surface_ums.c
|
||||
+++ b/src/qxl_surface_ums.c
|
||||
@@ -792,6 +792,7 @@ qxl_surface_cache_evacuate_all (surface_cache_t *cache)
|
||||
|
||||
unlink_surface (s);
|
||||
|
||||
+ evacuated->prev = NULL;
|
||||
evacuated->next = evacuated_surfaces;
|
||||
if (evacuated_surfaces)
|
||||
evacuated_surfaces->prev = evacuated;
|
||||
--
|
||||
2.19.2
|
||||
|
440
SPECS/xorg-x11-drv-qxl.spec
Normal file
440
SPECS/xorg-x11-drv-qxl.spec
Normal file
@ -0,0 +1,440 @@
|
||||
%global tarball xf86-video-qxl
|
||||
%global moduledir %(pkg-config xorg-server --variable=moduledir )
|
||||
%global driverdir %{moduledir}/drivers
|
||||
|
||||
%undefine _hardened_build
|
||||
|
||||
# Xspice is x86_64 and ARM only since spice-server is x86_64 / ARM only
|
||||
%ifarch %{ix86} x86_64 %{arm} aarch64
|
||||
%define with_xspice (0%{?fedora} || 0%{?rhel} > 6)
|
||||
%else
|
||||
%define with_xspice 0
|
||||
%endif
|
||||
|
||||
#global gitdate 20160929
|
||||
#global gitversion e13d28ee
|
||||
|
||||
%if 0%{?gitdate}
|
||||
|
||||
%define gver .%{gitdate}git%{gitversion}
|
||||
%endif
|
||||
|
||||
Summary: Xorg X11 qxl video driver
|
||||
Name: xorg-x11-drv-qxl
|
||||
|
||||
Version: 0.1.5
|
||||
|
||||
Release: 9%{?gver}%{?dist}
|
||||
URL: http://www.x.org
|
||||
Source0: http://xorg.freedesktop.org/releases/individual/driver/%{tarball}-%{version}.tar.bz2
|
||||
#Source0: %{tarball}-%{gitdate}.tar.bz2
|
||||
Patch1: 0001-worst-hack-of-all-time-to-qxl-driver.patch
|
||||
Patch2: 0002-Xspice-Use-print-instead-of-print.patch
|
||||
Patch3: 0003-Xspice-Remove-extra-space-before-assignment.patch
|
||||
Patch4: 0004-Xspice-Fix-Python3-str-vs-bytes-confusion.patch
|
||||
Patch6: 0006-qxl-call-provider-init.patch
|
||||
Patch7: 0007-modesetting-Validate-the-atom-for-enum-properties.patch
|
||||
Patch8: 0008-qxl-Initialize-prev-field-while-dup-surface-list.patch
|
||||
|
||||
|
||||
License: MIT
|
||||
Group: User Interface/X Hardware Support
|
||||
|
||||
ExcludeArch: s390 s390x
|
||||
|
||||
BuildRequires: pkgconfig
|
||||
BuildRequires: git-core
|
||||
BuildRequires: xorg-x11-server-devel >= 1.1.0-1
|
||||
BuildRequires: spice-protocol >= 0.12.1
|
||||
BuildRequires: libdrm-devel >= 2.4.46-1
|
||||
|
||||
%if %{with_xspice}
|
||||
BuildRequires: spice-server-devel >= 0.8.0
|
||||
BuildRequires: python3-rpm-macros
|
||||
%endif
|
||||
BuildRequires: glib2-devel
|
||||
BuildRequires: libtool
|
||||
BuildRequires: libudev-devel
|
||||
BuildRequires: libXfont2-devel
|
||||
|
||||
Requires: Xorg %(xserver-sdk-abi-requires ansic)
|
||||
Requires: Xorg %(xserver-sdk-abi-requires videodrv)
|
||||
|
||||
%description
|
||||
X.Org X11 qxl video driver.
|
||||
|
||||
%if %{with_xspice}
|
||||
%package -n xorg-x11-server-Xspice
|
||||
Summary: XSpice is an X server that can be accessed by a Spice client
|
||||
Requires: Xorg %(xserver-sdk-abi-requires ansic)
|
||||
Requires: Xorg %(xserver-sdk-abi-requires videodrv)
|
||||
Requires: xorg-x11-server-Xorg
|
||||
|
||||
%description -n xorg-x11-server-Xspice
|
||||
XSpice is both an X and a Spice server.
|
||||
%endif
|
||||
|
||||
%prep
|
||||
%autosetup -S git_am -n %{tarball}-%{?gitdate:%{gitdate}}%{!?gitdate:%{version}}
|
||||
|
||||
|
||||
%build
|
||||
autoreconf -ivf
|
||||
%if %{with_xspice}
|
||||
%define enable_xspice --enable-xspice
|
||||
%endif
|
||||
%configure --disable-static %{?enable_xspice}
|
||||
make %{?_smp_mflags}
|
||||
|
||||
|
||||
%install
|
||||
make install DESTDIR=$RPM_BUILD_ROOT INSTALL='install -p'
|
||||
|
||||
%if %{with_xspice}
|
||||
# Switch hardcoded python3 shebangs into the %%{__python3} macro
|
||||
sed -i '1s=^#!/usr/bin/python$=#!%{__python3}=' %{buildroot}%{_bindir}/Xspice
|
||||
%endif
|
||||
|
||||
# FIXME: Remove all libtool archives (*.la) from modules directory. This
|
||||
# should be fixed in upstream Makefile.am or whatever.
|
||||
find $RPM_BUILD_ROOT -regex ".*\.la$" | xargs rm -f --
|
||||
|
||||
%if %{with_xspice}
|
||||
mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/X11
|
||||
install -p -m 644 examples/spiceqxl.xorg.conf.example \
|
||||
$RPM_BUILD_ROOT%{_sysconfdir}/X11/spiceqxl.xorg.conf
|
||||
# FIXME: upstream installs this file by default, we install it elsewhere.
|
||||
# upstream should just not install it and let dist package deal with
|
||||
# doc/examples.
|
||||
rm -f $RPM_BUILD_ROOT/usr/share/doc/xf86-video-qxl/spiceqxl.xorg.conf.example
|
||||
%if !%{with_xspice}
|
||||
rm -f $RPM_BUILD_ROOT%{_sysconfdir}/X11/spiceqxl.xorg.conf
|
||||
%endif
|
||||
%endif
|
||||
|
||||
|
||||
%files
|
||||
%doc COPYING README
|
||||
%{driverdir}/qxl_drv.so
|
||||
|
||||
%if %{with_xspice}
|
||||
%files -n xorg-x11-server-Xspice
|
||||
%doc COPYING README.xspice README examples/spiceqxl.xorg.conf.example
|
||||
%config(noreplace) %{_sysconfdir}/X11/spiceqxl.xorg.conf
|
||||
%{_bindir}/Xspice
|
||||
%{driverdir}/spiceqxl_drv.so
|
||||
%endif
|
||||
|
||||
|
||||
%changelog
|
||||
* Tue Dec 18 2018 Victor Toso <victortoso@redhat.com> - 0.1.5-9
|
||||
- Fix crash on shutdown
|
||||
Resolves: rhbz#1641793
|
||||
|
||||
* Wed Jul 04 2018 Christophe Fergeau <cfergeau@redhat.com> - 0.1.5-8
|
||||
- Adjust python3 shebang to make it point at #!%{_python3}
|
||||
|
||||
* Thu May 17 2018 Christophe Fergeau <cfergeau@redhat.com> - 0.1.5-7
|
||||
- Add upstream patches for Python 3 support
|
||||
- Validate RANDR output property atoms
|
||||
- Add patch fixing crash with multiple QXL devices
|
||||
- This syncs the RHEL branch with both current rawhide and RHEL 7.6
|
||||
|
||||
* Mon May 14 2018 Adam Jackson <ajax@redhat.com> - 0.1.5-6.1
|
||||
- Rebuild for xserver 1.20
|
||||
|
||||
* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.5-6
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||
|
||||
* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.5-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
|
||||
|
||||
* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.5-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||
|
||||
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.5-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||
|
||||
* Tue Dec 20 2016 Christophe Fergeau <cfergeau@redhat.com> 0.1.5-2
|
||||
- Build on the same arches as spice-server
|
||||
|
||||
* Mon Dec 19 2016 Christophe Fergeau <cfergeau@redhat.com> 0.1.5-1%{?gver}%{?dist}
|
||||
- Update to latest upstream release. All patches except one have been upstreamed.
|
||||
|
||||
* Mon Dec 19 2016 Christophe Fergeau <cfergeau@redhat.com> 0.1.4-11.20160929gite13d28ee
|
||||
- Fix xspice crashing when used with xserver-1.19 (rhbz#1405939)
|
||||
Previous patch was only partially fixing the issue
|
||||
|
||||
* Tue Oct 4 2016 Hans de Goede <hdegoede@redhat.com> - 0.1.4-10.20160929gite13d28ee
|
||||
- Fix qxl driver crashing when used with xserver-1.19 (rhbz#1381045)
|
||||
|
||||
* Thu Sep 29 2016 Hans de Goede <hdegoede@redhat.com> - 0.1.4-9.20160929gite13d28ee
|
||||
- Update to latest git master for use with xserver-1.19
|
||||
- Rebuild against xserver-1.19
|
||||
- Really build xspice on ARMv7/aarch64
|
||||
|
||||
* Mon Jul 11 2016 Peter Robinson <pbrobinson@fedoraproject.org> 0.1.4-8
|
||||
- Spice server is on ARMv7/aarch64
|
||||
|
||||
* Fri Feb 05 2016 Fedora Release Engineering <releng@fedoraproject.org> - 0.1.4-7
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||
|
||||
* Wed Sep 16 2015 Dave Airlie <airlied@redhat.com> - 0.1.4-6
|
||||
- 1.18 ABI rebuild
|
||||
|
||||
* Thu Aug 06 2015 Christophe Fergeau <cfergeau@redhat.com> 0.1.4-5
|
||||
- Drop patches from 0.1.4-4 (one is not upstream, the other one is causing Xorg
|
||||
crashes at startup)
|
||||
- Add upstream patches fixing compilation with Xorg 1.18
|
||||
|
||||
* Tue Aug 04 2015 Adam Williamson <awilliam@redhat.com> - 0.1.4-4
|
||||
- fix build with a couple of patches from upstream list (from davidshea)
|
||||
|
||||
* Wed Jul 29 2015 Dave Airlie <airlied@redhat.com>
|
||||
- 1.15 ABI rebuild
|
||||
|
||||
* Fri Jun 19 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.1.4-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||
|
||||
* Tue Apr 28 2015 Marcin Juszkiewicz <mjuszkiewicz@redhat.com> - 0.1.4-2
|
||||
- fix build on aarch64 - rhbz#1201877
|
||||
|
||||
* Thu Apr 02 2015 Christophe Fergeau <cfergeau@redhat.com> 0.1.4-1
|
||||
- Update to 0.1.4 release
|
||||
|
||||
* Tue Mar 03 2015 Dave Airlie <airlied@redhat.com> 0.1.3-3
|
||||
- remove hardened build
|
||||
|
||||
* Wed Feb 11 2015 Hans de Goede <hdegoede@redhat.com> - 0.1.3-2
|
||||
- xserver 1.17 ABI rebuild
|
||||
|
||||
* Fri Oct 31 2014 Christophe Fergeau <cfergeau@redhat.com> 0.1.3-1
|
||||
- Update to 0.1.3 release
|
||||
|
||||
* Fri Oct 10 2014 Christophe Fergeau <cfergeau@redhat.com> 0.1.2-1
|
||||
- Update to new 0.1.2 upstream release
|
||||
|
||||
* Mon Aug 18 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.1.1-13
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
|
||||
|
||||
* Mon Jul 7 2014 Marc-André Lureau <marcandre.lureau@redhat.com> 0.1.1-12
|
||||
- add fix for invisible cursor after resize (#1116870)
|
||||
|
||||
* Mon Jun 16 2014 Hans de Goede <hdegoede@redhat.com> - 0.1.1-11
|
||||
- xserver 1.15.99.903 ABI rebuild
|
||||
|
||||
* Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.1.1-10
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||
|
||||
* Mon Apr 28 2014 Hans de Goede <hdegoede@redhat.com> - 0.1.1-9
|
||||
- Add patches for server managed fd support
|
||||
- xserver 1.15.99-20140428 git snapshot ABI rebuild
|
||||
|
||||
* Tue Jan 14 2014 Dave Airlie <airlied@redhat.com> 0.1.1-8
|
||||
- grab patches from F20 - fix dates
|
||||
|
||||
* Mon Jan 13 2014 Adam Jackson <ajax@redhat.com> - 0.1.1-7
|
||||
- 1.15 ABI rebuild
|
||||
|
||||
* Tue Dec 17 2013 Adam Jackson <ajax@redhat.com> - 0.1.1-6
|
||||
- 1.15RC4 ABI rebuild
|
||||
|
||||
* Wed Nov 20 2013 Adam Jackson <ajax@redhat.com> - 0.1.1-5
|
||||
- 1.15RC2 ABI rebuild
|
||||
|
||||
* Wed Nov 06 2013 Adam Jackson <ajax@redhat.com> - 0.1.1-4
|
||||
- 1.15RC1 ABI rebuild
|
||||
|
||||
* Fri Oct 25 2013 Adam Jackson <ajax@redhat.com> - 0.1.1-3
|
||||
- ABI rebuild
|
||||
|
||||
* Thu Oct 24 2013 Adam Jackson <ajax@redhat.com> 0.1.1-2
|
||||
- Drop qxl rev 1 patches
|
||||
|
||||
* Mon Oct 21 2013 Alon Levy <alevy@redhat.com> - 0.1.1-1
|
||||
- New upstream release
|
||||
- Fixes to said release to work with suid issues (upstream)
|
||||
|
||||
* Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.1.1-0.14.20130514git77a1594
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||
|
||||
* Wed Jul 03 2013 Dave Airlie <airlied@redhat.com> 0.1.1-0.13
|
||||
- resnapshot upstream to pick up a few patches
|
||||
- add userspace patch to use new kernel hotspot interface (#974662)
|
||||
|
||||
* Wed Jul 03 2013 Dave Airlie <airlied@redhat.com> 0.1.1-0.12
|
||||
- add support for udev event catching - for dynamic resize from kernel
|
||||
|
||||
* Tue Jul 02 2013 Dave Airlie <airlied@redhat.com> 0.1.1-0.11
|
||||
- helps if you apply the patch (#978612)
|
||||
|
||||
* Sat Jun 29 2013 Dave Airlie <airlied@redhat.com> 0.1.1-0.10
|
||||
- fix another resize issue due (#978612)
|
||||
|
||||
* Tue Jun 18 2013 Dave Airlie <airlied@redhat.com> 0.1.1-0.9
|
||||
- disable composite/a8 surfaces for KMS (#974198)
|
||||
|
||||
* Tue May 28 2013 Dave Airlie <airlied@redhat.com> 0.1.1-0.8
|
||||
- fix 32-bit (#965101)
|
||||
|
||||
* Tue May 14 2013 Dave Airlie <airlied@redhat.com> 0.1.1-0.7
|
||||
- resnapshot - fixes randr under KMS
|
||||
|
||||
* Tue May 14 2013 Daniel Mach <dmach@redhat.com> - 0.1.1-0.6
|
||||
- Fix with_xspice macro definition (airlied - cherrypick)
|
||||
|
||||
* Tue May 7 2013 Alon Levy <alevy@redhat.com> 0.1.1-0.5
|
||||
- Add Xspice fixes and dfps (upstream a474a71..77a1594)
|
||||
|
||||
* Tue Mar 19 2013 Adam Jackson <ajax@redhat.com> 0.1.1-0.4
|
||||
- Less RHEL customization
|
||||
|
||||
* Tue Mar 12 2013 Dave Airlie <airlied@redhat.com> 0.1.1-0.3.20130312gita474a71
|
||||
- add KMS support to userspace driver
|
||||
|
||||
* Thu Mar 07 2013 Peter Hutterer <peter.hutterer@redhat.com> - 0.1.1-0.2.20130306git9d45cc5
|
||||
- ABI rebuild
|
||||
|
||||
* Wed Mar 06 2013 Dave Airlie <airlied@redhat.com> 0.1.1-0.1
|
||||
- bump to get UMS bo abstraction in - kms coming soon
|
||||
|
||||
* Fri Feb 15 2013 Peter Hutterer <peter.hutterer@redhat.com> - 0.1.0-4
|
||||
- ABI rebuild
|
||||
|
||||
* Fri Feb 15 2013 Peter Hutterer <peter.hutterer@redhat.com> - 0.1.0-3
|
||||
- ABI rebuild
|
||||
|
||||
* Thu Jan 10 2013 Adam Jackson <ajax@redhat.com> - 0.1.0-2
|
||||
- ABI rebuild
|
||||
|
||||
* Sat Sep 22 2012 Soren Sandmann <ssp@redhat.com> 0.1.0-1
|
||||
- Upstream 0.1.0
|
||||
|
||||
* Wed Aug 29 2012 Adam Jackson <ajax@redhat.com> 0.0.22-6
|
||||
- Exclude Xspice from RHEL6 builds
|
||||
|
||||
* Sun Aug 26 2012 Alon Levy <alevy@redhat.com>
|
||||
- fix uxa_xorg_enable_disable_fb_access - 0.0.22-5.20120718gitde6620788 (#844463)
|
||||
|
||||
* Thu Aug 23 2012 Alon Levy <alevy@redhat.com>
|
||||
- fix break from introduction of screen privates - 0.0.22-4.20120718gitde6620788 (#844463)
|
||||
|
||||
* Sun Jul 22 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.0.22-3.20120718gitde6620788
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||
|
||||
* Wed Jul 18 2012 Dave Airlie <airlied@redhat.com> 0.0.22-2.20120718gitde6620788
|
||||
- git snapshot for new server API
|
||||
|
||||
* Thu Apr 05 2012 Adam Jackson <ajax@redhat.com> - 0.0.22-1
|
||||
- RHEL arch exclude updates
|
||||
|
||||
* Thu Mar 15 2012 Soren Sandmann <ssp@redhat.com> - 0.22.0
|
||||
- Upstream 0.0.17
|
||||
|
||||
* Sat Feb 11 2012 Peter Hutterer <peter.hutterer@redhat.com> - 0.0.21-16
|
||||
- ABI rebuild
|
||||
|
||||
* Fri Feb 10 2012 Peter Hutterer <peter.hutterer@redhat.com> - 0.0.21-15
|
||||
- ABI rebuild
|
||||
|
||||
* Tue Jan 24 2012 Peter Hutterer <peter.hutterer@redhat.com> - 0.0.21-14
|
||||
- ABI rebuild
|
||||
|
||||
* Fri Jan 13 2012 Marc-André Lureau <mlureau@redhat.com> 0.0.21-13
|
||||
- Add 0011-support-_ASYNC-io-calls-and-interrupt-handling-busy-.patch
|
||||
to use async calls
|
||||
|
||||
* Wed Jan 04 2012 Adam Jackson <ajax@redhat.com> 0.0.21-12
|
||||
- qxl-0.0.16-ftbfs.patch: Fix some FTBFS.
|
||||
|
||||
* Wed Nov 16 2011 Adam Jackson <ajax@redhat.com> 0.0.21-11
|
||||
- qxl-0.0.16-vgahw.patch: API compat for xserver 1.12 (#753928)
|
||||
|
||||
* Mon Nov 14 2011 Adam Jackson <ajax@redhat.com> - 0.0.21-10
|
||||
- ABI rebuild
|
||||
|
||||
* Wed Nov 09 2011 Adam Jackson <ajax@redhat.com> - 0.0.21-9
|
||||
- ABI rebuild
|
||||
|
||||
* Fri Oct 28 2011 Soren Sandmann <ssp@redhat.com> - 0.0.21-8
|
||||
- Bump release
|
||||
|
||||
* Fri Oct 28 2011 Soren Sandmann <ssp@redhat.com> - 0.0.21-7
|
||||
- Add patch to translate access regions according to drawable offset
|
||||
Bug 731245.
|
||||
|
||||
* Thu Oct 27 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.0.21-7
|
||||
- Rebuilt for glibc bug#747377
|
||||
|
||||
* Wed Oct 26 2011 Soren Sandmann <ssp@redhat.com> - 0.0.21-6
|
||||
- Add patch to confine access regions to the bounds of the drawable.
|
||||
Bug 731245.
|
||||
|
||||
* Mon Sep 12 2011 Hans de Goede <hdegoede@redhat.com> - 0.0.21-5
|
||||
- Rebase to latest upstream release
|
||||
- Enable building of the Xspice X-server and put it in its own
|
||||
xorg-x11-server-Xspice package
|
||||
|
||||
* Thu Aug 18 2011 Adam Jackson <ajax@redhat.com> - 0.0.21-4
|
||||
- Rebuild for xserver 1.11 ABI
|
||||
|
||||
* Wed Apr 20 2011 Hans de Goede <hdegoede@redhat.com> 0.0.21-3
|
||||
- Add various bugfixes from upstream git
|
||||
- Fixes VT-switching (rhbz#696711)
|
||||
- Add support for old qxl device (from rhel6 branch) (rhbz#642153)
|
||||
|
||||
* Mon Mar 07 2011 Dave Airlie <airlied@redhat.com> 0.0.21-2
|
||||
- Bump to for abi rebuild
|
||||
|
||||
* Sat Feb 12 2011 Soren Sandmann <ssp@redhat.com> 0.0.21-1
|
||||
- New version number to make sure upgrading works
|
||||
|
||||
* Tue Feb 08 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0.0.13-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
||||
|
||||
* Wed Jan 26 2011 Soren Sandmann <ssp@redhat.com> 0.0.13-1
|
||||
- Update to 0.0.13 with surfaces
|
||||
|
||||
* Mon Dec 06 2010 Adam Jackson <ajax@redhat.com> 0.0.20.f14b-10
|
||||
- Rebuild for new server ABI.
|
||||
|
||||
* Wed Oct 27 2010 Adam Jackson <ajax@redhat.com> 0.0.20.f14b-8
|
||||
- Add ABI requires magic (#542742)
|
||||
|
||||
* Sun Oct 17 2010 Hans de Goede <hdegoede@redhat.com> 0.0.20.f14b-7
|
||||
- Fix notification bubbles under gnome not showing (backport from the
|
||||
surface-fixes branch)
|
||||
|
||||
* Sun Oct 17 2010 Hans de Goede <hdegoede@redhat.com> 0.0.20.f14b-6
|
||||
- Fix a pointer casting bug which causes the qxl driver to trigger an
|
||||
assertion in the qxl device terminating the entire virtual machine
|
||||
|
||||
* Mon Oct 11 2010 Hans de Goede <hdegoede@redhat.com> 0.0.20.f14b-5
|
||||
- Don't access the qxl device when our vt is not focussed, this fixes
|
||||
Xorg crashing when switching to a text vc
|
||||
|
||||
* Sun Oct 10 2010 Hans de Goede <hdegoede@redhat.com> 0.0.20.f14b-4
|
||||
- Fix the driver not working on qxl devices with a framebuffer of 8MB
|
||||
|
||||
* Sat Oct 9 2010 Hans de Goede <hdegoede@redhat.com> 0.0.20.f14b-3
|
||||
- Add support for using resolutions > 1024x768 without needing an xorg.conf
|
||||
- Restore textmode font when switching back to a textmode virtual console
|
||||
|
||||
* Fri Oct 08 2010 Jesse Keating <jkeating@redhat.com> - 0.0.20.f14b-2.1
|
||||
- Rebuild for gcc bug 634757
|
||||
|
||||
* Tue Sep 14 2010 Soren Sandmann <ssp@redhat.com> 0.0.20.f14b-2
|
||||
- Patch to fix it up for the new privates ABI (I had apparently been
|
||||
testing with a too old X server).
|
||||
|
||||
* Tue Sep 14 2010 Soren Sandmann <ssp@redhat.com> 0.0.20.f14b-1
|
||||
- Add support for new device
|
||||
|
||||
* Sat Mar 13 2010 Dave Airlie <airlied@redhat.com> 0.0.12-2
|
||||
- fix bug in qxl with asserts
|
||||
|
||||
* Sat Mar 13 2010 Dave Airlie <airlied@redhat.com> 0.0.12-1
|
||||
- rebase to 0.0.12 release - fix some 16-bit bugs
|
||||
|
||||
* Mon Jan 11 2010 Dave Airlie <airlied@redhat.com> 0.0.9-0.1
|
||||
- Initial public release 0.0.9
|
Loading…
Reference in New Issue
Block a user