Update to latest git master for use with xserver-1.19

- Rebuild against xserver-1.19
This commit is contained in:
Hans de Goede 2016-09-29 14:39:34 +02:00
parent 52b9528699
commit a820dd64bc
5 changed files with 40 additions and 37 deletions

1
.gitignore vendored
View File

@ -17,3 +17,4 @@
/xf86-input-libinput-0.17.0.tar.bz2
/xf86-input-libinput-0.19.0.tar.bz2
/xf86-input-libinput-0.19.1.tar.bz2
/xf86-input-libinput-20160929.tar.xz

View File

@ -1,26 +0,0 @@
From cf8b629ebf30d6aa57dd405ce450fb0f33136626 Mon Sep 17 00:00:00 2001
From: Peter Hutterer <peter.hutterer@who-t.net>
Date: Mon, 13 Jul 2015 08:30:43 +1000
Subject: [PATCH xf86-input-libinput] Fedora: use unaccelerated vmask on input
ABI > 21
Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
---
src/libinput.c | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/src/libinput.c b/src/libinput.c
index a06e44f..5eb5adf 100644
--- a/src/xf86libinput.c
+++ b/src/xf86libinput.c
@@ -47,7 +47,7 @@
#define XI86_SERVER_FD 0x20
#endif
-#if GET_ABI_MAJOR(ABI_XINPUT_VERSION) * 1000 + GET_ABI_MINOR(ABI_XINPUT_VERSION) > 22000
+#if GET_ABI_MAJOR(ABI_XINPUT_VERSION) * 1000 + GET_ABI_MINOR(ABI_XINPUT_VERSION) > 21000
#define HAVE_VMASK_UNACCEL 1
#else
#undef HAVE_VMASK_UNACCEL
--
2.4.3

22
make-git-snapshot.sh Executable file
View File

@ -0,0 +1,22 @@
#!/bin/sh
# Usage: ./make-git-snapshot.sh [COMMIT]
#
# to make a snapshot of the given tag/branch. Defaults to HEAD.
# Point env var REF to a local mesa repo to reduce clone time.
DIRNAME=xf86-input-libinput-$( date +%Y%m%d )
echo REF ${REF:+--reference $REF}
echo DIRNAME $DIRNAME
echo HEAD ${1:-HEAD}
rm -rf $DIRNAME
git clone ${REF:+--reference $REF} \
git://git.freedesktop.org/git/xorg/driver/xf86-input-libinput $DIRNAME
GIT_DIR=$DIRNAME/.git git archive --format=tar --prefix=$DIRNAME/ ${1:-HEAD} \
| xz > $DIRNAME.tar.xz
# rm -rf $DIRNAME

View File

@ -1 +1 @@
337bbee23ee0cef9adefbfcb5e28370d xf86-input-libinput-0.19.1.tar.bz2
ab2a99e2548e18614946764b6bd05858 xf86-input-libinput-20160929.tar.xz

View File

@ -1,18 +1,21 @@
%global tarball xf86-input-libinput
%global moduledir %(pkg-config xorg-server --variable=moduledir )
%global driverdir %{moduledir}/input
%define gitdate 20160929
%define gitrev .%{gitdate}
Summary: Xorg X11 libinput input driver
Name: xorg-x11-drv-libinput
Version: 0.19.1
Release: 1%{?dist}
Release: 2%{?gitrev}%{?dist}
URL: http://www.x.org
License: MIT
%if 0%{?gitdate}
Source0: %{tarball}-%{gitdate}.tar.xz
%else
Source0: ftp://ftp.x.org/pub/individual/driver/%{tarball}-%{version}.tar.bz2
# Fedora-specific unless merged into 1.7.3 at least
Patch00: 0001-Fedora-use-unaccelerated-vmask-on-input-ABI-21.patch
%endif
ExcludeArch: s390 s390x
@ -26,16 +29,12 @@ Requires: Xorg %(xserver-sdk-abi-requires xinput)
Requires: xkeyboard-config
Requires: libinput >= 0.21.0
# For the unaccelerated valuator masks, drop in F23
Requires: xorg-x11-server-Xorg >= 1.17.1-14
%description
A generic input driver for the X.Org X11 X server based on libinput,
supporting all devices.
%prep
%setup -q -n %{tarball}-%{version}
%patch00 -p1
%setup -q -n %{tarball}-%{?gitdate:%{gitdate}}%{!?gitdate:%{dirsuffix}}
%build
autoreconf --force -v --install || exit 1
@ -49,7 +48,10 @@ make %{?_smp_mflags}
# should be fixed in upstream Makefile.am or whatever.
find $RPM_BUILD_ROOT -regex ".*\.la$" | xargs rm -f --
install -d $RPM_BUILD_ROOT%{_datadir}/X11/xorg.conf.d
# Keep libinput.conf at priority 60 for now, until we've obsoleted
# synaptics
mv $RPM_BUILD_ROOT%{_datadir}/X11/xorg.conf.d/40-libinput.conf \
$RPM_BUILD_ROOT%{_datadir}/X11/xorg.conf.d/60-libinput.conf
%files
%doc COPYING
@ -70,6 +72,10 @@ Xorg X11 libinput input driver development files.
%{_includedir}/xorg/libinput-properties.h
%changelog
* Thu Sep 29 2016 Hans de Goede <hdegoede@redhat.com> 0.19.1-2.20160929
- Update to latest git master for use with xserver-1.19
- Rebuild against xserver-1.19
* Wed Sep 14 2016 Peter Hutterer <peter.hutterer@redhat.com> 0.19.1-1
- xf86-input-libinput 0.19.1