From f1ca0dd029a0e9e46f14cec4ff5ee6ce1dfa0b98 Mon Sep 17 00:00:00 2001
From: CentOS Sources <bugs@centos.org>
Date: Fri, 2 Aug 2019 12:22:04 -0400
Subject: [PATCH] import xorg-x11-drv-intel-2.99.917-38.20180618.el8

---
 .gitignore                                    |   2 +
 .xorg-x11-drv-intel.metadata                  |   2 +
 SOURCES/0001-Fix-build-on-F28-and-later.patch | 101 ++++
 SOURCES/0001-Fix-build-on-i686.patch          |  49 ++
 ...ring-output-physical-size-with-xf86O.patch |  47 ++
 SOURCES/igt-stat.patch                        |  11 +
 SOURCES/intel-gcc-pr65873.patch               |  12 +
 SOURCES/make-git-snapshot.sh                  |  22 +
 SOURCES/make-intel-gpu-tools-snapshot.sh      |  22 +
 SPECS/xorg-x11-drv-intel.spec                 | 541 ++++++++++++++++++
 10 files changed, 809 insertions(+)
 create mode 100644 .gitignore
 create mode 100644 .xorg-x11-drv-intel.metadata
 create mode 100644 SOURCES/0001-Fix-build-on-F28-and-later.patch
 create mode 100644 SOURCES/0001-Fix-build-on-i686.patch
 create mode 100644 SOURCES/0001-sna-Avoid-clobbering-output-physical-size-with-xf86O.patch
 create mode 100644 SOURCES/igt-stat.patch
 create mode 100644 SOURCES/intel-gcc-pr65873.patch
 create mode 100755 SOURCES/make-git-snapshot.sh
 create mode 100755 SOURCES/make-intel-gpu-tools-snapshot.sh
 create mode 100644 SPECS/xorg-x11-drv-intel.spec

diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..e0aaf1d
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,2 @@
+SOURCES/intel-gpu-tools-1.9.tar.bz2
+SOURCES/xf86-video-intel-20180618.tar.bz2
diff --git a/.xorg-x11-drv-intel.metadata b/.xorg-x11-drv-intel.metadata
new file mode 100644
index 0000000..5f90364
--- /dev/null
+++ b/.xorg-x11-drv-intel.metadata
@@ -0,0 +1,2 @@
+396e9f50283681d50364b86a7af9988c56148ac8 SOURCES/intel-gpu-tools-1.9.tar.bz2
+7e044e8985f88104f40cc9a96bce001edff8a184 SOURCES/xf86-video-intel-20180618.tar.bz2
diff --git a/SOURCES/0001-Fix-build-on-F28-and-later.patch b/SOURCES/0001-Fix-build-on-F28-and-later.patch
new file mode 100644
index 0000000..ca525ec
--- /dev/null
+++ b/SOURCES/0001-Fix-build-on-F28-and-later.patch
@@ -0,0 +1,101 @@
+From 9c1151b4d65c356f0d25d952fe1a10c89fdb834a Mon Sep 17 00:00:00 2001
+From: Adam Jackson <ajax@redhat.com>
+Date: Mon, 5 Mar 2018 11:03:18 -0500
+Subject: [PATCH] Fix build on F28 and later
+
+Newer gcc complains that it doesn't know how to always-inline memcpy():
+
+  /usr/include/bits/string_fortified.h:31:1: error: inlining failed in
+  call to always_inline 'memcpy': target specific option mismatch
+
+This is because we need to wrap our declaration of memcpy() in the
+options we're trying to push at the top of blt.c. So: include compiler.h
+to define sse2, then push options, then include everything else.
+
+However if you do that, the word 'nonnull' collides with the usage in
+<X11/Xfuncproto.h>. I'm too lazy to fix that properly, just expand it to
+the __attribute__ form in the few places we say it.
+
+Signed-off-by: Adam Jackson <ajax@redhat.com>
+---
+ src/sna/blt.c         | 6 ++++--
+ src/sna/compiler.h    | 2 --
+ src/sna/gen6_common.h | 6 +++---
+ 3 files changed, 7 insertions(+), 7 deletions(-)
+
+diff --git a/src/sna/blt.c b/src/sna/blt.c
+index cb90437a..fb357d35 100644
+--- a/src/sna/blt.c
++++ b/src/sna/blt.c
+@@ -29,13 +29,15 @@
+ #include "config.h"
+ #endif
+ 
+-#include "sna.h"
+-#include <pixman.h>
++#include "compiler.h"
+ 
+ #if defined(sse2)
+ #pragma GCC push_options
+ #pragma GCC target("sse2,inline-all-stringops,fpmath=sse")
+ #pragma GCC optimize("Ofast")
++
++#include <pixman.h>
++#include "sna.h"
+ #include <xmmintrin.h>
+ 
+ #if __x86_64__
+diff --git a/src/sna/compiler.h b/src/sna/compiler.h
+index 0f3775ec..3c176a16 100644
+--- a/src/sna/compiler.h
++++ b/src/sna/compiler.h
+@@ -39,7 +39,6 @@
+ #define pure __attribute__((pure))
+ #define tightly_packed __attribute__((__packed__))
+ #define flatten __attribute__((flatten))
+-#define nonnull __attribute__((nonnull))
+ #define page_aligned __attribute__((aligned(4096)))
+ #else
+ #define likely(expr) (expr)
+@@ -52,7 +51,6 @@
+ #define pure
+ #define tighly_packed
+ #define flatten
+-#define nonnull
+ #define page_aligned
+ #endif
+ 
+diff --git a/src/sna/gen6_common.h b/src/sna/gen6_common.h
+index b53ec0c9..119a2d5d 100644
+--- a/src/sna/gen6_common.h
++++ b/src/sna/gen6_common.h
+@@ -133,7 +133,7 @@ inline static bool force_blt_ring(struct sna *sna, struct kgem_bo *bo)
+ 	return false;
+ }
+ 
+-nonnull inline static bool
++__attribute__((nonnull)) inline static bool
+ prefer_blt_ring(struct sna *sna, struct kgem_bo *bo, unsigned flags)
+ {
+ 	if (PREFER_RENDER)
+@@ -148,7 +148,7 @@ prefer_blt_ring(struct sna *sna, struct kgem_bo *bo, unsigned flags)
+ 	return can_switch_to_blt(sna, bo, flags);
+ }
+ 
+-nonnull inline static bool
++__attribute__((nonnull)) inline static bool
+ prefer_render_ring(struct sna *sna, struct kgem_bo *bo)
+ {
+ 	if (sna->kgem.ring == KGEM_RENDER)
+@@ -191,7 +191,7 @@ prefer_blt_composite(struct sna *sna, struct sna_composite_op *tmp)
+ 	return prefer_blt_bo(sna, tmp->src.bo, tmp->dst.bo);
+ }
+ 
+-nonnull static inline bool
++__attribute__((nonnull)) static inline bool
+ prefer_blt_fill(struct sna *sna, struct kgem_bo *bo, unsigned flags)
+ {
+ 	if (PREFER_RENDER)
+-- 
+2.16.2
+
diff --git a/SOURCES/0001-Fix-build-on-i686.patch b/SOURCES/0001-Fix-build-on-i686.patch
new file mode 100644
index 0000000..0851fbe
--- /dev/null
+++ b/SOURCES/0001-Fix-build-on-i686.patch
@@ -0,0 +1,49 @@
+From a414d4e24461da1cb4cef8ee910bc57bab360ceb Mon Sep 17 00:00:00 2001
+From: Adam Jackson <ajax@redhat.com>
+Date: Tue, 6 Mar 2018 12:07:46 -0500
+Subject: [PATCH] Fix build on i686
+
+Presumably this only matters for i686 because amd64 implies sse2, but:
+
+BUILDSTDERR: In file included from gen4_vertex.c:34:
+BUILDSTDERR: gen4_vertex.c: In function 'emit_vertex':
+BUILDSTDERR: sna_render_inline.h:40:26: error: inlining failed in call to always_inline 'vertex_emit_2s': target specific option mismatch
+BUILDSTDERR:  static force_inline void vertex_emit_2s(struct sna *sna, int16_t x, int16_t y)
+BUILDSTDERR:                           ^~~~~~~~~~~~~~
+BUILDSTDERR: gen4_vertex.c:308:25: note: called from here
+BUILDSTDERR:  #define OUT_VERTEX(x,y) vertex_emit_2s(sna, x,y) /* XXX assert(!too_large(x, y)); */
+BUILDSTDERR:                          ^~~~~~~~~~~~~~~~~~~~~~~~
+BUILDSTDERR: gen4_vertex.c:360:2: note: in expansion of macro 'OUT_VERTEX'
+BUILDSTDERR:   OUT_VERTEX(dstX, dstY);
+BUILDSTDERR:   ^~~~~~~~~~
+
+The bug here appears to be that emit_vertex() is declared 'sse2' but
+vertex_emit_2s is merely always_inline. gcc8 decides that since you said
+always_inline you need to have explicitly cloned it for every
+permutation of targets. Merely saying inline seems to do the job of
+cloning vertex_emit_2s as much as necessary.
+
+So to reiterate: if you say always-inline, it won't, but if you just say
+maybe inline, it will. Thanks gcc, that's helpful.
+
+- ajax
+---
+ src/sna/compiler.h | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/sna/compiler.h b/src/sna/compiler.h
+index 3c176a16..bc447c7a 100644
+--- a/src/sna/compiler.h
++++ b/src/sna/compiler.h
+@@ -32,7 +32,7 @@
+ #define likely(expr) (__builtin_expect (!!(expr), 1))
+ #define unlikely(expr) (__builtin_expect (!!(expr), 0))
+ #define noinline __attribute__((noinline))
+-#define force_inline inline __attribute__((always_inline))
++#define force_inline inline
+ #define fastcall __attribute__((regparm(3)))
+ #define must_check __attribute__((warn_unused_result))
+ #define constant __attribute__((const))
+-- 
+2.16.2
+
diff --git a/SOURCES/0001-sna-Avoid-clobbering-output-physical-size-with-xf86O.patch b/SOURCES/0001-sna-Avoid-clobbering-output-physical-size-with-xf86O.patch
new file mode 100644
index 0000000..cb279a7
--- /dev/null
+++ b/SOURCES/0001-sna-Avoid-clobbering-output-physical-size-with-xf86O.patch
@@ -0,0 +1,47 @@
+From 09bf64d69d97172f22fe08eb495bf50f920ae9ec Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Ville=20Syrj=C3=A4l=C3=A4?= <ville.syrjala@linux.intel.com>
+Date: Tue, 31 May 2016 11:11:21 +0300
+Subject: [PATCH] sna: Avoid clobbering output physical size with
+ xf86OutputSetEDID()
+MIME-Version: 1.0
+Content-Type: text/plain; charset=UTF-8
+Content-Transfer-Encoding: 8bit
+
+Signed-off-by: Ville Syrjälä <ville.syrjala@linux.intel.com>
+---
+ src/sna/sna_display.c | 6 ++++++
+ 1 file changed, 6 insertions(+)
+
+diff --git a/src/sna/sna_display.c b/src/sna/sna_display.c
+index 10d33f2..57de410 100644
+--- a/src/sna/sna_display.c
++++ b/src/sna/sna_display.c
+@@ -3576,6 +3576,7 @@ sna_output_attach_edid(xf86OutputPtr output)
+ {
+ 	struct sna *sna = to_sna(output->scrn);
+ 	struct sna_output *sna_output = output->driver_private;
++	unsigned old_mm_width, old_mm_height;
+ 	struct drm_mode_get_blob blob;
+ 	void *old, *raw = NULL;
+ 	xf86MonPtr mon = NULL;
+@@ -3678,12 +3679,17 @@ skip_read:
+ 	}
+ 
+ done:
++	output = sna_output->base;
++	old_mm_width = output->mm_width;
++	old_mm_height = output->mm_height;
+ 	sna_output_set_parsed_edid(output, mon);
+ 	if (raw) {
+ 		sna_output->edid_raw = raw;
+ 		sna_output->edid_len = blob.length;
+ 		sna_output->edid_blob_id = blob.blob_id;
+ 	}
++	output->mm_width = old_mm_width;
++	output->mm_height = old_mm_height;
+ }
+ 
+ static void
+-- 
+2.7.4
+
diff --git a/SOURCES/igt-stat.patch b/SOURCES/igt-stat.patch
new file mode 100644
index 0000000..1465f62
--- /dev/null
+++ b/SOURCES/igt-stat.patch
@@ -0,0 +1,11 @@
+diff -up intel-gpu-tools-1.9/tests/testdisplay_hotplug.c.jx intel-gpu-tools-1.9/tests/testdisplay_hotplug.c
+--- intel-gpu-tools-1.9/tests/testdisplay_hotplug.c.jx	2014-12-12 11:08:14.000000000 -0500
++++ intel-gpu-tools-1.9/tests/testdisplay_hotplug.c	2015-06-03 15:43:55.127775543 -0400
+@@ -24,6 +24,7 @@
+ #include <stdio.h>
+ #include <string.h>
+ #include <stdlib.h>
++#include <sys/stat.h>
+ 
+ #include "testdisplay.h"
+ #ifdef HAVE_CONFIG_H
diff --git a/SOURCES/intel-gcc-pr65873.patch b/SOURCES/intel-gcc-pr65873.patch
new file mode 100644
index 0000000..ed05bce
--- /dev/null
+++ b/SOURCES/intel-gcc-pr65873.patch
@@ -0,0 +1,12 @@
+diff -up xf86-video-intel-20150520/src/sna/compiler.h.jx xf86-video-intel-20150520/src/sna/compiler.h
+--- xf86-video-intel-20150520/src/sna/compiler.h.jx	2015-05-19 07:44:26.000000000 -0400
++++ xf86-video-intel-20150520/src/sna/compiler.h	2015-05-20 12:53:54.797918726 -0400
+@@ -64,7 +64,7 @@
+ #endif
+ 
+ #if HAS_GCC(4, 6) && defined(__OPTIMIZE__)
+-#define fast __attribute__((optimize("Ofast")))
++#define fast __attribute__((optimize("O3")))
+ #else
+ #define fast
+ #endif
diff --git a/SOURCES/make-git-snapshot.sh b/SOURCES/make-git-snapshot.sh
new file mode 100755
index 0000000..4d1ec9f
--- /dev/null
+++ b/SOURCES/make-git-snapshot.sh
@@ -0,0 +1,22 @@
+#!/bin/sh
+
+# Usage: ./make-git-snapshot.sh [COMMIT]
+#
+# to make a snapshot of the given tag/branch.  Defaults to HEAD.
+# Point env var REF to a local mesa repo to reduce clone time.
+
+DIRNAME=xf86-video-intel-$( date +%Y%m%d )
+
+echo REF ${REF:+--reference $REF}
+echo DIRNAME $DIRNAME
+echo HEAD ${1:-HEAD}
+
+rm -rf $DIRNAME
+
+git clone ${REF:+--reference $REF} \
+	git://git.freedesktop.org/git/xorg/driver/xf86-video-intel $DIRNAME
+
+GIT_DIR=$DIRNAME/.git git archive --format=tar --prefix=$DIRNAME/ ${1:-HEAD} \
+	| bzip2 > $DIRNAME.tar.bz2
+
+# rm -rf $DIRNAME
diff --git a/SOURCES/make-intel-gpu-tools-snapshot.sh b/SOURCES/make-intel-gpu-tools-snapshot.sh
new file mode 100755
index 0000000..20416bc
--- /dev/null
+++ b/SOURCES/make-intel-gpu-tools-snapshot.sh
@@ -0,0 +1,22 @@
+#!/bin/sh
+
+# Usage: ./make-git-snapshot.sh [COMMIT]
+#
+# to make a snapshot of the given tag/branch.  Defaults to HEAD.
+# Point env var REF to a local mesa repo to reduce clone time.
+
+DIRNAME=intel-gpu-tools-$( date +%Y%m%d )
+
+echo REF ${REF:+--reference $REF}
+echo DIRNAME $DIRNAME
+echo HEAD ${1:-HEAD}
+
+rm -rf $DIRNAME
+
+git clone --depth 1 ${REF:+--reference $REF} \
+	git://git.freedesktop.org/git/xorg/app/intel-gpu-tools $DIRNAME
+
+GIT_DIR=$DIRNAME/.git git archive --format=tar --prefix=$DIRNAME/ ${1:-HEAD} \
+	| bzip2 > $DIRNAME.tar.bz2
+
+# rm -rf $DIRNAME
diff --git a/SPECS/xorg-x11-drv-intel.spec b/SPECS/xorg-x11-drv-intel.spec
new file mode 100644
index 0000000..c60ea6e
--- /dev/null
+++ b/SPECS/xorg-x11-drv-intel.spec
@@ -0,0 +1,541 @@
+%define moduledir %(pkg-config xorg-server --variable=moduledir )
+%define driverdir	%{moduledir}/drivers
+%define gputoolsver 1.9
+%define gitdate 20180618
+%define gitrev .%{gitdate}
+
+%undefine _hardened_build
+
+Summary:   Xorg X11 Intel video driver
+Name:      xorg-x11-drv-intel
+Version:   2.99.917
+Release:   38%{?gitrev}%{?dist}
+URL:       http://www.x.org
+License:   MIT
+Group:     User Interface/X Hardware Support
+
+%if 0%{?gitdate}
+Source0:    xf86-video-intel-%{gitdate}.tar.bz2
+%else
+Source0:    https://xorg.freedesktop.org/archive/individual/driver/xf86-video-intel-%{version}.tar.bz2
+%endif
+Source1:    make-intel-gpu-tools-snapshot.sh
+Source3:    https://xorg.freedesktop.org/archive/individual/app/intel-gpu-tools-%{gputoolsver}.tar.bz2
+Source4:    make-git-snapshot.sh
+
+Patch0:	    intel-gcc-pr65873.patch
+Patch1:     igt-stat.patch
+# https://bugs.freedesktop.org/show_bug.cgi?id=96255#c11
+Patch4:     0001-sna-Avoid-clobbering-output-physical-size-with-xf86O.patch
+Patch5:     0001-Fix-build-on-F28-and-later.patch
+Patch6:     0001-Fix-build-on-i686.patch
+
+ExclusiveArch: %{ix86} x86_64 ia64
+
+BuildRequires: autoconf automake libtool
+BuildRequires: flex bison
+BuildRequires: xorg-x11-server-devel >= 1.10.99.902
+BuildRequires: libX11-devel
+BuildRequires: libXcursor-devel
+BuildRequires: libXdamage-devel
+BuildRequires: libXext-devel
+BuildRequires: libXfixes-devel
+BuildRequires: libXinerama-devel
+BuildRequires: libXrandr-devel
+BuildRequires: libXrender-devel
+BuildRequires: libXtst-devel
+BuildRequires: libXvMC-devel
+BuildRequires: libXfont2-devel
+BuildRequires: mesa-libGL-devel >= 6.5-9
+BuildRequires: libdrm-devel >= 2.4.25
+BuildRequires: kernel-headers >= 2.6.32.3
+BuildRequires: libudev-devel
+BuildRequires: libxcb-devel >= 1.5 
+BuildRequires: xcb-util-devel
+BuildRequires: cairo-devel
+BuildRequires: python3
+BuildRequires: libXScrnSaver-devel
+BuildRequires: libXext-devel
+BuildRequires: pixman-devel
+
+Requires: Xorg %(xserver-sdk-abi-requires ansic)
+Requires: Xorg %(xserver-sdk-abi-requires videodrv)
+Requires: polkit
+
+%description 
+X.Org X11 Intel video driver.
+
+%package devel
+Summary:   Xorg X11 Intel video driver development package
+Group:     Development/System
+Requires:  %{name} = %{version}-%{release}
+Provides:  xorg-x11-drv-intel-devel = %{version}-%{release}
+
+%description devel
+X.Org X11 Intel video driver development package.
+
+%package -n intel-gpu-tools
+Summary:    Debugging tools for Intel graphics chips
+Group:	    Development/Tools
+
+%description -n intel-gpu-tools
+Debugging tools for Intel graphics chips
+
+%if 0%{?gitdate}
+%define dirsuffix %{gitdate}
+%else
+%define dirsuffix %{version}
+%endif
+
+%prep
+%setup -q -n xf86-video-intel-%{?gitdate:%{gitdate}}%{!?gitdate:%{dirsuffix}} -b3
+%patch0 -p1 -b .gcc
+%patch4 -p1
+%patch5 -p1
+%patch6 -p1
+
+pushd ../intel-gpu-tools-%{gputoolsver}
+%patch1 -p1 -b .stat
+popd
+
+%build
+autoreconf -f -i -v
+%configure --enable-kms-only --with-default-dri=3 --enable-tools
+make %{?_smp_mflags} V=1
+
+pushd ../intel-gpu-tools-%{gputoolsver}
+touch lib/check-ndebug.h
+mkdir -p m4
+autoreconf -f -i -v
+# --disable-dumper: quick_dump is both not recommended for packaging yet,
+# and requires python3 to build; i'd like to keep this spec valid for rhel6
+# for at least a bit longer
+%configure --disable-dumper
+# some of the sources are in utf-8 and pre-preprocessed by python
+export LANG=en_US.UTF-8
+make %{?_smp_mflags}
+popd
+
+%install
+%make_install
+
+pushd ../intel-gpu-tools-%{gputoolsver}
+make install DESTDIR=$RPM_BUILD_ROOT
+rm -f $RPM_BUILD_ROOT%{_bindir}/eudb
+popd
+
+find $RPM_BUILD_ROOT -regex ".*\.la$" | xargs rm -f --
+
+# libXvMC opens the versioned file name, these are useless
+rm -f $RPM_BUILD_ROOT%{_libdir}/libI*XvMC.so
+
+
+%ldconfig_post
+%ldconfig_postun
+
+%files
+%doc COPYING
+%{driverdir}/intel_drv.so
+%{_libdir}/libIntelXvMC.so.1*
+%{_libexecdir}/xf86-video-intel-backlight-helper
+%{_datadir}/polkit-1/actions/org.x.xf86-video-intel.backlight-helper.policy
+%{_mandir}/man4/i*
+
+%files devel
+%{_bindir}/intel-gen4asm
+%{_bindir}/intel-gen4disasm
+%{_libdir}/pkgconfig/intel-gen4asm.pc
+
+%files -n intel-gpu-tools
+%doc COPYING
+%{_bindir}/gem_userptr_benchmark
+%{_bindir}/intel*
+%exclude %{_bindir}/intel-gen4asm
+%exclude %{_bindir}/intel-gen4disasm
+%{_datadir}/gtk-doc
+%{_mandir}/man1/intel_*.1*
+
+%changelog
+* Fri Jun 29 2018 Adam Jackson <ajax@redhat.com> - 2.99.917-38.20180618
+- Use ldconfig scriptlet macros
+
+* Mon Jun 18 2018 Adam Jackson <ajax@redhat.com> - 2.99.917-37
+- Today's git snapshot (commit 3d395062)
+- Clean up some conditionals
+- Build with python3
+
+* Wed May 30 2018 Adam Jackson <ajax@redhat.com> - 2.99.917-37
+
+* Mon Apr 02 2018 Adam Jackson <ajax@redhat.com> - 2.99.917-36.20171025
+- Rebuild for xserver 1.20
+
+* Sun Mar 18 2018 Iryna Shcherbina <ishcherb@redhat.com> - 2.99.917-35.20171025
+- Update Python 2 dependency declarations to new packaging standards
+  (See https://fedoraproject.org/wiki/FinalizingFedoraSwitchtoPython3)
+
+* Mon Mar 05 2018 Adam Jackson <ajax@redhat.com> - 2.99.917-34
+- Fix build on F28+
+
+* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 2.99.917-33.20171025
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
+
+* Mon Nov 06 2017 Merlin Mathesius <mmathesi@redhat.com> - 2.99.917-32.20171025
+- Cleanup spec file conditionals
+
+* Wed Oct 25 2017 Adam Jackson <ajax@redhat.com> - 2.99.917-31.20171025
+- New git snapshot
+
+* Thu Aug 03 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.99.917-30.20160929
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Binutils_Mass_Rebuild
+
+* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.99.917-29.20160929
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
+
+* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 2.99.917-28.20160929
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
+
+* Tue Jan 10 2017 Hans de Goede <hdegoede@redhat.com> - 2.99.917-27
+- Drop the patch to fail probe on skylake and newer, the xserver now
+  defaults to the modesetting driver for all recent GPUs
+
+* Thu Sep 29 2016 Hans de Goede <hdegoede@redhat.com> - 2.99.917-26
+- Update to latest git master for use with xserver-1.19
+- Rebuild against xserver-1.19
+
+* Wed Jul 20 2016 Bastien Nocera <bnocera@redhat.com> - 2.99.917-25
+- Avoid clobbering output physical size, should fix hidpi on Surface 3
+
+* Tue Jul 12 2016 Hans de Goede <hdegoede@redhat.com> - 2.99.917-24.20160712
+- Git snapshot du jour, bringing in a bunch of bugfixes
+- Fix dpi issues on Surface 3 (also needs some kernel fixes)
+- Hopefully fix rhbz#1354124
+
+* Thu May 12 2016 Hans de Goede <hdegoede@redhat.com> - 2.99.917-23.20160512
+- Update to 20160512 snapshot
+- This fixes laptops with switchable graphics hanging after a dpms off of
+  the lcd screen (rhbz#1334581)
+- Fix fd-leak when falling back to mode-setting on skylake, this fixes
+  Xorg exiting with a "drmSetMaster failed" error when not using server
+  managed fds (e.g. using a different login manager then gdm)
+- Fix duplicate binaries in -devel / intel-gpu-tools subpackages (rhbz#1323641)
+
+* Mon Mar 07 2016 Hans de Goede <hdegoede@redhat.com> - 2.99.917-22.20160119
+- xorg-x11-drv-intel hardly has any accel on skylake and newer, so make
+  Xorg fallback to modesetting + glamor by returning FALSE from probe
+- Using glamor also gives us proper Xvideo support on skylake (rhbz#1305369)
+
+* Fri Feb 05 2016 Fedora Release Engineering <releng@fedoraproject.org> - 2.99.917-21.20160119
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
+
+* Tue Jan 19 2016 Kevin Fenzi <kevin@scrye.com> - 2.99.917-20-20160119
+- Update to 20160119 snapshot
+
+* Sun Dec 06 2015 Adel Gadllah <adel.gadllah@gmail.com> - 2.99.917-19.20151109
+- Update to 20151206 snapshot
+
+* Tue Nov 17 2015 Adel Gadllah <adel.gadllah@gmail.com> - 2.99.917-18.20151109
+- Reenable DRI3 - we ship xserver 1.18 now
+
+* Mon Nov 09 2015 Kevin Fenzi <kevin@scrye.com> - 2.99.917-17.20151109
+- Update to 20151109 snapshot
+
+* Wed Sep 16 2015 Dave Airlie <airlied@redhat.com> - 2.99.917-16.20150729
+- 1.18 ABI rebuild
+
+* Wed Jul 29 2015 Dave Airlie <airlied@redhat.com> 2.99.917-15.20150729
+- update to upstream git snapshot for ABI
+
+* Wed Jul 29 2015 Dave Airlie <airlied@redhat.com> - 2.99.917-14.20150615
+- 1.15 ABI rebuild
+
+* Fri Jun 19 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.99.917-13.20150615
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
+
+* Mon Jun 15 2015 Dave Airlie <airlied@redhat.com> 2.99.917-12
+- you guessed it, git snap of the day
+- this should bring some PRIME corruption fixes.
+
+* Wed Jun 03 2015 Adam Jackson <ajax@redhat.com> 2.99.917-11
+- Today's git snap
+
+* Tue May 26 2015 Dave Airlie <airlied@redhat.com> 2.99.917-10
+- update git snap
+- fixes uninitialised properties crash
+
+* Wed May 20 2015 Adam Jackson <ajax@redhat.com> 2.99.917-9
+- Today's git snap
+- Don't force the default to DRI3, use upstream's preference
+- Fix build failure due to GCC PR65873
+
+* Mon Mar 02 2015 Dave Airlie <airlied@redhat.com> 2.99.917-8
+- this time for sure, now less hardended.
+
+* Mon Mar 02 2015 Dave Airlie <airlied@redhat.com> 2.99.917-7
+- remove cement, X.org drivers aren't hard enough.
+
+* Thu Feb 26 2015 Hans de Goede <hdegoede@redhat.com> - 2.99.917-6
+- Really really build intel-virtual-output (rhbz#1195962)
+
+* Thu Feb 26 2015 Hans de Goede <hdegoede@redhat.com> - 2.99.917-5
+- Add more missing BuildRequires so that intel-virtual-output really gets
+  build (rhbz#1195962)
+
+* Thu Feb 26 2015 Hans de Goede <hdegoede@redhat.com> - 2.99.917-4
+- Add missing BuildRequires libXext-devel so that intel-virtual-output gets
+  build (rhbz#1195962)
+
+* Wed Feb 11 2015 Hans de Goede <hdegoede@redhat.com> - 2.99.917-3
+- Git snapshot of the day to bring in various DPMS and other fixes
+- Update gpu-tools to 1.9
+- Xserver 1.17 ABI rebuild
+
+* Wed Dec 24 2014 Adel Gadllah <adel.gadllah@gmail.com> 2.99.917-2
+- Enable DRI3
+
+* Mon Dec 22 2014 Kevin Fenzi <kevin@scrye.com> 2.99.917-1
+- Update to 2.99.917
+
+* Mon Nov 17 2014 Adam Jackson <ajax@redhat.com> 2.99.916-3
+- Today's git snapshot
+
+* Thu Sep 11 2014 Dave Airlie <airlied@redhat.com> 2.99.916-2
+- backport some SNA and MST fixes.
+
+* Wed Sep 10 2014 Dave Airlie <airlied@redhat.com> 2.99.916-1
+- Rebase to 2.99.916
+
+* Wed Sep 03 2014 Dave Airlie <airlied@redhat.com> 2.99.914-4
+- Add UXA MST support as a fallback
+
+* Tue Sep 02 2014 Adel Gadllah <adel.gadllah@gmail.com> - 2.99.914-3
+- Backport fix for sna to fix broken shadow rendering in gtk
+
+* Mon Aug 18 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.99.914-2
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_22_Mass_Rebuild
+
+* Mon Jul 28 2014 Hans de Goede <hdegoede@redhat.com> - 2.99.914-1
+- Rebase to 2.99.914
+
+* Tue Jul 22 2014 Adel Gadllah <adel.gadllah@gmail.com> - 2.99.912-6
+- Apply fix for sna render corruption due to missing fencing, FDO #81551
+
+* Fri Jul 11 2014 Hans de Goede <hdegoede@redhat.com> - 2.99.912-5
+- Fix a security issue in the backlight helper (CVE-2014-4910)
+
+* Tue Jul  1 2014 Hans de Goede <hdegoede@redhat.com> - 2.99.912-4
+- Re-enable DRI3 support (the latest mesa fixes the gnome-shell hang)
+
+* Wed Jun 18 2014 Hans de Goede <hdegoede@redhat.com> - 2.99.912-3
+- xserver 1.15.99.903 ABI rebuild
+
+* Thu Jun 12 2014 Hans de Goede <hdegoede@redhat.com> - 2.99.912-2
+- DRI3 support causes gnome-shell to hang, disable for now
+
+* Wed Jun 11 2014 Hans de Goede <hdegoede@redhat.com> - 2.99.912-1
+- Rebase to 2.99.912
+- Rebuild for xserver 1.15.99.903
+- Update intel-gpu-tools to 1.7 release
+
+* Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.99.911-3
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
+
+* Mon Apr 28 2014 Hans de Goede <hdegoede@redhat.com> - 2.99.911-2
+- xserver 1.15.99-20140428 git snapshot ABI rebuild
+- Add 2 patches from upstream to not close server-fds of udl devices
+
+* Thu Apr 17 2014 Hans de Goede <hdegoede@redhat.com> - 2.99.911-1
+- Rebase to 2.99.911
+- Rebuild for xserver 1.15.99.902
+
+* Mon Jan 13 2014 Adam Jackson <ajax@redhat.com> - 2.21.15-13
+- 1.15 ABI rebuild
+
+* Sat Dec 21 2013 Ville Skyttä <ville.skytta@iki.fi> - 2.21.15-12
+- Call ldconfig in %%post* scriptlets.
+
+* Tue Dec 17 2013 Adam Jackson <ajax@redhat.com> - 2.21.15-11
+- 1.15RC4 ABI rebuild
+
+* Wed Nov 20 2013 Adam Jackson <ajax@redhat.com> - 2.21.15-10
+- 1.15RC2 ABI rebuild
+
+* Wed Nov 06 2013 Adam Jackson <ajax@redhat.com> - 2.21.15-9
+- 1.15RC1 ABI rebuild
+
+* Mon Oct 28 2013 Adam Jackson <ajax@redhat.com> - 2.21.15-8
+- Don't patch in xwayland in RHEL
+
+* Fri Oct 25 2013 Adam Jackson <ajax@redhat.com> - 2.21.15-7
+- ABI rebuild
+
+* Thu Oct 24 2013 Adam Jackson <ajax@redhat.com> 2.21.15-6
+- Disable UMS support in F21+
+
+* Thu Oct 24 2013 Adam Jackson <ajax@redhat.com> 2.21.15-5
+- xserver 1.15 API compat
+
+* Wed Oct 02 2013 Adam Jackson <ajax@redhat.com> 2.21.15-4
+- Default to uxa again
+
+* Mon Sep 23 2013 Adam Jackson <ajax@redhat.com> 2.21.15-2
+- Change xwayland requires to be explicitly versioned
+
+* Mon Sep 23 2013 Adam Jackson <ajax@redhat.com> 2.21.15-1
+- intel 2.21.15
+- xwayland support
+
+* Tue Aug 06 2013 Dave Airlie <airlied@redhat.com> 2.21.14-1
+- intel 2.21.24
+- add fix to make build - re-enable autoreconf
+
+* Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.21.12-2
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
+
+* Tue Jul 23 2013 Adam Jackson <ajax@redhat.com> 2.21.12-1
+- intel 2.21.12
+
+* Tue Jun 11 2013 Adam Jackson <ajax@redhat.com> 2.21.9-1
+- intel 2.21.9
+- New i-g-t snapshot
+- Drop useless symlinks from -devel
+- Repurpose -devel for intel-gen4{,dis}asm
+- Default to SNA in F20+
+
+* Tue May 28 2013 Adam Jackson <ajax@redhat.com> 2.21.8-1
+- intel 2.21.8
+
+* Fri Apr 12 2013 Dave Airlie <airlied@redhat.com> 2.21.6-1
+- intel 2.21.6
+
+* Thu Mar 21 2013 Adam Jackson <ajax@redhat.com> 2.21.5-1
+- intel 2.21.5
+
+* Mon Mar 11 2013 Adam Jackson <ajax@redhat.com> 2.21.4-1
+- intel 2.21.4
+
+* Thu Mar 07 2013 Adam Jackson <ajax@redhat.com> 2.21.3-1
+- intel 2.21.3
+
+* Thu Mar 07 2013 Peter Hutterer <peter.hutterer@redhat.com> - 2.21.2-4
+- ABI rebuild
+
+* Fri Feb 15 2013 Peter Hutterer <peter.hutterer@redhat.com> - 2.21.2-3
+- ABI rebuild
+
+* Fri Feb 15 2013 Peter Hutterer <peter.hutterer@redhat.com> - 2.21.2-2
+- ABI rebuild
+
+* Tue Feb 12 2013 Adam Jackson <ajax@redhat.com> 2.21.2-1
+- intel 2.21.2
+- New i-g-t snapshot
+- Pre-F16 changelog trim
+
+* Wed Jan 16 2013 Adam Jackson <ajax@redhat.com> 2.20.18-2
+- Compensate for rawhide's aclocal breaking in a newly stupid way
+
+* Wed Jan 16 2013 Adam Jackson <ajax@redhat.com> 2.20.18-1
+- intel 2.20.18
+
+* Tue Jan 08 2013 Dave Airlie <airlied@redhat.com> 2.20.17-2
+- Fix damage issue for reverse prime work
+
+* Fri Jan 04 2013 Adam Jackson <ajax@redhat.com> 2.20.17-1
+- intel 2.20.17
+
+* Wed Jan 02 2013 Dave Airlie <airlied@redhat.com> 2.20.16-2
+- Fix uxa bug that trips up ilk on 3.7 kernels
+
+* Mon Dec 17 2012 Adam Jackson <ajax@redhat.com> 2.20.16-1
+- intel 2.20.16
+
+* Wed Nov 28 2012 Adam Jackson <ajax@redhat.com> 2.20.14-1
+- intel 2.20.14
+
+* Mon Oct 22 2012 Adam Jackson <ajax@redhat.com> 2.20.12-1
+- intel 2.20.12
+
+* Fri Oct 19 2012 Adam Jackson <ajax@redhat.com> 2.20.10-2
+- Today's i-g-t
+- Don't bother building the nouveau bits of i-g-t on OSes without an X
+  server with prime support.
+
+* Mon Oct 15 2012 Dave Airlie <airlied@redhat.com> 2.20.10-1
+- intel 2.20.10
+
+* Fri Oct 05 2012 Adam Jackson <ajax@redhat.com> 2.20.9-1
+- intel 2.20.9
+- Today's intel-gpu-tools snapshot
+
+* Fri Sep 21 2012 Adam Jackson <ajax@redhat.com> 2.20.8-1
+- intel 2.20.8
+
+* Mon Sep 10 2012 Adam Jackson <ajax@redhat.com> 2.20.7-1
+- intel 2.20.7
+
+* Fri Sep 07 2012 Dave Airlie <airlied@redhat.com> 2.20.6-2
+- latest upstream git snapshot with prime + fixes
+
+* Tue Sep 04 2012 Adam Jackson <ajax@redhat.com> 2.20.6-2
+- Only bother to build UMS (read: i810) support on 32-bit.  If you've
+  managed to build a machine with an i810 GPU but a 64-bit CPU, please
+  don't have done that.
+
+* Tue Sep 04 2012 Adam Jackson <ajax@redhat.com> 2.20.6-1
+- intel 2.20.6 (#853783)
+
+* Thu Aug 30 2012 Adam Jackson <ajax@redhat.com> 2.20.5-2
+- Don't package I810XvMC when not building legacy i810
+
+* Mon Aug 27 2012 Adam Jackson <ajax@redhat.com> 2.20.5-1
+- intel 2.20.5
+
+* Mon Aug 20 2012 Adam Jackson <ajax@redhat.com> 2.20.4-3
+- Rebuild for new xcb-util soname
+
+* Mon Aug 20 2012 Adam Jackson <ajax@redhat.com> 2.20.4-2
+- Backport some patches to avoid binding to non-i915.ko-driven Intel GPUs,
+  like Cedarview and friends (#849475)
+
+* Mon Aug 20 2012 Adam Jackson <ajax@redhat.com> 2.20.4-1
+- intel 2.20.4
+
+* Thu Aug 16 2012 Dave Airlie <airlied@redhat.com> 2.20.3-3
+- fix vmap flush to correct upstream version in prime patch
+
+* Thu Aug 16 2012 Dave Airlie <airlied@redhat.com> 2.20.3-2
+- snapshot upstream + add prime support for now
+
+* Wed Aug 15 2012 Adam Jackson <ajax@redhat.com> 2.20.3-1
+- intel 2.20.3
+
+* Wed Aug 01 2012 Adam Jackson <ajax@redhat.com> 2.20.2-1
+- intel 2.20.2
+- Only disable UMS in RHEL7, since i810 exists in RHEL6
+
+* Mon Jul 23 2012 Adam Jackson <ajax@redhat.com> 2.20.1-1
+- intel 2.20.1
+
+* Sun Jul 22 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 2.20.0-2.20120718
+- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
+
+* Wed Jul 18 2012 Dave Airlie <airlied@redhat.com> 2.20.0-1.20120718
+- todays git snapshot
+
+* Tue Jun 12 2012 Dave Airlie <airlied@redhat.com> 2.19.0-5.20120612
+- today's git snapshot
+- resurrect copy-fb
+
+* Tue May 29 2012 Adam Jackson <ajax@redhat.com> 2.19.0-4.20120529
+- Today's git snapshot
+- Enable SNA (default is still UXA, use Option "AccelMethod" to switch)
+- build-fix.patch: Fix build with Fedora's default cflags
+
+* Tue May 29 2012 Adam Jackson <ajax@redhat.com> 2.19.0-3
+- Don't autoreconf the driver, fixes build on F16.
+
+* Mon May 21 2012 Adam Jackson <ajax@redhat.com> 2.19.0-2
+- Disable UMS support in RHEL.
+- Trim some Requires that haven't been needed since F15.
+
+* Thu May 03 2012 Adam Jackson <ajax@redhat.com> 2.19.0-1
+- intel 2.19.0