c824b770cc
- fbdef-0.4.0-Remove-useless-loader-symbol-lists.patch: fix linker error against X server >= 1.6.99.1
87 lines
2.3 KiB
Diff
87 lines
2.3 KiB
Diff
From 092f0f10cb243ef011a38a92e4eb48d424de80fa Mon Sep 17 00:00:00 2001
|
|
From: Adam Jackson <ajax@redhat.com>
|
|
Date: Sun, 23 Nov 2008 20:04:30 -0500
|
|
Subject: [PATCH] Make ISA optional
|
|
|
|
---
|
|
configure.ac | 8 ++++++++
|
|
src/fbdev.c | 13 ++++++++-----
|
|
2 files changed, 16 insertions(+), 5 deletions(-)
|
|
|
|
diff --git a/configure.ac b/configure.ac
|
|
index ec3d7aa..7e82996 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -59,6 +59,14 @@ XORG_DRIVER_CHECK_EXT(XV, videoproto)
|
|
PKG_CHECK_MODULES(XORG, [xorg-server >= 1.0.99.901 xproto fontsproto $REQUIRED_MODULES])
|
|
sdkdir=$(pkg-config --variable=sdkdir xorg-server)
|
|
|
|
+save_CFLAGS="$CFLAGS"
|
|
+CFLAGS="$XORG_CFLAGS"
|
|
+AC_CHECK_DECL(xf86ConfigIsaEntity,
|
|
+ [AC_DEFINE(HAVE_ISA, 1, [Have ISA support])],
|
|
+ [],
|
|
+ [#include "xf86.h"])
|
|
+CFLAGS="$save_CFLAGS"
|
|
+
|
|
AM_CONDITIONAL(PCIACCESS, [test "x$PCIACCESS" = xyes])
|
|
if test "x$PCIACCESS" = xyes; then
|
|
AC_DEFINE(PCIACCESS, 1, [Use libpciaccess])
|
|
diff --git a/src/fbdev.c b/src/fbdev.c
|
|
index df278f5..7f1a749 100644
|
|
--- a/src/fbdev.c
|
|
+++ b/src/fbdev.c
|
|
@@ -373,9 +373,7 @@ FBDevProbe(DriverPtr drv, int flags)
|
|
|
|
for (i = 0; i < numDevSections; i++) {
|
|
Bool isIsa = FALSE;
|
|
-#ifndef XSERVER_LIBPCIACCESS
|
|
Bool isPci = FALSE;
|
|
-#endif
|
|
|
|
dev = xf86FindOptionValue(devSections[i]->options,"fbdev");
|
|
if (devSections[i]->busID) {
|
|
@@ -387,14 +385,18 @@ FBDevProbe(DriverPtr drv, int flags)
|
|
isPci = TRUE;
|
|
} else
|
|
#endif
|
|
+#ifdef HAVE_ISA
|
|
if (xf86ParseIsaBusString(devSections[i]->busID))
|
|
isIsa = TRUE;
|
|
+ else
|
|
+#endif
|
|
+ 0;
|
|
|
|
}
|
|
if (fbdevHWProbe(NULL,dev,NULL)) {
|
|
pScrn = NULL;
|
|
-#ifndef XSERVER_LIBPCIACCESS
|
|
if (isPci) {
|
|
+#ifndef XSERVER_LIBPCIACCESS
|
|
/* XXX what about when there's no busID set? */
|
|
int entity;
|
|
|
|
@@ -410,9 +412,9 @@ FBDevProbe(DriverPtr drv, int flags)
|
|
xf86DrvMsg(pScrn->scrnIndex, X_CONFIG,
|
|
"claimed PCI slot %d:%d:%d\n",bus,device,func);
|
|
|
|
- } else
|
|
#endif
|
|
- if (isIsa) {
|
|
+ } else if (isIsa) {
|
|
+#ifdef HAVE_ISA
|
|
int entity;
|
|
|
|
entity = xf86ClaimIsaSlot(drv, 0,
|
|
@@ -420,6 +422,7 @@ FBDevProbe(DriverPtr drv, int flags)
|
|
pScrn = xf86ConfigIsaEntity(pScrn,0,entity,
|
|
NULL,RES_SHARED_VGA,
|
|
NULL,NULL,NULL,NULL);
|
|
+#endif
|
|
} else {
|
|
int entity;
|
|
|
|
--
|
|
1.6.3.rc1.2.g0164.dirty
|
|
|