New upstream release 0.7.3
- Fix undefined symbol error with xserver-1.19 (rhbz#1393114)
This commit is contained in:
parent
d65816258d
commit
579909d437
1
.gitignore
vendored
1
.gitignore
vendored
@ -1,3 +1,4 @@
|
||||
xf86-video-dummy-0.3.4.tar.bz2
|
||||
/xf86-video-dummy-0.3.5.tar.bz2
|
||||
/xf86-video-dummy-0.3.6.tar.bz2
|
||||
/xf86-video-dummy-0.3.7.tar.bz2
|
||||
|
@ -1,35 +0,0 @@
|
||||
From 44f04fd3046043ed31369025f34353c4e0e5c1cd Mon Sep 17 00:00:00 2001
|
||||
From: Adam Jackson <ajax@redhat.com>
|
||||
Date: Tue, 25 Sep 2012 08:54:36 -0400
|
||||
Subject: [PATCH] Remove mibstore.h
|
||||
|
||||
Signed-off-by: Adam Jackson <ajax@redhat.com>
|
||||
---
|
||||
src/dummy_driver.c | 4 ----
|
||||
1 file changed, 4 deletions(-)
|
||||
|
||||
diff --git a/src/dummy_driver.c b/src/dummy_driver.c
|
||||
index 62066d6..6062c39 100644
|
||||
--- a/src/dummy_driver.c
|
||||
+++ b/src/dummy_driver.c
|
||||
@@ -14,9 +14,6 @@
|
||||
/* All drivers initialising the SW cursor need this */
|
||||
#include "mipointer.h"
|
||||
|
||||
-/* All drivers implementing backing store need this */
|
||||
-#include "mibstore.h"
|
||||
-
|
||||
/* All drivers using the mi colormap manipulation need this */
|
||||
#include "micmap.h"
|
||||
|
||||
@@ -617,7 +614,6 @@ DUMMYScreenInit(SCREEN_INIT_ARGS_DECL)
|
||||
, lines - pScrn->virtualY);
|
||||
}
|
||||
|
||||
- miInitializeBackingStore(pScreen);
|
||||
xf86SetBackingStore(pScreen);
|
||||
xf86SetSilkenMouse(pScreen);
|
||||
|
||||
--
|
||||
1.8.0.2
|
||||
|
33
0001-Switch-to-using-dixChangeWindowProperty.patch
Normal file
33
0001-Switch-to-using-dixChangeWindowProperty.patch
Normal file
@ -0,0 +1,33 @@
|
||||
From 8706f60ab457867c120dd44e812b8fadc2be7179 Mon Sep 17 00:00:00 2001
|
||||
From: Peter Hutterer <peter.hutterer@who-t.net>
|
||||
Date: Thu, 14 Jan 2016 10:30:40 +1000
|
||||
Subject: [PATCH xf86-video-dummy] Switch to using dixChangeWindowProperty
|
||||
|
||||
eb36924ead40564325aa56d54a973dc8fb4eae83 removed ChangeWindowProperty from the
|
||||
server.
|
||||
|
||||
Signed-off-by: Peter Hutterer <peter.hutterer@who-t.net>
|
||||
Reviewed-by: Jon Turney <jon.turney@dronecode.org.uk>
|
||||
---
|
||||
src/dummy_driver.c | 5 +++--
|
||||
1 file changed, 3 insertions(+), 2 deletions(-)
|
||||
|
||||
diff --git a/src/dummy_driver.c b/src/dummy_driver.c
|
||||
index 470e125..9d4d5bf 100644
|
||||
--- a/src/dummy_driver.c
|
||||
+++ b/src/dummy_driver.c
|
||||
@@ -790,8 +790,9 @@ DUMMYCreateWindow(WindowPtr pWin)
|
||||
if (! ValidAtom(VFB_PROP))
|
||||
VFB_PROP = MakeAtom(VFB_PROP_NAME, strlen(VFB_PROP_NAME), 1);
|
||||
|
||||
- ret = ChangeWindowProperty(pWinRoot, VFB_PROP, XA_STRING,
|
||||
- 8, PropModeReplace, (int)4, (pointer)"TRUE", FALSE);
|
||||
+ ret = dixChangeWindowProperty(serverClient, pWinRoot, VFB_PROP,
|
||||
+ XA_STRING, 8, PropModeReplace,
|
||||
+ (int)4, (pointer)"TRUE", FALSE);
|
||||
if( ret != Success)
|
||||
ErrorF("Could not set VFB root window property");
|
||||
dPtr->prop = TRUE;
|
||||
--
|
||||
2.9.3
|
||||
|
2
sources
2
sources
@ -1 +1 @@
|
||||
dc40aebf031f933523dcf101befe99e4 xf86-video-dummy-0.3.6.tar.bz2
|
||||
071e408461f2fec1764723474fbafdf4 xf86-video-dummy-0.3.7.tar.bz2
|
||||
|
@ -1,19 +1,19 @@
|
||||
%global tarball xf86-video-dummy
|
||||
%global moduledir %(pkg-config xorg-server --variable=moduledir )
|
||||
%global driverdir %{moduledir}/drivers
|
||||
%global driverdir %{moduledir}/drivers
|
||||
|
||||
%undefine _hardened_build
|
||||
|
||||
Summary: Xorg X11 dummy video driver
|
||||
Name: xorg-x11-drv-dummy
|
||||
Version: 0.3.6
|
||||
Release: 26%{?dist}
|
||||
Version: 0.3.7
|
||||
Release: 1%{?dist}
|
||||
URL: http://www.x.org
|
||||
License: MIT
|
||||
Group: User Interface/X Hardware Support
|
||||
|
||||
Source0: ftp://ftp.x.org/pub/individual/driver/%{tarball}-%{version}.tar.bz2
|
||||
Patch0: 0001-Remove-mibstore.h.patch
|
||||
Patch0: 0001-Switch-to-using-dixChangeWindowProperty.patch
|
||||
|
||||
ExcludeArch: s390 s390x
|
||||
|
||||
@ -28,29 +28,29 @@ X.Org X11 dummy video driver.
|
||||
|
||||
%prep
|
||||
%setup -q -n %{tarball}-%{version}
|
||||
%patch0 -p1 -b .mibstore
|
||||
%patch0 -p1
|
||||
autoreconf -vif
|
||||
|
||||
%build
|
||||
autoreconf -vif
|
||||
%configure --disable-static
|
||||
make
|
||||
%make_build
|
||||
|
||||
%install
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
make install DESTDIR=$RPM_BUILD_ROOT
|
||||
%make_install
|
||||
|
||||
# FIXME: Remove all libtool archives (*.la) from modules directory. This
|
||||
# should be fixed in upstream Makefile.am or whatever.
|
||||
find $RPM_BUILD_ROOT -regex ".*\.la$" | xargs rm -f --
|
||||
|
||||
%clean
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
%files
|
||||
%doc README
|
||||
%{driverdir}/dummy_drv.so
|
||||
|
||||
%changelog
|
||||
* Wed Nov 9 2016 Hans de Goede <hdegoede@redhat.com> - 0.3.7-1
|
||||
- New upstream release 0.7.3
|
||||
- Fix undefined symbol error with xserver-1.19 (rhbz#1393114)
|
||||
|
||||
* Thu Sep 29 2016 Hans de Goede <hdegoede@redhat.com> - 0.3.6-26
|
||||
- Rebuild against xserver-1.19
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user