Fix handling of packages with dots in groupId
- Previous versions also fixed bug #948731
This commit is contained in:
parent
73a52360f1
commit
7d4c2bfd08
34
0002-Implement-desired-handling-dots-in-JPP-groupId.patch
Normal file
34
0002-Implement-desired-handling-dots-in-JPP-groupId.patch
Normal file
@ -0,0 +1,34 @@
|
||||
From 21994e6933147073498f5609834329e848a1cf99 Mon Sep 17 00:00:00 2001
|
||||
From: Mikolaj Izdebski <mizdebsk@redhat.com>
|
||||
Date: Fri, 31 May 2013 16:13:58 +0200
|
||||
Subject: [PATCH 2/2] Implement desired handling dots in JPP groupId
|
||||
|
||||
---
|
||||
.../src/main/java/org/fedoraproject/maven/repository/Layout.java | 7 ++++++-
|
||||
1 file changed, 6 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/xmvn-core/src/main/java/org/fedoraproject/maven/repository/Layout.java b/xmvn-core/src/main/java/org/fedoraproject/maven/repository/Layout.java
|
||||
index 3d8c7a5..23cb006 100644
|
||||
--- a/xmvn-core/src/main/java/org/fedoraproject/maven/repository/Layout.java
|
||||
+++ b/xmvn-core/src/main/java/org/fedoraproject/maven/repository/Layout.java
|
||||
@@ -105,11 +105,16 @@ public enum Layout
|
||||
path.append( groupId.replace( '/', '.' ) );
|
||||
path.append( '-' );
|
||||
}
|
||||
- else
|
||||
+ else if ( deep )
|
||||
{
|
||||
path.append( groupId.replace( '.', '/' ) );
|
||||
path.append( '/' );
|
||||
}
|
||||
+ else
|
||||
+ {
|
||||
+ path.append( groupId );
|
||||
+ path.append( '/' );
|
||||
+ }
|
||||
}
|
||||
|
||||
path.append( artifactId );
|
||||
--
|
||||
1.8.1.4
|
||||
|
11
xmvn.spec
11
xmvn.spec
@ -1,6 +1,6 @@
|
||||
Name: xmvn
|
||||
Version: 0.5.0
|
||||
Release: 3%{?dist}
|
||||
Release: 4%{?dist}
|
||||
Summary: Local Extensions for Apache Maven
|
||||
License: ASL 2.0
|
||||
URL: http://mizdebsk.fedorapeople.org/xmvn
|
||||
@ -10,6 +10,10 @@ Source0: https://fedorahosted.org/released/%{name}/%{name}-%{version}.tar
|
||||
# from upstream commit ccc197d to fix NPE
|
||||
Patch0: 0001-Be-careful-when-unboxing-Boolean-that-can-be-null.patch
|
||||
|
||||
# from upstream commit f62ca1f to fix handling of packages with dots in groupid
|
||||
Patch1: 0002-Implement-desired-handling-dots-in-JPP-groupId.patch
|
||||
|
||||
|
||||
BuildRequires: maven-local
|
||||
BuildRequires: beust-jcommander
|
||||
BuildRequires: cglib
|
||||
@ -45,6 +49,7 @@ This package provides %{summary}.
|
||||
%prep
|
||||
%setup -q
|
||||
%patch0 -p1
|
||||
%patch1 -p1
|
||||
|
||||
# Add cglib test dependency as a workaround for rhbz#911365
|
||||
%pom_add_dep cglib:cglib::test %{name}-core
|
||||
@ -133,6 +138,10 @@ end
|
||||
%doc LICENSE NOTICE
|
||||
|
||||
%changelog
|
||||
* Fri May 31 2013 Stanislav Ochotnicky <sochotnicky@redhat.com> - 0.5.0-4
|
||||
- Fix handling of packages with dots in groupId
|
||||
- Previous versions also fixed bug #948731
|
||||
|
||||
* Tue May 28 2013 Stanislav Ochotnicky <sochotnicky@redhat.com> - 0.5.0-3
|
||||
- Move pre scriptlet to pretrans and implement in lua
|
||||
|
||||
|
Loading…
Reference in New Issue
Block a user