Import from Fedora
This commit is contained in:
commit
dd9d60f77e
1
.fmf/version
Normal file
1
.fmf/version
Normal file
@ -0,0 +1 @@
|
||||
1
|
16
.gitignore
vendored
Normal file
16
.gitignore
vendored
Normal file
@ -0,0 +1,16 @@
|
||||
/results_*
|
||||
/*.src.rpm
|
||||
|
||||
/xmlunit1.0.zip
|
||||
/xmlunit-1.3-src.zip
|
||||
/xmlunit-1.4-src.zip
|
||||
/xmlunit-1.5-src.zip
|
||||
/xmlunit-1.6-src.zip
|
||||
/xmlunit-2.6.2-src.tar.gz
|
||||
/xmlunit-2.6.3-src.tar.gz
|
||||
/xmlunit-2.7.0-src.tar.gz
|
||||
/xmlunit-2.8.2-src.tar.gz
|
||||
/xmlunit-2.8.2.tar.gz
|
||||
/xmlunit-2.9.0.tar.gz
|
||||
/xmlunit-2.9.1.tar.gz
|
||||
/xmlunit-2.10.0.tar.gz
|
67
0001-Disable-tests-requiring-network-access.patch
Normal file
67
0001-Disable-tests-requiring-network-access.patch
Normal file
@ -0,0 +1,67 @@
|
||||
From e481d5b31aadaf8c9fc20280665b13ebd74c7d79 Mon Sep 17 00:00:00 2001
|
||||
From: Marian Koncek <mkoncek@redhat.com>
|
||||
Date: Fri, 9 Sep 2022 15:08:45 +0200
|
||||
Subject: [PATCH 1/4] Disable tests requiring network access
|
||||
|
||||
---
|
||||
.../java/org/custommonkey/xmlunit/test_AbstractNodeTester.java | 2 +-
|
||||
.../java/org/custommonkey/xmlunit/test_DifferenceEngine.java | 2 +-
|
||||
.../java/org/custommonkey/xmlunit/test_NewDifferenceEngine.java | 2 +-
|
||||
.../src/test/java/org/custommonkey/xmlunit/test_Validator.java | 2 +-
|
||||
4 files changed, 4 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/xmlunit-legacy/src/test/java/org/custommonkey/xmlunit/test_AbstractNodeTester.java b/xmlunit-legacy/src/test/java/org/custommonkey/xmlunit/test_AbstractNodeTester.java
|
||||
index 3a8ac80..df02659 100644
|
||||
--- a/xmlunit-legacy/src/test/java/org/custommonkey/xmlunit/test_AbstractNodeTester.java
|
||||
+++ b/xmlunit-legacy/src/test/java/org/custommonkey/xmlunit/test_AbstractNodeTester.java
|
||||
@@ -176,7 +176,7 @@ public class test_AbstractNodeTester extends TestCase {
|
||||
}
|
||||
|
||||
// never called as NodeTest directly jumps to the document element
|
||||
- public void testDocumentType() throws Exception {
|
||||
+ public void no_testDocumentType() throws Exception {
|
||||
AbstractNodeTester t = new AbstractNodeTester() { };
|
||||
DocumentType n = XMLUnit
|
||||
.buildControlDocument("<!DOCTYPE Book PUBLIC \"XMLUNIT/TEST/PUB1\" \"../test-resources/Book.dtd\">"
|
||||
diff --git a/xmlunit-legacy/src/test/java/org/custommonkey/xmlunit/test_DifferenceEngine.java b/xmlunit-legacy/src/test/java/org/custommonkey/xmlunit/test_DifferenceEngine.java
|
||||
index 344d66c..35220b8 100644
|
||||
--- a/xmlunit-legacy/src/test/java/org/custommonkey/xmlunit/test_DifferenceEngine.java
|
||||
+++ b/xmlunit-legacy/src/test/java/org/custommonkey/xmlunit/test_DifferenceEngine.java
|
||||
@@ -1020,7 +1020,7 @@ public class test_DifferenceEngine extends TestCase implements DifferenceConstan
|
||||
listener.different);
|
||||
}
|
||||
|
||||
- public void testDoctypeDifferences() throws Exception {
|
||||
+ public void no_testDoctypeDifferences() throws Exception {
|
||||
String control = "<?xml version = \"1.0\" encoding = \"UTF-8\"?>"
|
||||
+ "<!DOCTYPE Book PUBLIC \"XMLUNIT/TEST/PUB1\" \"../test-resources/Book.dtd\">"
|
||||
+ "<Book/>";
|
||||
diff --git a/xmlunit-legacy/src/test/java/org/custommonkey/xmlunit/test_NewDifferenceEngine.java b/xmlunit-legacy/src/test/java/org/custommonkey/xmlunit/test_NewDifferenceEngine.java
|
||||
index 0e23767..526be89 100644
|
||||
--- a/xmlunit-legacy/src/test/java/org/custommonkey/xmlunit/test_NewDifferenceEngine.java
|
||||
+++ b/xmlunit-legacy/src/test/java/org/custommonkey/xmlunit/test_NewDifferenceEngine.java
|
||||
@@ -567,7 +567,7 @@ public class test_NewDifferenceEngine extends TestCase implements DifferenceCons
|
||||
listener.different);
|
||||
}
|
||||
|
||||
- public void testDoctypeDifferences() throws Exception {
|
||||
+ public void no_testDoctypeDifferences() throws Exception {
|
||||
String control = "<?xml version = \"1.0\" encoding = \"UTF-8\"?>"
|
||||
+ "<!DOCTYPE Book PUBLIC \"XMLUNIT/TEST/PUB1\" \"../test-resources/Book.dtd\">"
|
||||
+ "<Book/>";
|
||||
diff --git a/xmlunit-legacy/src/test/java/org/custommonkey/xmlunit/test_Validator.java b/xmlunit-legacy/src/test/java/org/custommonkey/xmlunit/test_Validator.java
|
||||
index ad63592..cfcc5e2 100644
|
||||
--- a/xmlunit-legacy/src/test/java/org/custommonkey/xmlunit/test_Validator.java
|
||||
+++ b/xmlunit-legacy/src/test/java/org/custommonkey/xmlunit/test_Validator.java
|
||||
@@ -57,7 +57,7 @@ public class test_Validator extends XMLTestCase {
|
||||
private Validator validator;
|
||||
private File tempDTDFile;
|
||||
|
||||
- public void testXSchema() throws Exception{
|
||||
+ public void no_testXSchema() throws Exception{
|
||||
File xsdFile = new File(test_Constants.TEST_RESOURCE_DIR + "Book.xsd");
|
||||
assertTrue("xsdFile " + xsdFile.getAbsolutePath() + " exists",
|
||||
xsdFile.exists());
|
||||
--
|
||||
2.46.0
|
||||
|
50
0002-Use-local-schema.patch
Normal file
50
0002-Use-local-schema.patch
Normal file
@ -0,0 +1,50 @@
|
||||
From b5dfe90a1f5ccc2a49d24bbb327c549b5fb85080 Mon Sep 17 00:00:00 2001
|
||||
From: Marian Koncek <mkoncek@redhat.com>
|
||||
Date: Mon, 26 Sep 2022 12:28:11 +0200
|
||||
Subject: [PATCH 2/4] Use local schema
|
||||
|
||||
---
|
||||
test-resources/BookXsdGenerated.xml | 2 +-
|
||||
test-resources/BookXsdGeneratedWithComment.xml | 2 +-
|
||||
test-resources/invalidBook.xml | 4 ++--
|
||||
3 files changed, 4 insertions(+), 4 deletions(-)
|
||||
|
||||
diff --git a/test-resources/BookXsdGenerated.xml b/test-resources/BookXsdGenerated.xml
|
||||
index 1f55b93..2f09a58 100644
|
||||
--- a/test-resources/BookXsdGenerated.xml
|
||||
+++ b/test-resources/BookXsdGenerated.xml
|
||||
@@ -1,5 +1,5 @@
|
||||
<?xml version="1.0" encoding="UTF-8"?>
|
||||
-<Book xmlns:xsd="http://www.w3.org/2000/10/XMLSchema" xmlns="https://www.xmlunit.org/publishing" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="https://www.xmlunit.org/publishing https://www.xmlunit.org/test-support/Book.xsd">
|
||||
+<Book xmlns:xsd="http://www.w3.org/2000/10/XMLSchema" xmlns="https://www.xmlunit.org/publishing" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="https://www.xmlunit.org/publishing Book.xsd">
|
||||
<Title>Chicken Soup for the Soul</Title>
|
||||
<Author>Jack Canfield</Author>
|
||||
<Author>Mark Victor Hansen</Author>
|
||||
diff --git a/test-resources/BookXsdGeneratedWithComment.xml b/test-resources/BookXsdGeneratedWithComment.xml
|
||||
index e6f0364..d64500d 100644
|
||||
--- a/test-resources/BookXsdGeneratedWithComment.xml
|
||||
+++ b/test-resources/BookXsdGeneratedWithComment.xml
|
||||
@@ -1,6 +1,6 @@
|
||||
<?xml version="1.0" encoding="UTF-8"?>
|
||||
<!-- this is a comment -->
|
||||
-<Book xmlns:xsd="http://www.w3.org/2000/10/XMLSchema" xmlns="https://www.xmlunit.org/publishing" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="https://www.xmlunit.org/publishing https://raw.githubusercontent.com/xmlunit/test-resources/main/Book.xsd">
|
||||
+<Book xmlns:xsd="http://www.w3.org/2000/10/XMLSchema" xmlns="https://www.xmlunit.org/publishing" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="https://www.xmlunit.org/publishing Book.xsd">
|
||||
<Title>Chicken Soup for the Soul</Title>
|
||||
<Author>Jack Canfield</Author>
|
||||
<Author>Mark Victor Hansen</Author>
|
||||
diff --git a/test-resources/invalidBook.xml b/test-resources/invalidBook.xml
|
||||
index 1d50d5c..5858d00 100644
|
||||
--- a/test-resources/invalidBook.xml
|
||||
+++ b/test-resources/invalidBook.xml
|
||||
@@ -1,6 +1,6 @@
|
||||
<?xml version="1.0" encoding="UTF-8"?>
|
||||
-<Book xmlns:xsd="http://www.w3.org/2000/10/XMLSchema"
|
||||
- xmlns="https://www.xmlunit.org/publishing" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="https://www.xmlunit.org/publishing https://raw.githubusercontent.com/xmlunit/test-resources/main/Book.xsd">
|
||||
+<Book xmlns:xsd="http://www.w3.org/2000/10/XMLSchema"
|
||||
+ xmlns="https://www.xmlunit.org/publishing" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xsi:schemaLocation="https://www.xmlunit.org/publishing Book.xsd">
|
||||
<Title>Chicken Soup for the Soul</Title>
|
||||
<Author>Jack Canfield</Author>
|
||||
<Author>Mark Victor Hansen</Author>
|
||||
--
|
||||
2.46.0
|
||||
|
60
0003-Drop-support-for-JAXB.patch
Normal file
60
0003-Drop-support-for-JAXB.patch
Normal file
@ -0,0 +1,60 @@
|
||||
From 34dc88688ce38468746d1e190a75931225ace80b Mon Sep 17 00:00:00 2001
|
||||
From: Mikolaj Izdebski <mizdebsk@redhat.com>
|
||||
Date: Tue, 5 Nov 2019 12:14:08 +0100
|
||||
Subject: [PATCH 3/4] Drop support for JAXB
|
||||
|
||||
---
|
||||
xmlunit-core/src/main/java/org/xmlunit/builder/Input.java | 4 ++--
|
||||
.../src/test/java/org/xmlunit/builder/InputTest.java | 7 -------
|
||||
2 files changed, 2 insertions(+), 9 deletions(-)
|
||||
|
||||
diff --git a/xmlunit-core/src/main/java/org/xmlunit/builder/Input.java b/xmlunit-core/src/main/java/org/xmlunit/builder/Input.java
|
||||
index a7a23ee..6f91f32 100644
|
||||
--- a/xmlunit-core/src/main/java/org/xmlunit/builder/Input.java
|
||||
+++ b/xmlunit-core/src/main/java/org/xmlunit/builder/Input.java
|
||||
@@ -162,8 +162,8 @@ public class Input {
|
||||
* @param jaxbObject the object to use as source
|
||||
* @return a new builder
|
||||
*/
|
||||
- public static JaxbBuilder fromJaxb(Object jaxbObject) {
|
||||
- return JaxbBuilderFactoryLocator.getFactory().create(jaxbObject);
|
||||
+ public static Builder fromJaxb(Object jaxbObject) {
|
||||
+ throw new RuntimeException("This implementation has JAXB support removed");
|
||||
}
|
||||
|
||||
/**
|
||||
diff --git a/xmlunit-core/src/test/java/org/xmlunit/builder/InputTest.java b/xmlunit-core/src/test/java/org/xmlunit/builder/InputTest.java
|
||||
index e767f38..98e3fe7 100644
|
||||
--- a/xmlunit-core/src/test/java/org/xmlunit/builder/InputTest.java
|
||||
+++ b/xmlunit-core/src/test/java/org/xmlunit/builder/InputTest.java
|
||||
@@ -31,7 +31,6 @@ import org.w3c.dom.Document;
|
||||
import org.xmlunit.NullNode;
|
||||
import org.xmlunit.TestResources;
|
||||
import org.xmlunit.XMLUnitException;
|
||||
-import org.xmlunit.builder.jaxb.ComplexNode;
|
||||
import org.xmlunit.util.Convert;
|
||||
import org.xmlunit.xpath.JAXPXPathEngine;
|
||||
|
||||
@@ -132,10 +131,6 @@ public class InputTest {
|
||||
allIsWellFor(s, "furry");
|
||||
}
|
||||
|
||||
- @Test public void shouldParseJaxbObject() throws Exception {
|
||||
- allIsWellFor(Input.fromJaxb(new ComplexNode()).build(), "complexNode");
|
||||
- }
|
||||
-
|
||||
@Test public void shouldParseUnknownToSource() throws Exception {
|
||||
// from Source
|
||||
allIsWellFor(Input.from(Input.fromByteArray(readTestFile()).build()).build());
|
||||
@@ -153,8 +148,6 @@ public class InputTest {
|
||||
allIsWellFor(Input.from(new URI("file:" + TestResources.ANIMAL_FILE)).build());
|
||||
// from URL
|
||||
allIsWellFor(Input.from(new URL("file:" + TestResources.ANIMAL_FILE)).build());
|
||||
- // from Jaxb-Object
|
||||
- allIsWellFor(Input.from(new ComplexNode()).build(), "complexNode");
|
||||
// from InputStream
|
||||
try (FileInputStream is = new FileInputStream(TestResources.ANIMAL_FILE)) {
|
||||
allIsWellFor(Input.from(is).build());
|
||||
--
|
||||
2.46.0
|
||||
|
31
0004-Port-to-assertj-core-3.patch
Normal file
31
0004-Port-to-assertj-core-3.patch
Normal file
@ -0,0 +1,31 @@
|
||||
From a5449bbe527fcafa8a5a8b31a30724a7a2122d96 Mon Sep 17 00:00:00 2001
|
||||
From: Marian Koncek <mkoncek@redhat.com>
|
||||
Date: Mon, 26 Sep 2022 13:53:53 +0200
|
||||
Subject: [PATCH 4/4] Port to assertj-core 3
|
||||
|
||||
---
|
||||
.../src/test/java/org/xmlunit/assertj3/ValueAssertTest.java | 5 ++++-
|
||||
1 file changed, 4 insertions(+), 1 deletion(-)
|
||||
|
||||
diff --git a/xmlunit-assertj3/src/test/java/org/xmlunit/assertj3/ValueAssertTest.java b/xmlunit-assertj3/src/test/java/org/xmlunit/assertj3/ValueAssertTest.java
|
||||
index fa12a7f..6e7bb55 100644
|
||||
--- a/xmlunit-assertj3/src/test/java/org/xmlunit/assertj3/ValueAssertTest.java
|
||||
+++ b/xmlunit-assertj3/src/test/java/org/xmlunit/assertj3/ValueAssertTest.java
|
||||
@@ -283,10 +283,13 @@ public class ValueAssertTest {
|
||||
|
||||
thrown.expectAssertionErrorPattern(".*("
|
||||
// AssertJ 3.18.1
|
||||
- + Pattern.quote("expected:<\"[something]\"> but was:<\"[abc]\">")
|
||||
+ + Pattern.quote("expected: \"something\"\nbut was : \"abc\"")
|
||||
+ "|"
|
||||
// AssertJ 3.19.0+
|
||||
+ Pattern.quote("Expecting:\n <\"abc\">\nto be equal to:\n <\"something\">\nbut was not.")
|
||||
+ + "|"
|
||||
+ // AssertJ 3.23.0+
|
||||
+ + Pattern.quote("[XPath \"//a/b/@attr\" evaluated to value] \nexpected: \"something\"\n but was: \"abc\"")
|
||||
+ ")");
|
||||
|
||||
String xml = "<a><b attr=\"abc\"></b></a>";
|
||||
--
|
||||
2.46.0
|
||||
|
7
gating.yaml
Normal file
7
gating.yaml
Normal file
@ -0,0 +1,7 @@
|
||||
--- !Policy
|
||||
product_versions:
|
||||
- rhel-9
|
||||
decision_contexts:
|
||||
- osci_compose_gate
|
||||
rules:
|
||||
- !PassingTestCaseRule {test_case_name: osci.brew-build./plans/javapackages.functional}
|
20
generate-tarball.sh
Executable file
20
generate-tarball.sh
Executable file
@ -0,0 +1,20 @@
|
||||
#!/bin/bash
|
||||
set -e
|
||||
|
||||
name=xmlunit
|
||||
version="$(sed -n 's/Version:\s*//p' *.spec)"
|
||||
|
||||
# RETRIEVE
|
||||
wget "https://github.com/xmlunit/xmlunit/releases/download/v${version}/${name}-${version}-src.tar.gz" -O "${name}-${version}.orig.tar.gz"
|
||||
|
||||
rm -rf tarball-tmp
|
||||
mkdir tarball-tmp
|
||||
pushd tarball-tmp
|
||||
tar -xf "../${name}-${version}.orig.tar.gz"
|
||||
|
||||
# CLEAN TARBALL
|
||||
rm */GPATH */GRTAGS */GTAGS
|
||||
|
||||
tar -czf "../${name}-${version}.tar.gz" *
|
||||
popd
|
||||
rm -r tarball-tmp "${name}-${version}.orig.tar.gz"
|
7
plans/javapackages.fmf
Normal file
7
plans/javapackages.fmf
Normal file
@ -0,0 +1,7 @@
|
||||
summary: Run javapackages-specific tests
|
||||
discover:
|
||||
how: fmf
|
||||
url: https://src.fedoraproject.org/tests/javapackages
|
||||
ref: c9s
|
||||
execute:
|
||||
how: tmt
|
1
sources
Normal file
1
sources
Normal file
@ -0,0 +1 @@
|
||||
SHA512 (xmlunit-2.10.0.tar.gz) = 71bf82d2cb268378d0fecd13d31d9ecc175adfcfc2fa1e1249070c06940f8c0dbe8cf1679c6f9de2cddc1ba123aa0ef1c21b9a2ab746b78aea3ab4654775408c
|
361
xmlunit.spec
Normal file
361
xmlunit.spec
Normal file
@ -0,0 +1,361 @@
|
||||
%bcond_with bootstrap
|
||||
|
||||
Name: xmlunit
|
||||
Version: 2.10.0
|
||||
Release: 5%{?dist}
|
||||
Summary: Provides classes to do asserts on xml
|
||||
# The whole package is ASL 2.0 except for xmlunit-legacy which is BSD
|
||||
License: Apache-2.0
|
||||
URL: https://www.xmlunit.org/
|
||||
BuildArch: noarch
|
||||
ExclusiveArch: %{java_arches} noarch
|
||||
|
||||
# ./generate-tarball.sh
|
||||
Source0: %{name}-%{version}.tar.gz
|
||||
# Remove bundled binaries which cannot be easily verified for licensing
|
||||
Source1: generate-tarball.sh
|
||||
|
||||
Patch: 0001-Disable-tests-requiring-network-access.patch
|
||||
# This also solves the problem of tests requiring network. The files that would
|
||||
# be fetched are identical to the local file
|
||||
Patch: 0002-Use-local-schema.patch
|
||||
Patch: 0003-Drop-support-for-JAXB.patch
|
||||
Patch: 0004-Port-to-assertj-core-3.patch
|
||||
|
||||
BuildRequires: jurand
|
||||
%if %{with bootstrap}
|
||||
BuildRequires: javapackages-bootstrap
|
||||
%else
|
||||
BuildRequires: maven-local
|
||||
BuildRequires: mvn(junit:junit)
|
||||
BuildRequires: mvn(org.apache.felix:maven-bundle-plugin)
|
||||
BuildRequires: mvn(org.assertj:assertj-core)
|
||||
BuildRequires: mvn(org.hamcrest:hamcrest-core)
|
||||
BuildRequires: mvn(org.hamcrest:hamcrest-library)
|
||||
BuildRequires: mvn(org.mockito:mockito-core)
|
||||
%endif
|
||||
|
||||
%description
|
||||
XMLUnit provides you with the tools to verify the XML you emit is the one you
|
||||
want to create. It provides helpers to validate against an XML Schema, assert
|
||||
the values of XPath queries or compare XML documents against expected outcomes.
|
||||
|
||||
%package javadoc
|
||||
Summary: API documentation for %{name}
|
||||
|
||||
%description javadoc
|
||||
API documentation for %{name}.
|
||||
|
||||
%package assertj
|
||||
Summary: Assertj for %{name}
|
||||
|
||||
%description assertj
|
||||
This package provides %{summary}.
|
||||
|
||||
%package core
|
||||
Summary: Core package for %{name}
|
||||
|
||||
%description core
|
||||
This package provides %{summary}.
|
||||
|
||||
%package legacy
|
||||
Summary: Legacy package for %{name}
|
||||
License: BSD-3-Clause
|
||||
|
||||
%description legacy
|
||||
This package provides %{summary}.
|
||||
|
||||
%package matchers
|
||||
Summary: Matchers for %{name}
|
||||
|
||||
%description matchers
|
||||
This package provides %{summary}.
|
||||
|
||||
%package placeholders
|
||||
Summary: Placeholders for %{name}
|
||||
|
||||
%description placeholders
|
||||
This package provides %{summary}.
|
||||
|
||||
%prep
|
||||
%autosetup -p1 -n %{name}-%{version}-src
|
||||
|
||||
|
||||
rm -r xmlunit-core/src/main/java/org/xmlunit/builder/javax_jaxb\
|
||||
xmlunit-core/src/main/java/org/xmlunit/builder/JaxbBuilderFactory.java\
|
||||
xmlunit-core/src/main/java/org/xmlunit/builder/JaxbBuilderFactoryLocator.java\
|
||||
xmlunit-core/src/test/java/org/xmlunit/builder/javax_jaxb\
|
||||
;
|
||||
|
||||
|
||||
# Port to hamcrest 2.1
|
||||
%java_remove_annotations xmlunit-matchers -p org[.]hamcrest[.]Factory
|
||||
|
||||
%pom_disable_module xmlunit-assertj
|
||||
%pom_disable_module xmlunit-jakarta-jaxb-impl
|
||||
|
||||
%pom_remove_plugin org.codehaus.mojo:buildnumber-maven-plugin
|
||||
%pom_remove_plugin :maven-assembly-plugin
|
||||
%pom_remove_plugin -r :maven-shade-plugin
|
||||
%pom_remove_plugin -r org.cyclonedx:cyclonedx-maven-plugin
|
||||
|
||||
%mvn_alias org.xmlunit:xmlunit-legacy xmlunit:xmlunit
|
||||
%mvn_alias org.xmlunit:xmlunit-assertj3 org.xmlunit:xmlunit-assertj
|
||||
|
||||
# JAXB and JAF are not available in JDK11
|
||||
%pom_remove_dep org.glassfish.jaxb: xmlunit-core
|
||||
%pom_remove_dep jakarta.xml.bind: xmlunit-core
|
||||
rm -rf xmlunit-core/src/{main,test}/java/org/xmlunit/builder/{jaxb/,JaxbBuilder.java,JaxbBuilderTest.java}
|
||||
|
||||
%build
|
||||
%mvn_build -s -- -Dmaven.compile.source=1.8 -Dmaven.compile.target=1.8
|
||||
|
||||
%install
|
||||
%mvn_install
|
||||
|
||||
%files -f .mfiles-xmlunit-parent
|
||||
%doc README.md CONTRIBUTING.md RELEASE_NOTES.md
|
||||
%license LICENSE
|
||||
|
||||
%files javadoc -f .mfiles-javadoc
|
||||
|
||||
%files assertj -f .mfiles-xmlunit-assertj3
|
||||
|
||||
%files core -f .mfiles-xmlunit-core
|
||||
|
||||
%files legacy -f .mfiles-xmlunit-legacy
|
||||
|
||||
%files matchers -f .mfiles-xmlunit-matchers
|
||||
|
||||
%files placeholders -f .mfiles-xmlunit-placeholders
|
||||
|
||||
%changelog
|
||||
* Fri Nov 29 2024 Mikolaj Izdebski <mizdebsk@redhat.com> - 2.10.0-2
|
||||
- Update javapackages test plan to f42
|
||||
|
||||
* Fri Aug 23 2024 Mikolaj Izdebski <mizdebsk@redhat.com> - 2.10.0-1
|
||||
- Update to upstream version 2.10.0
|
||||
- Resolves: rhbz#2277615
|
||||
|
||||
* Sat Jul 20 2024 Fedora Release Engineering <releng@fedoraproject.org> - 2.9.1-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_41_Mass_Rebuild
|
||||
|
||||
* Mon Apr 08 2024 Marian Koncek <mkoncek@redhat.com> - 2.9.1-1
|
||||
- Update to upstream version 2.9.1
|
||||
|
||||
* Sat Mar 02 2024 Jiri Vanek <jvanek@redhat.com> - 2.9.0-11
|
||||
- bump of release for for java-21-openjdk as system jdk
|
||||
|
||||
* Tue Feb 27 2024 Jiri Vanek <jvanek@redhat.com> - 2.9.0-10
|
||||
- Rebuilt for java-21-openjdk as system jdk
|
||||
|
||||
* Fri Feb 23 2024 Jiri Vanek <jvanek@redhat.com> - 2.9.0-9
|
||||
- bump of release for for java-21-openjdk as system jdk
|
||||
|
||||
* Tue Feb 20 2024 Marian Koncek <mkoncek@redhat.com> - 2.9.0-8
|
||||
- Update Java source/target to 1.8
|
||||
|
||||
* Sat Jan 27 2024 Fedora Release Engineering <releng@fedoraproject.org> - 2.9.0-7
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_40_Mass_Rebuild
|
||||
|
||||
* Fri Sep 01 2023 Mikolaj Izdebski <mizdebsk@redhat.com> - 2.9.0-6
|
||||
- Convert License tag to SPDX format
|
||||
|
||||
* Wed Aug 30 2023 Mikolaj Izdebski <mizdebsk@redhat.com> - 2.9.0-5
|
||||
- Build with Jurand instead of deprecated javapackages-extra
|
||||
|
||||
* Sat Jul 22 2023 Fedora Release Engineering <releng@fedoraproject.org> - 2.9.0-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_39_Mass_Rebuild
|
||||
|
||||
* Sat Jan 21 2023 Fedora Release Engineering <releng@fedoraproject.org> - 2.9.0-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_38_Mass_Rebuild
|
||||
|
||||
* Tue Oct 04 2022 Mikolaj Izdebski <mizdebsk@redhat.com> - 2.9.0-2
|
||||
- Fix BuildRequires on javapackages-extra
|
||||
|
||||
* Fri Sep 09 2022 Marian Koncek <mkoncek@redhat.com> - 2.9.0-1
|
||||
- Update to upstream version 2.9.0
|
||||
|
||||
* Sat Jul 23 2022 Fedora Release Engineering <releng@fedoraproject.org> - 2.8.2-8
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_37_Mass_Rebuild
|
||||
|
||||
* Fri Apr 22 2022 Mikolaj Izdebski <mizdebsk@redhat.com> - 2.8.2-7
|
||||
- Disable more tests that require network access
|
||||
|
||||
* Sat Feb 05 2022 Jiri Vanek <jvanek@redhat.com> - 2.8.2-6
|
||||
- Rebuilt for java-17-openjdk as system jdk
|
||||
|
||||
* Sat Jan 22 2022 Fedora Release Engineering <releng@fedoraproject.org> - 2.8.2-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_36_Mass_Rebuild
|
||||
|
||||
* Fri Jul 23 2021 Fedora Release Engineering <releng@fedoraproject.org> - 2.8.2-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_35_Mass_Rebuild
|
||||
|
||||
* Fri Jun 18 2021 Mikolaj Izdebski <mizdebsk@redhat.com> - 2.8.2-3
|
||||
- Clean tarball from content with questionable licensing
|
||||
- Resolves: rhbz#1973721
|
||||
|
||||
* Mon May 17 2021 Mikolaj Izdebski <mizdebsk@redhat.com> - 2.8.2-2
|
||||
- Bootstrap build
|
||||
- Non-bootstrap build
|
||||
|
||||
* Thu Feb 04 2021 Merlin Mathesius <mmathesi@redhat.com> - 0:2.7.0-7
|
||||
- Update previous patch to use improved version that was merged upstream
|
||||
|
||||
* Fri Jan 29 2021 Merlin Mathesius <mmathesi@redhat.com> - 0:2.7.0-6
|
||||
- Fix FTBFS by patching ValueAssertTest to adjust for changed format of
|
||||
mismatched string exception
|
||||
|
||||
* Thu Jan 28 2021 Fedora Release Engineering <releng@fedoraproject.org> - 0:2.7.0-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_34_Mass_Rebuild
|
||||
|
||||
* Tue Jan 26 2021 Marian Koncek <mkoncek@redhat.com> - 2.8.2-1
|
||||
- Update to upstream version 2.8.2
|
||||
|
||||
* Wed Jul 29 2020 Marian Koncek <mkoncek@redhat.com> - 2.7.0-1
|
||||
- Update to upstream version 2.7.0
|
||||
|
||||
* Wed Jul 29 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0:2.7.0-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_33_Mass_Rebuild
|
||||
|
||||
* Mon Jul 20 2020 Mat Booth <mat.booth@redhat.com> - 0:2.7.0-3
|
||||
- Allow building against JDK 11
|
||||
|
||||
* Sat Jul 11 2020 Jiri Vanek <jvanek@redhat.com> - 0:2.7.0-2
|
||||
- Rebuilt for JDK-11, see https://fedoraproject.org/wiki/Changes/Java11
|
||||
|
||||
* Wed May 13 2020 Dr. Tilmann Bubeck <bubeck@fedoraproject.org> - 0:2.7.0-1
|
||||
- Update to version 2.7.0.
|
||||
|
||||
* Fri Jan 31 2020 Fedora Release Engineering <releng@fedoraproject.org> - 0:2.6.3-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_32_Mass_Rebuild
|
||||
|
||||
* Tue Nov 05 2019 Mikolaj Izdebski <mizdebsk@redhat.com> - 2.6.3-2
|
||||
- Mass rebuild for javapackages-tools 201902
|
||||
|
||||
* Mon Jul 29 2019 Fabio Valentini <decathorpe@gmail.com> - 0:2.6.3-1
|
||||
- Update to version 2.6.3.
|
||||
|
||||
* Sat Jul 27 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0:1.6-10
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_31_Mass_Rebuild
|
||||
|
||||
* Wed Jun 26 2019 Marian Koncek <mkoncek@redhat.com> - 2.6.3-1
|
||||
- Update to upstream version 2.6.3
|
||||
|
||||
* Fri May 24 2019 Mikolaj Izdebski <mizdebsk@redhat.com> - 2.6.2-2
|
||||
- Mass rebuild for javapackages-tools 201901
|
||||
|
||||
* Mon Mar 04 2019 Marian Koncek <mkoncek@redhat.com> - 0:2.6.2-1
|
||||
- Update to upstream version 2.6.2
|
||||
|
||||
* Sun Feb 03 2019 Fedora Release Engineering <releng@fedoraproject.org> - 0:1.6-9
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_30_Mass_Rebuild
|
||||
|
||||
* Sat Jul 14 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0:1.6-8
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_29_Mass_Rebuild
|
||||
|
||||
* Fri Feb 09 2018 Fedora Release Engineering <releng@fedoraproject.org> - 0:1.6-7
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild
|
||||
|
||||
* Thu Jul 27 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0:1.6-6
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_27_Mass_Rebuild
|
||||
|
||||
* Wed Mar 01 2017 Michael Simacek <msimacek@redhat.com> - 0:1.6-5
|
||||
- Install with XMvn
|
||||
|
||||
* Sat Feb 11 2017 Fedora Release Engineering <releng@fedoraproject.org> - 0:1.6-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_26_Mass_Rebuild
|
||||
|
||||
* Fri Feb 05 2016 Fedora Release Engineering <releng@fedoraproject.org> - 0:1.6-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_24_Mass_Rebuild
|
||||
|
||||
* Fri Jun 19 2015 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0:1.6-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_23_Mass_Rebuild
|
||||
|
||||
* Sun Jan 04 2015 Dr. Tilmann Bubeck <tilmann@bubecks.de> - 0:1.6-1
|
||||
- update to upstream's xmlunit-1.6
|
||||
|
||||
* Wed Nov 5 2014 Mikolaj Izdebski <mizdebsk@redhat.com> - 0:1.5-3
|
||||
- Remove workaround for RPM bug #646523
|
||||
|
||||
* Sun Jun 08 2014 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0:1.5-2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_21_Mass_Rebuild
|
||||
|
||||
* Fri Oct 11 2013 Dr. Tilmann Bubeck <tilmann@bubecks.de> - 0:1.5-1
|
||||
- update to upstream's xmlunit-1.5
|
||||
|
||||
* Fri Sep 27 2013 Mikolaj Izdebski <mizdebsk@redhat.com> - 0:1.4-4
|
||||
- Enable test suite
|
||||
- Resolves: rhbz#987412
|
||||
|
||||
* Sun Aug 04 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0:1.4-3
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_20_Mass_Rebuild
|
||||
|
||||
* Wed Jun 12 2013 Stanislav Ochotnicky <sochotnicky@redhat.com> - 0:1.4-2
|
||||
- Update to latest packaging guidelines
|
||||
- Cleanup BuildRequires
|
||||
|
||||
* Fri Feb 15 2013 Dr. Tilmann Bubeck <t.bubeck@reinform.de> - 0:1.4-1
|
||||
- update to upstream's xmlunit-1.4
|
||||
|
||||
* Fri Feb 15 2013 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0:1.3-7
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_19_Mass_Rebuild
|
||||
|
||||
* Sun Jul 22 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0:1.3-6
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_18_Mass_Rebuild
|
||||
|
||||
* Sat Jan 14 2012 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0:1.3-5
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_17_Mass_Rebuild
|
||||
|
||||
* Mon Feb 07 2011 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0:1.3-4
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_15_Mass_Rebuild
|
||||
|
||||
* Thu Dec 30 2010 Alexander Kurtakov <akurtako@redhat.com> 0:1.3-3
|
||||
- Build javadoc only.
|
||||
|
||||
* Thu Dec 30 2010 Alexander Kurtakov <akurtako@redhat.com> 0:1.3-2
|
||||
- BR java 1.6 to prevent gcj failure.
|
||||
|
||||
* Thu Dec 30 2010 Alexander Kurtakov <akurtako@redhat.com> 0:1.3-1
|
||||
- Update to new upstream.
|
||||
- Drop gcj.
|
||||
- Rebuild docs.
|
||||
|
||||
* Thu Mar 11 2010 Peter Lemenkov <lemenkov@gmail.com> - 0:1.0-8.3
|
||||
- Added missing Requires jpackage-utils
|
||||
|
||||
* Mon Jul 27 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0:1.0-8.2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_12_Mass_Rebuild
|
||||
|
||||
* Thu Feb 26 2009 Fedora Release Engineering <rel-eng@lists.fedoraproject.org> - 0:1.0-7.2
|
||||
- Rebuilt for https://fedoraproject.org/wiki/Fedora_11_Mass_Rebuild
|
||||
|
||||
* Thu Jul 10 2008 Tom "spot" Callaway <tcallawa@redhat.com> - 0:1.0-6.2
|
||||
- drop repotag
|
||||
|
||||
* Tue Feb 19 2008 Fedora Release Engineering <rel-eng@fedoraproject.org> - 0:1.0-6jpp.1
|
||||
- Autorebuild for GCC 4.3
|
||||
|
||||
* Thu Jan 17 2008 Permaine Cheung <pcheung@redhat.com> - 0:1.0-5jpp.1
|
||||
- Update to the same version as upstream
|
||||
|
||||
Tue Dec 18 2007 Ralph Apel <r.apel at r-apel.de> - 0:1.0-5jpp
|
||||
- Add poms and depmap frags
|
||||
- Make Vendor, Distribution based on macro
|
||||
- Add gcj_support option
|
||||
|
||||
* Mon Mar 12 2007 Permaine Cheung <pcheung@redhat.com> - 0:1.0-4jpp.1
|
||||
- Add missing BR, patch to build javadoc, and other rpmlint issues
|
||||
|
||||
* Mon May 08 2006 Ralph Apel <r.apel at r-apel.de> - 0:1.0-4jpp
|
||||
- First JPP-1.7 release
|
||||
|
||||
* Thu Aug 26 2004 Ralph Apel <r.apel at r-apel.de> - 0:1.0-3jpp
|
||||
- Build with ant-1.6.2
|
||||
|
||||
* Wed Dec 17 2003 Paul Nasrat <pauln at truemesh.com> - 0:1.0-2jpp
|
||||
- Fix license and improved description
|
||||
- Thanks to Ralph Apel who produced a spec - merged version info
|
||||
|
||||
* Wed Dec 17 2003 Paul Nasrat <pauln at truemesh.com> - 0:1.0-1jpp
|
||||
- Initial Version
|
Loading…
Reference in New Issue
Block a user