re-import sources as agreed with the maintainer

This commit is contained in:
Adam Samalik 2023-06-29 11:06:44 +02:00 committed by root
parent ebf373dbe0
commit b314a082ef
7 changed files with 6 additions and 372 deletions

6
.gitignore vendored
View File

@ -1 +1,5 @@
SOURCES/xmlunit-1.6-src.zip
xmlunit1.0.zip
xmlunit-1.3-src.zip
/xmlunit-1.4-src.zip
/xmlunit-1.5-src.zip
/xmlunit-1.6-src.zip

1
.xmlunit.metadata Normal file
View File

@ -0,0 +1 @@
3cb4be3578fa4ad22fba2b75330f2f45563b3c94 xmlunit-1.6-src.zip

View File

@ -1,127 +0,0 @@
From 73abcb06636217e52a9d56b4dc3c69bd37141d44 Mon Sep 17 00:00:00 2001
From: Marian Koncek <mkoncek@redhat.com>
Date: Mon, 4 Mar 2019 14:52:59 +0100
Subject: [PATCH 1/4] Disable tests requiring network access
---
.../java/org/xmlunit/assertj3/XmlAssertNodesByXPathTest.java | 2 ++
.../java/org/xmlunit/assertj3/XmlAssertValidationTest.java | 6 ++++++
.../java/org/xmlunit/assertj3/XmlAssertValueByXPathTest.java | 2 ++
.../java/org/xmlunit/matchers/ValidationMatcherTest.java | 2 ++
4 files changed, 12 insertions(+)
diff --git a/xmlunit-assertj3/src/test/java/org/xmlunit/assertj3/XmlAssertNodesByXPathTest.java b/xmlunit-assertj3/src/test/java/org/xmlunit/assertj3/XmlAssertNodesByXPathTest.java
index 6499f67..c465a51 100644
--- a/xmlunit-assertj3/src/test/java/org/xmlunit/assertj3/XmlAssertNodesByXPathTest.java
+++ b/xmlunit-assertj3/src/test/java/org/xmlunit/assertj3/XmlAssertNodesByXPathTest.java
@@ -13,6 +13,7 @@
*/
package org.xmlunit.assertj3;
+import org.junit.Ignore;
import org.junit.Rule;
import org.junit.Test;
@@ -43,6 +44,7 @@ public class XmlAssertNodesByXPathTest {
}
@Test
+ @Ignore
public void testNodesByXPath_withNull_shouldFailed() {
thrown.expectAssertionError(format("%nExpecting not blank but was:<null>"));
diff --git a/xmlunit-assertj3/src/test/java/org/xmlunit/assertj3/XmlAssertValidationTest.java b/xmlunit-assertj3/src/test/java/org/xmlunit/assertj3/XmlAssertValidationTest.java
index 7e2dc0e..f743cc4 100644
--- a/xmlunit-assertj3/src/test/java/org/xmlunit/assertj3/XmlAssertValidationTest.java
+++ b/xmlunit-assertj3/src/test/java/org/xmlunit/assertj3/XmlAssertValidationTest.java
@@ -14,6 +14,7 @@
package org.xmlunit.assertj3;
import org.junit.ClassRule;
+import org.junit.Ignore;
import org.junit.Rule;
import org.junit.Test;
import org.xmlunit.TestResources;
@@ -91,6 +92,7 @@ public class XmlAssertValidationTest {
}
@Test
+ @Ignore
public void testIsValidAgainst_withEmptySourcesArray_shouldPass() {
StreamSource xml = new StreamSource(new File(TestResources.TEST_RESOURCE_DIR + "BookXsdGenerated.xml"));
@@ -100,6 +102,7 @@ public class XmlAssertValidationTest {
}
@Test
+ @Ignore
public void testIsValidAgainst_withBrokenXmlAndEmptySourcesArray_shouldFailed() {
thrown.expectAssertionError("1. line=9; column=8; type=ERROR;" +
@@ -112,6 +115,7 @@ public class XmlAssertValidationTest {
}
@Test
+ @Ignore
public void testIsValid_shouldPass() {
StreamSource xml = new StreamSource(new File(TestResources.TEST_RESOURCE_DIR + "BookXsdGenerated.xml"));
@@ -120,6 +124,7 @@ public class XmlAssertValidationTest {
}
@Test
+ @Ignore
public void testIsValid_withBrokenXml_shouldPass() {
thrown.expectAssertionError("1. line=9; column=8; type=ERROR;" +
@@ -140,6 +145,7 @@ public class XmlAssertValidationTest {
}
@Test
+ @Ignore
public void testIsInvalid_shouldField() {
thrown.expectAssertionErrorPattern("^\\nExpecting:\\n <.*"
diff --git a/xmlunit-assertj3/src/test/java/org/xmlunit/assertj3/XmlAssertValueByXPathTest.java b/xmlunit-assertj3/src/test/java/org/xmlunit/assertj3/XmlAssertValueByXPathTest.java
index 3ce5284..63c3db0 100644
--- a/xmlunit-assertj3/src/test/java/org/xmlunit/assertj3/XmlAssertValueByXPathTest.java
+++ b/xmlunit-assertj3/src/test/java/org/xmlunit/assertj3/XmlAssertValueByXPathTest.java
@@ -14,6 +14,7 @@
package org.xmlunit.assertj3;
import org.junit.ClassRule;
+import org.junit.Ignore;
import org.junit.Rule;
import org.junit.Test;
import org.xmlunit.assertj3.util.SetEnglishLocaleRule;
@@ -31,6 +32,7 @@ public class XmlAssertValueByXPathTest {
public static SetEnglishLocaleRule locale = new SetEnglishLocaleRule();
@Test
+ @Ignore
public void testValueByXPath_withNull_shouldFailed() {
thrown.expectAssertionError(format("%nExpecting not blank but was:<null>"));
diff --git a/xmlunit-matchers/src/test/java/org/xmlunit/matchers/ValidationMatcherTest.java b/xmlunit-matchers/src/test/java/org/xmlunit/matchers/ValidationMatcherTest.java
index 6f26927..bf9a153 100644
--- a/xmlunit-matchers/src/test/java/org/xmlunit/matchers/ValidationMatcherTest.java
+++ b/xmlunit-matchers/src/test/java/org/xmlunit/matchers/ValidationMatcherTest.java
@@ -13,6 +13,7 @@
*/
package org.xmlunit.matchers;
+import org.junit.Ignore;
import org.junit.Rule;
import org.junit.Test;
import org.junit.rules.ExpectedException;
@@ -79,6 +80,7 @@ public class ValidationMatcherTest {
}
@Test
+ @Ignore
public void shouldSuccessfullyValidateInstanceWithoutExplicitSchemaSource() {
try {
Class.forName("java.nio.file.FileSystem");
--
2.25.4

View File

@ -1,156 +0,0 @@
From c81eb91d7b9aa9728dfc83d68a881b4e2a0fa8d2 Mon Sep 17 00:00:00 2001
From: Marian Koncek <mkoncek@redhat.com>
Date: Thu, 29 Aug 2019 13:58:24 +0200
Subject: [PATCH 2/4] Port to hamcrest 2.1
---
.../src/main/java/org/xmlunit/matchers/CompareMatcher.java | 3 ---
.../main/java/org/xmlunit/matchers/EvaluateXPathMatcher.java | 2 --
.../src/main/java/org/xmlunit/matchers/HasXPathMatcher.java | 2 --
.../src/main/java/org/xmlunit/matchers/TypeMatcher.java | 5 -----
.../main/java/org/xmlunit/matchers/ValidationMatcher.java | 3 ---
5 files changed, 15 deletions(-)
diff --git a/xmlunit-matchers/src/main/java/org/xmlunit/matchers/CompareMatcher.java b/xmlunit-matchers/src/main/java/org/xmlunit/matchers/CompareMatcher.java
index 6452081..226399c 100644
--- a/xmlunit-matchers/src/main/java/org/xmlunit/matchers/CompareMatcher.java
+++ b/xmlunit-matchers/src/main/java/org/xmlunit/matchers/CompareMatcher.java
@@ -33,7 +33,6 @@ import org.xmlunit.util.Predicate;
import org.hamcrest.BaseMatcher;
import org.hamcrest.Description;
-import org.hamcrest.Factory;
import org.hamcrest.Matcher;
import java.lang.reflect.Constructor;
@@ -112,7 +111,6 @@ public final class CompareMatcher extends BaseMatcher<Object>
* <p>
* As input all types are supported which are supported by {@link Input#from(Object)}.
*/
- @Factory
public static CompareMatcher isIdenticalTo(final Object control) {
return new CompareMatcher(control).checkForIdentical();
}
@@ -128,7 +126,6 @@ public final class CompareMatcher extends BaseMatcher<Object>
* <p>
* As input all types are supported which are supported by {@link Input#from(Object)}.
*/
- @Factory
public static CompareMatcher isSimilarTo(final Object control) {
return new CompareMatcher(control).checkForSimilar();
}
diff --git a/xmlunit-matchers/src/main/java/org/xmlunit/matchers/EvaluateXPathMatcher.java b/xmlunit-matchers/src/main/java/org/xmlunit/matchers/EvaluateXPathMatcher.java
index 6eb23e5..1e9b8b5 100644
--- a/xmlunit-matchers/src/main/java/org/xmlunit/matchers/EvaluateXPathMatcher.java
+++ b/xmlunit-matchers/src/main/java/org/xmlunit/matchers/EvaluateXPathMatcher.java
@@ -16,7 +16,6 @@ package org.xmlunit.matchers;
import org.hamcrest.BaseMatcher;
import org.hamcrest.Description;
-import org.hamcrest.Factory;
import org.hamcrest.Matcher;
import org.w3c.dom.Node;
import org.xmlunit.builder.Input;
@@ -93,7 +92,6 @@ public class EvaluateXPathMatcher extends BaseMatcher<Object> {
* @param valueMatcher matcher for the value at the specified xpath
* @return the xpath matcher
*/
- @Factory
public static EvaluateXPathMatcher hasXPath(String xPath, Matcher<String> valueMatcher) {
return new EvaluateXPathMatcher(xPath, valueMatcher);
}
diff --git a/xmlunit-matchers/src/main/java/org/xmlunit/matchers/HasXPathMatcher.java b/xmlunit-matchers/src/main/java/org/xmlunit/matchers/HasXPathMatcher.java
index 08325cd..6fbf0ac 100644
--- a/xmlunit-matchers/src/main/java/org/xmlunit/matchers/HasXPathMatcher.java
+++ b/xmlunit-matchers/src/main/java/org/xmlunit/matchers/HasXPathMatcher.java
@@ -16,7 +16,6 @@ package org.xmlunit.matchers;
import org.hamcrest.BaseMatcher;
import org.hamcrest.Description;
-import org.hamcrest.Factory;
import org.hamcrest.Matcher;
import org.w3c.dom.Node;
import org.xmlunit.builder.Input;
@@ -135,7 +134,6 @@ public class HasXPathMatcher extends BaseMatcher<Object> {
* @param xPath the target xpath
* @return the xpath matcher
*/
- @Factory
public static HasXPathMatcher hasXPath(String xPath) {
return new HasXPathMatcher(xPath);
}
diff --git a/xmlunit-matchers/src/main/java/org/xmlunit/matchers/TypeMatcher.java b/xmlunit-matchers/src/main/java/org/xmlunit/matchers/TypeMatcher.java
index b9002a1..7cd6843 100644
--- a/xmlunit-matchers/src/main/java/org/xmlunit/matchers/TypeMatcher.java
+++ b/xmlunit-matchers/src/main/java/org/xmlunit/matchers/TypeMatcher.java
@@ -15,7 +15,6 @@
package org.xmlunit.matchers;
import org.hamcrest.Description;
-import org.hamcrest.Factory;
import org.hamcrest.Matcher;
import org.hamcrest.TypeSafeMatcher;
@@ -128,7 +127,6 @@ public abstract class TypeMatcher<T> extends TypeSafeMatcher<String> {
* @param valueMatcher valueMatcher for the converted value
* @return the BigDecimal matcher
*/
- @Factory
public static TypeMatcher<BigDecimal> asBigDecimal(Matcher<? extends BigDecimal> valueMatcher) {
return new BigDecimalTypeMatcher(valueMatcher);
}
@@ -146,7 +144,6 @@ public abstract class TypeMatcher<T> extends TypeSafeMatcher<String> {
* @param valueMatcher valueMatcher for the converted value
* @return the Double matcher
*/
- @Factory
public static TypeMatcher<Double> asDouble(Matcher<? extends Double> valueMatcher) {
return new DoubleTypeMatcher(valueMatcher);
}
@@ -164,7 +161,6 @@ public abstract class TypeMatcher<T> extends TypeSafeMatcher<String> {
* @param valueMatcher valueMatcher for the converted value
* @return the Integer matcher
*/
- @Factory
public static TypeMatcher<Integer> asInt(Matcher<? extends Integer> valueMatcher) {
return new IntegerTypeMatcher(valueMatcher);
}
@@ -182,7 +178,6 @@ public abstract class TypeMatcher<T> extends TypeSafeMatcher<String> {
* @param valueMatcher valueMatcher for the converted value
* @return the Boolean matcher
*/
- @Factory
public static TypeMatcher<Boolean> asBoolean(Matcher<? extends Boolean> valueMatcher) {
return new BooleanTypeMatcher(valueMatcher);
}
diff --git a/xmlunit-matchers/src/main/java/org/xmlunit/matchers/ValidationMatcher.java b/xmlunit-matchers/src/main/java/org/xmlunit/matchers/ValidationMatcher.java
index 3126349..51f58ec 100644
--- a/xmlunit-matchers/src/main/java/org/xmlunit/matchers/ValidationMatcher.java
+++ b/xmlunit-matchers/src/main/java/org/xmlunit/matchers/ValidationMatcher.java
@@ -27,7 +27,6 @@ import org.xmlunit.validation.ValidationProblem;
import org.xmlunit.validation.ValidationResult;
import org.hamcrest.BaseMatcher;
import org.hamcrest.Description;
-import org.hamcrest.Factory;
import javax.xml.transform.Source;
import javax.xml.validation.Schema;
@@ -121,7 +120,6 @@ public class ValidationMatcher extends BaseMatcher {
}
}
- @Factory
public static ValidationMatcher valid(final Object schemaSource) {
return new ValidationMatcher(schemaSource);
}
@@ -129,7 +127,6 @@ public class ValidationMatcher extends BaseMatcher {
/**
* @since XMLUnit 2.3.0
*/
- @Factory
public static ValidationMatcher valid(final Schema schema) {
return new ValidationMatcher(schema);
}
--
2.21.0

View File

@ -1,60 +0,0 @@
From 9866f331db726db0ac6af64649c308b01b34ea56 Mon Sep 17 00:00:00 2001
From: Mikolaj Izdebski <mizdebsk@redhat.com>
Date: Tue, 5 Nov 2019 12:14:08 +0100
Subject: [PATCH 4/4] Drop support for JAXB
---
xmlunit-core/src/main/java/org/xmlunit/builder/Input.java | 4 ++--
.../src/test/java/org/xmlunit/builder/InputTest.java | 7 -------
2 files changed, 2 insertions(+), 9 deletions(-)
diff --git a/xmlunit-core/src/main/java/org/xmlunit/builder/Input.java b/xmlunit-core/src/main/java/org/xmlunit/builder/Input.java
index 27d9c5a..81165cc 100644
--- a/xmlunit-core/src/main/java/org/xmlunit/builder/Input.java
+++ b/xmlunit-core/src/main/java/org/xmlunit/builder/Input.java
@@ -153,8 +153,8 @@ public class Input {
/**
* Build a Source from a Jaxb-Object.
*/
- public static JaxbBuilder fromJaxb(Object jaxbObject) {
- return new JaxbBuilder(jaxbObject);
+ public static Builder fromJaxb(Object jaxbObject) {
+ throw new RuntimeException("This implementation has JAXB support removed");
}
/**
diff --git a/xmlunit-core/src/test/java/org/xmlunit/builder/InputTest.java b/xmlunit-core/src/test/java/org/xmlunit/builder/InputTest.java
index e767f38..98e3fe7 100644
--- a/xmlunit-core/src/test/java/org/xmlunit/builder/InputTest.java
+++ b/xmlunit-core/src/test/java/org/xmlunit/builder/InputTest.java
@@ -31,7 +31,6 @@ import org.w3c.dom.Document;
import org.xmlunit.NullNode;
import org.xmlunit.TestResources;
import org.xmlunit.XMLUnitException;
-import org.xmlunit.builder.jaxb.ComplexNode;
import org.xmlunit.util.Convert;
import org.xmlunit.xpath.JAXPXPathEngine;
@@ -132,10 +131,6 @@ public class InputTest {
allIsWellFor(s, "furry");
}
- @Test public void shouldParseJaxbObject() throws Exception {
- allIsWellFor(Input.fromJaxb(new ComplexNode()).build(), "complexNode");
- }
-
@Test public void shouldParseUnknownToSource() throws Exception {
// from Source
allIsWellFor(Input.from(Input.fromByteArray(readTestFile()).build()).build());
@@ -153,8 +148,6 @@ public class InputTest {
allIsWellFor(Input.from(new URI("file:" + TestResources.ANIMAL_FILE)).build());
// from URL
allIsWellFor(Input.from(new URL("file:" + TestResources.ANIMAL_FILE)).build());
- // from Jaxb-Object
- allIsWellFor(Input.from(new ComplexNode()).build(), "complexNode");
// from InputStream
try (FileInputStream is = new FileInputStream(TestResources.ANIMAL_FILE)) {
allIsWellFor(Input.from(is).build());
--
2.29.2

View File

@ -1,8 +0,0 @@
--- !Policy
product_versions:
- rhel-9
decision_contexts:
- osci_compose_gate
rules:
# https://docs.engineering.redhat.com/display/RHELPLAN/Maven+Bootstrap+manual+gating+test
- !PassingTestCaseRule {test_case_name: manual.sst_cs_apps.maven.bootstrap}

View File

@ -1,20 +0,0 @@
#!/bin/bash
set -e
name=xmlunit
version="$(sed -n 's/Version:\s*//p' *.spec)"
# RETRIEVE
wget "https://github.com/xmlunit/xmlunit/releases/download/v${version}/${name}-${version}-src.tar.gz" -O "${name}-${version}.orig.tar.gz"
rm -rf tarball-tmp
mkdir tarball-tmp
pushd tarball-tmp
tar xf "../${name}-${version}.orig.tar.gz"
# CLEAN TARBALL
rm */GPATH */GRTAGS */GTAGS
tar -czf "../${name}-${version}.tar.gz" *
popd
rm -r tarball-tmp "${name}-${version}.orig.tar.gz"