auto-import xmlunit-1.0-4jpp.1 on branch devel from
xmlunit-1.0-4jpp.1.src.rpm
This commit is contained in:
parent
c4b205f48b
commit
54e2ebb7b3
@ -0,0 +1 @@
|
||||
xmlunit1.0.zip
|
20
xmlunit-build_xml.patch
Normal file
20
xmlunit-build_xml.patch
Normal file
@ -0,0 +1,20 @@
|
||||
--- build.xml.orig 2007-03-12 21:31:05.000000000 -0400
|
||||
+++ build.xml 2007-03-12 21:31:54.000000000 -0400
|
||||
@@ -25,7 +25,7 @@
|
||||
|
||||
<target name="compile" depends="init">
|
||||
<mkdir dir="${out.dir}"/>
|
||||
- <javac srcdir="${src.dir}/java:${test.dir}/java" destdir="${out.dir}" debug="on" target="1.2">
|
||||
+ <javac srcdir="${src.dir}/java:${test.dir}/java" destdir="${out.dir}" debug="on" target="1.2" source="1.2">
|
||||
<classpath>
|
||||
<pathelement location="${xmlxsl.lib}"/>
|
||||
<pathelement location="${junit.lib}"/>
|
||||
@@ -78,7 +78,7 @@
|
||||
<mkdir dir="${docs.dir}"/>
|
||||
<delete includeEmptyDirs="true" dir="${docs.dir}/org"/>
|
||||
<javadoc destdir="${docs.dir}"
|
||||
- overview="${src.dir}/java/overview.html"
|
||||
+ source="1.4"
|
||||
windowtitle="XMLUnit Documentation"
|
||||
footer="<p><a href="http://xmlunit.sourceforge.net/">XMLUnit</a> is hosted by sourceforge.net</p>">
|
||||
<group title="XMLUnit v${xmlunit.version}"
|
134
xmlunit.spec
Normal file
134
xmlunit.spec
Normal file
@ -0,0 +1,134 @@
|
||||
# Copyright (c) 2000-2005, JPackage Project
|
||||
# All rights reserved.
|
||||
#
|
||||
# Redistribution and use in source and binary forms, with or without
|
||||
# modification, are permitted provided that the following conditions
|
||||
# are met:
|
||||
#
|
||||
# 1. Redistributions of source code must retain the above copyright
|
||||
# notice, this list of conditions and the following disclaimer.
|
||||
# 2. Redistributions in binary form must reproduce the above copyright
|
||||
# notice, this list of conditions and the following disclaimer in the
|
||||
# documentation and/or other materials provided with the
|
||||
# distribution.
|
||||
# 3. Neither the name of the JPackage Project nor the names of its
|
||||
# contributors may be used to endorse or promote products derived
|
||||
# from this software without specific prior written permission.
|
||||
#
|
||||
# THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
|
||||
# "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
|
||||
# LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
|
||||
# A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
|
||||
# OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
|
||||
# SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
|
||||
# LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
|
||||
# DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
|
||||
# THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
|
||||
# (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
|
||||
# OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
|
||||
#
|
||||
|
||||
Name: xmlunit
|
||||
Version: 1.0
|
||||
Release: 4jpp.1%{?dist}
|
||||
Epoch: 0
|
||||
Summary: Unit Testing framework for XML
|
||||
License: BSD Style
|
||||
Source0: http://download.sourceforge.net/xmlunit/xmlunit1.0.zip
|
||||
Patch0: xmlunit-build_xml.patch
|
||||
URL: http://xmlunit.sourceforge.net/
|
||||
BuildRequires: jpackage-utils >= 0:1.6
|
||||
BuildRequires: ant >= 0:1.6
|
||||
BuildRequires: ant-junit >= 0:1.6
|
||||
BuildRequires: ant-nodeps >= 0:1.6
|
||||
BuildRequires: junit >= 0:3.8
|
||||
BuildRequires: xalan-j2
|
||||
BuildRequires: xerces-j2
|
||||
BuildRequires: xml-commons-apis
|
||||
Requires: junit >= 0:3.8
|
||||
Requires: xalan-j2
|
||||
Requires: xml-commons-apis
|
||||
Requires: jaxp_parser_impl
|
||||
Group: Development/Testing
|
||||
BuildArch: noarch
|
||||
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
|
||||
|
||||
%description
|
||||
XMLUnit extends JUnit to simplify unit testing of XML. It compares a control
|
||||
XML document to a test document or the result of a transformation, validates
|
||||
documents against a DTD, and (from v0.5) compares the results of XPath
|
||||
expressions.
|
||||
|
||||
%package javadoc
|
||||
Summary: Javadoc for %{name}
|
||||
Group: Development/Documentation
|
||||
|
||||
%description javadoc
|
||||
Javadoc for %{name}
|
||||
|
||||
%prep
|
||||
%setup -q -n %{name}
|
||||
# remove all binary libs and javadocs
|
||||
find . -name "*.jar" -exec rm -f {} \;
|
||||
rm -rf doc
|
||||
|
||||
cat >build.properties <<EOF
|
||||
junit.lib=$(build-classpath junit ant/ant-junit xalan-j2)
|
||||
xmlxsl.lib=$(build-classpath xalan-j2 xerces-j2)
|
||||
test.report.dir=test
|
||||
EOF
|
||||
|
||||
%patch0
|
||||
|
||||
#Fix wrong-file-end-of-line-encoding
|
||||
sed -i 's/\r//g' README.txt example.html LICENSE.txt
|
||||
|
||||
%build
|
||||
export CLASSPATH=$(build-classpath junit ant/ant-junit xalan-j2 \
|
||||
xalan-j2 xerces-j2)
|
||||
ant -Dbuild.compiler=modern jar test docs
|
||||
|
||||
|
||||
%install
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
mkdir -p $RPM_BUILD_ROOT%{_javadir}
|
||||
cp -p lib/%{name}%{version}.jar $RPM_BUILD_ROOT%{_javadir}/%{name}-%{version}.jar
|
||||
|
||||
# Jar versioning
|
||||
(cd $RPM_BUILD_ROOT%{_javadir} && for jar in *-%{version}.jar; do ln -sf ${jar} `echo $jar| sed "s|-%{version}||g"`; done)
|
||||
|
||||
# Javadoc
|
||||
mkdir -p $RPM_BUILD_ROOT%{_javadocdir}/%{name}-%{version}
|
||||
cp -pr doc/* $RPM_BUILD_ROOT%{_javadocdir}/%{name}-%{version}
|
||||
ln -s %{name}-%{version} $RPM_BUILD_ROOT%{_javadocdir}/%{name}
|
||||
|
||||
%clean
|
||||
rm -rf $RPM_BUILD_ROOT
|
||||
|
||||
%files
|
||||
%defattr(0644,root,root,0755)
|
||||
%{_javadir}/*
|
||||
%doc README.txt LICENSE.txt XMLUnit.pdf example.html
|
||||
|
||||
%files javadoc
|
||||
%defattr(0644,root,root,0755)
|
||||
%doc %{_javadocdir}/%{name}-%{version}
|
||||
%doc %{_javadocdir}/%{name}
|
||||
|
||||
%changelog
|
||||
* Mon Mar 12 2007 Permaine Cheung <pcheung@redhat.com> - 0:1.0-4jpp.1
|
||||
- Add missing BR, patch to build javadoc, and other rpmlint issues
|
||||
|
||||
* Mon May 08 2006 Ralph Apel <r.apel at r-apel.de> - 0:1.0-4jpp
|
||||
- First JPP-1.7 release
|
||||
|
||||
* Thu Aug 26 2004 Ralph Apel <r.apel at r-apel.de> - 0:1.0-3jpp
|
||||
- Build with ant-1.6.2
|
||||
|
||||
* Wed Dec 17 2003 Paul Nasrat <pauln at truemesh.com> - 0:1.0-2jpp
|
||||
- Fix license and improved description
|
||||
- Thanks to Ralph Apel who produced a spec - merged version info
|
||||
|
||||
* Wed Dec 17 2003 Paul Nasrat <pauln at truemesh.com> - 0:1.0-1jpp
|
||||
- Initial Version
|
Loading…
Reference in New Issue
Block a user