diff --git a/.gitignore b/.gitignore
index f129c9f..937380e 100644
--- a/.gitignore
+++ b/.gitignore
@@ -3,3 +3,4 @@ xmlunit-1.3-src.zip
/xmlunit-1.4-src.zip
/xmlunit-1.5-src.zip
/xmlunit-1.6-src.zip
+/xmlunit-2.6.2-src.tar.gz
diff --git a/sources b/sources
index 2132d48..98f45df 100644
--- a/sources
+++ b/sources
@@ -1 +1 @@
-SHA512 (xmlunit-1.6-src.zip) = a7d15905d959ab5bfeb1807c80eab3e0aa58d501a2136335961da842b9571b95b4aab18189e9a21e59afac960ea83f9a2d32e3af398f63c0f839587b60b9f96b
+SHA512 (xmlunit-2.6.2-src.tar.gz) = 7e71626e604f475e0dffaabf814a81e0d2a6fd43790e2371858c815c676d5b3d6e9f285f98d817ff1b41a81323441bdadb56b8d172419f5546ff6ffc1f7ace7c
diff --git a/xmlunit-1.0.pom b/xmlunit-1.0.pom
deleted file mode 100644
index c5aa039..0000000
--- a/xmlunit-1.0.pom
+++ /dev/null
@@ -1,6 +0,0 @@
-
- 4.0.0
- xmlunit
- xmlunit
- 1.0
-
\ No newline at end of file
diff --git a/xmlunit.spec b/xmlunit.spec
index f725502..fd49cf2 100644
--- a/xmlunit.spec
+++ b/xmlunit.spec
@@ -29,32 +29,30 @@
#
Name: xmlunit
-Version: 1.6
-Release: 7%{?dist}
+Version: 2.6.2
+Release: 1%{?dist}
Summary: Provides classes to do asserts on xml
-License: BSD
-Source0: http://downloads.sourceforge.net/xmlunit/xmlunit-1.6-src.zip
-Source1: http://repo1.maven.org/maven2/xmlunit/xmlunit/1.0/xmlunit-1.0.pom
-URL: http://xmlunit.sourceforge.net/
-BuildRequires: javapackages-local
-BuildRequires: ant
-BuildRequires: ant-junit
-BuildRequires: junit
-BuildRequires: xalan-j2
-BuildRequires: xerces-j2
-BuildRequires: xml-commons-apis
+License: ASL 2.0
+Source0: https://github.com/xmlunit/xmlunit/releases/download/v%{version}/%{name}-%{version}-src.tar.gz
+URL: https://www.xmlunit.org/
-Requires: junit
-Requires: xalan-j2
-Requires: xml-commons-apis
+Patch0: 0001-Disable-tests-requiring-network-access.patch
+
+BuildRequires: maven-local
+BuildRequires: mvn(junit:junit)
+BuildRequires: mvn(org.apache.felix:maven-bundle-plugin)
+BuildRequires: mvn(org.apache.maven.plugins:maven-shade-plugin)
+BuildRequires: mvn(org.assertj:assertj-core)
+BuildRequires: mvn(org.hamcrest:hamcrest-core)
+BuildRequires: mvn(org.hamcrest:hamcrest-library)
+BuildRequires: mvn(org.mockito:mockito-core)
BuildArch: noarch
%description
-XMLUnit extends JUnit to simplify unit testing of XML. It compares a control
-XML document to a test document or the result of a transformation, validates
-documents against a DTD, and (from v0.5) compares the results of XPath
-expressions.
+XMLUnit provides you with the tools to verify the XML you emit is the one you
+want to create. It provides helpers to validate against an XML Schema, assert
+the values of XPath queries or compare XML documents against expected outcomes.
%package javadoc
Summary: Javadoc for %{name}
@@ -62,41 +60,67 @@ Summary: Javadoc for %{name}
%description javadoc
Javadoc for %{name}
+%package assertj
+Summary: Assertj for %{name}
+
+%description assertj
+This package provides %{summary}.
+
+%package core
+Summary: Core package for %{name}
+
+%description core
+This package provides %{summary}.
+
+%package legacy
+Summary: Legacy package for %{name}
+
+%description legacy
+This package provides %{summary}.
+
+%package matchers
+Summary: Matchers for %{name}
+
+%description matchers
+This package provides %{summary}.
+
+%package placeholders
+Summary: Placeholders for %{name}
+
+%description placeholders
+This package provides %{summary}.
+
%prep
-%setup -q
+%setup -q -n %{name}-%{version}-src
-sed -i /java.class.path/d build.xml
-# remove all binary libs and javadocs
-find . -name "*.jar" -exec rm -f {} \;
-rm -rf doc
+%patch0 -p1
-#Fix wrong-file-end-of-line-encoding
-sed -i 's/\r//g' README.txt LICENSE.txt
+%pom_remove_plugin org.codehaus.mojo:buildnumber-maven-plugin
+%pom_remove_plugin :maven-assembly-plugin
-%mvn_file : %{name}
+%mvn_alias "org.xmlunit:xmlunit-legacy" "xmlunit:xmlunit"
%build
-ant -Dbuild.compiler=modern -Dhaltonfailure=yes \
- -Djunit.lib=$(build-classpath junit) \
- -Dxmlxsl.lib= -Dtest.report.dir=test \
- -Ddb5.xsl=%{_datadir}/sgml/docbook/xsl-ns-stylesheets \
- jar javadocs
-
-%mvn_artifact %{SOURCE1} build/lib/%{name}-%{version}.jar
+%mvn_build -s
%install
-%mvn_install -J build/doc/api/
+%mvn_install
-%check
-ant
-
-
-%files -f .mfiles
-%doc README.txt LICENSE.txt userguide/XMLUnit-Java.pdf
+%files -f .mfiles-xmlunit-parent
+%doc README.md CONTRIBUTING.md RELEASE_NOTES.md
+%license LICENSE
%files javadoc -f .mfiles-javadoc
+%files assertj -f .mfiles-xmlunit-assertj
+%files core -f .mfiles-xmlunit-core
+%files legacy -f .mfiles-xmlunit-legacy
+%files matchers -f .mfiles-xmlunit-matchers
+%files placeholders -f .mfiles-xmlunit-placeholders
%changelog
+* Mon Mar 04 2019 Marian Koncek - 0:2.6.2-1
+- Update to upstream version 2.6.2
+
* Fri Feb 09 2018 Fedora Release Engineering - 0:1.6-7
- Rebuilt for https://fedoraproject.org/wiki/Fedora_28_Mass_Rebuild